libuser-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522
  1. %define WITH_SELINUX 0
  2. %define python %(python -c 'import sys;print(sys.version[0:3])')
  3. Name: libuser
  4. Version: 0.62
  5. Release: 1%{?_dist_release}
  6. Summary: A user and group account administration library.
  7. Summary(ja): ユーザアカウントとグループアカウントを管理するライブラリ
  8. Group: System Environment/Base
  9. Distribution: Vine Linux
  10. Vendor: Project Vine
  11. License: LGPL
  12. URL: https://pagure.io/libuser
  13. Source: libuser-%{version}.tar.xz
  14. Patch0: libuser-selinux.patch
  15. BuildRoot: %{_tmppath}/%{name}-root
  16. BuildRequires: pam-devel
  17. BuildRequires: popt
  18. BuildRequires: python-devel
  19. BuildRequires: gtk-doc
  20. BuildRequires: linuxdoc-tools
  21. BuildRequires: pkgconfig
  22. BuildRequires: glib2-devel
  23. BuildRequires: popt-devel
  24. #BuildPrereq: cyrus-sasl-devel, openldap-devel
  25. %description
  26. The libuser library implements a standardized interface for manipulating
  27. and administering user and group accounts. The library uses pluggable
  28. back-ends to interface to its data sources.
  29. Sample applications modeled after those included with the shadow password
  30. suite are included.
  31. %package devel
  32. Group: Development/Libraries
  33. Summary: Files needed for developing applications which use libuser.
  34. Requires: %{name} = %{version}-%{release}
  35. %description devel
  36. The libuser-devel package contains header files, static libraries, and other
  37. files useful for developing applications with libuser.
  38. %prep
  39. %setup -q
  40. %if %{WITH_SELINUX}
  41. #SELinux
  42. %patch0 -p1 -b .selinux
  43. %endif
  44. %build
  45. CFLAGS="$RPM_OPT_FLAGS -fPIC" ; export CFLAGS
  46. %configure \
  47. --with-python-version=%{python} \
  48. --with-python-path=%{_includedir}/python%{python} \
  49. --with-html-dir=%{_datadir}/gtk-doc/html \
  50. --with-pic
  51. make
  52. %clean
  53. rm -fr $RPM_BUILD_ROOT
  54. %install
  55. rm -fr $RPM_BUILD_ROOT
  56. make install DESTDIR=$RPM_BUILD_ROOT
  57. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  58. LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_libdir}:${LD_LIBRARY_PATH}
  59. export LD_LIBRARY_PATH
  60. # Verify that all python modules load, just in case.
  61. pushd $RPM_BUILD_ROOT/%{_libdir}/python%{python}/site-packages/
  62. python%{python} -c "import libuser"
  63. popd
  64. # remove .la
  65. rm -f $RPM_BUILD_ROOT%{_libdir}/libuser/*.la
  66. rm -f $RPM_BUILD_ROOT%{_libdir}/python%{python}/site-packages/*.la
  67. %find_lang %{name}
  68. %post -p /sbin/ldconfig
  69. %postun -p /sbin/ldconfig
  70. %files -f %{name}.lang
  71. %defattr(-,root,root)
  72. %license COPYING
  73. %doc AUTHORS NEWS README TODO docs/*.txt python/modules.txt
  74. %config(noreplace) %{_sysconfdir}/libuser.conf
  75. %attr(0755,root,root) %{_bindir}/*
  76. %attr(0755,root,root) %{python_sitearch}/*.so
  77. %attr(0755,root,root) %{_libdir}/*.so.*
  78. %dir %attr(0755,root,root) %{_libdir}/%{name}
  79. %attr(0755,root,root) %{_libdir}/%{name}/*.so
  80. #%attr(0644,root,root) %{_libdir}/%{name}/*.la
  81. %attr(0755,root,root) %{_sbindir}/*
  82. %files devel
  83. %defattr(-,root,root)
  84. %attr(0755,root,root) %dir %{_includedir}/libuser
  85. %attr(0644,root,root) %{_includedir}/libuser/*
  86. #attr(0644,root,root) %{_libdir}/*.la
  87. %attr(0755,root,root) %{_libdir}/*.so
  88. #%attr(0644,root,root) %{_mandir}/man3/*
  89. %attr(0644,root,root) %{_mandir}/man5/*
  90. %attr(0644,root,root) %{_libdir}/pkgconfig/*
  91. %{_datadir}/gtk-doc/html/*
  92. %{_mandir}/man1/*
  93. %changelog
  94. * Tue Mar 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.62-1
  95. - new upstream release.
  96. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.60-1
  97. - new upstream release
  98. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-5
  99. - rebuild with python-2.7.2
  100. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-4
  101. - rebuild with rpm-4.8.1 for pkg-config file
  102. * Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-3
  103. - add BuildRequires: pkgconfig, glib2-devel, popt-devel
  104. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-2
  105. - rebuild for python-2.6
  106. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-1
  107. - new upstream release
  108. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.53.8-3
  109. - rebuilt with python-2.5.2
  110. - removed *.la
  111. * Mon Jun 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.53.8-2
  112. - applied new versioning policy
  113. * Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53.8-1vl1
  114. - new upstream release
  115. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl3
  116. - rebuild with python-2.4.1-0vl1
  117. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl2
  118. - rebuild with python-2.3.3-0vl1
  119. * Thu Apr 15 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl1.1
  120. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  121. * Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.51.7-7vl1
  122. - resync to fedora
  123. * Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51.2-1vl1
  124. - initial build for Vine Linux
  125. * Wed Dec 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.2-1
  126. - degrade gracefully
  127. - build with --with-pic and -fPIC
  128. - remove unpackaged man page
  129. * Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-2
  130. - translation updates
  131. * Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-1
  132. - doc updates -- cvs tree moved
  133. - language updates
  134. - disallow weird characters in account names
  135. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  136. - automated rebuild
  137. * Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51-1
  138. - files: ignore blank lines in files
  139. - libuser: disallow creation of accounts with names containing whitespace,
  140. control characters, or non-ASCII characters
  141. * Tue Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50.2-1
  142. - refresh translations
  143. - fix a heap-corruption bug in the python bindings
  144. * Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50-1
  145. - bump version
  146. - refresh translations
  147. * Thu Mar 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.102-1
  148. - ldap: cache an entity's dn in the entity structure to try to speed things up
  149. * Mon Mar 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-3
  150. - rebuild in new environment
  151. * Thu Mar 7 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-2
  152. - add missing buildreqs on cyrus-sasl-devel and openldap-devel (#59456)
  153. - translation refresh
  154. * Fri Mar 1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-1
  155. - fix python bindings of enumerateFull functions
  156. - adjust prompter wrapping to not error out on successful returns
  157. * Thu Feb 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.100-1
  158. - be more careful about printing error messages
  159. - fix refreshing after adding of accounts
  160. - ldap: try to use a search to convert names to DNs, and only fall back to
  161. guessing if it turns up nothing
  162. - files: fix an off-by-one in removal of entries
  163. * Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.99-1
  164. - refresh translations
  165. - fix admin() constructor comments in the python module
  166. * Thu Feb 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.98-1
  167. - automatically refresh entities after add, modify, setpass, removepass,
  168. lock, and unlock operations
  169. - remove debug spewage when creating and removing mail spools
  170. - files: fix saving of multi-valued attributes
  171. - rename MEMBERUID attribute for groups to MEMBERNAME
  172. * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.97-1
  173. - files: fix bug in removals
  174. - ldap: revert attempts at being smart at startup time, because it makes UIs
  175. very messy (up the three whole dialogs just to start the ldap stuff!)
  176. * Sat Feb 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.96-1
  177. - fix thinko in dispatch routines
  178. * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.95-1
  179. - lgroupmod: fix thinko
  180. * Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.94-2
  181. - rebuild in new environment
  182. * Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.93-1
  183. - move shadow initialization for groups to the proper callback
  184. - rework locking in the files module to not require that files be writable
  185. * Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com>
  186. - expose lu_strerror()
  187. - add various typedefs for types used by the library
  188. * Mon Jan 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.92-1
  189. - add removepass() functions
  190. * Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com>
  191. - lchfn,lchsh,lpasswd - reorder PAM authentication calls
  192. - include API docs in the package
  193. * Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.91-1
  194. - ldap: finish port to new API
  195. - sasl: finish port to new API (needs test)
  196. - libuser: don't commit object changes before passing data to service
  197. functions which might need differing data sets to figure out what to
  198. change (for example, ldap)
  199. * Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.90-1
  200. - bind the internal mail spool creation/removal functions for python
  201. * Wed Jan 16 2002 Nalin Dahyabhai <nalin@redhat.com>
  202. - renamed the python module
  203. - revamped internals to use gobject's gvalues and gvaluearrays instead of
  204. glists of cached strings
  205. - add enumeration-with-data functions to the C library
  206. * Mon Jan 07 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  207. - require linuxdoc-tools instead of sgml-tools for rawhide
  208. * Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  209. - fixup build files to allow building for arbitrary versions of python
  210. * Wed Aug 29 2001 Nalin Dahyabhai <nalin@redhat.com> 0.32-1
  211. - link the python module against libpam
  212. - attempt to import the python modules at build-time to verify dependencies
  213. * Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 0.31-1
  214. - fix a file-parsing bug that popped up in 0.29's mmap modifications
  215. * Mon Aug 27 2001 Nalin Dahyabhai <nalin@redhat.com> 0.30-1
  216. - quotaq: fix argument order when reading quota information
  217. - user_quota: set quota grace periods correctly
  218. - luseradd: never create home directories for system accounts
  219. * Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com>
  220. - add da translation files
  221. - update translations
  222. * Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com> 0.29-1
  223. - add an explicit build dependency on jade (for the docs)
  224. * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com>
  225. - HUP nscd on modifications
  226. - userutil.c: mmap files we're reading for probable speed gain
  227. - userutil.c: be conservative with the amount of random data we read
  228. - docs fixes
  229. * Wed Aug 15 2001 Nalin Dahyabhai <nalin@redhat.com> 0.28-1
  230. - apps: print usage on errors
  231. - lnewusers.c: initialize groups as groups, not users
  232. - lnewusers.c: set passwords for new accounts
  233. - luseradd.c: accept group names in addition to IDs for the -g flag
  234. - luseradd.c: allow the primary GID to be a preexisting group
  235. * Tue Aug 14 2001 Nalin Dahyabhai <nalin@redhat.com> 0.27-1
  236. - add ko translation files
  237. - files.c: fix a heap corruption bug in lock/unlock (#51750)
  238. - files.c: close a memory leak in reading of files
  239. * Mon Aug 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  240. - files.c: remove implementation limits on lengths of lines
  241. * Thu Aug 9 2001 Nalin Dahyabhai <nalin@redhat.com> 0.26-1
  242. - lusermod: change user name in groups the user is a member of during renames
  243. - lgroupmod: change primary GID for users who are in the group during renumbers
  244. - ldap.c: handle new attributes more gracefully if possible
  245. - add ru translation files
  246. * Tue Aug 7 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25.1-1
  247. - rename the quota source files to match the library, which clears up a
  248. file conflict with older quota packages
  249. - add ja translation files
  250. * Thu Aug 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  251. - add lu_ent_clear_all() function
  252. * Thu Aug 2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25-1
  253. - close up some memory leaks
  254. - add the ability to include resident versions of modules in the library
  255. * Wed Aug 1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-4
  256. - fix incorrect Py_BuildValue invocation in python module
  257. * Tue Jul 31 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-3
  258. - stop leaking descriptors in the files module
  259. - speed up user creation by reordering some checks for IDs being in use
  260. - update the shadowLastChanged attribute when we set a password
  261. - adjust usage of getXXXXX_r where needed
  262. - fix assorted bugs in python binding which break prompting
  263. * Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.23-1
  264. - install sv translation
  265. - make lpasswd prompt for passwords when none are given on the command line
  266. - make sure all user-visible strings are marked for translation
  267. - clean up some user-visible strings
  268. - require PAM authentication in lchsh, lchfn, and lpasswd for non-networked modules
  269. * Fri Jul 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  270. - print uids and gids of users and names in lid app
  271. - fix tree traversal in users_enumerate_by_group and groups_enumerate_by_users
  272. - implement enumerate_by_group and enumerate_by_user in ldap module
  273. - fix id-based lookups in the ldap module
  274. - implement islocked() method in ldap module
  275. - implement setpass() method in ldap module
  276. - add lchfn and lchsh apps
  277. - add %%d substitution to libuser.conf
  278. * Thu Jul 26 2001 Nalin Dahyabhai <nalin@redhat.com> 0.21-1
  279. - finish adding a sasldb module which manipulates a sasldb file
  280. - add users_enumerate_by_group and groups_enumerate_by_users
  281. * Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  282. - luserdel: remove the user's primary group if it has the same name as
  283. the user and has no members configured (-G disables)
  284. - fixup some configure stuff to make libuser.conf get generated correctly
  285. even when execprefix isn't specified
  286. * Tue Jul 24 2001 Nalin Dahyabhai <nalin@redhat.com> 0.20-1
  287. - only call the auth module when setting passwords (oops)
  288. - use GTrees instead of GHashTables for most internal tables
  289. - files: complain properly about unset attributes
  290. - files: group passwords are single-valued, not multiple-valued
  291. - add lpasswd app, make sure all apps start up popt with the right names
  292. * Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com> 0.18-1
  293. - actually make the new optional arguments optional
  294. - fix lu_error_new() to actually report errors right
  295. - fix part of the python bindings
  296. - include tools in the binary package again
  297. - fixup modules so that password-changing works right again
  298. - add a "key" field to prompt structures for use by apps which like to
  299. cache these things
  300. - add an optional "mvhomedir" argument to userModify (python)
  301. * Fri Jul 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.16.1-1
  302. - finish home directory population
  303. - implement home directory moving
  304. - change entity get semantics in the python bindings to allow default values for .get()
  305. - add lu_ent_has(), and a python has_key() method to Entity types
  306. - don't include tools in the binary package
  307. - add translated strings
  308. * Thu Jul 19 2001 Nalin Dahyabhai <nalin@redhat.com>
  309. - lib/user.c: catch and ignore errors when running stacks
  310. - lusermod: fix slightly bogus help messages
  311. - luseradd: when adding a user and group, use the gid of the group
  312. instead of the user's uid as the primary group
  313. - properly set the password field in user accounts created using
  314. auth-only auth modules (shadow needs "x" instead of "!!")
  315. - implement home directory removal, start on population
  316. * Wed Jul 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  317. - fix group password setting in the files module
  318. - setpass affects both auth and info, so run both stacks
  319. * Tue Jul 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  320. - make the testbed apps noinst
  321. * Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  322. - fix errors due to uninitialized fields in the python bindings
  323. - add kwargs support to all python wrappers
  324. - add a mechanism for passing arguments to python callbacks
  325. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  326. - stub out the krb5 and ldap modules so that they'll at least compile again
  327. * Tue Jul 10 2001 Nalin Dahyabhai <nalin@redhat.com>
  328. - don't bail when writing empty fields to colon-delimited files
  329. - use permissions of the original file when making backup files instead of 0600
  330. * Fri Jul 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  331. - finish implementing is_locked methods in files/shadow module
  332. - finish cleanup of the python bindings
  333. - allow conditional builds of modules so that we can build without
  334. all of the prereqs for all of the modules
  335. * Thu Jun 21 2001 Nalin Dahyabhai <nalin@redhat.com>
  336. - add error reporting facilities
  337. - split public header into pieces by function
  338. - backend cleanups
  339. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  340. - make %%{name}-devel require %%{name} and not %%{name}-devel
  341. * Fri Jun 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  342. - clean up quota bindings some more
  343. - finish most of the ldap bindings
  344. - fix a subtle bug in the files module that would show up when renaming accounts
  345. - fix mapping methods for entity structures in python
  346. * Thu Jun 14 2001 Nalin Dahyabhai <nalin@redhat.com>
  347. - get bindings for prompts to work correctly
  348. - clean up some of the add/remove semantics (set source on add)
  349. - ldap: implement enumeration
  350. - samples/enum: fix the argument order
  351. * Wed Jun 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  352. - clean up python bindings for quota
  353. * Tue Jun 12 2001 Nalin Dahyabhai <nalin@redhat.com> 0.11
  354. - finish up python bindings for quota support
  355. * Sun Jun 10 2001 Nalin Dahyabhai <nalin@redhat.com>
  356. - finish up quota support libs
  357. * Fri Jun 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  358. - start quota support library to get some type safety
  359. * Thu Jun 7 2001 Nalin Dahyabhai <nalin@redhat.com>
  360. - start looking at quota manipulation
  361. * Wed Jun 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  362. - add functions for enumerating users and groups, optionally per-module
  363. - lusermod.c: -s should specify the shell, not the home directory
  364. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.10
  365. - finish the python bindings and verify that the file backend works again
  366. * Wed May 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  367. - remove a redundant check which was breaking modifications
  368. * Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  369. - finish adding setpass methods
  370. * Wed May 2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.9
  371. - get a start on some Python bindings
  372. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.2
  373. - make binary-incompatible change in headers
  374. * Mon Apr 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.1
  375. - add doxygen docs and a "doc" target for them
  376. * Sat Jan 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8
  377. - add a "quiet" prompter
  378. - add --interactive flag to sample apps and default to using quiet prompter
  379. - ldap: attempt a "self" bind if other attempts fail
  380. - krb5: connect to the password-changing service if the user principal has
  381. the NULL instance
  382. * Wed Jan 10 2001 Nalin Dahyabhai <nalin@redhat.com>
  383. - the great adding-of-the-copyright-statements
  384. - take more care when creating backup files in the files module
  385. * Wed Jan 3 2001 Nalin Dahyabhai <nalin@redhat.com> 0.7
  386. - add openldap-devel as a buildprereq
  387. - krb5: use a continuous connection
  388. - krb5: add "realm" config directive
  389. - ldap: use a continuous connection
  390. - ldap: add "server", "basedn", "binddn", "user", "authuser" config directives
  391. - ldap: actually finish the account deletion function
  392. - ldap: don't send cleartext passwords to the directory
  393. - fix naming attribute for users (should be uid, not gid)
  394. - refine the search-by-id,convert-to-name,search-by-name logic
  395. - fix handling of defaults when the config file is read in but contains no value
  396. - implement an LDAP information store
  397. - try to clean up module naming with libtool
  398. - luseradd: pass plaintext passwords along
  399. - luseradd: use symbolic attribute names instead of hard-coded
  400. - lusermod: pass plaintext passwords along
  401. - lgroupadd: pass plaintext passwords along
  402. - lgroupmod: pass plaintext passwords along
  403. - add libuser as a dependency of libuser-devel
  404. * Tue Jan 2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.6
  405. - initial packaging