libmpc-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142
  1. Summary: C library for multiple precision complex arithmetic
  2. Name: libmpc
  3. Version: 1.1.0
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Libraries
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: LGPLv3+
  9. URL: http://www.multiprecision.org/
  10. Source0: https://ftp.gnu.org/gnu/mpc/mpc-1.1.0.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. BuildRequires: gmp-devel >= 4.3.2
  13. BuildRequires: mpfr-devel >= 2.4.2
  14. BuildRequires: grep
  15. BuildRequires: texinfo
  16. %description
  17. MPC is a C library for the arithmetic of complex numbers with
  18. arbitrarily high precision and correct rounding of the result. It is
  19. built upon and follows the same principles as Mpfr.
  20. %package devel
  21. Summary: Header and shared development libraries for MPC
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. Requires: gmp-devel
  25. Requires: mpfr-devel
  26. Requires(post): /sbin/install-info
  27. Requires(preun): /sbin/install-info
  28. %description devel
  29. Header files and shared object symlinks for MPC is a C library.
  30. %prep
  31. %setup -q -n mpc-%{version}
  32. %build
  33. export CPPFLAGS="%{optflags} -std=gnu99"
  34. export CFLAGS="%{optflags} -std=gnu99"
  35. export EGREP=egrep
  36. %configure --disable-static
  37. make %{?_smp_mflags}
  38. %check
  39. make check
  40. %install
  41. rm -rf %{buildroot}
  42. make install DESTDIR=%{buildroot}
  43. rm -f %{buildroot}/%{_libdir}/libmpc.{l,}a
  44. rm -f %{buildroot}/%{_infodir}/dir
  45. %clean
  46. rm -rf %{buildroot}
  47. %post -p /sbin/ldconfig
  48. %postun -p /sbin/ldconfig
  49. %post devel
  50. if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
  51. /sbin/install-info %{_infodir}/mpc.info.gz %{_infodir}/dir || :
  52. fi
  53. %preun devel
  54. if [ $1 = 0 ]; then
  55. if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
  56. /sbin/install-info --delete %{_infodir}/mpc.info.gz %{_infodir}/dir || :
  57. fi
  58. fi
  59. %files
  60. %defattr(-,root,root,-)
  61. %license COPYING.LESSER
  62. %doc README NEWS
  63. %{_libdir}/libmpc.so.*
  64. %files devel
  65. %defattr(-,root,root,-)
  66. %{_libdir}/libmpc.so
  67. %{_includedir}/mpc.h
  68. %{_infodir}/*.info*
  69. %changelog
  70. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.0-1
  71. - new upstream release.
  72. * Fri May 20 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  73. - updated to 1.0.3
  74. * Fri Sep 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
  75. - updated to 1.0.2
  76. - change Group to System Environment/Libraries (libmpc)
  77. * Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
  78. - update to 1.0.1
  79. * Tue Nov 01 2011 NAKAMURA Kenta <kenta@vinelinux.org> - 0.9-2
  80. - initial build for Vine Linux
  81. * Wed Jun 22 2011 <pmachata@redhat.com> - 0.9-1
  82. - Upstream 0.9
  83. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-0.3.svn855
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  85. * Tue Nov 30 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.2.svn855
  86. - Bump for rebuild against the new mpfr
  87. * Fri Nov 19 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.1.svn855
  88. - Devel updates (to-be-0.8.3, SVN release 855)
  89. - New functions mpc_set_dc, mpc_set_ldc, mpc_get_dc, mpc_get_ldc
  90. - Speed-up mpc_pow_si and mpc_pow_z
  91. - Bug fixes in trigonometric functions, exp, sqrt
  92. - Upstream 0.8.2
  93. - Speed-up mpc_pow_ui
  94. - Adjust BuildRequires
  95. - Resolves: #653931
  96. * Wed Jan 20 2010 Petr Machata <pmachata@redhat.com> - 0.8.1-1
  97. - Upstream 0.8.1
  98. - acosh, asinh, atanh: swap of precisions between real and imaginary parts
  99. - atan: memory leak
  100. - log: wrong ternary value in data file; masked by bug in Mpfr 2.4.1
  101. - Resolves: #555471 FTBFS libmpc-0.8-3.fc13
  102. * Fri Nov 13 2009 Petr Machata <pmachata@redhat.com> - 0.8-3
  103. - Require mpfr-devel, gmp-devel in -devel subpackage
  104. - Don't pass --entry to install-info
  105. * Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-2
  106. - Rename the package to libmpc, it's a better choice of name
  107. - %%preun should uninstall mpc's info page, not make's
  108. - Move info page to -devel
  109. - BR on -devel packages
  110. - Drop postscript documentation
  111. * Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-1
  112. - Initial package.