chkconfig-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362
  1. Summary: A system tool for maintaining the /etc/rc*.d hierarchy.
  2. Summary(ja): /etc/rc.d の階層をメンテナンスするためのシステムツール
  3. Name: chkconfig
  4. Version: 1.3.61
  5. Release: 3%{?_dist_release}
  6. Group: System Environment/Base
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPL
  10. Source: %{name}-%{version}.tar.bz2
  11. Source2: chkconfig.8
  12. Source3: ntsysv.8
  13. Source4: update-alternatives.ja.8
  14. Patch1: chkconfig-1.3.51-vine.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: newt-devel
  17. BuildRequires: popt-devel
  18. Conflicts: initscripts <= 5.30-1
  19. %description
  20. Chkconfig is a basic system utility. It updates and queries runlevel
  21. information for system services. Chkconfig manipulates the numerous
  22. symbolic links in /etc/rc.d, to relieve system administrators of some
  23. of the drudgery of manually editing the symbolic links.
  24. %description -l ja
  25. chkconfig は基本的なシステムユーティリティである。これはシステムサービスの
  26. runlevel の情報をアップデートや検証する。chkconfig は /etc/rc.d の
  27. 多数のシンボリックリンクを操作しますので、システム管理者は手動で
  28. シンボリックリンクをたびたびエディットしなくてもよい。
  29. %package -n ntsysv
  30. Summary: A tool to set the stop/start of system services in a runlevel.
  31. Summary(ja): /etc/rc.d 階階層をメンテナンスするシステムツール
  32. Group: System Environment/Base
  33. %description -n ntsysv
  34. Ntsysv provides a simple interface for setting which system services
  35. are started or stopped in various runlevels (instead of directly
  36. manipulating the numerous symbolic links in /etc/rc.d). Unless you
  37. specify a runlevel or runlevels on the command line (see the man
  38. page), ntsysv configures the current runlevel (5 if you're using X).
  39. %description -n ntsysv -l ja
  40. ntsysv はシステムサービスの runlevel の情報をアップデートや検証する。
  41. ntsysv は システム管理者が直接/etc/rc.d の多数のシンボリックリンクを
  42. 操作することから解放する。
  43. %package -n alternatives
  44. Summary: maintain symbolic links determining default commands (from Debian dpkg utilities)
  45. Summary(ja): コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
  46. Group: System Environment/Base
  47. %description -n alternatives
  48. maintain symbolic links determining default commands (from Debian dpkg utilities)
  49. %description -n alternatives -l ja
  50. コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
  51. %prep
  52. %setup -q
  53. %patch1 -p1
  54. %build
  55. %ifarch sparc
  56. LIBMHACK=-lm
  57. %endif
  58. %__make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" LIBMHACK=$LIBMHACK
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. %__make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} SBINDIR=%{_sbindir} install
  62. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
  63. ln -s rc.d/init.d $RPM_BUILD_ROOT/etc/init.d
  64. for n in 0 1 2 3 4 5 6; do
  65. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/rc${n}.d
  66. ln -s rc.d/rc${n}.d $RPM_BUILD_ROOT/etc/rc${n}.d
  67. done
  68. mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
  69. cp %SOURCE2 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/ja/man8
  70. # alternatives
  71. mv -f $RPM_BUILD_ROOT/%{_sbindir}/*alternatives $RPM_BUILD_ROOT/%{_syssbindir}
  72. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/alternatives
  73. mkdir -p $RPM_BUILD_ROOT/var/lib/rpm/alternatives
  74. install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/ja/man8/alternatives.8
  75. ln -sf alternatives.8.gz $RPM_BUILD_ROOT%{_mandir}/ja/man8/update-alternatives.8.gz
  76. # create compat symlinks
  77. mkdir -p $RPM_BUILD_ROOT/%{_sbindir}
  78. for i in alternatives update-alternatives chkconfig
  79. do
  80. ln -sf /sbin/$i $RPM_BUILD_ROOT/%{_sbindir}/$i
  81. done
  82. %clean
  83. rm -rf $RPM_BUILD_ROOT
  84. %files
  85. %defattr(-,root,root)
  86. /sbin/chkconfig
  87. %{_sbindir}/chkconfig
  88. /etc/init.d
  89. /etc/rc.d/init.d
  90. /etc/rc[0-6].d
  91. /etc/rc.d/rc[0-6].d
  92. %{_mandir}/*/chkconfig*
  93. %{_mandir}/ja/*/chkconfig*
  94. %{_localedir}/*/LC_MESSAGES/chkconfig.mo
  95. %files -n ntsysv
  96. %defattr(-,root,root)
  97. %{_sbindir}/ntsysv
  98. %{_mandir}/*/ntsysv.8*
  99. %{_mandir}/ja/*/ntsysv.8*
  100. %files -n alternatives
  101. %defattr (-, root, root)
  102. /sbin/alternatives
  103. /sbin/update-alternatives
  104. %{_sbindir}/alternatives
  105. %{_sbindir}/update-alternatives
  106. %{_sysconfdir}/alternatives
  107. %{_mandir}/man8/*
  108. %{_mandir}/ja/man8/*
  109. /var/lib/rpm/alternatives
  110. %changelog
  111. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.61-3
  112. - rebuilt with current environment.
  113. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.61-2
  114. - rebuild with VineSeed environment
  115. * Wed Nov 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.61-1
  116. - update to 1.3.61
  117. - create compat symlinks in %%{_sbindir}
  118. * Thu Jun 06 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.60-1
  119. - update to 1.3.60
  120. * Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.51-2
  121. - change BuildRequires: popt-devel intead of popt
  122. * Fri Apr 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.51-1
  123. - new upstream release
  124. - enable fedora version of alternatives
  125. - add alternatives subpackage, replace debian's alternatives
  126. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.37-1
  127. - new upstream release
  128. * Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.34-1vl5
  129. - applied new versioning policy and spec in utf-8
  130. * Fri May 04 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.34-0vl2
  131. - dropped obsoleted Makefile.x86_64.patch
  132. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.34-0vl1
  133. - new upstream release
  134. * Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.17-1vl9
  135. - add Makefile.x86_64.patch
  136. * Wed May 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.17-1vl8
  137. - add Patch10 to skip xinetd parsing if not exist.
  138. * Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.17-1vl7
  139. - rebuild
  140. * Thu Sep 06 2001 akira yamada <akira@vinelinux.org> 1.2.17-1vl6
  141. - Requires -> Conflicts.
  142. apt-0.3.19.cnc.52-3vl1 can handle Conflicts-field nicely, so
  143. Conflicts/Pre-Depends-loop does not happen.
  144. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl5
  145. - Oops not PreReq but Requires. Fixed.
  146. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl4
  147. - change Conflicts: initscripts <= 5.30-1 to PreReq: initscripts > 5.30-1
  148. to avoid Conflicts/Pre-Depends loop on apt
  149. * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  150. - 1.2.17-1vl3
  151. - change checkbox color
  152. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  153. - 1.2.17-1vl2
  154. - rebuilt for VineSeed
  155. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org>
  156. - 1.2.17-1vl1
  157. * Wed Oct 18 2000 Bill Nottingham <notting@redhat.com>
  158. - ignore .rpmnew files (#18915)
  159. - fix typo in error message (#17575)
  160. * Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  161. - make xinetd config files mode 0644, not 644
  162. * Thu Aug 24 2000 Erik Troan <ewt@redhat.com>
  163. - updated it and es translations
  164. * Sun Aug 20 2000 Bill Nottingham <notting@redhat.com>
  165. - get man pages in proper packages
  166. * Sun Aug 20 2000 Matt Wilson <msw@redhat.com>
  167. - new translations
  168. * Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  169. - don't worry about extra whitespace on chkconfig: lines (#16150)
  170. * Thu Aug 10 2000 Trond Eivind Glomsr <teg@redhat.com>
  171. - i18n merge
  172. * Wed Jul 26 2000 Matt Wilson <msw@redhat.com>
  173. - new translations for de fr it es
  174. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  175. - change prereqs
  176. * Sun Jul 23 2000 Bill Nottingham <notting@redhat.com>
  177. - fix ntsysv's handling of xinetd/init files with the same name
  178. * Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
  179. - fix segv when reading malformed files
  180. * Wed Jul 19 2000 Bill Nottingham <notting@redhat.com>
  181. - put links, rc[0-6].d dirs back, those are necessary
  182. * Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
  183. - add quick hack support for reading descriptions from xinetd files
  184. * Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  185. - don't own the /etc/rc[0-6].d symlinks; they're owned by initscripts
  186. * Sat Jul 15 2000 Matt Wilson <msw@redhat.com>
  187. - move back to old file layout
  188. * Thu Jul 13 2000 Preston Brown <pbrown@redhat.com>
  189. - bump copyright date
  190. * Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
  191. - no %pre today. Maybe tomorrow.
  192. * Thu Jul 6 2000 Bill Nottingham <notting@redhat.com>
  193. - put initscripts %pre here too
  194. * Mon Jul 3 2000 Bill Nottingham <notting@redhat.com>
  195. - oops, if we don't prereq initscripts, we *need* to own /etc/rc[0-6].d
  196. * Sun Jul 2 2000 Bill Nottingham <notting@redhat.com>
  197. - add xinetd support
  198. * Tue Jun 27 2000 Matt Wilson <msw@redhat.com>
  199. - changed Prereq: initscripts >= 5.18 to Conflicts: initscripts < 5.18
  200. - fixed sumary and description where a global string replace nuked them
  201. * Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
  202. - what Bill said, but actually build this version
  203. * Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
  204. - don't own /etc/rc.*
  205. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  206. - typo in man page
  207. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  208. - fix description
  209. * Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
  210. - link chkconfig statically against popt
  211. * Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
  212. - fix querying alternate levels
  213. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  214. - don't use strchr to skip unwanted files, look at extension instead (#4166).
  215. * Thu Aug 5 1999 Bill Nottingham <notting@redhat.com>
  216. - fix --help, --verson
  217. * Mon Aug 2 1999 Matt Wilson <msw@redhat.com>
  218. - rebuilt ntsysv against newt 0.50
  219. * Mon Aug 2 1999 Jeff Johnson <jbj@redhat.com>
  220. - fix i18n problem in usage message (#4233).
  221. - add --help and --version.
  222. * Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
  223. - release for Red Hat 6.0
  224. * Thu Apr 8 1999 Matt Wilson <msw@redhat.com>
  225. - added support for a "hide: true" tag in initscripts that will make
  226. services not appear in ntsysv when run with the "--hide" flag
  227. * Thu Apr 1 1999 Matt Wilson <msw@redhat.com>
  228. - added --hide flag for ntsysv that allows you to hide a service from the
  229. user.
  230. * Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
  231. - fix glob, once and for all. Really. We mean it.
  232. * Thu Mar 18 1999 Bill Nottingham <notting@redhat.com>
  233. - revert fix for services@levels, it's broken
  234. - change default to only edit the current runlevel
  235. * Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
  236. - don't remove scripts that don't support chkconfig
  237. * Tue Mar 09 1999 Erik Troan <ewt@redhat.com>
  238. - made glob a bit more specific so xinetd and inetd don't cause improper matches
  239. * Thu Feb 18 1999 Matt Wilson <msw@redhat.com>
  240. - removed debugging output when starting ntsysv
  241. * Thu Feb 18 1999 Preston Brown <pbrown@redhat.com>
  242. - fixed globbing error
  243. - fixed ntsysv running services not at their specified levels.
  244. * Tue Feb 16 1999 Matt Wilson <msw@redhat.com>
  245. - print the value of errno on glob failures.
  246. * Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
  247. - rebuilt for newt 0.40 (ntsysv)
  248. * Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
  249. - add ru.po.
  250. * Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
  251. - build for Raw Hide (slang-1.2.2)
  252. * Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
  253. - translation updates
  254. * Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
  255. - updated czech translation (and use cs instead of cz)
  256. * Tue Sep 22 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
  257. - added pt_BR translations
  258. - added more translatable strings
  259. - support for i18n init.d scripts description
  260. * Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
  261. - built against newt 0.30
  262. - split ntsysv into a separate package
  263. * Thu May 07 1998 Erik Troan <ewt@redhat.com>
  264. - added numerous translations
  265. * Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
  266. - added i18n support
  267. * Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
  268. - added --back