elfutils-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define eu_version 0.161
  3. %define eu_release 2
  4. %global nocheck true
  5. Summary: A collection of utilities and DSOs to handle compiled objects
  6. Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
  7. Name: elfutils
  8. Version: %{eu_version}
  9. Release: %{eu_release}%{?_dist_release}
  10. License: GPLv3+ and (GPLv2+ or LGPLv3+)
  11. Group: Development/Tools
  12. URL: https://fedorahosted.org/elfutils/
  13. Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
  14. #Patch1: elfutils-robustify.patch
  15. #Patch2: elfutils-portability.patch
  16. Patch1: elfutils-portability-%{version}.patch
  17. Patch2: elfutils-0.161-ar-long-name.patch
  18. # libdw: fix offset for sig8 lookup in dwarf_formref_die
  19. Patch3: elfutils-0.161-formref-type.patch
  20. # rhbz#1189928 - Consider sh_addralign 0 as 1
  21. Patch4: elfutils-0.161-addralign.patch
  22. ##VINE##
  23. Patch10: elfutils-0.131-readelf_c.patch
  24. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  25. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: bison >= 1.875
  28. BuildRequires: flex >= 2.5.4a
  29. BuildRequires: bzip2
  30. BuildRequires: bzip2-devel
  31. BuildRequires: zlib-devel
  32. BuildRequires: xz-devel
  33. BuildRequires: gettext
  34. BuildRequires: m4
  35. BuildRequires: gcc >= 3.4
  36. # Need <byteswap.h> that gives unsigned bswap_16 etc.
  37. BuildRequires: glibc-headers >= 2.3.4-11
  38. %define _gnu %{nil}
  39. %define _program_prefix eu-
  40. %description
  41. Elfutils is a collection of utilities, including ld (a linker),
  42. nm (for listing symbols from object files), size (for listing the
  43. section sizes of an object or archive file), strip (for discarding
  44. symbols), readelf (to see the raw ELF file structures), and elflint
  45. (to check for well-formed ELF files).
  46. %package libs
  47. Summary: Libraries to handle compiled objects
  48. Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
  49. License: GPLv2+ or LGPLv3+
  50. Group: System Environment/Libraries
  51. Provides: elfutils-libs-%{_arch} = %{version}-%{release}
  52. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  53. Conflicts: elfutils < %{version}-%{release}
  54. Conflicts: elfutils > %{version}-%{release}
  55. Conflicts: elfutils-devel < %{version}-%{release}
  56. Conflicts: elfutils-devel > %{version}-%{release}
  57. %description libs
  58. The elfutils-libs package contains libraries which implement DWARF, ELF,
  59. and machine-specific ELF handling. These libraries are used by the programs
  60. in the elfutils package. The elfutils-devel package enables building
  61. other programs using these libraries.
  62. %package devel
  63. Summary: Development libraries to handle compiled objects
  64. Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
  65. License: GPLv2+ or LGPLv3+
  66. Group: Development/Libraries
  67. Provides: elfutils-devel-%{_arch} = %{version}-%{release}
  68. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  69. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  70. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  71. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  72. %description devel
  73. The elfutils-devel package contains the libraries to create
  74. applications for handling compiled objects. libebl provides some
  75. higher-level ELF access functionality. libdw provides access to
  76. the DWARF debugging information. libasm provides a programmable
  77. assembler interface.
  78. %package devel-static
  79. Summary: Static archives to handle compiled objects
  80. Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
  81. License: GPLv2+ or LGPLv3+
  82. Group: Development/Libraries
  83. Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
  84. Requires: elfutils-devel-%{_arch} = %{version}-%{release}
  85. Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  86. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  87. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  88. %description devel-static
  89. The elfutils-devel-static package contains the static archives
  90. with the code to handle compiled objects.
  91. %package libelf
  92. Summary: Library to read and write ELF files
  93. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  94. License: GPLv2+ or LGPLv3+
  95. Group: System Environment/Libraries
  96. Provides: libelf = %{version}-%{release}
  97. Obsoletes: libelf <= 0.8.2-2
  98. Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
  99. Conflicts: elfutils < %{version}-%{release}
  100. Conflicts: elfutils > %{version}-%{release}
  101. Conflicts: elfutils-libs < %{version}-%{release}
  102. Conflicts: elfutils-libs > %{version}-%{release}
  103. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  104. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  105. %description libelf
  106. The elfutils-libelf package provides a DSO which allows reading and
  107. writing ELF files on a high level. Third party programs depend on
  108. this package to read internals of ELF files. The programs of the
  109. elfutils package use it also to generate new ELF files.
  110. %package libelf-devel
  111. Summary: Development support for libelf
  112. Summary(ja): libelf の開発用ライブラリ
  113. License: GPLv2+ or LGPLv3+
  114. Group: Development/Libraries
  115. Provides: libelf-devel = %{version}-%{release}
  116. Obsoletes: libelf-devel <= 0.8.2-2
  117. Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  118. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  119. Conflicts: libelf-devel < %{version}-%{release}
  120. %description libelf-devel
  121. The elfutils-libelf-devel package contains the libraries to create
  122. applications for handling compiled objects. libelf allows you to
  123. access the internals of the ELF object file format, so you can see the
  124. different sections of an ELF file.
  125. %package libelf-devel-static
  126. Summary: Static archive of libelf
  127. Summary(ja): libelf の静的ライブラリ
  128. License: GPLv2+ or LGPLv3+
  129. Group: Development/Libraries
  130. Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  131. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  132. %description libelf-devel-static
  133. The elfutils-libelf-static package contains the static archive
  134. for libelf.
  135. # compat32
  136. %package -n compat32-%{name}-libelf
  137. Summary: Library to read and write ELF files
  138. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  139. License: GPLv2+ or LGPLv3+
  140. Group: System Environment/Libraries
  141. Provides: compat32-libelf = %{version}-%{release}
  142. %description -n compat32-%{name}-libelf
  143. The elfutils-libelf package provides a DSO which allows reading and
  144. writing ELF files on a high level. Third party programs depend on
  145. this package to read internals of ELF files. The programs of the
  146. elfutils package use it also to generate new ELF files.
  147. %prep
  148. %setup -q
  149. #patch1 -p1 -b .robustify
  150. %patch1 -p1 -b .portability
  151. %patch2 -p1 -b .ar_long_name
  152. %patch3 -p1 -b .formref_type
  153. %patch4 -p1 -b .addralign
  154. %patch10 -p0 -b .readelf_c
  155. find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
  156. %build
  157. # Remove -Wall from default flags. The makefiles enable enough warnings
  158. # themselves, and they use -Werror. Appending -Wall defeats the cases where
  159. # the makefiles disable some specific warnings for specific code.
  160. RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
  161. %configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
  162. make -s %{?_smp_mflags}
  163. %install
  164. rm -rf ${RPM_BUILD_ROOT}
  165. make -s install DESTDIR=${RPM_BUILD_ROOT}
  166. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
  167. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
  168. %find_lang %{name}
  169. # XXX Nuke unpackaged files
  170. { cd ${RPM_BUILD_ROOT}
  171. rm -f .%{_bindir}/eu-ld
  172. }
  173. %check
  174. make -s %{?_smp_mflags} check || (cat tests/test-suite.log; %{nocheck})
  175. %clean
  176. rm -rf ${RPM_BUILD_ROOT}
  177. %post libs -p /sbin/ldconfig
  178. %postun libs -p /sbin/ldconfig
  179. %post libelf -p /sbin/ldconfig
  180. %postun libelf -p /sbin/ldconfig
  181. %post -n compat32-%{name}-libelf -p /sbin/ldconfig
  182. %postun -n compat32-%{name}-libelf -p /sbin/ldconfig
  183. %files -f %{name}.lang
  184. %defattr(-,root,root)
  185. %doc README TODO
  186. %{_bindir}/eu-addr2line
  187. %{_bindir}/eu-ar
  188. %{_bindir}/eu-elfcmp
  189. %{_bindir}/eu-elflint
  190. %{_bindir}/eu-findtextrel
  191. %{_bindir}/eu-nm
  192. %{_bindir}/eu-objdump
  193. %{_bindir}/eu-ranlib
  194. %{_bindir}/eu-readelf
  195. %{_bindir}/eu-size
  196. %{_bindir}/eu-stack
  197. %{_bindir}/eu-strings
  198. %{_bindir}/eu-strip
  199. #%{_bindir}/eu-ld
  200. %{_bindir}/eu-unstrip
  201. %{_bindir}/eu-make-debug-archive
  202. %files libs
  203. %defattr(-,root,root)
  204. %{_libdir}/libasm-%{version}.so
  205. %{_libdir}/libasm.so.*
  206. %{_libdir}/libdw-%{version}.so
  207. %{_libdir}/libdw.so.*
  208. %dir %{_libdir}/elfutils
  209. %{_libdir}/elfutils/lib*.so
  210. %files devel
  211. %defattr(-,root,root)
  212. %{_includedir}/dwarf.h
  213. %dir %{_includedir}/elfutils
  214. %{_includedir}/elfutils/elf-knowledge.h
  215. %{_includedir}/elfutils/libasm.h
  216. %{_includedir}/elfutils/libebl.h
  217. %{_includedir}/elfutils/libdw.h
  218. %{_includedir}/elfutils/libdwelf.h
  219. %{_includedir}/elfutils/libdwfl.h
  220. %{_includedir}/elfutils/version.h
  221. %{_libdir}/libebl.a
  222. %{_libdir}/libasm.so
  223. %{_libdir}/libdw.so
  224. %files devel-static
  225. %defattr(-,root,root)
  226. %{_libdir}/libasm.a
  227. %{_libdir}/libdw.a
  228. %files libelf
  229. %defattr(-,root,root)
  230. %{_libdir}/libelf-%{version}.so
  231. %{_libdir}/libelf.so.*
  232. %files libelf-devel
  233. %defattr(-,root,root)
  234. %{_includedir}/libelf.h
  235. %{_includedir}/gelf.h
  236. %{_includedir}/nlist.h
  237. %{_libdir}/libelf.so
  238. %files libelf-devel-static
  239. %defattr(-,root,root)
  240. %{_libdir}/libelf.a
  241. %if %{build_compat32}
  242. %files -n compat32-%{name}-libelf
  243. %defattr(-,root,root)
  244. %{_libdir}/libelf-%{version}.so
  245. %{_libdir}/libelf.so.*
  246. %endif
  247. %changelog
  248. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-2
  249. - create compat32-elfutils-libelf subpackage
  250. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
  251. - update to 0.161
  252. - added Japanese summary
  253. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
  254. - update to 0.157
  255. * Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
  256. - add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
  257. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
  258. - update to 0.152
  259. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
  260. - elfutils-libs: changed Group to System Environment/Libraries
  261. - elfutils-libelf: changed Group to System Environment/Libraries
  262. - elfutils-devel: changed Group to Development/Libraries
  263. - elfutils-devel-static: changed Group to Development/Libraries
  264. - elfutils-libelf-devel: changed Group to Development/Libraries
  265. - elfutils-libelf-devel-static: changed Group to Development/Libraries
  266. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
  267. - merged with Fedora 9 0.135-1
  268. - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
  269. - applied new versioning policy
  270. - added elfutils-0.131-readelf_c.patch
  271. - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
  272. - new upstream release
  273. - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
  274. - remove Obsoletes: libelf, libelf-devel from elfutils
  275. - add Obsoletes: libelf to elfutils-libelf
  276. - add Obsoletes: libelf-devel to elfutils-libelf-devel
  277. * Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
  278. - Update to 0.135
  279. - libdwfl: bug fixes
  280. - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
  281. * Wed Apr 9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
  282. - Update to 0.134
  283. - elflint: backend improvements for sparc, alpha (#204170)
  284. - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
  285. - Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
  286. * Sun Mar 2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
  287. - Update to 0.133
  288. - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
  289. - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
  290. - libdwfl: bug fixes and optimization in relocation handling
  291. - elfcmp: bug fix for non-allocated section handling
  292. - ld: implement newer features of binutils linker.
  293. - Install eu-objdump and libasm, now has limited disassembler support.
  294. * Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
  295. - Update to 0.132
  296. - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
  297. - eu-readelf: Fix handling of ET_REL files in archives.
  298. - libcpu: Implement x86 and x86-64 disassembler.
  299. - libasm: Add interface for disassembler.
  300. - all programs: add debugging of branch prediction.
  301. - libelf: new function elf_scnshndx.
  302. * Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
  303. - Update to 0.131
  304. - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
  305. bug fixes for oddly-formatted DWARF
  306. - libdwfl: bug fixes in offline archive support, symbol table handling;
  307. apply partial relocations for dwfl_module_address_section on ET_REL
  308. - libebl: powerpc backend support for Altivec registers
  309. * Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
  310. - Fix ET_REL support.
  311. - Fix odd indentation in eu-readelf -x output.
  312. * Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
  313. - Update to 0.130
  314. - eu-readelf -p option can take an argument like -x for one section
  315. - eu-readelf --archive-index (or -c)
  316. - eu-readelf -n improved output for core dumps
  317. - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
  318. - eu-elflint: ditto
  319. - eu-elflint: stricter checks on debug sections
  320. - eu-unstrip: new options, --list (or -n), --relocate (or -R)
  321. - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
  322. new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
  323. - libebl: backend improvements (#324031)
  324. - libdwfl: build_id support, new functions for it
  325. - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
  326. - libdwfl offline archive support, new script eu-make-debug-archive
  327. * Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
  328. - Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
  329. * Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
  330. - Update to 0.129
  331. - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
  332. - addr2line: new option --symbols (or -S)
  333. - libdw: dwarf_getscopes fixes (#230235)
  334. - libdwfl: dwfl_module_addrsym fixes (#249490)
  335. * Fri Jun 8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
  336. - Update to 0.128
  337. - new program: unstrip
  338. - elfcmp: new option --hash-inexact
  339. - Replace Conflicts: with Provides/Requires using -arch
  340. * Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
  341. - Update to 0.127
  342. - libdw: new function dwarf_getsrcdirs
  343. - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
  344. dwfl_module_address_section
  345. * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
  346. - Update to 0.126
  347. - New program eu-ar.
  348. - libdw: fix missing dwarf_getelf (#227206)
  349. - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
  350. - Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
  351. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
  352. - Fix overeager warn_unused_result build failures.
  353. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
  354. - Update to 0.125
  355. - elflint: Compare DT_GNU_HASH tests.
  356. - move archives into -static RPMs
  357. - libelf, elflint: better support for core file handling
  358. - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
  359. - Resolves: RHBZ #220817, RHBZ #213792
  360. * Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
  361. - eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
  362. - Update to 0.124
  363. - libebl: fix ia64 reloc support (#206981)
  364. - libebl: sparc backend support for return value location
  365. - libebl, libdwfl: backend register name support extended with more info
  366. - libelf, libdw: bug fixes for unaligned accesses on machines that care
  367. - readelf, elflint: trivial bugs fixed
  368. * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
  369. - Update to 0.123
  370. - libebl: Backend build fixes, thanks to Stepan Kasal.
  371. - libebl: ia64 backend support for register names, return value location
  372. - libdwfl: Handle truncated linux kernel module section names.
  373. - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
  374. - elflint: Fix checks to permit --hash-style=gnu format.
  375. * Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
  376. - Fix warnings in elflint compilation.
  377. * Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
  378. - Update to 0.122
  379. - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
  380. - libebl: add function to test for relative relocation
  381. - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
  382. - elflint, readelf: add support for DT_GNU_HASH
  383. - libelf: add elf_gnu_hash
  384. - elflint, readelf: add support for 64-bit SysV-style hash tables
  385. - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
  386. * Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
  387. - Update to 0.121
  388. - libelf: bug fixes for rewriting existing files when using mmap (#187618).
  389. - make all installed headers usable in C++ code (#193153).
  390. - eu-readelf: better output format.
  391. - eu-elflint: fix tests of dynamic section content.
  392. - libdw, libdwfl: handle files without aranges info.
  393. * Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
  394. - rebuild to pick up -devel deps
  395. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
  396. - Update to 0.120
  397. - License changed to GPL, with some exceptions for using
  398. the libelf, libebl, libdw, and libdwfl library interfaces.
  399. Red Hat elfutils is an included package of the Open Invention Network.
  400. - dwarf.h updated for DWARF 3.0 final specification.
  401. - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
  402. - libdwfl: New function dwfl_version; fixes for offline.
  403. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
  404. - bump again for double-long bug on ppc(64)
  405. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
  406. - rebuilt for new gcc4.1 snapshot and glibc changes
  407. * Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
  408. - update to 0.119
  409. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  410. - rebuilt
  411. * Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
  412. - update to 0.118
  413. - elflint: more tests.
  414. - libdwfl: New function dwfl_module_register_names.
  415. - libebl: New backend hook for register names.
  416. - Make sure -fexceptions is always in CFLAGS.
  417. * Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
  418. - update to 0.117
  419. - libdwfl: New function dwfl_module_return_value_location (#166118)
  420. - libebl: Backend improvements for several CPUs
  421. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
  422. - update to 0.116
  423. - libdw fixes, API changes and additions
  424. - libdwfl fixes (#169672)
  425. - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
  426. * Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
  427. - Update requires/conflicts for better biarch update behavior.
  428. * Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
  429. - update to 0.115
  430. - New program eu-strings.
  431. - libdw: New function dwarf_getscopes_die.
  432. - libelf: speed-ups of non-mmap reading.
  433. - Implement --enable-gcov option for configure.
  434. * Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
  435. - update to 0.114
  436. - new program eu-ranlib
  437. - libdw: new calls for inlines
  438. - libdwfl: new calls for offline modules
  439. * Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
  440. - update to 0.113
  441. - elflint: relax a bit. Allow version definitions for defined symbols
  442. against DSO versions also for symbols in nobits sections.
  443. Allow .rodata section to have STRINGS and MERGE flag set.
  444. - strip: add some more compatibility with binutils.
  445. - libdwfl: bug fixes.
  446. - Separate libdw et al into elfutils-libs subpackage.
  447. * Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
  448. - update to 0.112
  449. - elfcmp: some more relaxation.
  450. - elflint: many more tests, especially regarding to symbol versioning.
  451. - libelf: Add elfXX_offscn and gelf_offscn.
  452. - libasm: asm_begin interface changes.
  453. - libebl: Add three new interfaces to directly access machine, class,
  454. and data encoding information.
  455. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
  456. - update portability patch
  457. * Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
  458. - update to 0.111
  459. - libdwfl library now merged into libdw
  460. * Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
  461. - update to 0.110
  462. * Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
  463. - update to 0.109
  464. - verify that libebl modules are from the same build
  465. - new eu-elflint checks on copy relocations
  466. - new program eu-elfcmp
  467. - new experimental libdwfl library
  468. * Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
  469. - robustification of eu-strip and eu-readelf
  470. * Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
  471. - more robustification
  472. * Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
  473. - robustification
  474. * Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
  475. - update to 0.108
  476. - merge strip fixes
  477. - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
  478. - update elf.h from glibc
  479. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
  480. - fix strip -f byte-swapping bug
  481. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
  482. - update to 0.107
  483. - readelf: improve DWARF output format
  484. - elflint: -d option to support checking separate debuginfo files
  485. - strip: fix ET_REL debuginfo files (#156341)
  486. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
  487. - fix some bugs in new code, reenable make check
  488. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
  489. - disable make check for most arches, for now
  490. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
  491. - update to 0.106
  492. * Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
  493. - update to 0.104
  494. * Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
  495. - update to 0.103
  496. * Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
  497. - update to 0.101.
  498. - use %%configure macro to get CFLAGS etc. right
  499. * Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
  500. - upgrade to 0.99.
  501. * Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
  502. - upgrade to 0.97.
  503. * Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
  504. - upgrade to 0.96.
  505. * Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
  506. - rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
  507. warning
  508. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  509. - rebuilt
  510. * Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
  511. - upgrade to 0.95.
  512. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  513. - rebuilt
  514. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  515. - rebuilt
  516. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
  517. - upgrade to 0.94
  518. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
  519. - upgrade to 0.93
  520. * Thu Jan 8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
  521. - full version
  522. - macroized spec file for GPL or OSL builds
  523. - include only libelf under GPL plus wrapper scripts
  524. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
  525. - macroized spec file for GPL or OSL builds
  526. * Wed Jan 7 2004 Ulrich Drepper <drepper@redhat.com>
  527. - split elfutils-devel into two packages.
  528. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
  529. - include only libelf under GPL plus wrapper scripts
  530. * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
  531. - readelf, not readline, in %%description (#111214).
  532. * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
  533. - update to 0.89 (fix eu-strip)
  534. * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
  535. - update to 0.86 (fix eu-strip on s390x/alpha)
  536. - libebl is an archive now; remove references to DSO
  537. * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
  538. - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
  539. * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
  540. - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
  541. * Wed Jul 9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
  542. - upgrade to 0.82 (strip tests fixed on big-endian).
  543. * Tue Jul 8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
  544. - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
  545. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
  546. - upgrade to 0.80 (debugedit changes for kernel in progress).
  547. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  548. - rebuilt
  549. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
  550. - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
  551. * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
  552. - upgrade to 0.78 (libdwarf bugfix, libdw additions).
  553. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  554. - debuginfo rebuild
  555. * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
  556. - use the correct way of identifying the section via the sh_info link.
  557. * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
  558. - update to 0.75 (eu-strip -g fix)
  559. * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
  560. - update to 0.74 (fix for writing with some non-dirty sections)
  561. * Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
  562. - another -0.73 update (with sparc fixes).
  563. - do "make check" in %%check, not %%install, section.
  564. * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
  565. - update to 0.73 (with s390 fixes).
  566. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  567. - rebuilt
  568. * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
  569. - fix arguments to gelf_getsymshndx and elf_getshstrndx
  570. - fix other warnings
  571. - reenable checks on s390x
  572. * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
  573. - temporarily disable checks on s390x, until someone has
  574. time to look at it
  575. * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
  576. - update to 0.72
  577. * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
  578. - update to 0.71
  579. * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
  580. - update to 0.69.
  581. - add "make check" and segfault avoidance patch.
  582. - elfutils-libelf needs to run ldconfig.
  583. * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
  584. - update to 0.68.
  585. * Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
  586. - update to 0.67.
  587. * Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
  588. - update to 0.65.
  589. * Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
  590. - update to 0.64.
  591. * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
  592. - split packages further into elfutils-libelf
  593. * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
  594. - update to 0.63.
  595. * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
  596. - Adjust for dropping libtool
  597. * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
  598. - update to 0.59
  599. * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
  600. - update to 0.56
  601. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
  602. - update to 0.54
  603. * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
  604. - update to 0.53
  605. - drop x86_64 hack, ICE fixed in gcc-3.2-11.
  606. * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
  607. - get beehive to punch a rhpkg generated package.
  608. * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
  609. - build in 8.0.1.
  610. - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
  611. * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
  612. - Add libelf-devel to conflicts for elfutils-devel
  613. * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
  614. - Split into runtime and devel package
  615. * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
  616. - integrate into official sources
  617. * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
  618. - Swaddle.