123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566 |
- %define module Data-Buffer
- %define name perl-%{module}
- %define version 0.04
- %define release 2%{_dist_release}
- Name: %{name}
- Version: %{version}
- Release: %{release}
- Summary: Read/write buffer class
- Group: Development/Languages
- License: GPL or Artistic
- Url: http://search.cpan.org/dist/%{module}/
- Source: http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
- BuildArch: noarch
- BuildRoot: %{_tmppath}/%{name}-%{version}
- Vendor: Project Vine
- Distribution: Vine Linux
- %description
- Data::Buffer implements a low-level binary buffer in which you can get and
- put integers, strings, and other data.
- Internally the implementation is based on pack and unpack,
- such that Data::Buffer is really a layer on top of those built-in functions.
- %prep
- %setup -q -n %{module}-%{version}
- %build
- CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
- %{__make}
- %check
- %{__make} test
- %install
- rm -rf %{buildroot}
- %makeinstall
- rm -f %{buildroot}%{perl_archlib}/perllocal.pod
- rm -rf %{buildroot}%{perl_vendorarch}
- %clean
- rm -rf %{buildroot}
- %files
- %defattr(-,root,root)
- %doc README Changes
- %{_mandir}/man3*/*
- %{perl_vendorlib}/Data/*
- %changelog
- * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.04-2
- - rebuild with perl-5.12.3
- * Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.04-1vl5
- - rebuild with perl 5.10
- - new versioning policy
- * Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.04-0vl1
- - built for VineSeed
- * Sun Mar 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.04-0vl0.43
- - rebuilt to relase for VinePlus 4.2
- * Tue Mar 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.04-0vl0.42
- - built for Vine 4.2 (testing)
|