nghttp2-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %bcond_with test
  3. %bcond_without app
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: Experimental HTTP/2 client, server and proxy
  6. Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
  7. Name: nghttp2
  8. Version: 1.29.0
  9. Release: 2%{?_dist_release}
  10. License: MIT
  11. Group: Applications/Internet
  12. URL: https://nghttp2.org/
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Packager: tomop
  16. Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
  17. %if %{with test}
  18. BuildRequires: CUnit-devel
  19. %endif
  20. BuildRequires: jemalloc-devel
  21. BuildRequires: libboost-devel
  22. BuildRequires: libboost-thread
  23. BuildRequires: libev-devel
  24. BuildRequires: openssl-devel
  25. BuildRequires: zlib-devel
  26. %if %{with app}
  27. Requires: libnghttp2 = %{version}-%{release}
  28. BuildRequires: c-ares-devel
  29. BuildRequires: jansson-devel
  30. BuildRequires: libxml2-devel
  31. %endif
  32. %description
  33. This package contains the HTTP/2 client, server and proxy programs.
  34. %description -l ja
  35. This package contains the HTTP/2 client, server and proxy programs.
  36.  このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
  37. が含まれています。
  38. %package -n libnghttp2
  39. Summary: A library implementing the HTTP/2 protocol
  40. Summary(ja): HTTP/2ライブラリ
  41. Group: Development/Libraries
  42. %description -n libnghttp2
  43. libnghttp2 is a library implementing the Hypertext Transfer Protocol
  44. version 2 (HTTP/2) protocol in C.
  45. %description -l ja -n libnghttp2
  46.  libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
  47. 実装したライブラリです。
  48. %package -n libnghttp2-devel
  49. Summary: Files needed for building applications with libnghttp2
  50. Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
  51. Group: Development/Libraries
  52. Requires: libnghttp2%{?_isa} = %{version}-%{release}
  53. Requires: pkgconfig
  54. %description -n libnghttp2-devel
  55. The libnghttp2-devel package includes libraries and header files needed
  56. for building applications with libnghttp2.
  57. %description -l ja -n libnghttp2-devel
  58.  libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
  59. をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
  60. す。
  61. %package -n compat32-libnghttp2
  62. Summary: A library implementing the HTTP/2 protocol
  63. Summary(ja): HTTP/2ライブラリ
  64. Group: Development/Libraries
  65. %description -n compat32-libnghttp2
  66. libnghttp2 is a library implementing the Hypertext Transfer Protocol
  67. version 2 (HTTP/2) protocol in C.
  68. %description -l ja -n compat32-libnghttp2
  69.  libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
  70. 実装したライブラリです。
  71. %package -n compat32-libnghttp2-devel
  72. Summary: Files needed for building applications with libnghttp2
  73. Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
  74. Group: Development/Libraries
  75. Requires: compat32-libnghttp2%{?_isa} = %{version}-%{release}
  76. Requires: pkgconfig
  77. %description -n compat32-libnghttp2-devel
  78. The libnghttp2-devel package includes libraries and header files needed
  79. for building applications with libnghttp2.
  80. %description -l ja -n compat32-libnghttp2-devel
  81.  libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
  82. をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
  83. す。
  84. %prep
  85. %setup -q
  86. %build
  87. LIBEV_CFLAGS=`pkg-config --cflags libev`
  88. CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS" \
  89. CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS" \
  90. %configure \
  91. %if %{with app}
  92. --enable-app \
  93. %endif
  94. --enable-asio-lib \
  95. --with-pic \
  96. --with-boost \
  97. --with-boost-asio \
  98. --with-boost-system \
  99. --with-boost-thread \
  100. --disable-python-bindings \
  101. --disable-static \
  102. --without-libxml2 \
  103. --without-spdylay
  104. # avoid using rpath
  105. sed -i libtool \
  106. -e 's/^runpath_var=.*/runpath_var=/' \
  107. -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
  108. make %{?_smp_mflags} V=1
  109. %install
  110. %make_install
  111. # not needed on Fedora/RHEL
  112. rm -f %{buildroot}%{_libdir}/libnghttp2*.la
  113. # will be installed via %%doc
  114. rm -f "%{buildroot}%{_datadir}/doc/nghttp2/README.rst"
  115. %if ! %{with app}
  116. rm -f %{buildroot}%{_mandir}/man1/*
  117. %endif
  118. %post -n libnghttp2
  119. /sbin/ldconfig
  120. %postun -n libnghttp2
  121. /sbin/ldconfig
  122. %post -n compat32-libnghttp2
  123. /sbin/ldconfig
  124. %postun -n compat32-libnghttp2
  125. /sbin/ldconfig
  126. %check
  127. %if %{with test}
  128. # test the just built library instead of the system one, without using rpath
  129. export "LD_LIBRARY_PATH=%{buildroot}%{_libdir}:$LD_LIBRARY_PATH"
  130. make %{?_smp_mflags} check
  131. %endif
  132. %if %{with app}
  133. %files
  134. %{_bindir}/h2load
  135. %{_bindir}/nghttp
  136. %{_bindir}/nghttpd
  137. %{_bindir}/nghttpx
  138. %{_bindir}/deflatehd
  139. %{_bindir}/inflatehd
  140. %{_datadir}/nghttp2
  141. %{_mandir}/man1/h2load.1*
  142. %{_mandir}/man1/nghttp.1*
  143. %{_mandir}/man1/nghttpd.1*
  144. %{_mandir}/man1/nghttpx.1*
  145. %endif
  146. %files -n libnghttp2
  147. %{_libdir}/libnghttp2*.so.*
  148. %{_datadir}/%{name}/fetch-ocsp-response
  149. %{!?_licensedir:%global license %%doc}
  150. %license COPYING
  151. %files -n libnghttp2-devel
  152. %{_includedir}/nghttp2
  153. %{_libdir}/pkgconfig/libnghttp2*.pc
  154. %{_libdir}/libnghttp2*.so
  155. %doc README.rst
  156. %if %{build_compat32}
  157. %files -n compat32-libnghttp2
  158. %{_libdir}/libnghttp2*.so.*
  159. %{!?_licensedir:%global license %%doc}
  160. %license COPYING
  161. %files -n compat32-libnghttp2-devel
  162. %{_includedir}/nghttp2
  163. %{_libdir}/pkgconfig/libnghttp2*.pc
  164. %{_libdir}/libnghttp2*.so
  165. %doc README.rst
  166. %endif
  167. %changelog
  168. * Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-2
  169. - rebuilt with libboost-1.66.0.
  170. * Sun Dec 24 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-1
  171. - new upstream release.
  172. - enabled to build apps as default.
  173. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.0-1
  174. - new upstream release.
  175. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.20.0-1
  176. - new upstream release.
  177. - disabled to build apps as default.
  178. * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.17.0-1
  179. - new upstream release.
  180. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
  181. - added compat32-* packages.
  182. * Thu Jul 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
  183. - new upstream release.
  184. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
  185. - initial build for Vne Linux.
  186. * Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
  187. - update to the latest upstream release
  188. * Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
  189. - update to the latest upstream release
  190. * Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
  191. - update to the latest upstream release
  192. * Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
  193. - update to the latest upstream release
  194. * Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
  195. - update to the latest upstream release
  196. * Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
  197. - update to the latest upstream release
  198. * Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
  199. - update to the latest upstream release (fixes CVE-2016-1544)
  200. * Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
  201. - make the package compile with gcc-6
  202. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
  203. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  204. * Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
  205. - update to the latest upstream release
  206. * Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
  207. - update to the latest upstream release (fixes CVE-2015-8659)
  208. * Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
  209. - update to the latest upstream release
  210. * Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
  211. - update to the latest upstream release
  212. * Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
  213. - update to the latest upstream release
  214. * Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
  215. - update to the latest upstream release
  216. * Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
  217. - update to the latest upstream release
  218. * Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
  219. - update to the latest upstream release
  220. * Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
  221. - update to the latest upstream release
  222. * Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
  223. - update to the latest upstream release
  224. * Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
  225. - update to the latest upstream release
  226. * Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
  227. - update to the latest upstream release
  228. * Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
  229. - packaged for Fedora (#1237247)