subversion-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631
  1. %bcond_with systemd
  2. %define neon_version 0.30.2
  3. %define swig_version 3.0.0
  4. %define apache_version 2.4
  5. %define apache_dir /usr
  6. %define swigdirs swig_pydir=%{python3_sitearch}/libsvn swig_pydir_extra=%{python3_sitearch}/svn
  7. Summary: Modern Version Control System
  8. Summary(ja): モダンなバージョン管理システム
  9. Name: subversion
  10. Version: 1.14.2
  11. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  12. Group: programming
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Packager: iwaim, daisuke
  16. License: ASL 2.0
  17. URL: https://subversion.apache.org/
  18. Source0: http://ftp.jaist.ac.jp/pub/apache/subversion/subversion-%{version}.tar.bz2
  19. Source1: subversion.conf
  20. Source2: httpd.davcheck.conf
  21. Source3: filter-requires.sh
  22. Source6: svnserve.service
  23. Source7: svnserve.tmpfiles
  24. Source8: svnserve.sysconf
  25. Patch1: subversion-1.12.0-linking.patch
  26. Patch2: subversion-1.14.0-testwarn.patch
  27. Patch3: subversion-1.14.0-soversion.patch
  28. Patch4: subversion-1.8.0-rubybind.patch
  29. Patch5: subversion-1.8.5-swigplWall.patch
  30. BuildRequires: apache2-devel >= %{apache_version}
  31. BuildRequires: apr-devel, apr-util-devel
  32. BuildRequires: autoconf >= 2.53
  33. BuildRequires: libdb-devel
  34. BuildRequires: expat-devel
  35. BuildRequires: gdbm-devel
  36. BuildRequires: libtool >= 1.4.2
  37. BuildRequires: neon-devel >= %{neon_version}
  38. BuildRequires: openssl-devel
  39. BuildRequires: swig >= %{swig_version}
  40. BuildRequires: texinfo
  41. BuildRequires: zlib-devel
  42. BuildRequires: lz4-devel
  43. BuildRequires: utf8proc-devel
  44. BuildRequires: openldap-devel
  45. BuildRequires: ruby >= 2.2.3
  46. BuildRequires: ruby-devel >= 2.2.3
  47. BuildRequires: perl >= 2:5.26.2
  48. BuildRequires: sqlite3-devel
  49. BuildRequires: krb5-devel
  50. BuildRequires: keyutils-libs-devel
  51. BuildRequires: dbus-devel
  52. BuildRequires: libsecret-devel
  53. BuildRequires: libserf-devel
  54. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  55. %if %{with systemd}
  56. BuildRequires: systemd
  57. %{?systemd_requires}
  58. %endif
  59. %define __perllib_requires %{SOURCE3}
  60. %description
  61. Subversion is a concurrent version control system which enables one
  62. or more users to collaborate in developing and maintaining a
  63. hierarchy of files and directories while keeping a history of all
  64. changes. Subversion only stores the differences between versions,
  65. instead of every complete file. Subversion is intended to be a
  66. compelling replacement for CVS.
  67. %package devel
  68. Summary: Development package for Subversion developers.
  69. Group: programming
  70. Requires: subversion = %{version}-%{release}
  71. Requires: apr-devel, apr-util-devel
  72. %description devel
  73. The subversion-devel package includes the static libraries and include files
  74. for developers interacting with the subversion package.
  75. %package mod_dav_svn
  76. Summary: Apache server module for Subversion server.
  77. Group: servers
  78. Requires: apache2 >= %{apache_version}
  79. Requires: subversion = %{version}-%{release}
  80. %description mod_dav_svn
  81. The subversion-mod_dav_svn package adds the Subversion server Apache module to
  82. the Apache directories and configuration.
  83. %package tools
  84. Summary: Tools for Subversion
  85. Group: programming
  86. BuildRequires: perl >= 5.8.0
  87. Requires: perl >= 5.8.0
  88. Requires: subversion = %{version}-%{release}
  89. %description tools
  90. Tools for Subversion.
  91. %package perl
  92. Summary: Perl bindings to the Subversion libraries
  93. Group: programming
  94. Requires: subversion = %{version}-%{release}
  95. Requires: perl >= 2:5.34.0
  96. %description perl
  97. This package includes the Perl bindings to the Subversion libraries.
  98. %package ruby
  99. Summary: Ruby bindings to the Subversion libraries
  100. Group: programming
  101. Requires: subversion = %{version}-%{release}
  102. Requires: ruby >= 2.0
  103. %description ruby
  104. This package includes the Ruby bindings to the Subversion libraries.
  105. %package -n python3-subversion
  106. Summary: Python bindings to the Subversion libraries
  107. Group: programming
  108. BuildRequires: python3
  109. BuildRequires: python3-devel
  110. BuildRequires: py3c-devel
  111. Requires: subversion = %{version}-%{release}, python3
  112. %description -n python3-subversion
  113. This package includes the Python bindings to the Subversion libraries.
  114. %debug_package
  115. %prep
  116. %setup -q
  117. %patch1 -p1 -b .linking
  118. %patch2 -p1 -b .testwarn
  119. %patch3 -p1 -b .soversion
  120. %patch4 -p1 -b .rubybind
  121. %patch5 -p1 -b .swigplWall
  122. %build
  123. export LANG=ja_JP.UTF-8
  124. # Regenerate the buildsystem, so that:
  125. # 1) patches applied to configure.in take effect
  126. # 2) the swig bindings are regenerated using the system swig
  127. # (2) is not ideal since typically upstream test with a different
  128. # swig version
  129. # This PATH order makes the fugly test for libtoolize work...
  130. mv build-outputs.mk build-outputs.mk.old
  131. export PYTHON=%{__python3}
  132. ### Force regeneration of swig bindings with the buildroot's SWIG.
  133. # Generated files depend on the build/generator/swig/*.py which
  134. # generates them, so when autogen-standalone.mk's autogen-swig target
  135. # is run by autogen.sh it will regenerate them:
  136. touch build/generator/swig/*.py
  137. PATH=/usr/bin:$PATH ./autogen.sh --release
  138. # fix shebang lines, #111498
  139. perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
  140. # fix python executable
  141. perl -pi -e 's|/usr/bin/env python.*|%{svn_python}|' subversion/tests/cmdline/svneditor.py
  142. # override weird -shrext from ruby
  143. export svn_cv_ruby_link="%{__cc} -shared"
  144. export svn_cv_ruby_sitedir_libsuffix=""
  145. export svn_cv_ruby_sitedir_archsuffix=""
  146. %if 0
  147. # Fix include path for ruby2.7
  148. export svn_cv_ruby_includes="-I%{_includedir}"
  149. %endif
  150. export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
  151. export LIBTOOL=/usr/bin/libtool
  152. %configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
  153. --with-swig --with-serf=%{_prefix} \
  154. --with-ruby-sitedir=%{rarchdir} \
  155. --with-apxs=%{_bindir}/apxs \
  156. --disable-mod-activation \
  157. --with-apache-libexecdir=%{_libdir}/apache2/modules/ \
  158. --with-gnome-keyring \
  159. --with-berkeley-db \
  160. --disable-mod-activation \
  161. --disable-static
  162. make %{?_smp_mflags} all tools
  163. make swig-py swig-py-lib %{swigdirs}
  164. make swig-pl swig-pl-lib
  165. make swig-rb swig-rb-lib
  166. %install
  167. rm -rf $RPM_BUILD_ROOT
  168. make install \
  169. install-swig-py \
  170. install-swig-pl-lib \
  171. install-swig-rb \
  172. DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
  173. make pure_vendor_install -C subversion/bindings/swig/perl/native \
  174. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  175. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
  176. install -m 755 -d $RPM_BUILD_ROOT%{_libdir}/apache2/modules
  177. # Add subversion.conf configuration file into apache2/conf.d directory.
  178. install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
  179. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
  180. # Remove unpackaged files
  181. rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
  182. $RPM_BUILD_ROOT%{python3_sitearch}/*/*.{a,la} \
  183. $RPM_BUILD_ROOT%{_libdir}/*.la
  184. # The SVN build system is broken w.r.t. DSO support; it treats
  185. # normal libraries as DSOs and puts them in $libdir, whereas they
  186. # should go in some subdir somewhere, and be linked using -module,
  187. # etc. So, forcibly nuke the .so's for libsvn_auth_{gnome,kde},
  188. # since nothing should ever link against them directly.
  189. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libsvn_auth_*.so
  190. # remove stuff produced with Perl modules
  191. find $RPM_BUILD_ROOT -type f \
  192. -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
  193. -print0 | xargs -0 rm -f
  194. # make Perl modules writable so they get stripped
  195. find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
  196. xargs -0 chmod 755
  197. # unnecessary libraries for swig bindings
  198. rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
  199. # Remove unnecessary ruby libraries
  200. rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
  201. # Trim what goes in docdir
  202. rm -rf tools/*/*.in tools/test-scripts
  203. # Rename authz_svn INSTALL doc for docdir
  204. ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
  205. # Install bash completion
  206. install -Dpm 644 tools/client-side/bash_completion \
  207. $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/svn
  208. for comp in svnadmin svndumpfilter svnlook svnsync svnversion; do
  209. ln -s svn \
  210. $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/${comp}
  211. done
  212. # Install tools ex diff*
  213. make install-tools DESTDIR=$RPM_BUILD_ROOT toolsdir=%{_bindir}
  214. rm -f $RPM_BUILD_ROOT%{_bindir}/diff*
  215. for f in svn-populate-node-origins-index \
  216. svnauthz-validate svnmucc svnraisetreeconflict; do
  217. echo %{_bindir}/$f
  218. done | tee tools.files | sed 's/^/%%exclude /' > exclude.tools.files
  219. %find_lang %{name}
  220. cat %{name}.lang exclude.tools.files >> %{name}.files
  221. %if %{with systemd}
  222. install -D -p -m 644 %{SOURCE6} %{buildroot}%{_unitdir}/svnserve.service
  223. install -D -p -m 644 %{SOURCE7} %{buildroot}%{_tmpfilesdir}/svnserve.conf
  224. install -D -p -m 644 %{SOURCE8} %{buildroot}%{_sysconfdir}/sysconfig/svnserve
  225. %endif
  226. %if %{with systemd}
  227. %post
  228. %systemd_post svnserve.service
  229. %preun
  230. %systemd_preun svnserve.service
  231. %postun
  232. %systemd_postun_with_restart svnserve.service
  233. %endif
  234. %files
  235. %defattr(-,root,root)
  236. %license LICENSE
  237. %doc BUGS CHANGES COMMITTERS NOTICE INSTALL README
  238. %{_bindir}/*
  239. %{_libdir}/libsvn_*.so.*
  240. %{_localedir}/*/*/subversion.mo
  241. %{_mandir}/man*/*
  242. %{_datadir}/bash-completion/completions/*
  243. %dir %{_sysconfdir}/subversion
  244. %exclude %{_mandir}/man*/*::*
  245. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  246. %exclude %{_libdir}/libsvn_swig_py*.so.*
  247. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  248. %if %{with systemd}
  249. %{_unitdir}/svnserve.service
  250. %{_tmpfilesdir}/svnserve.conf
  251. %config(noreplace) %{_sysconfdir}/sysconfig/svnserve
  252. %endif
  253. %files devel
  254. %defattr(-,root,root)
  255. %{_includedir}/subversion-1
  256. %{_libdir}/libsvn*.so
  257. %exclude %{_libdir}/libsvn_swig_perl*
  258. %exclude %{_libdir}/libsvn_swig_py*
  259. %exclude %{_libdir}/libsvn_swig_ruby*
  260. %{_datadir}/pkgconfig/*
  261. %files mod_dav_svn
  262. %defattr(-,root,root)
  263. %config(noreplace) /etc/apache2/conf.d/subversion.conf
  264. %{apache_dir}/%{_lib}/apache2/modules/mod_*.*
  265. %files tools -f tools.files
  266. %defattr(-,root,root)
  267. %files perl
  268. %defattr(-,root,root,-)
  269. %{perl_vendorarch}/auto/SVN
  270. %{perl_vendorarch}/SVN
  271. %{_libdir}/libsvn_swig_perl*
  272. %{_mandir}/man*/*::*
  273. %files ruby
  274. %defattr(-,root,root,-)
  275. %{_libdir}/libsvn_swig_ruby*
  276. %{rarchdir}/svn
  277. %files -n python3-subversion
  278. %defattr(-,root,root,-)
  279. %{_libdir}/libsvn_swig_py*
  280. %{python3_sitearch}/*
  281. %changelog
  282. * Fri May 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.2-1
  283. - new upstream release.
  284. * Thu Nov 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.1-3
  285. - rebuilt with perl-5.34.0.
  286. * Mon Nov 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.1-2
  287. - rebuilt with ruby-3.0.2.
  288. * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.1-1
  289. - new upstream release.
  290. - re-imported patches from rawhide.
  291. * Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.0-1
  292. - new upstream release.
  293. * Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.2-1
  294. - new upstream release.
  295. - dropped Patch1 and 2.
  296. - imported Patch1 and 2 from rawhide.
  297. - switched to python3.
  298. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.4-1
  299. - new upstream release.
  300. - rebuilt with perl-5.26.
  301. - dropped BR:libgnome-keyring-devel.
  302. - added BR:libxcrypt-devel,libnsl2-devel,libsecret-devel,utf8proc-devel.
  303. * Wed May 31 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.17-1
  304. - update to 1.8.17
  305. * Sat Sep 12 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-4
  306. - rebuild with ruby-2.2.3
  307. * Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.9-3
  308. - build with Perl 5.16
  309. - using %%__perllib_requires
  310. * Fri Jun 27 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-2
  311. - rebuild with ruby-2.1.2-6
  312. * Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-1
  313. - update to 1.8.9
  314. - remove unneeded explisit dependency
  315. - add BR: apache2-devel >= 2.4
  316. - add BR: libdb-devel instead of db4-devel
  317. - add R: apache2 > 2.4 to mod_dav_svn
  318. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  319. - update to 1.8.8
  320. - add BR: libserf-devel to handle http* scheme
  321. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
  322. - update to 1.7.7
  323. - rebuild with ruby-1.9.3
  324. * Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
  325. - new upstream release
  326. - update License
  327. - update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
  328. - drop deplibs patch (Patch1)
  329. - drop obsolete patch files: Patch6, 10
  330. * Fri Jun 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  331. - new upstream release with security fix (CVE-2011-1752, 1783, 1921)
  332. - add configure option with-gnome-keyring
  333. - add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
  334. - fix Packager name
  335. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
  336. - build with perl 5.12.3
  337. - add Requires: perl(:MODULE_COMPAT_...)
  338. * Sat Mar 5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
  339. - new upstream release with security fix
  340. - add Vendor/Distri tags
  341. * Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
  342. - new upstream release
  343. * Tue Mar 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
  344. - fix <BTS:VineLinux:941>
  345. - using rpm macro: rarchdir
  346. - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
  347. - using rpm macros: perl_vendorarch and python_sitearch
  348. - add BuildRequires: sqlite3-devel krb5-devel
  349. * Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  350. - new upstream release
  351. - update URL
  352. - update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
  353. - update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
  354. - stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
  355. - stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
  356. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
  357. - new upstream release
  358. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
  359. - new upstream release
  360. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
  361. - rebuilt with python-2.5.2
  362. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
  363. - new upstream release
  364. - rebuild with neon-0.28.2
  365. - dropped old-Patch10 by adding --disable-neon-version-check to %%configure
  366. - added Patch6, 8, 9, 10 from Fedora Core
  367. * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
  368. - Correct install location of java stuff (#433295)
  369. * Wed Aug 8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
  370. - fix build with new glibc open()-as-macro
  371. - build all swig code in %%build, not %%install
  372. * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
  373. - build /usr/bin/* as PIEs
  374. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  375. - rebuild with expat-2.0.1
  376. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
  377. - new upstream release
  378. - add Patch10 to build with neon.
  379. 1.3.2-0vl5 does not support neon..
  380. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
  381. - rebuild with new neon
  382. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
  383. - rebuilt with new toolchain and db4-4.3.x
  384. * Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
  385. - modified %%files section for lib64 architecture
  386. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
  387. - new upstream release
  388. - rebuild with new openldap-2.3.24
  389. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
  390. - new upstream release
  391. - change Group to Develoment/Tools
  392. - build with apr-1.2.7/apr-util-1.2.7
  393. - require apr/apr-util instead of apache2-apr
  394. - build with swig-1.3.29
  395. - split {perl,python,ruby} related files to subpackage.
  396. * Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
  397. - new upstream release
  398. - add noreplace option for config file
  399. * Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
  400. - fix Requires and BuildPreReq.
  401. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
  402. - new upstream release.
  403. - add swig-runtime to 'BuildPreReq:'.
  404. - fix %%files.
  405. * Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
  406. - require neon version 0.24.7 for ra_dav
  407. - add BuildPreReq: openldap-devel
  408. - replace BuildPreReq: httpd to BuildPreReq: apache2
  409. - replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
  410. * Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
  411. - new upstream release
  412. * Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
  413. - new upstream release
  414. * Fri Jun 4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
  415. - new upstream release
  416. - clean up specfile.
  417. * Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
  418. - new upstream release
  419. - build with apache2-2.0.47
  420. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
  421. - build Vine Linux
  422. * Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
  423. - Enabled RA_DAV checking.
  424. Now requires httpd package to build because of RA_DAV tests.
  425. * Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
  426. - Created tools package to hold the tools.
  427. * Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
  428. - Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
  429. version of APR/APR-UTILS as of 2003.01.15.
  430. - Added svnversion command.
  431. * Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
  432. - Create a svnadmin.static which is copied to svnadmin-version-release
  433. when the package is erased, so users can still dump/load their repositories
  434. even after they have upgraded the RPM package.
  435. * Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
  436. - SWIG now builds so we can use cvs2svn.
  437. * Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
  438. - Made cvs2svn conditional (at least until we can get it to build consistently
  439. and work).
  440. * Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
  441. - Added SWIG dependencies to add cvs2svn capabilities.
  442. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
  443. - Now requires neon-0.22.0.
  444. * Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
  445. - Took out loading mod_dav_svn from subversion.spec file and put it in
  446. subversion.conf file which goes into the apache conf directory.
  447. - Simplify what gets put into httpd.conf to only the include for the
  448. subversion.conf file.
  449. (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
  450. me to do this).
  451. * Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
  452. - Updated to APR/APR-UTIL 2002-08-08.
  453. * Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
  454. - Updated to APACHE/APR/APR-UTIL 2002-06-25.
  455. - Previous version had a few problems because of missing apache error/ files.
  456. * Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
  457. - Updated to apache-2.0.40-0.3.
  458. - Updated to subversion-0.13.1-2318.
  459. * Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
  460. - Updated for RedHat 7.3 (autoconf253).
  461. - Added a bunch of pre-requisites I didn't know were needed because I built a
  462. new machine that didn't have them already installed.
  463. - Fixed installation of man and info documentation pages.
  464. * Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
  465. - Back to apache-libapr* stuff, hopefully to stay.
  466. * Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
  467. - Fixed expat.patch to not have to make so many changes by writing a small
  468. shell script that changes libexpat to -lexpat.
  469. * Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
  470. - Updated to neon-0.19.2.
  471. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
  472. - Back to using apr and apr-util separately from apache.
  473. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
  474. - Updated to APR and APR-UTIL 2002.02.11.
  475. - Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
  476. - Took out a (now non-existant) documentation file.
  477. - Moved SPEC file changelog to after all package definitions.
  478. * Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
  479. - Updated to neon-0.18.5.
  480. - Broke up apache and apache-devel into apache-apr, apache-apr-devel,
  481. apache-apr-utils, and apache-apr-utils-devel.
  482. - Updated apache to APR and APR-UTILS to 2002.02.03 version.
  483. * Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
  484. - Now builds without the separate APR package as it is built into and
  485. "exported" from apache-2.0.31-0.3.
  486. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
  487. - Took out patches to install procedure now not required because of fixes
  488. in rev 1130.
  489. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
  490. - Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
  491. program was added.
  492. * Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
  493. - Release M5-r340: Added the subversion-server package.
  494. * Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
  495. - Release M5-r327: No longer need expat-lite. We can use the normal expat.
  496. * Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
  497. - Release M3-r117: Initial Version.