libxslt-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Library providing the Gnome XSLT engine
  3. Summary(ja): XSLT エンジンライブラリ
  4. Name: libxslt
  5. Version: 1.1.27
  6. Release: 1%{_dist_release}
  7. License: MIT
  8. Group: System Environment/Libraries
  9. URL: http://xmlsoft.org/XSLT/
  10. Source0: ftp://xmlsoft.org/XSLT/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: libxml2-devel >= 2.6.27
  13. BuildRequires: zlib-devel >= 1.1.4
  14. BuildRequires: python python-devel perl libxml2-python
  15. Requires: libxml2 >= 2.6.27
  16. %description
  17. This C library allows to transform XML files into other XML files
  18. (or HTML, text, ...) using the standard XSLT stylesheet transformation
  19. mechanism. To use it you need to have a version of libxml2 >= 2.6.15
  20. installed. The xsltproc command is a command line interface to the XSLT engine
  21. %description -l ja
  22. XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
  23. %package devel
  24. Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
  25. Summary(ja): XSLT 開発用ファイル
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. Requires: libxml2-devel >= 2.6.27
  29. %description devel
  30. This C library allows to transform XML files into other XML files
  31. (or HTML, text, ...) using the standard XSLT stylesheet transformation
  32. mechanism. To use it you need to have a version of libxml2 >= 2.6.15
  33. installed.
  34. %description devel -l ja
  35. XSLTのための開発用ファイルです。
  36. %package static
  37. Summary: Static library for %{name}
  38. Summary(ja): %{name} のスタティックライブラリ
  39. Group: Development/Libraries
  40. Requires: libxslt-devel = %{version}-%{release}
  41. %description static
  42. The libxslt-static package contains the static library for libxslt.
  43. %package python
  44. Summary: Python bindings for the libxslt library
  45. Group: Development/Libraries
  46. Requires: libxslt = %{version}-%{release}
  47. Requires: libxml2 >= 2.6.27
  48. Requires: python
  49. %description python
  50. The libxslt-python package contains a module that permits applications
  51. written in the Python programming language to use the interface
  52. supplied by the libxslt library to apply XSLT transformations.
  53. This library allows to parse sytlesheets, uses the libxml2-python
  54. to load and save XML and HTML files. Direct access to XPath and
  55. the XSLT transformation context are possible to extend the XSLT language
  56. with XPath functions written in Python.
  57. # compat32
  58. %package -n compat32-%{name}
  59. Summary: Library providing the Gnome XSLT engine
  60. Summary(ja): XSLT エンジンライブラリ
  61. Group: System Environment/Libraries
  62. Requires: %{name} = %{version}-%{release}
  63. Requires: compat32-libxml2 >= 2.6.27
  64. %description -n compat32-%{name}
  65. This C library allows to transform XML files into other XML files
  66. (or HTML, text, ...) using the standard XSLT stylesheet transformation
  67. mechanism. To use it you need to have a version of libxml2 >= 2.6.15
  68. installed. The xsltproc command is a command line interface to the XSLT engine
  69. %description -n compat32-%{name} -l ja
  70. XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
  71. %package -n compat32-%{name}-devel
  72. Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
  73. Summary(ja): XSLT 開発用ファイル
  74. Group: Development/Libraries
  75. Requires: %{name}-devel = %{version}-%{release}
  76. Requires: compat32-%{name} = %{version}-%{release}
  77. Requires: compat32-libxml2-devel >= 2.6.27
  78. %description -n compat32-%{name}-devel
  79. This C library allows to transform XML files into other XML files
  80. (or HTML, text, ...) using the standard XSLT stylesheet transformation
  81. mechanism. To use it you need to have a version of libxml2 >= 2.6.15
  82. installed.
  83. %description -n compat32-%{name}-devel -l ja
  84. XSLTのための開発用ファイルです。
  85. %prep
  86. %setup -q
  87. %build
  88. %configure --without-crypto
  89. make %{?_smp_mflags}
  90. %install
  91. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  92. make DESTDIR=$RPM_BUILD_ROOT install
  93. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  94. rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.{a,la}
  95. #
  96. # this is a bit ugly but tries to generate the bindings for all versions
  97. # of python installed
  98. #for i in %{prefix}/include/python*
  99. #do
  100. # py_version=`echo $i | sed "s+%{prefix}/include/python++"`
  101. # if test -x %{prefix}/bin/python$py_version
  102. # then
  103. # echo generating bindings for Python $py_version
  104. # (cd python ; make clean ; \
  105. # make PYTHON="%{prefix}/bin/python$py_version" \
  106. # PYTHON_VERSION="$py_version"; \
  107. # make PYTHON="%{prefix}/bin/python$py_version" \
  108. # PYTHON_VERSION="$py_version" \
  109. # prefix=$RPM_BUILD_ROOT%{prefix} \
  110. # mandir=$RPM_BUILD_ROOT%{_mandir} install)
  111. # fi
  112. #done
  113. %clean
  114. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  115. %post -p /sbin/ldconfig
  116. %postun -p /sbin/ldconfig
  117. %post -n compat32-%{name} -p /sbin/ldconfig
  118. %postun -n compat32-%{name} -p /sbin/ldconfig
  119. %files
  120. %defattr(-, root, root)
  121. %doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
  122. %doc doc/*.html doc/html doc/tutorial doc/EXSLT
  123. %{_bindir}/xsltproc
  124. %{_libdir}/lib*.so.*
  125. %{_mandir}/man1/xsltproc.1*
  126. %files devel
  127. %defattr(-, root, root)
  128. %doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
  129. %{_includedir}/*
  130. %{_libdir}/lib*.so
  131. %{_libdir}/*.sh
  132. %{_libdir}/pkgconfig/*.pc
  133. %{_bindir}/xslt-config
  134. %{_datadir}/aclocal/*.m4
  135. %{_mandir}/man3/*
  136. %files static
  137. %defattr(-, root, root)
  138. %{_libdir}/lib*.a
  139. %files python
  140. %defattr(-, root, root)
  141. %doc AUTHORS ChangeLog NEWS README Copyright FEATURES
  142. %doc python/TODO
  143. %doc python/libxsltclass.txt
  144. %doc python/tests/*.py
  145. %doc python/tests/*.xml
  146. %doc python/tests/*.xsl
  147. %{_libdir}/python*/site-packages/libxslt.py
  148. %{_libdir}/python*/site-packages/libxsltmod*
  149. # compat32
  150. %if %{build_compat32}
  151. %files -n compat32-%{name}
  152. %defattr(-, root, root)
  153. %{_libdir}/lib*.so.*
  154. %files -n compat32-%{name}-devel
  155. %defattr(-, root, root)
  156. %{_libdir}/lib*.so
  157. %{_libdir}/lib*.a
  158. %{_libdir}/*.sh
  159. %endif
  160. %changelog
  161. * Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-1
  162. - new upstream release
  163. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.26-7
  164. - rebuild with python-2.7.2
  165. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.1.26-6
  166. - build with rpm-4.8.1-1 for pkg-config file
  167. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-5
  168. - rebuilt with gcc-4.4.3-3 on ppc
  169. * Sat Feb 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-4
  170. - removed %%{_libdir}/python*/site-packages/*.{a,la}
  171. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.26-3
  172. - rebuild with python-2.6
  173. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-2
  174. - rebuilt with new toolchain
  175. * Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-1
  176. - new upstream release
  177. - split static libraries to subpackage
  178. * Mon Jul 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.23-3
  179. - added compat32 package for x86_64 arch support
  180. * Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.23-2
  181. - rebuilt with python-2.5.2
  182. * Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.23-1
  183. - new upstream release
  184. - remove *.la file from devel package
  185. * Wed Oct 3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.22-0vl1
  186. - new upstream release
  187. * Sun Feb 4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-0vl1
  188. - new upstream release
  189. - updated BuildRequires: libxml2-devel >= 2.6.27
  190. - updated Requires: libxml2 >= 2.6.27
  191. * Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.17-0vl1
  192. - added --libdir=%%{_libdir} to ./configure option
  193. * Fri Jul 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.17-0vl1
  194. - new upstream release
  195. - updated libxml2 dependancy
  196. * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.15-0vl1
  197. - new upstream release
  198. * Tue Apr 12 2005 Satoshi MACHINO <machino@vinelinux.org> 1.1.14-0vl1
  199. - new upstream release
  200. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 1.1.12-0vl3
  201. - rebuild with python-2.4.1-0vl1
  202. * Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl2
  203. - build without libgcrypt (add --without-crypto to configure option)
  204. - remove lines about snapshot release
  205. - use %%makeinstall
  206. - add %%{_libdir}/python*/site-packages/libxsltmod* to python package
  207. * Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl1
  208. - source upgrade (security fix)
  209. - BuildPrereq: libxml2-devel >= 2.6.15
  210. - Requires: libxml2 >= 2.6.15
  211. - add doc/EXSLT to %%doc
  212. * Tue Sep 07 2004 Satoshi MACHINO <machino@vinelinux.org> 1.1.9-0vl1
  213. - new upstream version
  214. * Tue Apr 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.6-0vl1
  215. - source upgrade
  216. - BuildPrereq: libxml2-devel >= 2.6.8
  217. - Requires: libxml2 >= 2.6.8
  218. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl2
  219. - rebuild with python-2.3.3-0vl1
  220. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl1.1
  221. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  222. * Thu Mar 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.4-0vl1
  223. - new upstream release
  224. * Thu Jan 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.2-0vl1
  225. - new upstream release
  226. - BuildPrereq: libxml2-devel >= 2.6.3
  227. - Requires: libxml2 >= 2.6.3
  228. * Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.32-0vl1
  229. - new upstream release
  230. * Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.31-0vl1
  231. - source upgrade
  232. * Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.30-0vl1
  233. - source upgrade
  234. * Tue Feb 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.26-0vl1
  235. - source upgrade
  236. - BuildPrereq: libxml2-devel >= 2.5.2
  237. - Requires: libxml2 >= 2.5.2
  238. * Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.23-0vl1
  239. - source upgrade
  240. - build with new toolchains
  241. * Tue Oct 29 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-0vl1
  242. - source update to 1.0.22
  243. - BuildPrereq: libxml2-devel >= 2.4.23
  244. - Requires: libxml2 >= 2.4.23
  245. * Sun May 26 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.17-1vl1
  246. - merged with 1.0.17-1
  247. -- Fri Feb 8 2002 Daniel.Veillard <veillard@redhat.com>
  248. - added the python module
  249. - clean up spec
  250. - BuildPrereq: libxml2-devel >= 2.4.17
  251. - Requires: libxml2 >= 2.4.17
  252. * Mon Mar 18 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl2
  253. - changed License to MIT (not LGPL)
  254. - add BuildPrereq: zlib-devel >= 1.1.4 perl
  255. * Sun Feb 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl1
  256. - source update
  257. - BuildPrereq: libxml2-devel >= 2.4.13
  258. * Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.9-0vl1
  259. - add gtk-doc to BuildPrereq
  260. * Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com>
  261. - 1.0.1-1vl2
  262. - Build for VineSeed
  263. * Fri Aug 24 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
  264. - 1.0.1-1vl1
  265. - cleaning
  266. * Fri Jul 27 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
  267. - 1.0.1-1vl0
  268. - modify for Vine Linux 2.1x
  269. * Mon Jan 22 2001 Daniel.Veillard <daniel@veillard.com>
  270. - created based on libxml2 spec file