nginx-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. %if "%{_dist_release}" > "vl6"
  4. %define nginx_user www-data
  5. %else
  6. %define nginx_user nginx
  7. %endif
  8. %define nginx_group %{nginx_user}
  9. %define nginx_home %{_localstatedir}/lib/nginx
  10. %define nginx_home_tmp %{nginx_home}/tmp
  11. %define nginx_home_cache %{nginx_home}/cache
  12. %define nginx_logdir %{_localstatedir}/log/nginx
  13. %define nginx_confdir %{_sysconfdir}/nginx
  14. %define nginx_datadir %{_datadir}/nginx
  15. %define nginx_webroot %{nginx_datadir}/html
  16. Summary: Robust, small and high performance http and reverse proxy server
  17. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  18. Name: nginx
  19. Version: 1.2.2
  20. Release: 1%{?_dist_release}
  21. Group: System Environment/Daemons
  22. # BSD License (two clause)
  23. # http://www.freebsd.org/copyright/freebsd-license.html
  24. License: BSD
  25. URL: http://nginx.net/
  26. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  27. Source1: %{name}.init
  28. Source2: %{name}.logrotate
  29. Source3: nginx-virtual.conf.template
  30. Source4: nginx-ssl.conf
  31. Source5: %{name}.sysconfig
  32. Source10: nginx-vine.conf
  33. Source11: nginx-default-vine
  34. Source20: proxy_cache.conf
  35. Source100: nginx-index.html
  36. Source101: poweredby-vine.png
  37. Source102: nginx-logo.png
  38. Source103: nginx-50x.html
  39. Source104: nginx-404.html
  40. %define ngx_fancyindex_version 0.3
  41. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
  42. %define nginx_accept_language_module_version 02262ce
  43. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  44. %define passenger_version 3.0.12
  45. Source1020: passenger-%{passenger_version}.tar.gz
  46. %define upstream_fair_version 2131c73
  47. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  48. %define mod_wsgi_version 6975f0ec7eeb
  49. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  50. # removes -Werror in upstream build scripts. -Werror conflicts with
  51. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  52. Patch0: nginx-auto-cc-gcc.patch
  53. # configuration patch to match all the Vine Linux paths for logs, pid files
  54. # etc.
  55. Patch1: nginx-conf.patch
  56. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  57. BuildRequires: pcre-devel
  58. BuildRequires: zlib-devel
  59. BuildRequires: openssl-devel
  60. BuildRequires: gd-devel
  61. BuildRequires: perl
  62. BuildRequires: perl(ExtUtils::Embed)
  63. BuildRequires: libxml2-devel
  64. BuildRequires: libxslt-devel
  65. BuildRequires: curl-devel
  66. %if "%{?_dist_release}" == "vl4"
  67. Requires: perl >= 5.8.6
  68. %else
  69. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  70. %endif
  71. # for /usr/sbin/useradd
  72. Requires(pre): shadow-utils
  73. Requires(post): chkconfig
  74. # for /sbin/service
  75. Requires(preun): chkconfig, initscripts
  76. Requires(postun): initscripts
  77. %if "%{_dist_release}" > "vl6"
  78. Requires(pre): www-common
  79. %endif
  80. Provides: webserver
  81. Vendor: Project Vine
  82. Distribution: Vine Linux
  83. Packager: daisuke
  84. %description
  85. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  86. proxy server written by Igor Sysoev.
  87. %description -l ja
  88. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  89. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  90. - HTTP(S) サーバ
  91. - HTTP(S) リバースプロキシサーバ
  92. - IMAP/POP3 プロキシサーバ
  93. %package passenger
  94. Summary: Nginx with mod_passenger support
  95. Summary(ja): Passenger サポート入りの Nginx
  96. Group: System Environment/Daemons
  97. BuildRequires: ruby, rubygems, rubygem-rake
  98. Requires: nginx
  99. %description passenger
  100. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  101. This package contains nginx server with passenger support.
  102. %description -l ja passenger
  103. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  104. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  105. - HTTP(S) サーバ
  106. - HTTP(S) リバースプロキシサーバ
  107. - IMAP/POP3 プロキシサーバ
  108. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  109. %prep
  110. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
  111. %patch0 -p0
  112. %patch1 -p1
  113. %build
  114. # nginx does not utilize a standard configure script. It has its own
  115. # and the standard configure options cause the nginx configure script
  116. # to error out. This is is also the reason for the DESTDIR environment
  117. # variable. The configure script(s) have been patched (Patch1 and
  118. # Patch2) in order to support installing into a build environment.
  119. export DESTDIR=%{buildroot}
  120. ## build with passenger
  121. ./configure \
  122. --user=%{nginx_user} \
  123. --group=%{nginx_group} \
  124. --prefix=%{nginx_datadir} \
  125. --sbin-path=%{_sbindir}/%{name} \
  126. --conf-path=%{nginx_confdir}/%{name}.conf \
  127. --error-log-path=%{nginx_logdir}/error.log \
  128. --http-log-path=%{nginx_logdir}/access.log \
  129. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  130. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  131. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  132. --pid-path=%{_localstatedir}/run/%{name}.pid \
  133. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  134. --with-file-aio \
  135. --with-ipv6 \
  136. --with-http_ssl_module \
  137. --with-http_realip_module \
  138. --with-http_addition_module \
  139. --with-http_xslt_module \
  140. --with-http_image_filter_module \
  141. --with-http_sub_module \
  142. --with-http_dav_module \
  143. --with-http_flv_module \
  144. --with-http_gzip_static_module \
  145. --with-http_random_index_module \
  146. --with-http_secure_link_module \
  147. --with-http_stub_status_module \
  148. --with-http_perl_module \
  149. --with-mail \
  150. --with-mail_ssl_module \
  151. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  152. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  153. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  154. %if %{with wsgi}
  155. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  156. %endif
  157. --add-module=passenger-%{passenger_version}/ext/nginx \
  158. %ifarch i686
  159. --with-cpu-opt=pentiumpro \
  160. --with-zlib-asm=pentiumpro \
  161. --with-md5-asm \
  162. --with-sha1-asm \
  163. %endif
  164. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  165. make %{?_smp_mflags}
  166. mv objs/nginx objs/nginx.passenger
  167. ## build without passenger
  168. ./configure \
  169. --user=%{nginx_user} \
  170. --group=%{nginx_group} \
  171. --prefix=%{nginx_datadir} \
  172. --sbin-path=%{_sbindir}/%{name} \
  173. --conf-path=%{nginx_confdir}/%{name}.conf \
  174. --error-log-path=%{nginx_logdir}/error.log \
  175. --http-log-path=%{nginx_logdir}/access.log \
  176. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  177. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  178. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  179. --pid-path=%{_localstatedir}/run/%{name}.pid \
  180. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  181. --with-file-aio \
  182. --with-ipv6 \
  183. --with-http_ssl_module \
  184. --with-http_realip_module \
  185. --with-http_addition_module \
  186. --with-http_xslt_module \
  187. --with-http_image_filter_module \
  188. --with-http_sub_module \
  189. --with-http_dav_module \
  190. --with-http_flv_module \
  191. --with-http_gzip_static_module \
  192. --with-http_random_index_module \
  193. --with-http_secure_link_module \
  194. --with-http_stub_status_module \
  195. --with-http_perl_module \
  196. --with-mail \
  197. --with-mail_ssl_module \
  198. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  199. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  200. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  201. %if %{with wsgi}
  202. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  203. %endif
  204. %ifarch i686
  205. --with-cpu-opt=pentiumpro \
  206. --with-zlib-asm=pentiumpro \
  207. --with-md5-asm \
  208. --with-sha1-asm \
  209. %endif
  210. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  211. make %{?_smp_mflags}
  212. %install
  213. rm -rf %{buildroot}
  214. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  215. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  216. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  217. find %{buildroot} -type f -empty -exec rm -f {} \;
  218. find %{buildroot} -type f -exec chmod 0644 {} \;
  219. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  220. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  221. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  222. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  223. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  224. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  225. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  226. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  227. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  228. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  229. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  230. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  231. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  232. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  233. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  234. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  235. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  236. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  237. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  238. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  239. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  240. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  241. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  242. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  243. %if %{with wsgi}
  244. %{__install} -p -m 0644 \
  245. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  246. %{buildroot}%{nginx_confdir}
  247. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  248. %endif
  249. # upstream fair module document
  250. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  251. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  252. # convert to UTF-8 all files that give warnings.
  253. for textfile in CHANGES
  254. do
  255. mv $textfile $textfile.old
  256. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  257. rm -f $textfile.old
  258. done
  259. %clean
  260. rm -rf %{buildroot}
  261. %post
  262. if [ $1 == 1 ]; then
  263. /sbin/chkconfig --add %{name}
  264. fi
  265. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  266. %post passenger
  267. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  268. %preun
  269. if [ $1 = 0 ]; then
  270. /sbin/service %{name} stop >/dev/null 2>&1
  271. /sbin/chkconfig --del %{name}
  272. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  273. fi
  274. %preun passenger
  275. if [ $1 = 0 ]; then
  276. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  277. fi
  278. %postun
  279. if [ $1 == 2 ]; then
  280. /sbin/service %{name} upgrade || :
  281. fi
  282. %files
  283. %defattr(-,root,root,-)
  284. %doc LICENSE CHANGES README
  285. %doc README.upstream_fair
  286. %doc %{?with_wsgi:README.mod_wsgi}
  287. %{nginx_datadir}/
  288. %{_sbindir}/%{name}.normal
  289. %{_mandir}/man3/%{name}.3pm.gz
  290. %{_initrddir}/%{name}
  291. %dir %{nginx_confdir}
  292. %dir %{nginx_confdir}/conf.d
  293. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  294. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  295. %config(noreplace) %{nginx_confdir}/sites.d/*
  296. %config(noreplace) %{nginx_confdir}/win-utf
  297. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  298. %config(noreplace) %{nginx_confdir}/mime.types.default
  299. %config(noreplace) %{nginx_confdir}/fastcgi_params
  300. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  301. %config(noreplace) %{nginx_confdir}/koi-win
  302. %config(noreplace) %{nginx_confdir}/koi-utf
  303. %config(noreplace) %{nginx_confdir}/%{name}.conf
  304. %config(noreplace) %{nginx_confdir}/mime.types
  305. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  306. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  307. %config(noreplace) %{nginx_confdir}/scgi_params
  308. %config(noreplace) %{nginx_confdir}/scgi_params.default
  309. %config(noreplace) %{nginx_confdir}/uwsgi_params
  310. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  311. %if %{with wsgi}
  312. %config(noreplace) %{nginx_confdir}/wsgi_vars
  313. %endif
  314. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  315. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  316. %dir %{perl_vendorarch}/auto/%{name}
  317. %{perl_vendorarch}/%{name}.pm
  318. %{perl_vendorarch}/auto/%{name}/%{name}.so
  319. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  320. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  321. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  322. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  323. %files passenger
  324. %defattr(-,root,root,-)
  325. %doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
  326. %doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
  327. %doc passenger-%{passenger_version}/doc/Architectural\ overview.*
  328. %doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
  329. %doc passenger-%{passenger_version}/doc/template
  330. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  331. %doc passenger-%{passenger_version}/doc/images
  332. %{_sbindir}/%{name}.passenger
  333. %changelog
  334. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  335. - update to 1.2.2
  336. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  337. - update to 1.2.1
  338. - change nginx user from nginx to www-data
  339. - R(pre): www-common
  340. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  341. - update to 1.2.0
  342. - update passenger to 3.0.12
  343. - drop http_upstream_keepalive
  344. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  345. - new upstream release
  346. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  347. - update to 1.0.12
  348. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  349. - update to 1.0.11
  350. - update passenger to 3.0.11
  351. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  352. - update to 1.0.10
  353. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  354. - update passenger to 3.0.9
  355. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  356. - update to 1.0.6
  357. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  358. - update to 1.0.4
  359. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  360. - add gnosek-nginx-upstream-fair module
  361. - add ngx_http_upstream_keepalive module
  362. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  363. - add nginx-passenger sub pakckage
  364. - use alternatives to choose nginx with or without passenger
  365. - add BR: ruby, rubygems, rubygem-rake
  366. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  367. - update to 1.0.2
  368. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  369. - update to 1.0.1
  370. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  371. - add bcond_with wsgi for mod_wsgi
  372. - add bcond_with passenger
  373. - you need to install rake.gem to build with this option.
  374. - add Provides: webserver
  375. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  376. - new upstream release 1.0.0!
  377. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  378. - rebuild with perl-5.12.3
  379. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  380. - update to 0.8.54
  381. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  382. - update to 0.8.53
  383. - add nginx_accept_language_module
  384. * Sat Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  385. - update to 0.8.50
  386. - update ngx-fancyindex to 0.3
  387. - add BR: libxml2-devel, libxslt-devel
  388. - add scgi_params* and uwsgi_params* to %%files
  389. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  390. - update to 0.8.35 (development version)
  391. - add sites.d/ to store vitualhost settings
  392. - split out default server settings to sites.d/default
  393. - add fancyindex module
  394. * Wed Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  395. - new upstream release
  396. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  397. - update to 0.7.62 (included security fix: VU#180065)
  398. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  399. - fix typo
  400. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  401. - add translated descriptions
  402. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  403. - update 404.html/50x.html to use powered by vine logo.
  404. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  405. - initial build for Vine Linux
  406. - update to 0.7.61
  407. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  408. - init script updates from Gena Makhomed
  409. - remove nginx-upstream-fair
  410. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  411. - update to 0.6.36
  412. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  413. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  414. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  415. - rebuild
  416. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  417. - update to 0.6.35
  418. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  419. - rebuild with new openssl
  420. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  421. - update to 0.6.34
  422. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  423. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  424. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  425. - update to 0.6.33
  426. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  427. - update to 0.6.32
  428. - nginx now supports DESTDIR so removed the patches that enabled it
  429. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  430. - init script fixes
  431. - resolve 'listen 80 default' [#447873]
  432. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  433. - update to 0.6.31
  434. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  435. - upate to new upstream stable branch 0.6
  436. - added 3rd party module nginx-upstream-fair
  437. - added default webpages
  438. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  439. - update init script to match recommended guidelines
  440. - add /etc/nginx/conf.d support [#443280]
  441. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  442. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  443. - add Requires for versioned perl (libperl.so)
  444. - drop silly file Requires
  445. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  446. - Autorebuild for GCC 4.3
  447. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  448. - update to 0.5.35
  449. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  450. - update to 0.5.34
  451. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  452. - Rebuild for deps
  453. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  454. - update to 0.5.33
  455. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  456. - updated to 0.5.32
  457. - fixed rpmlint UTF-8 complaints.
  458. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  459. - added --with-http_stub_status_module build option.
  460. - added --with-http_sub_module build option.
  461. - added use of pcre-config --cflags
  462. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  463. - Update to 0.5.31
  464. - specify license is BSD
  465. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  466. - Add BuildRequires: perl-devel - fixing rawhide build
  467. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  468. - Update to 0.5.30
  469. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  470. - Update to 0.5.29
  471. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  472. - Update to 0.5.28
  473. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  474. - Update to 0.5.27
  475. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  476. - Update to 0.5.26
  477. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  478. - Update to 0.5.19
  479. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  480. - Update to 0.5.17
  481. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  482. - Update to 0.5.16
  483. - add ownership of /usr/share/nginx/html (#233950)
  484. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  485. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  486. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  487. - fixed package review bugs (#233522) given by kevin@tummy.com
  488. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  489. - create patches to assist with building for Fedora
  490. - initial packaging for Fedora