notification-daemon-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262
  1. %define gtk2_version 2.10.0
  2. %define glib2_version 2.8.0
  3. %define dbus_version 0.60
  4. %define libnotify_version 0.4.0
  5. Summary: Notification Daemon
  6. Name: notification-daemon
  7. Version: 0.4.0
  8. Release: 9%{?_dist_release}
  9. URL: http://www.galago-project.org/specs/notification/
  10. License: GPL
  11. Group: System Environment/Libraries
  12. Source0: %{name}-%{version}.tar.bz2
  13. Source1: notification-daemon-0.4.0-ja.po
  14. Patch1: notification-daemon-0.4.0-ja.patch
  15. # patches from ubuntu
  16. Patch103: notification-daemon-0.4.0-fix-xinerama-stack.patch
  17. Patch104: notification-daemon-0.4.0-dont-crash-on-critical-warnings.patch
  18. Patch105: notification-daemon-0.4.0-spacing.patch
  19. Patch107: notification-daemon-0.4.0-memleak-daemon.patch
  20. Patch109: notification-daemon-0.4.0-change-themes-crash-rev1.patch
  21. # vine theme (based on coco) and vine5 theme (old theme)
  22. # http://github.com/tatofoo/notification-daemon-engine-coco
  23. Source200: notification-daemon-engine-vine.tar.bz2
  24. # Vine patch
  25. # use gvfs-open instead of gnome-open
  26. Patch300: notification-daemon-0.4.0-browser.patch
  27. # dirty hack to change notification bubble position.
  28. Patch310: notification-daemon-0.4.0-position.patch
  29. # add vine and vine5 theme
  30. Patch320: notification-daemon-0.4.0-vine-theme.patch
  31. # change default to slider
  32. Patch330: notification-daemon-0.4.0-default-theme.patch
  33. # change default notify location to TOP_RIGHT
  34. Patch340: notification-daemon-0.4.0-location.patch
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  36. Requires: dbus >= %{dbus_version}
  37. Requires: dbus-glib >= %{dbus_version}
  38. Requires(post): GConf2
  39. BuildRequires: glib2-devel >= %{glib2_version}
  40. BuildRequires: dbus-devel >= %{dbus_version}
  41. BuildRequires: dbus-glib-devel >= %{dbus_version}
  42. BuildRequires: libnotify-devel >= %{libnotify_version}
  43. BuildRequires: libsexy-devel
  44. BuildRequires: libwnck-devel
  45. BuildRequires: GConf2-devel
  46. BuildRequires: libglade2-devel
  47. BuildRequires: gstreamer-devel
  48. BuildRequires: desktop-file-utils
  49. %description
  50. notification-daemon is the server implementation of the freedesktop.org
  51. desktop notification specification.
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. Packager: daisuke
  55. %prep
  56. %setup -q -a 200
  57. %patch1 -p1 -b .ja
  58. %patch103 -p1
  59. %patch104 -p1
  60. %patch105 -p0
  61. %patch107 -p1
  62. %patch109 -p1
  63. %patch300 -p1
  64. %patch310 -p1
  65. %patch320 -p1
  66. %patch330 -p1
  67. %patch340 -p1
  68. # install japanese message catalog
  69. %{__cp} %{SOURCE1} po/ja.po
  70. %build
  71. autoreconf -f -i
  72. %configure --disable-schemas-install
  73. make %{?_smp_mflags}
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. %{__make} install DESTDIR=$RPM_BUILD_ROOT
  77. %find_lang %name
  78. # remove unpackaged files
  79. rm -f $RPM_BUILD_ROOT%{_libdir}/notification-daemon-1.0/engines/*.{a,la}
  80. # install desktop file
  81. desktop-file-install --delete-original \
  82. --dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
  83. --add-category DesktopSettings \
  84. ${RPM_BUILD_ROOT}%{_datadir}/applications/notification-properties.desktop
  85. %pre
  86. if [ "$1" -gt 1 ]; then
  87. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  88. gconftool-2 --makefile-uninstall-rule \
  89. %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
  90. fi
  91. %post
  92. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  93. gconftool-2 --makefile-install-rule \
  94. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  95. touch --no-create %{_datadir}/icons/hicolor
  96. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  97. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  98. fi
  99. %preun
  100. if [ "$1" -eq 0 ]; then
  101. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  102. gconftool-2 --makefile-uninstall-rule \
  103. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  104. fi
  105. %postun
  106. touch --no-create %{_datadir}/icons/hicolor
  107. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  108. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  109. fi
  110. %clean
  111. rm -rf %{buildroot}
  112. %files -f %{name}.lang
  113. %defattr(-,root,root)
  114. %doc COPYING ChangeLog NEWS
  115. %{_bindir}/notification-properties
  116. %{_sysconfdir}/gconf/schemas/%{name}.schemas
  117. %dir %{_libdir}/notification-daemon-1.0
  118. %dir %{_libdir}/notification-daemon-1.0/engines
  119. %{_libdir}/notification-daemon-1.0/engines/*.so
  120. %{_libexecdir}/notification-daemon
  121. %{_datadir}/dbus-1/services/org.freedesktop.Notifications.service
  122. %{_datadir}/applications/notification-properties.desktop
  123. %{_datadir}/icons/hicolor/16x16/apps/notification-properties.png
  124. %{_datadir}/icons/hicolor/22x22/apps/notification-properties.png
  125. %{_datadir}/icons/hicolor/24x24/apps/notification-properties.png
  126. %{_datadir}/icons/hicolor/32x32/apps/notification-properties.png
  127. %{_datadir}/icons/hicolor/48x48/apps/notification-properties.png
  128. %{_datadir}/icons/hicolor/scalable/apps/notification-properties.svg
  129. %{_datadir}/notification-daemon/notification-properties.glade
  130. %changelog
  131. * Wed Apr 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.0-9
  132. - add BuildRequires: gstreamer-devel, desktop-file-utils
  133. * Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.0-8
  134. - add missing BuildRequires: GConf2-devel, libglade2-devel
  135. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 0.4.0-7
  136. - rebuilt with rpm-4.8.1-3
  137. * Sun May 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-6
  138. - update Source201
  139. * Sat May 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-5
  140. - rebuild with new toolchain
  141. - update Source201 (add modified coco theme as new default)
  142. - add patch300 to use gvfs-open instead of gnome-open
  143. - add patch310 to change notification bubble position
  144. - add patch320 to add new vine theme
  145. - add patch340 to change default notification localtion to top_right.
  146. - add BR: libwnck-devel
  147. * Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-4
  148. - add Categories=DesktopSettings for notification-properties.desktop
  149. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-3
  150. - add Source200, Patch200,201
  151. - add vine theme engine based on ubuntu engine.
  152. - add patch101-109 from ubuntu
  153. - Patch103: fix xinerama stack
  154. - Patch104: dont crash on critical warnings
  155. - Patch105: fix notification spacing
  156. - Patch107: fix memleak
  157. - Patch109: fix crash on theme changing
  158. * Sat Mar 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-2
  159. - add japanese translation (Source1 and Patch1)
  160. - prperly install/uninstall gconf schemas
  161. - update gtk icon cache with %%post, %%postun
  162. * Fri Mar 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-1
  163. - new upstream release
  164. - change required gtk2 version to 2.10.0
  165. * Sun Oct 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-1
  166. - applied new versioning policy
  167. * Tue Dec 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl2
  168. - rebuilt with libwnck 2.20.2
  169. * Tue May 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl1
  170. - new upstream release
  171. - rebuilt with libsexy 0.1.10
  172. - added BuildRequores: libsexy-devel
  173. * Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.5-0vl1
  174. - new upstream release
  175. * Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.4-0vl1
  176. - initial build for Vine Linux partialy based on FC package.
  177. * Wed Mar 08 2006 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-9
  178. - Add patch to fix struct handling in the dbus glib binding for dbus 0.61
  179. so image data works again
  180. * Tue Feb 14 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-8
  181. - BuildRequires love, for all you lovers out there.
  182. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-7.1
  183. - bump again for double-long bug on ppc(64)
  184. * Thu Feb 09 2006 Florian La Roche <laroche@redhat.com>
  185. - remove empty scripts from .spec file
  186. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-6.1
  187. - rebuilt for new gcc4.1 snapshot and glibc changes
  188. * Fri Feb 3 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-6
  189. - Add patch to determine whether a compositing manager is running
  190. when drawing a new notification bubble, as long as the CM grabs
  191. the appropriate XSelection.
  192. * Fri Jan 20 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-5
  193. - Make it so that marked-up messages appear with markup
  194. * Thu Jan 12 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-4
  195. - Provide desktop-notification-daemon, since libnotify requires a
  196. notification deamon, but not this specific one. Other notification
  197. daemons can exist on the system so long as they meet the provides
  198. (and the API of course).
  199. * Mon Jan 9 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-3
  200. - Fix positioning of the notification bubble to not draw off-screen
  201. * Wed Dec 14 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
  202. - Actuall release of 0.3.1
  203. * Thu Nov 17 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-1
  204. - Upgrade to upstream 0.3.1
  205. * Tue Nov 15 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.0-1
  206. - inital build