blueman-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174
  1. Summary: Full featured bluetooth manager for GNOME/GTK
  2. Summary(ja): GNOME/GTK 用の高機能な Bluetooth マネージャ
  3. Name: blueman
  4. Version: 1.21
  5. Release: 4%{?_dist_release}
  6. License: GPLv2+
  7. Group: Applications/System
  8. Url: http://blueman-project.org/
  9. Source0: %{name}-%{version}.tar.gz
  10. Buildroot: %{_tmppath}/%{name}-%{version}
  11. BuildRequires: desktop-file-utils
  12. BuildRequires: perl(XML::Parser)
  13. BuildRequires: glib2-devel
  14. BuildRequires: gtk2-devel
  15. BuildRequires: GConf2-devel
  16. BuildRequires: pygtk2-devel
  17. BuildRequires: intltool
  18. BuildRequires: startup-notification-devel
  19. BuildRequires: pygobject-devel
  20. BuildRequires: notify-python
  21. BuildRequires: bluez-libs-devel >= 4.37
  22. BuildRequires: python-devel
  23. BuildRequires: python-pyrex
  24. BuildRequires: dbus-python
  25. Requires: obex-data-server
  26. Requires: notify-python
  27. Requires: pygtk2
  28. Requires: gnome-python
  29. Requires: dbus-python
  30. Requires: pygobject
  31. Requires: PolicyKit-gnome
  32. Provides: dbus-bluez-pin-helper
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. Packager: daisuke
  36. %description
  37. Blueman is designed to provide simple, yet effective means for
  38. controlling BlueZ API and simplifying bluetooth tasks such as:
  39. * Connecting to 3G/EDGE/GPRS via dial-up
  40. * Connecting to/Creating bluetooth networks
  41. * Connecting to input devices
  42. * Connecting to audio devices
  43. * Sending/Receiving/Browsing files via OBEX
  44. * Pairing
  45. Blueman also integrates with Network Manager 0.7, so any Dialup/Network
  46. connections will be made available (via HAL) to Network Manager.
  47. %prep
  48. %setup -q
  49. %build
  50. %configure --disable-desktop-update --disable-icon-update --disable-schemas-install
  51. %__make %{?_smp_mflags}
  52. %install
  53. rm -rf %{buildroot}
  54. %__make install DESTDIR=${RPM_BUILD_ROOT}
  55. mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/devices
  56. cp $RPM_BUILD_ROOT%{_datadir}/blueman/icons/hicolor/scalable/devices/* \
  57. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/devices/
  58. desktop-file-install --vendor="" \
  59. --add-category="GNOME;GTK" \
  60. --add-category="Settings;HardwareSettings" \
  61. --dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/%{name}-manager.desktop
  62. %find_lang %{name}
  63. %clean
  64. rm -rf %{buildroot}
  65. %post
  66. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  67. gconftool-2 --makefile-install-rule \
  68. %{_sysconfdir}/gconf/schemas/blueman-manager.schemas >& /dev/null ||:
  69. update-desktop-database %{_datadir}/applications >& /dev/null || :
  70. touch --no-create %{_datadir}/icons/hicolor
  71. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  72. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  73. fi
  74. %pre
  75. if [ "$1" -gt 1 ]; then
  76. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  77. gconftool-2 --makefile-uninstall-rule \
  78. %{_sysconfdir}/gconf/schemas/blueman-manager.schemas >& /dev/null ||:
  79. fi
  80. %preun
  81. if [ "$1" -eq 0 ]; then
  82. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  83. gconftool-2 --makefile-uninstall-rule \
  84. %{_sysconfdir}/gconf/schemas/blueman-manager.schemas >& /dev/null ||:
  85. fi
  86. %postun
  87. update-desktop-database %{_datadir}/applications >& /dev/null || :
  88. touch --no-create %{_datadir}/icons/hicolor
  89. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  90. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  91. fi
  92. %files -f %{name}.lang
  93. %defattr(-,root,root)
  94. %{_sysconfdir}/dbus-1/system.d/org.%{name}*.conf
  95. %{_sysconfdir}/xdg/autostart/%{name}.desktop
  96. %{_bindir}/%{name}-*
  97. %{_datadir}/applications/%{name}-manager.desktop
  98. %{_datadir}/%{name}/ui/*.ui
  99. %{_datadir}/%{name}/icons/hicolor/*/*s/*.png
  100. %{_datadir}/%{name}/icons/hicolor/scalable/status/*.svg
  101. %{_datadir}/%{name}/icons/hicolor/scalable/actions/*.svg
  102. %{_datadir}/icons/hicolor/scalable/devices/*.svg
  103. %{_datadir}/icons/hicolor/*/apps/*.png
  104. %{_datadir}/icons/hicolor/scalable/apps/*.svg
  105. %{_datadir}/blueman/icons/hicolor/scalable/devices/blueman-device.svg
  106. %{_datadir}/blueman/icons/hicolor/scalable/devices/blueman-serial.svg
  107. %{_datadir}/dbus-1/services/%{name}-applet.service
  108. %{_datadir}/dbus-1/system-services/org.%{name}*.service
  109. %{_datadir}/polkit-1/actions/org.blueman.policy
  110. %{_mandir}/man1/%{name}*1.*
  111. %{python_sitelib}/*
  112. %if %_lib == lib64
  113. %{python_sitearch}/*
  114. %endif
  115. %{_libexecdir}/%{name}-*
  116. %changelog
  117. * Mon Apr 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-4
  118. - rebuild with rpm-4.8.1
  119. * Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-3
  120. - add BuildRequires: gtk2-devel
  121. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.21-2
  122. - rebuilt with python-2.6.4
  123. * Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-1
  124. - new upstream release
  125. * Mon Jan 04 2010 Shu KONNO <owa@bg.wakwak.com> 1.10-2
  126. - added _blueman to %%files (if lib64)
  127. * Tue May 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-1
  128. - initial build for Vine Linux
  129. * Fri Mar 27 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-4mdv2009.1
  130. + Revision: 361574
  131. - don't explicitely requires notification-daemon
  132. * Mon Mar 02 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-3mdv2009.1
  133. + Revision: 347587
  134. - requires python-blueman
  135. * Mon Mar 02 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-2mdv2009.1
  136. + Revision: 347346
  137. - fix files
  138. - BR python-dbus
  139. - fix BR
  140. - BR python-devel
  141. - import blueman