SDL_gfx-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172
  1. Summary: SDL graphics drawing primitives and other support functions
  2. Summary(ja): SDLの基本的な描画機能とその他の機能を提供するライブラリ
  3. Name: SDL_gfx
  4. Version: 2.0.23
  5. Release: 1%{?_dist_release}
  6. Source0: %{name}-%{version}.tar.gz
  7. License: LGPL
  8. Group: System Environment/Libraries
  9. URL: http://www.ferzkopp.net/joomla/
  10. BuildRequires: SDL-devel >= 1.2.0
  11. BuildRequires: libX11-devel
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. %define all_x86 i386 i586 i686 athlon
  14. %description
  15. The SDL_gfx library evolved out of the SDL_gfxPrimitives code which
  16. provided basic drawing routines such as lines, circles or polygons and
  17. SDL_rotozoom which implemented a interpolating rotozoomer for SDL
  18. surfaces.
  19. The current components of the SDL_gfx library are:
  20. * Graphic Primitives (SDL_gfxPrimitves.h)
  21. * Rotozoomer (SDL_rotozoom.h)
  22. * Framerate control (SDL_framerate.h)
  23. %ifarch %{all_x86}
  24. * MMX image filters (SDL_imageFilter.h)
  25. %endif
  26. The library is backwards compatible to the above mentioned code. Its
  27. is written in plain C and can be used in C++ code.
  28. %description -l ja
  29. SDL_gfx は SDL_gfxPrimitives コードから発展したライブラリであり、線や
  30. 円、ポリゴンの描画を行う基本的な機能と、SDL サーフェースの回転・拡大
  31. ・縮小を行う SDL_rotozoom を提供します。
  32. 現在の SDL_gfx ライブラリに含まれているのは:
  33. * 基本的な画像の描画 (SDL_gfxPrimitves.h)
  34. * SDL サーフェースの回転、拡大、縮小 (SDL_rotozoom.h)
  35. * フレームレート制御 (SDL_framerate.h)
  36. %ifarch %{all_x86}
  37. * MMX イメージフィルタ (SDL_imageFilter.h)
  38. %endif
  39. このライブラリは先に述べたコードとの後方互換性を持っています。この
  40. ライブラリは C 言語で記述されており、C++ からでも使用できます。
  41. #-----------------------------------------------------------------------------
  42. %package devel
  43. Summary: Libraries and includes to develop SDL_gfx programs
  44. Summary(ja): SDL_gfx 用の開発ライブラリおよびヘッダファイル
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}
  47. %description devel
  48. This package includes the files needed for developing and compiling
  49. applications which use the SDL_gfx library.
  50. You should install the SDL_gfx-devel package if you would like to
  51. develop applications based on SDL_gfx.
  52. %description devel -l ja
  53. このパッケージは SDL_gfx ライブラリを使用するアプリケーションを開発
  54. するのに必要なライブラリやヘッダファイルを含んでいます。
  55. SDL_gfx をベースにしたアプリケーションを開発するなら、このパッケージ
  56. をインストールしてください。
  57. #-----------------------------------------------------------------------------
  58. %package demos
  59. Summary: SDL_gfx demo programs
  60. Summary(ja): SDL_gfx デモプログラム
  61. Group: Applications/Other
  62. Requires: %{name} = %{version}
  63. AutoReqProv: no
  64. %description demos
  65. SDL_gfx demo applications and source code.
  66. It is necessary to compile to run demo applications.
  67. %description demos -l ja
  68. SDL_gfx のデモアプリケーションとソースコードです。
  69. デモアプリケーションを実行するには自分でコンパイルする必要があります。
  70. #-----------------------------------------------------------------------------
  71. %prep
  72. %setup -q
  73. %build
  74. %ifarch %{ix86}
  75. %configure --disable-static
  76. %else
  77. %configure --disable-static --disable-mmx
  78. %endif
  79. %__make
  80. %install
  81. %__rm -rf $RPM_BUILD_ROOT
  82. %__make install DESTDIR=$RPM_BUILD_ROOT
  83. %__install -d $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos
  84. %__install -d $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos/m4
  85. %__install -m644 %{_builddir}/%{name}-%{version}/Test/m4/* $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos/m4
  86. %__rm -rf %{_builddir}/%{name}-%{version}/Test/m4
  87. %__install -m755 %{_builddir}/%{name}-%{version}/Test/* $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos
  88. rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
  89. %clean
  90. %__rm -rf $RPM_BUILD_ROOT
  91. %post -p /sbin/ldconfig
  92. %postun -p /sbin/ldconfig
  93. %files
  94. %defattr(-,root,root)
  95. %doc AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README*
  96. %doc Docs/
  97. %{_libdir}/libSDL_gfx.so.*
  98. %files devel
  99. %defattr(-,root,root)
  100. %{_libdir}/pkgconfig/SDL_gfx.pc
  101. %{_libdir}/libSDL_gfx.so
  102. %{_includedir}/SDL/*
  103. %files demos
  104. %defattr(-,root,root)
  105. %{_datadir}/SDL_gfx-demos
  106. %changelog
  107. * Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.23-1
  108. - new upstream release
  109. - add BuildRequires: libX11-devel
  110. * Mon Sep 20 2010 IWAI, Masaharu <iwai@alib.jp> 2.0.22-1
  111. - new upstream release
  112. - add pkg-config file in devel package
  113. - remove *.a
  114. - move *.so file: main to devel
  115. * Sat Sep 20 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-1
  116. - new upstream release
  117. - applied new versioning policy
  118. - spec in UTF-8
  119. * Mon Jan 15 2007 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
  120. - new upstream release
  121. - added %post and %postun section
  122. * Mon Jun 26 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.13-1vl2
  123. - rebuild to correct version mismatch.(1vl1 already exist in Vine Plus/3.0)
  124. - change SDL_gfx-demos Group to Applications/Other.
  125. - add SDL_gfx-demos description.
  126. * Wed Aug 24 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.13-0vl2
  127. - disable MMX on non-x86 archtecture
  128. * Sat May 14 2005 kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.13-0vl1
  129. - initial build for VineSeed Plus.