123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203 |
- # Filter provides from Python libraries
- %{?filter_setup:
- %filter_provides_in %{python_sitearch}.*\.so$
- %filter_setup
- }
- Name: OpenColorIO
- Version: 1.0.8
- Release: 8%{?_dist_release}
- Summary: Enables color transforms and image display across graphics apps
- Summary(ja): アプリケーション間での色変換と画像表示を行うためのライブラリ
- License: BSD
- Group: System Environment/Libraries
- URL: http://opencolorio.org/
- # Github archive was generated on the fly using the following URL:
- # https://github.com/imageworks/OpenColorIO/tarball/v1.0.8
- Source0: %{name}-%{version}.tar.gz
- Patch0: OpenColorIO-pull_300.patch
- Patch1: OpenColorIO-yaml_cpp3.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: cmake
- BuildRequires: help2man
- BuildRequires: texlive-collection-fontsrecommended
- BuildRequires: texlive-collection-latexextra
- BuildRequires: texlive-collection-latexrecommended
- # Libraries
- BuildRequires: python-devel
- BuildRequires: mesa-libGL-devel mesa-libGLU-devel
- BuildRequires: libX11-devel libXmu-devel libXi-devel
- BuildRequires: freeglut-devel
- BuildRequires: glew-devel
- BuildRequires: zlib-devel
- #######################
- # Unbundled libraries #
- #######################
- BuildRequires: tinyxml-devel
- BuildRequires: lcms2-devel
- #BuildRequires: yaml-cpp-devel
- # The following bundled projects are only used for document generation.
- #BuildRequires: python-docutils
- #BuildRequires: python-jinja2
- #BuildRequires: python-pygments
- #BuildRequires: python-setuptools
- #BuildRequires: python-sphinx
- %description
- OCIO enables color transforms and image display to be handled in a consistent
- manner across multiple graphics applications. Unlike other color management
- solutions, OCIO is geared towards motion-picture post production, with an
- emphasis on visual effects and animation color pipelines.
- %package devel
- Summary: Development libraries and headers for %{name}
- Summary(ja): %{name} の開発用ライブラリおよびヘッダファイル
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description devel
- Development libraries and headers for %{name}.
- %package doc
- Summary: API Documentation for %{name}
- Summary(ja): %{name} API のドキュメント
- Group: Documentation
- BuildArch: noarch
- Requires: %{name} = %{version}-%{release}
- %description doc
- API documentation for %{name}.
- %prep
- %setup -q
- %patch0 -p1 -b .pull300
- #patch1 -p1 -b .yaml3
- # Remove what bundled libraries
- rm -f ext/lcms*
- rm -f ext/tinyxml*
- #rm -f ext/yaml*
- %build
- rm -rf build && mkdir build && pushd build
- %cmake -DOCIO_BUILD_STATIC=OFF \
- -DOCIO_BUILD_DOCS=ON \
- -DOCIO_BUILD_TESTS=ON \
- -DOCIO_PYGLUE_SONAME=OFF \
- -DUSE_EXTERNAL_YAML=FALSE \
- -DUSE_EXTERNAL_TINYXML=TRUE \
- -DUSE_EXTERNAL_LCMS=TRUE \
- %ifnarch x86_64
- -DOCIO_USE_SSE=OFF \
- %endif
- -DCMAKE_SKIP_RPATH=OFF \
- ../
- # -DUSE_EXTERNAL_YAML=FALSE \
- make %{?_smp_mflags}
-
- %install
- rm -rf %{buildroot}
- pushd build
- make install DESTDIR=%{buildroot}
- # Generate man pages
- mkdir -p %{buildroot}%{_mandir}/man1
- help2man -N -s 1 --version-string=%{version} \
- -o %{buildroot}%{_mandir}/man1/ociocheck.1 \
- src/apps/ociocheck/ociocheck
- help2man -N -s 1 --version-string=%{version} \
- -o %{buildroot}%{_mandir}/man1/ociobakelut.1 \
- src/apps/ociobakelut/ociobakelut
- # Move installed documentation back so it doesn't conflict with the main package
- popd
- rm -rf _tmpdoc
- mkdir -p _tmpdoc
- mv %{buildroot}%{_docdir}/%{name}/* _tmpdoc/
- %check
- # Testing passes locally in mock but fails on the fedora build servers.
- #pushd build && make test
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %clean
- rm -rf %{buildroot}
- %files
- %doc ChangeLog LICENSE README
- %{_bindir}/*
- %{_libdir}/*.so.*
- %dir %{_datadir}/ocio
- %{_datadir}/ocio/setup_ocio.sh
- %{_mandir}/man1/*
- %{python_sitearch}/*.so
- %files devel
- %{_includedir}/OpenColorIO/
- %{_includedir}/PyOpenColorIO/
- %{_libdir}/*.so
- %{_libdir}/pkgconfig/%{name}.pc
- %files doc
- %doc _tmpdoc/*
- %changelog
- * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.8-8
- - rebuild with gcc-5.4.0
- * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.8-7
- - Initial build for Vine Linux
- - used bundled yaml-cpp
- * Mon Sep 23 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-6
- - Rebuild against yaml-cpp03 compatibility package.
- * Mon Aug 26 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-5
- - Fix for new F20 feature, unversion doc dir. Fixes BZ#1001264
- * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
- * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
- * Tue Dec 11 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-1
- - Update to latest upstream release.
- * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
- * Thu Apr 26 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-4
- - Only use SSE instructions on x86_64.
- * Wed Apr 25 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-3
- - Misc spec cleanup for packaging guidelines.
- - Disable testing for now since it fails on the build servers.
- * Wed Apr 18 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-1
- - Latest upstream release.
- * Thu Apr 05 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.6-1
- - Latest upstream release.
- * Wed Nov 16 2011 Richard Shaw <hobbes1069@gmail.com> - 1.0.2-1
- - Initial release.
|