ModemManager-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379
  1. #%define git_snapshot .git20130607
  2. %define git_snapshot %{nil}
  3. #define ppp_version 2.4.7
  4. %define glib2_version 2.40
  5. Name: ModemManager
  6. Summary: Mobile broadband modem management service
  7. Summary(ja): Mobile broadband modem management service
  8. Version: 1.6.12
  9. Release: 1%{git_snapshot}%{?_dist_release}
  10. License: GPLv2+
  11. Group: System Environment/Base
  12. URL: http://www.gnome.org/projects/NetworkManager/
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. #
  16. # Source from git://anongit.freedesktop.org/ModemManager/ModemManager
  17. # tarball built with:
  18. # ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  19. # make distcheck
  20. #
  21. #Source: %{name}-%{version}%{git_snapshot}.tar.bz2
  22. Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
  23. Patch0: buildsys-hates-openpty.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  25. BuildRequires: glib2-devel >= %{glib2_version}
  26. BuildRequires: libgudev-devel
  27. BuildRequires: automake autoconf intltool libtool
  28. BuildRequires: gobject-introspection-devel
  29. BuildRequires: polkit-devel
  30. BuildRequires: gtk-doc
  31. # for xsltproc
  32. BuildRequires: libxslt
  33. Requires: dbus-glib
  34. %description
  35. The ModemManager service manages WWAN modems and provides a consistent API for
  36. interacting with these devices to client applications.
  37. %package devel
  38. Summary: Development tools for %{name}
  39. Summary(ja): %{name} の開発環境
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. Requires: pkgconfig
  43. %description devel
  44. Header files and libraries for building a extension library for the %{name}.
  45. %package glib
  46. Summary: Libraries for adding ModemManager support to applications that use glib.
  47. Summary(ja): Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
  48. Group: System Environment/Libraries
  49. Requires: glib2 >= %{glib2_version}
  50. %description glib
  51. This package contains the libraries that make it easier to use some ModemManager
  52. functionality from applications that use glib.
  53. %package glib-devel
  54. Summary: Development tools for %{name}-glib
  55. Summary(ja): %{name}-glib の開発環境
  56. Group: Development/Libraries
  57. Requires: %{name}-glib = %{version}-%{release}
  58. Requires: %{name}-devel = %{version}-%{release}
  59. Requires: glib2-devel
  60. Requires: pkgconfig
  61. %description glib-devel
  62. Header files and libraries for building a extension library for the %{name}-glib.
  63. %prep
  64. %setup -q
  65. %patch0 -p1 -b .pty
  66. %build
  67. aclocal
  68. autoconf
  69. automake
  70. #pppddir=`ls -1d %{_libdir}/pppd/2*`
  71. %configure \
  72. --disable-static \
  73. --enable-gtk-doc=yes \
  74. --enable-vala=no \
  75. --enable-more-warnings=yes \
  76. --with-udev-base-dir=/lib/udev \
  77. --without-mbim \
  78. --without-qmi \
  79. --with-dist-version=%{version}-%{release}
  80. make %{?_smp_mflags}
  81. %check
  82. make check
  83. %install
  84. make install DESTDIR=$RPM_BUILD_ROOT
  85. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  86. #rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  87. %find_lang %{name}
  88. %post
  89. /sbin/ldconfig
  90. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  91. %postun
  92. /sbin/ldconfig
  93. if [ $1 -eq 0 ]; then
  94. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  95. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  96. fi
  97. %posttrans
  98. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  99. %post glib -p /sbin/ldconfig
  100. %postun glib -p /sbin/ldconfig
  101. %files -f %{name}.lang
  102. %defattr(-,root, root,-)
  103. %doc COPYING README
  104. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
  105. %{_libdir}/girepository-1.0/ModemManager-1.0.typelib
  106. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
  107. %attr(0755,root,root) %{_sbindir}/ModemManager
  108. %attr(0755,root,root) %{_bindir}/mmcli
  109. %dir %{_libdir}/%{name}
  110. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  111. /lib/udev/rules.d/*
  112. %{_datadir}/dbus-1/interfaces/*.xml
  113. %{_datadir}/icons/hicolor/22x22/apps/*.png
  114. %{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
  115. %{_mandir}/man8/*
  116. %files devel
  117. %defattr(-,root,root,-)
  118. %{_includedir}/ModemManager/*.h
  119. %dir %{_datadir}/gtk-doc/html/%{name}
  120. %{_datadir}/gir-1.0/ModemManager-1.0.gir
  121. %{_datadir}/gtk-doc/html/%{name}/*
  122. %{_libdir}/pkgconfig/%{name}.pc
  123. %files glib
  124. %defattr(-,root,root,-)
  125. %{_libdir}/libmm-glib.so.*
  126. %files glib-devel
  127. %defattr(-,root,root,-)
  128. %{_libdir}/libmm-glib.so
  129. %dir %{_includedir}/libmm-glib
  130. %{_includedir}/libmm-glib/*.h
  131. %{_libdir}/pkgconfig/mm-glib.pc
  132. %dir %{_datadir}/gtk-doc/html/libmm-glib
  133. %{_datadir}/gtk-doc/html/libmm-glib/*
  134. %changelog
  135. * Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.12-1
  136. - new upstream release.
  137. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
  138. - new upstream release
  139. - change BuildRequires: libgudev-devel instead of eudev-libgudev1-devel
  140. * Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-3
  141. - fix spec file
  142. * Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-2
  143. - fix spec file
  144. * Fri Oct 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-1
  145. - new upstream release
  146. - add BuildRequires: gobject-introspection-devel, polkit-devel
  147. * Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.10-1
  148. - new upstream release
  149. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
  150. - new upstream release
  151. * Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
  152. - new upstream release
  153. * Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  154. - new upstream release
  155. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  156. - new upstream release
  157. * Tue Oct 7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
  158. - moved ModemManager-glib to System Environment/Libraries Group
  159. - removed BR: ppp, ppp-devel and dbus-glib-devel
  160. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  161. - new upstream release
  162. - remove Patch1 (ModemManager-1.0.0-git20130911.patch)
  163. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
  164. - add Patch1 (ModemManager-1.0.0-git20130911.patch)
  165. * Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  166. - new upstream release
  167. - update Patch0
  168. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
  169. - update to 0.7.991 snapshot
  170. - fix spec file based on FC package
  171. * Fri Jun 7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
  172. - Update to 0.7.991 snapshot
  173. - Fix SMS validity parsing
  174. - Allow registration changes to 'searching' without disconnecting
  175. - Fix reading SMS messages from some QMI-based devices
  176. - Increase connection timeout for Novatel E362
  177. - Fix PIN retries checking when unlocking Ericsson devices
  178. - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
  179. - add configure option (--enable-gtk-doc=yes, --without-qmi)
  180. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
  181. - new upstream release
  182. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
  183. - new upstream release
  184. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
  185. - delete Patch20
  186. * Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  187. - update Patch20 (ModemManager-0.4-git20110428.patch)
  188. - delete Patch21,22
  189. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  190. - update to 0.4
  191. - add Patch20 (ModemManager-0.4-git20100720.patch)
  192. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  193. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  194. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  195. - initial build for Vine Linux
  196. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  197. - core: ignore some failures on disconnect (rh #578280)
  198. - core: add support for platform serial devices
  199. - gsm: better Blackberry DUN support
  200. - gsm: periodically poll access technology
  201. - cdma: prevent crash on modem removal (rh #571921)
  202. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  203. - novatel: better signal strength reporting on CDMA cards
  204. - novatel: add access technology and mode preference support on GSM cards
  205. - zte: fix mode preference retrieval
  206. - longcheer: add support for Zoom modems (4595, 4596, etc)
  207. - longcheer: add access technology and mode preference support
  208. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  209. - Silence %%post
  210. - Update scripts
  211. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  212. - gsm: fix parsing Blackberry supported character sets response
  213. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  214. - mbm: fix retrieval of current allowed mode
  215. - gsm: fix initialization issues with some devices (like Blackberries)
  216. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  217. - core: fix detection of some generic devices (rh #579247)
  218. - core: fix detection regression of some Huawei devices in 0.3-5
  219. - cdma: periodically poll registration state and signal quality
  220. - cdma: really fix registration detection on various devices (rh #569067)
  221. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  222. - core: fix PPC/SPARC/etc builds
  223. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  224. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  225. - cdma: handle signal quality requests while connected for more devices
  226. - cdma: handle serving system requests while connected for more devices
  227. - gsm: determine current access technology earlier
  228. - huawei: work around automatic registration issues on some devices
  229. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  230. - core: ensure enabled modems are disabled when MM stops
  231. - core: better capability detection for Blackberry devices (rh #573510)
  232. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  233. - gsm: don't block modem when it requires PIN2
  234. - option: fix access technology updates
  235. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  236. - mbm: add device IDs for C3607w
  237. - mbm: fail earlier during connection failures
  238. - mbm: fix username/password authentication when checked by the network
  239. - hso: implement asynchronous signal quality updates
  240. - option: implement asynchronous signal quality updates
  241. - novatel: correctly handle CDMA signal quality
  242. - core: basic PolicyKit support
  243. - core: fix direct GSM registration information requests
  244. - core: general GSM PIN/PUK unlock fixes
  245. - core: poll GSM registration state internally for quicker status updates
  246. - core: implement GSM 2G/3G preference
  247. - core: implement GSM roaming allowed/disallowed preference
  248. - core: emit signals on access technology changes
  249. - core: better handling of disconnections
  250. - core: fix simple CDMA status requests
  251. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  252. - core: startup speed improvements
  253. - core: GSM PIN checking improvements
  254. - huawei: fix EVDO-only connections on various devices (rh #553199)
  255. - longcheer: add support for more devices
  256. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  257. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  258. - core: fix crashes when devices are unplugged during operation (rh #553953)
  259. - cdma: prefer primary port for status/registration queries
  260. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  261. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  262. - gsm: fix Nokia N80 network scan parsing
  263. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  264. - core: fix apparent hangs by limiting retried serial writes
  265. - gsm: ensure modem state is reset when disabled
  266. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  267. - sierra: fix CDMA registration detection in some cases (rh #547513)
  268. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  269. - sierra: ensure CDMA device is powered up when trying to use it
  270. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  271. - zte: handle unsolicited messages better during probing
  272. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  273. - cdma: fix signal strength reporting on some devices
  274. - cdma: better registration state detection when dialing (ex Sierra 5275)
  275. - option: always use the correct tty for dialing commands
  276. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  277. - core: fix reconnect after manual disconnect (rh #541314)
  278. - core: fix various segfaults during registration
  279. - core: fix probing of various modems on big-endian architectures (ie PPC)
  280. - core: implement modem states to avoid duplicate operations
  281. - hso: fix authentication for Icera-based devices like iCON 505
  282. - zte: use correct port for new devices
  283. - nozomi: fix detection
  284. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  285. - Update to latest git
  286. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  287. - cdma: wait for network registration before trying to connect
  288. - gsm: add cell access technology reporting
  289. - gsm: allow longer-running network scans
  290. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  291. - nokia: don't power down phones on disconnect
  292. - hso: fix disconnection/disable
  293. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  294. - Fixes for Motorola and Ericsson devices
  295. - Fixes for CDMA "serving-system" command parsing
  296. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  297. - Fix a typo in one of the udev rules files
  298. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  299. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  300. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  301. - Fix source repo location
  302. - Fix directory ownership
  303. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  304. - Initial version