kde-partitionmanager-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139
  1. Name: kde-partitionmanager
  2. Summary: KDE Partition Manager
  3. Summary(ja): KDE パーティションマネージャ
  4. Version: 1.0.3
  5. Release: 2%{?_dist_release}
  6. Group: Applications/Administration
  7. License: GPLv2+
  8. URL: http://partitionman.sourceforge.net/
  9. Source0: http://downloads.sourceforge.net/project/partitionman/partitionmanager/1.0.3/partitionmanager-%{version}.tar.bz2
  10. Patch0: partitionmanager-1.0.3-r1263692.patch
  11. ## upstreamable patches
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: kdelibs4-devel
  14. BuildRequires: parted-devel
  15. BuildRequires: e2fsprogs-devel
  16. %if %{?_dist_release} !="vl5"
  17. BuildRequires: libuuid-devel
  18. BuildRequires: libblkid-devel
  19. BuildRequires: libatasmart-devel
  20. %endif
  21. BuildRequires: pkgconfig
  22. BuildRequires: gettext
  23. BuildRequires: cmake
  24. Requires: parted
  25. Requires: e2fsprogs
  26. %global kde4_version %((kde4-config --version 2>/dev/null || echo "KDE 4.4.5") | grep ^KDE | cut -d' ' -f2)
  27. #{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
  28. %description
  29. KDE Partition Manager is a utility program to help you manage the disk devices,
  30. partitions and file systems on your computer. It allows you to easily create,
  31. copy, move, delete, resize without losing data, backup and restore partitions.
  32. KDE Partition Manager supports a large number of file systems,
  33. including ext2/3/4, reiserfs, NTFS, FAT16/32, jfs, xfs and more.
  34. It makes use of external programs to get its job done, so you might have to
  35. install additional software (preferably packages from your distribution)
  36. to make use of all features and get full support for all file systems.
  37. %prep
  38. %setup -q -n partitionmanager-%{version}
  39. %patch0 -p1
  40. ## Due to the name change
  41. mv src/partitionmanager.desktop src/kde-partitionmanager.desktop
  42. #mv src/kcm/kcm_partitionmanager.desktop src/kcm/kcm_kde-partitionmanager.desktop
  43. sed -i 's,partitionmanager.desktop,kde-partitionmanager.desktop,' src/CMakeLists.txt
  44. %build
  45. mkdir -p %{_target_platform}
  46. pushd %{_target_platform}
  47. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  48. %{cmake} \
  49. -DCMAKE_BUILD_TYPE=release \
  50. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  51. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  52. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  53. ..
  54. popd
  55. make %{?_smp_mflags} -C %{_target_platform}
  56. %install
  57. rm -rf %{buildroot}
  58. make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
  59. %find_lang partitionmanager --with-kde
  60. %check
  61. desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/%{name}.desktop
  62. %clean
  63. rm -rf %{buildroot}
  64. %post
  65. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  66. %posttrans
  67. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  68. %postun
  69. if [ $1 -eq 0 ] ; then
  70. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  71. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  72. fi
  73. %files -f partitionmanager.lang
  74. %defattr(-,root,root,-)
  75. %doc README COPYING CHANGES
  76. %{_bindir}/partitionmanager*
  77. %{_libdir}/*.so
  78. %{_libdir}/kde4/pmlibpartedbackendplugin.so
  79. %{_datadir}/applications/kde4/%{name}.desktop
  80. %{_datadir}/icons/hicolor/*/*/*.png
  81. %{_datadir}/kde4/apps/partitionmanager
  82. %{_datadir}/kde4/services/pmlibpartedbackendplugin.desktop
  83. %{_datadir}/kde4/servicetypes/pmcorebackendplugin.desktop
  84. ## %{_kde4_datadir}/kde4/services/kcm_kde-partitionmanager.desktop
  85. %changelog
  86. * Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-2
  87. - add Patch0 (partitionmanager-1.0.3-r1263692.patch)
  88. - add BuildRequires: libatasmart-devel
  89. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-1
  90. - new upstream release
  91. * Fri Jul 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-3
  92. - disabled BR: libuuid-devel, libblkid-devel on Vine Linux 5
  93. * Mon Jul 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-2
  94. - Initial build for Vine Linux
  95. * Tue May 18 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.2-1
  96. - bugfix release
  97. * Wed Mar 31 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1%{?dist}.2
  98. - rebuild for new parted
  99. * Sun Feb 14 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1%{?dist}.1
  100. - DSO fix for rawhide
  101. * Mon Jan 25 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1
  102. - New upstream source
  103. * Wed Nov 18 2009 Thomas Janssen <thomasj@fedoraproject.org> 1.0.0-2
  104. - Moved desktop-file-validate to %%install
  105. - Removed superfluous BR qt4-devel
  106. * Wed Nov 18 2009 Thomas Janssen <thomasj@fedoraproject.org> 1.0.0-1
  107. - Initial Fedora release