iputils-vl.spec 10.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298
  1. Summary: Network monitoring tools including ping.
  2. Summary(ja): ping 等のネットワークモニタツール集
  3. Name: iputils
  4. Version: 20140519
  5. Release: 1%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Daemons
  8. URL: https://github.com/iputils/iputils
  9. Source0: https://github.com/iputils/iputils/archive/s%{version}.tar.gz#/%{name}-s%{version}.tar.gz
  10. Source1: ifenslave.tar.gz
  11. Source3: rdisc.initd
  12. Source5: rdisc.sysconfig
  13. Patch0: iputils-rh.patch
  14. Patch1: iputils-ifenslave.patch
  15. Patch2: iputils-tracepath-doc.patch
  16. # Vine Source(s)/Patch(es)
  17. Source10: iputils-s20140519-ja.po
  18. Patch100: iputils-s20140519-gettext.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: docbook-utils perl-SGMLSpm
  21. BuildRequires: glibc-kernheaders >= 2.4-8.19
  22. BuildRequires: libidn-devel
  23. BuildRequires: openssl-devel
  24. BuildRequires: libcap-devel
  25. Requires(post): chkconfig
  26. Requires(preun): chkconfig
  27. Requires(preun): initscripts
  28. Requires(postun): initscripts
  29. %description
  30. The iputils package contains basic utilities for monitoring a network,
  31. including ping. The ping command sends a series of ICMP protocol
  32. ECHO_REQUEST packets to a specified network host to discover whether
  33. the target machine is alive and receiving network traffic.
  34. %prep
  35. %setup -q -a 1 -n %{name}-s%{version}
  36. %patch0 -p1 -b .rh
  37. %patch1 -p1
  38. %patch2 -p1
  39. #
  40. %patch100 -p1 -b .gettext
  41. # add ja.po
  42. cp %{SOURCE10} po/ja.po
  43. %build
  44. %ifarch s390 s390x
  45. export CFLAGS="$RPM_OPT_FLAGS -fPIE"
  46. %else
  47. export CFLAGS="$RPM_OPT_FLAGS -fpie"
  48. %endif
  49. export LDFLAGS="-pie"
  50. make %{?_smp_mflags} arping clockdiff ping ping6 rdisc tracepath tracepath6
  51. gcc -Wall $RPM_OPT_FLAGS ifenslave.c -o ifenslave
  52. make -C doc man
  53. make -C po
  54. %install
  55. rm -rf ${RPM_BUILD_ROOT}
  56. mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
  57. mkdir -p ${RPM_BUILD_ROOT}/{bin,sbin}
  58. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  59. install -c clockdiff ${RPM_BUILD_ROOT}%{_sbindir}/
  60. install -cp arping ${RPM_BUILD_ROOT}/sbin/
  61. ln -s /sbin/arping ${RPM_BUILD_ROOT}%{_sbindir}/arping
  62. install -cp ping ${RPM_BUILD_ROOT}/bin/
  63. install -cp ifenslave ${RPM_BUILD_ROOT}/sbin/
  64. install -cp rdisc ${RPM_BUILD_ROOT}/sbin/
  65. install -cp ping6 ${RPM_BUILD_ROOT}/bin/
  66. install -cp tracepath ${RPM_BUILD_ROOT}/bin/
  67. install -cp tracepath6 ${RPM_BUILD_ROOT}/bin/
  68. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  69. ln -sf /bin/ping6 ${RPM_BUILD_ROOT}%{_sbindir}
  70. ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
  71. ln -sf /bin/tracepath6 ${RPM_BUILD_ROOT}%{_sbindir}
  72. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
  73. install -cp doc/clockdiff.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  74. install -cp doc/arping.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  75. install -cp doc/ping.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  76. install -cp doc/rdisc.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  77. install -cp doc/tracepath.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  78. install -cp ifenslave.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  79. ln -s ping.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/ping6.8.gz
  80. ln -s tracepath.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/tracepath6.8.gz
  81. install -dp ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
  82. install -m 755 -p %SOURCE3 ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/rdisc
  83. install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rdisc
  84. make -C po install DESTDIR=$RPM_BUILD_ROOT
  85. %find_lang %{name}
  86. %post
  87. /sbin/chkconfig --add rdisc
  88. %preun
  89. if [ $1 = 0 ]; then
  90. service rdisc stop >/dev/null 2>&1
  91. /sbin/chkconfig --del rdisc
  92. fi
  93. %postun
  94. if [ "$1" -ge "1" ]; then
  95. service rdisc restart >/dev/null 2>&1 || :
  96. fi
  97. %clean
  98. rm -rf ${RPM_BUILD_ROOT}
  99. %files -f %{name}.lang
  100. %defattr(-,root,root)
  101. %doc RELNOTES README.bonding
  102. %{_sbindir}/clockdiff
  103. /sbin/arping
  104. %{_sbindir}/arping
  105. %attr(4755,root,root) /bin/ping
  106. /sbin/ifenslave
  107. /sbin/rdisc
  108. %attr(4755,root,root) /bin/ping6
  109. /bin/tracepath
  110. /bin/tracepath6
  111. %{_sbindir}/ping6
  112. %{_sbindir}/tracepath
  113. %{_sbindir}/tracepath6
  114. %attr(0644,root,root) %{_mandir}/man8/*
  115. %{_sysconfdir}/rc.d/init.d/rdisc
  116. %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/rdisc
  117. %changelog
  118. * Sun Jul 13 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 20140519-1
  119. - update to 20140519
  120. - update URL to new upstream
  121. - update gettext patch and translation
  122. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 20101006-1
  123. - new upstream release
  124. - merget with fedora/20101006-8
  125. - update gettext patch and ja.po
  126. * Fri Apr 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-2
  127. - rebuild to add sign..
  128. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-1
  129. - new upstream release
  130. - spec in utf-8
  131. * Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-41vl1
  132. - remove traceroute6 that is now provided by traceroute package.
  133. - merge changes from FC
  134. * Sat Jul 31 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20020927-13vl2
  135. - ppc patch (Patch110) removed (it's no necessary now)
  136. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-13vl1
  137. - update to 20020927 merged with 20020927-13
  138. - update i18n patch, ja.po
  139. * Thu Oct 02 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-12
  140. - Fixed unaligned access problem on ia64 (#101417)
  141. * Wed Sep 10 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-11
  142. - Dont use own headers, use glibc and kernheaders.
  143. * Thu Sep 04 2003 Bill Nottingham <notting@redhat.com> 20020927-10
  144. - fix build with new glibc-kernheaders
  145. * Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9
  146. - Start icmp_seq from 0 instead of 1 (Conform with debian and Solaris #100609).
  147. * Thu Jul 31 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-8
  148. - One more update to ifenslave.c
  149. * Mon Jun 16 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-7
  150. - Updated ifenslave.c and README.bonding to latest version.
  151. * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-5
  152. - Bumped release and rebuilt
  153. * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-4
  154. - Fixed DNS lookup problems (#68212).
  155. - Added warning if binding problem failed on subinterface (#81640).
  156. * Tue May 13 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-3
  157. - Removed bonding tarball and replaced it with ifenslave.c and README
  158. - FHS compliance for all tools, now to be found in /bin with compat symlinks to
  159. old places.
  160. * Fri Nov 29 2002 Phil Knirsch <pknirsch@redhat.com> 20020927-1
  161. - Updated to latest upstream version.
  162. * Tue Jun 18 2002 Phil Knirsch <pknirsch@redhat.com> 20020124-7
  163. - Added new BuildPreReqs for docbook-utils and perl-SGMLSpm (#66661)
  164. - Fixed ipv6 error printing problem (#66659).
  165. * Tue May 21 2002 Phil Knirsch <pknirsch@redhat.com>
  166. - Added a patch to activate the rdisc server (#64270).
  167. - Display the countermeasures warning only in verbose (#55236)
  168. * Thu Apr 18 2002 Bill Nottingham <notting@redhat.com>
  169. - quit trying to build HTML versions of the man pages
  170. * Thu Mar 14 2002 Phil Knirsch <pknirsch@redhat.com>
  171. - Added fix by Tom "spot" Callaway to fix buffer overflow problems in stats.
  172. * Wed Feb 27 2002 Phil Knirsch <pknirsch@redhat.com>
  173. - Update to iputils-ss020124.
  174. * Sat Feb 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl2
  175. - changed Patch110 to have clear_bit() within the ipv6 source for ppc
  176. * Sun Jan 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl1
  177. - based on 20001110-7 from Rawhide
  178. - merged Vine changes from 20001010-1vl4
  179. --- Mon Jul 16 2001 <sagami@vinelinux.org>
  180. - 20001010-1vl4
  181. - use %%{find_lang} to fix so as not to own locale dir
  182. --- Thu Jun 07 2001 <sagami@vinelinux.org>
  183. - 20001010-1vl3: rebuilt for %%{_mandir}
  184. --- Fri Oct 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  185. - 20001010-1vl2
  186. - remove ping6 for ppc
  187. - added Japanese summary and description
  188. --- Thu Oct 26 2000 Jun Nishii <jun@vinelinux.org>
  189. - added ja.po and nls patch
  190. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  191. - automated rebuild
  192. * Mon Aug 27 2001 Philipp Knirsch <pknirsch@redhat.de> 20001110-6
  193. - Fixed buffer overflow problem in traceroute6.c (#51135)
  194. * Mon Jul 01 2001 Philipp Knirsch <pknirsch@redhat.de>
  195. - Made ping6 and traceroute6 setuid (safe as they drop it VERY early) (#46769)
  196. * Thu Jun 28 2001 Philipp Knirsch <pknirsch@redhat.de>
  197. - Fixed ping statistics overflow bug (#43801)
  198. * Tue Jun 26 2001 Philipp Knirsch <pknirsch@redhat.de>
  199. - Fixed a bunch of compiler warnings (#37131)
  200. - Fixed wrong exit code for no packets and deadline (#40323)
  201. - Moved arping to /sbin from /usr/sbin due to ifup call (#45785). Symlink from
  202. /usr/sbin/ provided for backwards compatibility.
  203. * Mon Apr 30 2001 Preston Brown <pbrown@redhat.com>
  204. - install in.rdisc.8c as rdisc.8
  205. * Tue Jan 16 2001 Jeff Johnson <jbj@redhat.com>
  206. - update to ss001110
  207. - doco fixes (#23844).
  208. * Sun Oct 8 2000 Jeff Johnson <jbj@redhat.com>
  209. - update to ss001007.
  210. * Tue Aug 8 2000 Tim Waugh <twaugh@redhat.com>
  211. - fix spelling mistake (#15714).
  212. * Tue Aug 8 2000 Tim Waugh <twaugh@redhat.com>
  213. - turn on -U on machines without TSC (#15223).
  214. * Tue Aug 1 2000 Jeff Johnson <jbj@redhat.com>
  215. - better doco patch (#15050).
  216. * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
  217. - fix include-glibc/ to work with new glibc 2.2 resolver headers
  218. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  219. - automatic rebuild
  220. * Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
  221. - FHS packaging.
  222. - update to ss000418.
  223. - perform reverse DNS lookup only once for same input.
  224. * Sun Mar 5 2000 Jeff Johnson <jbj@redhat.com>
  225. - include README.ifenslave doco.
  226. - "ping -i N" was broke for N >= 3 (#9929).
  227. - update to ss000121:
  228. -- clockdiff: preserve raw socket errno.
  229. -- ping: change error exit code to 1 (used to be 92,93, ...)
  230. -- ping,ping6: if -w specified, transmit until -c limit is reached.
  231. -- ping,ping6: exit code non-zero if some packets not received within deadline.
  232. * Tue Feb 22 2000 Jeff Johnson <jbj@redhat.com>
  233. - man page corrections (#9690).
  234. * Wed Feb 9 2000 Jeff Johnson <jbj@jbj.org>
  235. - add ifenslave.
  236. * Thu Feb 3 2000 Elliot Lee <sopwith@redhat.com>
  237. - List /usr/sbin/rdisc in %files list.
  238. * Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
  239. - add remaining binaries.
  240. - casts to remove compilation warnings.
  241. - terminate if -w deadline is reached exactly (#8724).
  242. * Fri Dec 24 1999 Jeff Johnson <jbj@redhat.com>
  243. - create (only ping for now, traceroute et al soon).