totem-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582
  1. # define versions
  2. %define _glib_ver 2.44.0
  3. %define _gtk_ver 3.16.0
  4. %define _gnomeicon_ver 3.12.0
  5. %define _gnome_doc_utils_ver 0.20.0
  6. %define _dbus_ver 1.6.0
  7. %define _gst_ver 1.2.0
  8. %define _gstpb_ver 1.2.0
  9. %define _gstpg_ver 1.2.0
  10. %define _gstpbad_ver 1.2.0
  11. %define _xulrunner_ver 1.9
  12. %define _nautilus_ver 3.16.0
  13. %define _shared_mime_info_ver 0.17
  14. %define _unique_ver 1.0
  15. %define _totem_pl_parser_ver 3.4.4
  16. %define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
  17. Summary: Movie player for GNOME 3
  18. Summary(ja): GNOME3 用動画プレイヤー
  19. Name: totem
  20. Version: 3.16.4
  21. Release: 1%{?_dist_release}
  22. License: GPL
  23. Group: Applications/Multimedia
  24. URL: http://www.gnome.org/projects/totem/
  25. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. Packager: Takemikaduchi
  30. BuildRequires: gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  31. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  32. BuildRequires: dbus-devel >= %{_dbus_ver}
  33. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  34. BuildRequires: gnome-desktop3-devel
  35. BuildRequires: gettext
  36. BuildRequires: perl-XML-Parser
  37. BuildRequires: iso-codes
  38. BuildRequires: yelp-tools
  39. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  40. BuildRequires: grilo-devel
  41. BuildRequires: bluez-libs-devel >= 4.15
  42. BuildRequires: lirc
  43. BuildRequires: unique-devel >= %{_unique_ver}
  44. BuildRequires: python-devel
  45. BuildRequires: pylint
  46. BuildRequires: pygobject3-devel
  47. BuildRequires: libpeas-devel
  48. BuildRequires: libXtst-devel
  49. BuildRequires: gsettings-desktop-schemas-devel
  50. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  51. BuildRequires: vala
  52. BuildRequires: gstreamer1-devel >= %{_gst_ver}
  53. BuildRequires: gstreamer1-plugins-base-devel >= %{_gstpb_ver}
  54. BuildRequires: gstreamer1-plugins-good >= %{_gstpg_ver}
  55. BuildRequires: clutter-gtk-devel
  56. BuildRequires: clutter-gst3-devel
  57. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  58. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  59. Requires: gstreamer1 >= %{_gst_ver}
  60. Requires: gstreamer1-plugins-base >= %{_gstpb_ver}
  61. Requires: gstreamer1-plugins-good >= %{_gstpg_ver}
  62. Requires: iso-codes
  63. Requires: grilo-plugins
  64. Obsoletes: nautilus-media
  65. Obsoletes: %{name}-gstreamer < 2.30.1-2
  66. Obsoletes: %{name}-xine < 2.30.1-2
  67. Obsoletes: %{name}-common < 2.30.1-3
  68. Obsoletes: %{name}-mozilla < 3.14.0
  69. Provides: nautilus-media
  70. Provides: %{name}-common = %{version}-%{release}
  71. Requires(post): ldconfig, desktop-file-utils
  72. Requires(postun): ldconfig, desktop-file-utils
  73. %description
  74. Totem is simple movie player for the Gnome desktop. It features a
  75. simple playlist, a full-screen mode, seek and volume controls, as well as
  76. a pretty complete keyboard navigation.
  77. %package devel
  78. Summary: Plugin writer's documentation for totem
  79. Group: Development/Libraries
  80. Requires: %{name} = %{version}-%{release}
  81. %description devel
  82. The %{name}-devel package contains API documentation for
  83. developing developing plugins for %{name}.
  84. %prep
  85. %setup -q
  86. %build
  87. #DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
  88. #export MOZILLA_PLUGINDIR=%{mozplug_dir}
  89. %configure \
  90. --enable-python \
  91. --enable-vala \
  92. --enable-nautilus
  93. make %{?_smp_mflags}
  94. %install
  95. rm -rf $RPM_BUILD_ROOT
  96. make install DESTDIR=$RPM_BUILD_ROOT
  97. # remove unneeded files
  98. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  99. %__rm -f %{buildroot}%{_libdir}/*.{a,la}
  100. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  101. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  102. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  103. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  104. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  105. # remove unused file
  106. %__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
  107. %__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
  108. %find_lang %{name} --with-gnome
  109. # save space by linking identical images in translated docs
  110. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  111. for f in $helpdir/C/figures/*.png; do
  112. b="$(basename $f)"
  113. for d in $helpdir/*; do
  114. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  115. g="$d/figures/$b"
  116. if [ -f "$g" ]; then
  117. if cmp -s $f $g; then
  118. rm "$g"; ln -s "../../C/figures/$b" "$g"
  119. fi
  120. fi
  121. fi
  122. done
  123. done
  124. %clean
  125. %__rm -rf %{buildroot}
  126. %post
  127. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  128. touch %{_datadir}/icons/hicolor
  129. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  130. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  131. fi
  132. %postun
  133. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  134. touch %{_datadir}/icons/hicolor
  135. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  136. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  137. fi
  138. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  139. %posttrans
  140. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  141. %files -f %{name}.lang
  142. %defattr(-,root,root,-)
  143. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  144. %{_bindir}/totem
  145. %{_bindir}/totem-audio-preview
  146. %{_bindir}/totem-video-thumbnailer
  147. %{_datadir}/GConf/gsettings/opensubtitles.convert
  148. #%{_datadir}/GConf/gsettings/pythonconsole.convert
  149. %{_datadir}/GConf/gsettings/totem.convert
  150. %{_datadir}/appdata/org.gnome.Totem.appdata.xml
  151. %{_datadir}/applications/org.gnome.Totem.desktop
  152. %{_datadir}/dbus-1/services/org.gnome.Totem.service
  153. %{_datadir}/glib-2.0/schemas/*.xml
  154. %{_datadir}/icons/*/*/*/*
  155. %{_datadir}/thumbnailers/totem.thumbnailer
  156. %{_datadir}/%{name}
  157. %{_datadir}/gtk-doc/html/totem
  158. %{_libdir}/libtotem.so.*
  159. %{_libdir}/girepository-1.0/*.typelib
  160. %dir %{_libdir}/totem
  161. %dir %{_libdir}/totem/plugins
  162. %{_libdir}/totem/plugins/apple-trailers/
  163. %{_libdir}/totem/plugins/autoload-subtitles
  164. %{_libdir}/totem/plugins/brasero-disc-recorder
  165. %{_libdir}/totem/plugins/dbus
  166. %{_libdir}/totem/plugins/gromit
  167. %{_libdir}/totem/plugins/im-status/libtotem-im-status.so
  168. %{_libdir}/totem/plugins/im-status/totem-im-status.plugin
  169. %{_libdir}/totem/plugins/lirc
  170. %{_libdir}/totem/plugins/media-player-keys
  171. %{_libdir}/totem/plugins/ontop
  172. %{_libdir}/totem/plugins/opensubtitles
  173. %{_libdir}/totem/plugins/properties
  174. %{_libdir}/totem/plugins/pythonconsole
  175. %{_libdir}/totem/plugins/recent
  176. %{_libdir}/totem/plugins/rotation
  177. %{_libdir}/totem/plugins/screensaver
  178. %{_libdir}/totem/plugins/screenshot
  179. %{_libdir}/totem/plugins/skipto
  180. %{_libdir}/totem/plugins/save-file/libsave-file.so
  181. %{_libdir}/totem/plugins/save-file/save-file.plugin
  182. %{_libdir}/totem/plugins/vimeo
  183. %{_libdir}/nautilus/extensions-3.0/*.so*
  184. %{_mandir}/man1/*
  185. %files devel
  186. %defattr(-, root, root,-)
  187. %{_includedir}/totem
  188. %{_libdir}/libtotem.so
  189. %{_libdir}/pkgconfig/totem.pc
  190. %{_datadir}/gir-1.0/Totem-1.0.gir
  191. %{_datadir}/gtk-doc/html/totem
  192. %changelog
  193. * Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
  194. - new upstream release
  195. * Wed Jul 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
  196. - add Requires: grilo-plugins
  197. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
  198. - remove BuildRequires: gstreamer1-plugins-bad-free-devel
  199. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
  200. - new upstream release
  201. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  202. - new upstream release
  203. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  204. - new upstream release
  205. - change BuildRequires: clutter-gst3-devel instead of clutter-gst-devel
  206. * Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  207. - new upstream release
  208. * Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
  209. - new upstream release
  210. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
  211. - new upstream release
  212. - add BuildRequires: gnome-desktop3-devel
  213. - remove BuildRequires: xulrunner-devel
  214. - remove %%{name}-mozilla subpackage
  215. * Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  216. - new upstream release
  217. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  218. - new upstream release
  219. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  220. - new upstream release
  221. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
  222. - rebuild with VineSeed environment
  223. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  224. - new upstream release
  225. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  226. - new upstream release
  227. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
  228. - new upstream release
  229. - add BuildRequires: yelp-tools, vala
  230. - change configure option (--enable-vala)
  231. * Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  232. - new upstream release
  233. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  234. - new upstream release
  235. - change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
  236. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  237. - new upstream release
  238. - add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
  239. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  240. - new upstream release
  241. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  242. - add configure option (--disable-vegas-plugin)
  243. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  244. - new upstream release
  245. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  246. - new upstream release
  247. - add BuildRequires: pylint
  248. - remove BuildRequires: libgdata-devel
  249. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  250. - new upstream release
  251. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  252. - new upstream release
  253. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  254. - new upstream release
  255. - change BuildRequires: pygobject3-devel instead of pygobject-devel
  256. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  257. - new upstream release
  258. - change BuildRequires: gtk3-devel instead of gtk2-devel
  259. - add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
  260. clutter-gst-devel, libmx-devel
  261. - change configure option (--disable-vala)
  262. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  263. - new upstream release
  264. - fix %files
  265. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  266. - new upstream release
  267. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  268. - clean up spec file
  269. - remove totem-common and merged to totem main package.
  270. - add Obsoletes: totem-common
  271. - remove unneeded BR: and R:
  272. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  273. - libmusicbrainz, alternatives
  274. - remove explicit dependency
  275. - gtk2, glib2, dbus
  276. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  277. - add R: gstreamer-plugins-good
  278. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  279. - rebuild with libgdata (add youtube plugin)
  280. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  281. - add Obsolete: totem-gstreamer, totem-xine)
  282. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  283. - new upstream release
  284. - chagnge _gst_ver from 0.10.19 to 0.10.29
  285. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  286. - new upstream release
  287. - drop totem-tracker package
  288. - add BuildRequires: unique-devel
  289. - remove BuildRequires: hal-devel
  290. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  291. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  292. - remove unneeded autoreconf
  293. - add BR: lirc
  294. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  295. - new upstream release
  296. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  297. - remove bemused plugin
  298. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  299. - new upstream release
  300. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  301. - added tracker video search sub-package
  302. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  303. - new upstream release
  304. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  305. - new upstream release
  306. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  307. - remove libxine dependency from totem-common
  308. - build xine backend with minimum dependency
  309. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  310. - add BR: bluez-libs-devel >= 4.15
  311. - fix typo in %%postun xine
  312. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  313. - rebuild with bluez-libs-devel-4.15
  314. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  315. - new upstream release
  316. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  317. - new upstream release
  318. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  319. - new upstream release
  320. - add patch1 to build with xulrunner-1.9
  321. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  322. - new upstream release
  323. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  324. - new upstream release
  325. - disabled devel package (replaced by totem-pl-parser-devel)
  326. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  327. - new upstream release
  328. - update version macros
  329. - enable browser plugins on x86_64
  330. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  331. - new upstream release
  332. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  333. - upstream release
  334. - drop obsolete ja.po.patch (patch0)
  335. - revert change of 1.4.4-0vl2
  336. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  337. - upstream release
  338. - enable browser plugins (exclude x86_64 arch)
  339. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  340. - upstream release
  341. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  342. - update configure options
  343. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  344. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  345. - fix mistranslation (patch0)
  346. - add icon symlink
  347. - add BuildRequires: gstreamer-plugins-good
  348. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  349. - upstream release
  350. - update %%_glib_ver, %%_xine_ver
  351. - add BuildRequires: hal
  352. - update %%configure options
  353. - update %%files
  354. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  355. - upstream release
  356. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  357. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  358. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  359. - upstream release
  360. - drop obsolete patch0
  361. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  362. - upstream release
  363. - add patch0 to build with intltool-0.35
  364. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  365. - upstream release
  366. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  367. - upstream release
  368. - update alternatives entry
  369. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  370. - upstream release
  371. - drop fix-sort-function.patch (was merged to upstream, #331426)
  372. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  373. - rebuild with gnome-2.14rc
  374. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  375. - upstream release
  376. - add macros
  377. - _gtk_ver, _glib_ver
  378. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  379. - _dbus_ver
  380. - _gst_ver, gstpb_ver, _xine_ver
  381. - add fix-sort-function.patch to build with glib < 2.9.1
  382. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  383. - upstream release
  384. - add BuildRequires:
  385. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  386. - gnome-vfs2-devel >= 2.9.92
  387. - dbus-devel >= 0.35
  388. - use gstreamer-0.10 as backend for totem-gstreamer
  389. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  390. - use gstreamer08 instead of gstreamer
  391. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  392. - upstream release
  393. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  394. - fix missing links
  395. - update file list
  396. - update update-alternatives scripts
  397. - fix totem-gstreamer's %%postun script
  398. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  399. - upstream release
  400. - add BuildRequires: iso-codes, libmusicbrainz-devel
  401. - add Requires: iso-codes, libmusicbrains to -common package
  402. - remove BuildRequires: nautilus-cd-burner
  403. - remove Requires: nautilus-cd-burner from -common package
  404. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  405. - totem-gstreamer obsoletes nautilus-media
  406. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  407. - upstream release
  408. - add Requires(post,postun): alternatives for gstreamer,xine
  409. - add Requires(postun,triggers): alternatives for common
  410. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  411. - upstream release
  412. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  413. - build xine backend
  414. - move common files to common package
  415. - move GStreamer related files to gstreamer package
  416. - install xine related files to xine package
  417. - fix scripts
  418. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  419. - upstream release
  420. - update URL
  421. - move *.{a,la} to devel package
  422. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  423. - fix %%{post,preun} script (video-thumbnail.schemas)
  424. - sync with Fedora Core's 1.0.1-1
  425. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  426. - Update to upstream version 1.0.1
  427. - Break out devel package
  428. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  429. - add %%{post,pre}un script
  430. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  431. - initial build for Vine Linux
  432. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  433. - fix %%post
  434. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  435. - Obsolete nautilus-media
  436. - Install property page and thumbnailer
  437. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  438. - Update to 0.101
  439. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  440. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  441. missing menu entry (144088)
  442. - Remove workaround for desktop file being misinstalled, fixed
  443. by above patch
  444. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  445. - New upstream version 0.100
  446. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  447. - update to 0.99.22
  448. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  449. - Add patch to remove removed items from package from help
  450. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  451. - New upstream 0.99.19
  452. - Fixes crasher with CD playback (see NEWS)
  453. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  454. - Call update-desktop-database in post
  455. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  456. - update to 0.99.18
  457. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  458. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>