libmpc-vl.spec 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134
  1. Summary: C library for multiple precision complex arithmetic
  2. Name: libmpc
  3. Version: 1.0.3
  4. Release: 1%{?_dist_release}
  5. License: LGPLv3+
  6. Group: System Environment/Libraries
  7. URL: http://www.multiprecision.org/
  8. Source0: mpc-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  10. BuildRequires: gmp-devel >= 4.3.2
  11. BuildRequires: mpfr-devel >= 2.4.2
  12. BuildRequires: grep
  13. BuildRequires: texinfo
  14. %description
  15. MPC is a C library for the arithmetic of complex numbers with
  16. arbitrarily high precision and correct rounding of the result. It is
  17. built upon and follows the same principles as Mpfr.
  18. %package devel
  19. Summary: Header and shared development libraries for MPC
  20. Group: Development/Libraries
  21. Requires: %{name} = %{version}-%{release}
  22. Requires: gmp-devel
  23. Requires: mpfr-devel
  24. Requires(post): /sbin/install-info
  25. Requires(preun): /sbin/install-info
  26. %description devel
  27. Header files and shared object symlinks for MPC is a C library.
  28. %prep
  29. %setup -q -n mpc-%{version}
  30. %build
  31. export CPPFLAGS="%{optflags} -std=gnu99"
  32. export CFLAGS="%{optflags} -std=gnu99"
  33. export EGREP=egrep
  34. %configure --disable-static
  35. make %{?_smp_mflags}
  36. %check
  37. make check
  38. %install
  39. rm -rf $RPM_BUILD_ROOT
  40. make install DESTDIR=$RPM_BUILD_ROOT
  41. rm -f $RPM_BUILD_ROOT/%{_libdir}/libmpc.{l,}a
  42. rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
  43. %clean
  44. rm -rf $RPM_BUILD_ROOT
  45. %post -p /sbin/ldconfig
  46. %postun -p /sbin/ldconfig
  47. %post devel
  48. if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
  49. /sbin/install-info %{_infodir}/mpc.info.gz %{_infodir}/dir || :
  50. fi
  51. %preun devel
  52. if [ $1 = 0 ]; then
  53. if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
  54. /sbin/install-info --delete %{_infodir}/mpc.info.gz %{_infodir}/dir || :
  55. fi
  56. fi
  57. %files
  58. %defattr(-,root,root,-)
  59. %doc README NEWS COPYING.LESSER
  60. %{_libdir}/libmpc.so.*
  61. %files devel
  62. %defattr(-,root,root,-)
  63. %{_libdir}/libmpc.so
  64. %{_includedir}/mpc.h
  65. %{_infodir}/*.info*
  66. %changelog
  67. * Fri May 20 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  68. - updated to 1.0.3
  69. * Fri Sep 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
  70. - updated to 1.0.2
  71. - change Group to System Environment/Libraries (libmpc)
  72. * Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
  73. - update to 1.0.1
  74. * Tue Nov 01 2011 NAKAMURA Kenta <kenta@vinelinux.org> - 0.9-2
  75. - initial build for Vine Linux
  76. * Wed Jun 22 2011 <pmachata@redhat.com> - 0.9-1
  77. - Upstream 0.9
  78. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-0.3.svn855
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  80. * Tue Nov 30 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.2.svn855
  81. - Bump for rebuild against the new mpfr
  82. * Fri Nov 19 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.1.svn855
  83. - Devel updates (to-be-0.8.3, SVN release 855)
  84. - New functions mpc_set_dc, mpc_set_ldc, mpc_get_dc, mpc_get_ldc
  85. - Speed-up mpc_pow_si and mpc_pow_z
  86. - Bug fixes in trigonometric functions, exp, sqrt
  87. - Upstream 0.8.2
  88. - Speed-up mpc_pow_ui
  89. - Adjust BuildRequires
  90. - Resolves: #653931
  91. * Wed Jan 20 2010 Petr Machata <pmachata@redhat.com> - 0.8.1-1
  92. - Upstream 0.8.1
  93. - acosh, asinh, atanh: swap of precisions between real and imaginary parts
  94. - atan: memory leak
  95. - log: wrong ternary value in data file; masked by bug in Mpfr 2.4.1
  96. - Resolves: #555471 FTBFS libmpc-0.8-3.fc13
  97. * Fri Nov 13 2009 Petr Machata <pmachata@redhat.com> - 0.8-3
  98. - Require mpfr-devel, gmp-devel in -devel subpackage
  99. - Don't pass --entry to install-info
  100. * Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-2
  101. - Rename the package to libmpc, it's a better choice of name
  102. - %%preun should uninstall mpc's info page, not make's
  103. - Move info page to -devel
  104. - BR on -devel packages
  105. - Drop postscript documentation
  106. * Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-1
  107. - Initial package.