R-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365
  1. %define pkg_version 2.12.1
  2. %define pkg_release 3%{?_dist_release}
  3. Summary: A language for data analysis and graphics
  4. Summary(ja): データ解析・グラフィック化の言語
  5. Name: R
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. Source0: ftp://cran.r-project.org/pub/R/src/base/R-2/%{name}-%{version}.tar.gz
  9. #Patch0: R-release.diff.gz
  10. License: GPLv2+
  11. Group: Applications/Engineering
  12. URL: http://www.r-project.org
  13. Requires: libgfortran
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gcc-c++
  16. BuildRequires: gcc-gfortran libgfortran
  17. %if %{?_dist_release} == "vl5"
  18. BuildRequires: tetex
  19. %else
  20. BuildRequires: texlive
  21. BuildRequires: texlive-collection-basic
  22. BuildRequires: texlive-collection-texinfo
  23. %endif
  24. BuildRequires: texinfo tcl tk
  25. BuildRequires: libpng-devel libjpeg-devel libtiff-devel
  26. BuildRequires: readline-devel libtermcap-devel
  27. BuildRequires: zlib-devel bzip2-devel
  28. BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
  29. BuildRequires: cairo-devel pango-devel
  30. BuildRequires: libicu-devel
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. Packager: Toshiaki Ara <ara_t@384.jp>
  34. %description
  35. 'GNU S' - A language and environment for statistical computing and
  36. graphics. R is similar to the award-winning S system, which was
  37. developed at Bell Laboratories by John Chambers et al. It provides
  38. a wide variety of statistical and graphical techniques (linear and
  39. nonlinear modelling, statistical tests, time series analysis,
  40. classification, clustering, ...).
  41. R is designed as a true computer language with control-flow
  42. constructions for iteration and alternation, and it allows users to
  43. add additional functionality by defining new functions.
  44. For computationally intensive tasks, C, C++ and Fortran code
  45. can be linked and called at run time.
  46. %description -l ja
  47. 'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
  48. Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
  49. 線形・非線型モデル、統計検定、時系列分析、クラスター分析など
  50. 幅広い統計解析・視覚化手法を提供する。
  51. Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
  52. として設計されており、ユーザが新たに関数を組み込むことが可能である。
  53. また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
  54. 使用することができる。
  55. %package devel
  56. Summary: files for development of R packages.
  57. Summary(ja): Rパッケージ開発用ファイル
  58. Group: Development/Libraries
  59. Requires: R = %{version}-%{release}
  60. %description devel
  61. Install R-devel if you are going to develop or compile R packages.
  62. This is just a stub package containing the documentation on "Writing R
  63. Extensions". However, installing it will ensure that the build
  64. environment for R packages is correct.
  65. %description -l ja devel
  66. Rパッケージを開発したりコンパイルする場合には、このR-develを
  67. インストールします。R-exts.pdf ("Writing R Extensions": 英文)
  68. が含まれているだけのサブパッケージですが、正しくRパッケージを
  69. 開発するための助けになるでしょう。
  70. %package -n libRmath
  71. Summary: standalone math library from the R project
  72. Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
  73. Group: System Environment/Libraries
  74. %description -n libRmath
  75. A standalone library of mathematical and statistical functions derived
  76. from the R project. This packages provides the shared libRmath library.
  77. %description -l ja -n libRmath
  78. 単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
  79. 共有ライブラリを提供する。
  80. %package -n libRmath-devel
  81. Summary: standalone math library from the R project
  82. Summary(ja): libRmathの開発ライブラリ
  83. Group: Development/Libraries
  84. Requires: libRmath = %{version}-%{release}
  85. %description -n libRmath-devel
  86. A standalone library of mathematical and statistical functions derived
  87. from the R project. This packages provides the header files.
  88. %description -l ja -n libRmath-devel
  89. libRmathのヘッダファイル(Rmath.h)
  90. %package -n libRmath-static
  91. Summary: Static R Standalone math library
  92. Summary(ja): libRmath の静的ライブラリ
  93. Group: Development/Libraries
  94. Requires: libRmath-devel = %{version}-%{release}
  95. %description -n libRmath-static
  96. A standalone library of mathematical and statistical functions derived
  97. from the R project. This package provides the static libRmath library.
  98. %prep
  99. %{__rm} -rf ${RPM_BUILD_ROOT}
  100. %setup -q
  101. #%patch0 -p1
  102. %build
  103. export R_PDFVIEWER="%{_bindir}/xdg-open"
  104. export R_PRINTCMD="lpr"
  105. export R_BROWSER="%{_bindir}/xdg-open"
  106. %configure --enable-R-shlib
  107. %{__make} %{?_smp_mflags}
  108. (cd src/nmath/standalone; %{__make} %{?_smp_mflags})
  109. LANG=C make check-all
  110. %{__make} pdf
  111. #We can only "make info" if we have an up to date version of texinfo
  112. %{?INFO: %{__make} info}
  113. %install
  114. %{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
  115. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  116. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
  117. #Install libRmath files
  118. (cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
  119. mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  120. echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
  121. #Fix lication of R_HOME_DIR in shell wrapper
  122. sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  123. > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  124. chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  125. sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  126. > ${RPM_BUILD_ROOT}%{_bindir}/R
  127. chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
  128. %files
  129. %defattr(-, root, root)
  130. %{_bindir}/R
  131. %{_bindir}/Rscript
  132. %{_libdir}/R
  133. %{?INFO:%{_infodir}/R-*.info*}
  134. %{_mandir}/man1/*
  135. /etc/ld.so.conf.d/*
  136. %files devel
  137. %defattr(-, root, root)
  138. %doc doc/manual/R-exts.pdf
  139. %files -n libRmath
  140. %defattr(-, root, root)
  141. %{_libdir}/libRmath.so
  142. %files -n libRmath-devel
  143. %defattr(-, root, root)
  144. %{_libdir}/pkgconfig/*.pc
  145. %{_includedir}/Rmath.h
  146. %files -n libRmath-static
  147. %defattr(-, root, root)
  148. %{_libdir}/libRmath.a
  149. %clean
  150. %{__rm} -rf ${RPM_BUILD_ROOT}
  151. %post
  152. %if 0%{?INFO}
  153. # Create directory entries for info files
  154. # (optional doc files, so we must check that they are installed)
  155. for doc in admin data exts FAQ intro lang; do
  156. file=%{_infodir}/R-${doc}.info.gz
  157. if [ -e $file ]; then
  158. /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
  159. fi
  160. done
  161. %endif
  162. %{_syssbindir}/ldconfig
  163. %preun
  164. %if 0%{?INFO}
  165. if [ $1 = 0 ]; then
  166. # Delete directory entries for info files (if they were installed)
  167. for doc in admin data exts FAQ intro lang; do
  168. file=%{_infodir}/R-${doc}.info.gz
  169. if [ -e ${file} ]; then
  170. /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
  171. fi
  172. done
  173. fi
  174. %endif
  175. %postun -p %{_syssbindir}/ldconfig
  176. %post -n libRmath -p %{_syssbindir}/ldconfig
  177. %postun -n libRmath -p %{_syssbindir}/ldconfig
  178. %changelog
  179. * Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
  180. - add BuildRequires: libicu-devel
  181. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
  182. - synchronized to VinePlus/5 package
  183. * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
  184. - Updated to 2.12.1
  185. - added --enable-R-shlib option to %%configure
  186. - added static subpackage
  187. - use BR: texlive instead of tetex on VineSeed
  188. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
  189. - rebuilt with rpm-4.8.1 for pkg-config
  190. * Thu Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
  191. - recompiled because tcl/tk were not linked
  192. * Thu Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
  193. - Updated to 2.11.0
  194. - added Requires: libgfortran
  195. * Thu Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
  196. - Updated to 2.10.1
  197. * Thu Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
  198. - patched to 2.10.0
  199. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
  200. - spec in UTF-8
  201. * Thu Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
  202. - Updated to 2.10.0
  203. * Thu Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
  204. - Updated to 2.9.2
  205. - deleted BuildRequires: lapack-devel blas-devel
  206. - rewrote SPEC file
  207. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
  208. - Updated to 2.5.1
  209. - added BuildRequires: gcc-gfortran for VineSeed
  210. - added BuildRequires: lapack-devel blas-devel
  211. - fixed %preun script
  212. * Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
  213. - Updated to 2.4.1
  214. - Added INFO option
  215. - Exclude Japanese Rprofile.site
  216. * Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  217. - Updated to 2.4.0
  218. * Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
  219. - Added optimization flags
  220. * Tue Jun 6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
  221. - Packaged for VineLinux3.2
  222. * Tue May 9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
  223. - Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
  224. * Mon May 8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
  225. - Packaged for VineLinux3.2
  226. - Slipped texinfo
  227. - Fixed preun error
  228. - Preset Japanese fonts
  229. * Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  230. - Packaged for VineLinux3.2
  231. * Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
  232. - Restored CAPABILITIES file lost in 2.2.1beta
  233. * Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
  234. - Configure uses --without-blas by default.
  235. - Install pdf manuals.
  236. - All toplevel documentation files are installed into _libdir/R
  237. as they may be required by R (qv note on AUTHORS and THANKS below).
  238. - Legacy scripts for rebuilding package indices removed.
  239. * Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
  240. - R now compiles with gcc 4.0.1 and default rpm optimization flags.
  241. * Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
  242. - The files AUTHORS and THANKS need to be installed into _libdir/R
  243. as they are required by the function contributors(). Previously
  244. they were installed only as documentation files.
  245. * Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
  246. - Corrected date error in SPEC file.
  247. * Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
  248. - Dropped support for Red Hat boxed set.
  249. - Synchronized with Fedora Extras 4 RPM by Tom Calloway
  250. including support for shared R library.
  251. - Added gfortran support. However, gcc 4.0.0 will not compile R correctly
  252. with the default optimization flags, so there is a temporary work-around.
  253. * Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
  254. - Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
  255. * Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
  256. - Install R-data.info file as well.
  257. - Make info processing conditional on texinfo version, not platform release,
  258. so that if a new enough version is installed, we will build and install info.
  259. * Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
  260. - Built R 2.1.0. R now supports internationalization, so the patch
  261. to set the locale to "C" is now dropped.
  262. - install.packages() exits gracefully with a helpful message if
  263. the file INSTALL is not present, so this is now included in the
  264. R-devel package.
  265. * Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
  266. - Added support for Scientific Linux (http://www.scientificlinux.org)
  267. A distribution based on RHEL. Thanks to Jon Peatfield.
  268. * Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
  269. - Fixed file ownership in R-devel and libRmath packages
  270. * Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
  271. - R-devel package is now a stub package with no files, except a documentation
  272. file (RPM won't accept sub-packages with no files). R now conflicts
  273. with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
  274. - Created libRmath subpackage with shared library.
  275. * Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
  276. - Created R-devel and libRmath-devel subpackages
  277. * Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
  278. - Built R 2.0.1
  279. * Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
  280. - Set R_PRINTCMD at configure times so that by default getOption(printcmd)
  281. gives "lpr".
  282. - Define macro fcx for all Fedora distributions. This replaces Rinfo
  283. * Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
  284. - Info support is now conditional on the macro Rinfo, which is only
  285. defined for Fedora 1 and 2.
  286. * Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
  287. - Built R 2.0.0
  288. - There is no longer a BUGS file, so this is not installed as a
  289. documentation file.