123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458 |
- %bcond_with selinux
- %bcond_without pam
- %bcond_without audit
- %bcond_without inotify
- %define ver 1.5.0
- %define rel 1
- Summary: Cron daemon for executing programs at set times
- Name: cronie
- Version: %{ver}
- Release: %{rel}%{?_dist_release}
- License: MIT and BSD and ISC and GPLv2+
- Group: System Environment/Base
- URL: https://fedorahosted.org/cronie
- Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
- # from cronie 1.4.8 tarball
- Source1: cronie.init
- Patch0: cronie-1.5.0-temp-name.patch
- Requires: dailyjobs
- Conflicts: vixie-cron
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: iwaim
- %if %{with selinux}
- Requires: libselinux >= 2.0.64
- Buildrequires: libselinux-devel >= 2.0.64
- %endif
- %if %{with pam}
- Requires: pam >= 1.0.1
- Buildrequires: pam-devel >= 1.0.1
- %endif
- %if %{with audit}
- Buildrequires: audit-libs-devel >= 1.4.1
- %endif
- Requires(post): coreutils sed
- Requires(post): chkconfig
- Requires(preun): chkconfig
- Obsoletes: vixie-cron <= 3.0.1
- %description
- Cronie contains the standard UNIX daemon crond that runs specified programs at
- scheduled times and related tools. It is a fork of the original vixie-cron and
- has security and configuration enhancements like the ability to use pam and
- SELinux.
- %package anacron
- Summary: Utility for running regular jobs
- Requires: crontabs
- Group: System Environment/Base
- Provides: dailyjobs
- Provides: anacron = 2.4
- Obsoletes: anacron <= 2.3
- Requires(post): coreutils
- Requires: %{name} = %{version}-%{release}
- %description anacron
- Anacron is part of cronie that is used for running jobs with regular
- periodicity which do not have exact time of day of execution.
- The default settings of anacron execute the daily, weekly, and monthly
- jobs, but anacron allows setting arbitrary periodicity of jobs.
- Using anacron allows running the periodic jobs even if the system is often
- powered off and it also allows randomizing the time of the job execution
- for better utilization of resources shared among multiple systems.
- %package noanacron
- Summary: Utility for running simple regular jobs in old cron style
- Group: System Environment/Base
- Provides: dailyjobs
- Requires: crontabs
- Requires: %{name} = %{version}-%{release}
- %description noanacron
- Old style of running {hourly,daily,weekly,monthly}.jobs without anacron. No
- extra features.
- %prep
- %setup -q
- %patch0 -p1
- %build
- %configure \
- %if %{with pam}
- --with-pam \
- %endif
- %if %{with selinux}
- --with-selinux \
- %endif
- %if %{with audit}
- --with-audit \
- %endif
- %if %{with inotify}
- --with-inotify \
- %endif
- --enable-anacron \
- --enable-pie \
- --enable-relro
- make %{?_smp_mflags}
- %install
- make install DESTDIR=$RPM_BUILD_ROOT DESTMAN=$RPM_BUILD_ROOT%{_mandir}
- mkdir -pm700 $RPM_BUILD_ROOT%{_localstatedir}/spool/cron
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
- mkdir -pm755 $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/
- %if ! %{with pam}
- rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/crond
- %endif
- install -m 600 crond.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/crond
- touch $RPM_BUILD_ROOT%{_sysconfdir}/cron.deny
- install -m 600 contrib/anacrontab $RPM_BUILD_ROOT%{_sysconfdir}/anacrontab
- install -c -m755 contrib/0hourly $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/0hourly
- mkdir -pm 700 $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly
- install -c -m755 contrib/0anacron $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/0anacron
- mkdir -p $RPM_BUILD_ROOT/var/spool/anacron
- touch $RPM_BUILD_ROOT/var/spool/anacron/cron.daily
- touch $RPM_BUILD_ROOT/var/spool/anacron/cron.weekly
- touch $RPM_BUILD_ROOT/var/spool/anacron/cron.monthly
- # noanacron package
- install -m 644 contrib/dailyjobs $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/dailyjobs
- # install initscript
- mkdir -p $RPM_BUILD_ROOT%{_initddir}
- install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/crond
- %post
- # run after an installation
- /sbin/chkconfig --add crond
- %post anacron
- [ -e /var/spool/anacron/cron.daily ] || touch /var/spool/anacron/cron.daily
- [ -e /var/spool/anacron/cron.weekly ] || touch /var/spool/anacron/cron.weekly
- [ -e /var/spool/anacron/cron.monthly ] || touch /var/spool/anacron/cron.monthly
- %preun
- # run before a package is removed
- if [ "$1" -eq 0 ]; then
- /sbin/service crond stop >/dev/null 2>&1
- /sbin/chkconfig --del crond
- fi
- %postun
- # run after a package is removed
- if [ "$1" -ge "1" ]; then
- /sbin/service crond condrestart >/dev/null 2>&1 || :
- fi
- %triggerpostun -- vixie-cron
- /sbin/chkconfig --add crond
- %files
- %doc AUTHORS COPYING INSTALL README ChangeLog
- %attr(755,root,root) %{_sbindir}/crond
- %attr(4755,root,root) %{_bindir}/crontab
- %{_mandir}/man8/crond.*
- %{_mandir}/man8/cron.*
- %{_mandir}/man5/crontab.*
- %{_mandir}/man1/crontab.*
- %dir %{_localstatedir}/spool/cron
- %dir %{_sysconfdir}/cron.d
- %if %{with pam}
- %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/pam.d/crond
- %endif
- %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/crond
- %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/cron.deny
- %attr(0644,root,root) %{_sysconfdir}/cron.d/0hourly
- %attr(0755,root,root) %{_initddir}/crond
- %files anacron
- %{_sbindir}/anacron
- %attr(0755,root,root) %{_sysconfdir}/cron.hourly/0anacron
- %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/anacrontab
- %dir /var/spool/anacron
- %ghost %verify(not md5 size mtime) /var/spool/anacron/cron.daily
- %ghost %verify(not md5 size mtime) /var/spool/anacron/cron.weekly
- %ghost %verify(not md5 size mtime) /var/spool/anacron/cron.monthly
- %{_mandir}/man5/anacrontab.*
- %{_mandir}/man8/anacron.*
- %files noanacron
- %attr(0644,root,root) %{_sysconfdir}/cron.d/dailyjobs
- %changelog
- * Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.0-1
- - new upstream release.
- - dropped all patches.
- - imported Patch0 from rawhide.
- - added O:vixie-cron.
- * Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-2
- - run chkconfig for vixie-cron in triggerpostun script
- * Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-1
- - initial build for Vine Linux
- * Mon Jan 27 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-11
- - now it's work even on ppc64, all checks working correctly
- - Related: rhbz#1031384
- * Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 1.4.11-10
- - Mass rebuild 2014-01-24
- * Wed Jan 22 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-9
- - fix coverity warnings about dead code. Incorrect checking of values.
- - Related: rhbz#1031384
- * Mon Jan 20 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-8
- - anacron do not execute jobs run from command line
- - Related: rhbz#1031384
- * Wed Jan 08 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-7
- - anacron segfaults with certain config data
- - Resolves: rhbz#1031384
- * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 1.4.11-6
- - Mass rebuild 2013-12-27
- * Tue Oct 15 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-5
- - Cronie doesn't work when is executed as stand alone without systemd (for
- debuging issues)
- - Fix another permission, hopefully all now.
- - Resolves: rhbz#1012420, rhbz#1015567
- * Fri Sep 13 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-4
- - fix permission on configuration files, same as rhbz#706979
- * Fri Aug 30 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-3
- - 919290 systemd script use "KillMode=process"
- - Fcntl locking has different semantics than flock. Prefer flock.
- - 49225e172d156531ca142518d2638350752e373a
- - Pull PAM environment variables also from session modules.
- - c8e7d1b43c86a85441cb09cf7e08090f3ec1f384
- * Mon Jul 22 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-2
- - scriptlets are not created correctly if systemd is not in BR 986698
- - remove sub-package sysvinit, which is not needed anymore
- - update license, anacron is under GPLv2+
- * Thu Jul 18 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-1
- - new release 1.4.11 (contains previous bug fixes from 1.4.10-5)
- * Tue Jun 11 2013 Tomáš Mráz <tmraz@redhat.com> - 1.4.10-5
- - add support for RANDOM_DELAY - delaying job startups
- - pass some environment variables to processes (LANG, etc.) (#969761)
- - do not use putenv() with string literals (#971516)
- * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.10-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
- * Wed Jan 2 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-3
- - change configuration files to 644
- - change 6755 to 4755 for crontab binary
- * Tue Nov 27 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-1
- - New release 1.4.10
- * Thu Nov 22 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.9-1
- - New release 1.4.9
- * Wed Sep 05 2012 Václav Pavlín <vpavlin@redhat.com> - 1.4.8-13
- - Scriptlets replaced with new systemd macros (#850070)
- * Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-12
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
- * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-11
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-10
- - Rebuilt for glibc bug#747377
- * Tue Oct 25 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-9
- - make crond run a little bit later in the boot process (#747759)
- * Mon Oct 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-8
- - change triggerun to fix 735802 during upgrade
- * Wed Jul 27 2011 Karsten Hopp <karsten@redhat.com> 1.4.8-7
- - rebuild again, ppc still had the broken rpm in the buildroots
- * Thu Jul 21 2011 Rex Dieter <rdieter@fedoraproject.org> 1.4.8-6
- - rebuild (broken rpm in buildroot)
- * Thu Jul 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-5
- - fix permission of init.d/crond
- * Thu Jun 30 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-4
- - drop the without systemd build condition
- - add the chkconfig readding trigger to the sysvinit subpackage
- * Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-3
- - start crond after auditd
- * Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-2
- - fix inotify support to not leak fds (#717505)
- * Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-1
- - update to 1.4.8
- - create sub-package sysvinit for initscript
- * Mon May 9 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-3
- - missing requirement on systemd-sysv for scriptlets
- * Thu May 05 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.7-2
- - use only systemd units with systemd
- - add trigger for restart on glibc, libselinux or pam upgrades (#699189)
- * Tue Mar 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-1
- - new release 1.4.7
- * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-9
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Mon Jan 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-8
- - enable crond even with systemctl
- * Thu Dec 16 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-7
- - 663193 rewritten selinux support
- * Wed Dec 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-6
- - apply selinux patch from dwalsh
- * Fri Dec 10 2010 Tomas Mraz <tmraz@redhat.com> - 1.4.6-5
- - do not lock jobs that fall out of allowed range - 661966
- * Thu Dec 02 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-4
- - fix post (thanks plautrba for review)
- * Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-3
- - systemd init script 617320
- * Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-2
- - fix typos in man pages
- * Fri Oct 22 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-1
- - update to 1.4.6
- * Fri Aug 13 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-4
- - 623908 fix fd leak in anacron, which caused denail of prelink
- and others
- * Mon Aug 9 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-2
- - remove sendmail from requirements. If it's not installed, it will
- log into (r)syslog.
- * Mon Aug 2 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-1
- - update to new release
- * Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.4-1
- - update to new release
- * Mon Feb 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-3
- - 564894 FTBFS DSOLinking
- * Thu Nov 5 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-2
- - 533189 pam needs add a line and selinux needs defined one function
- * Fri Oct 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-1
- - 531963 and 532482 creating noanacron package
- * Mon Oct 19 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-2
- - 529632 service crond stop returns appropriate value
- * Mon Oct 12 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-1
- - new release
- * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-3
- - rebuilt with new audit
- * Fri Aug 14 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-2
- - create the anacron timestamps in correct post script
- * Fri Aug 14 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.1-1
- - update to 1.4.1
- - create and own /var/spool/anacron/cron.{daily,weekly,monthly} to
- remove false warning about non existent files
- - Resolves: 517398
- * Wed Aug 5 2009 Tomas Mraz <tmraz@redhat.com> - 1.4-4
- - 515762 move anacron provides and obsoletes to the anacron subpackage
- * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Mon Jul 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4-2
- - merge cronie and anacron in new release of cronie
- - obsolete/provide anacron in spec
- * Thu Jun 18 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-2
- - 506560 check return value of access
- * Mon Apr 27 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-1
- - new release
- * Fri Apr 24 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-8
- - 496973 close file descriptors after exec
- * Mon Mar 9 2009 Tomas Mraz <tmraz@redhat.com> - 1.2-7
- - rebuild
- * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Tue Dec 23 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-5
- - 477100 NO_FOLLOW was removed, reload after change in symlinked
- crontab is needed, man updated.
- * Fri Oct 24 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-4
- - update init script
- * Thu Sep 25 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-3
- - add sendmail file into requirement, cause it's needed some MTA
- * Thu Sep 18 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-2
- - 462252 /etc/sysconfig/crond does not need to be executable
- * Thu Jun 26 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-1
- - update to 1.2
- * Tue Jun 17 2008 Tomas Mraz <tmraz@redhat.com> - 1.1-3
- - fix setting keycreate context
- - unify logging a bit
- - cleanup some warnings and fix a typo in TZ code
- - 450993 improve and fix inotify support
- * Wed Jun 4 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-2
- - 49864 upgrade/update problem. Syntax error in spec.
- * Wed May 28 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-1
- - release 1.1
- * Tue May 20 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-6
- - 446360 check for lock didn't call chkconfig
- * Tue Feb 12 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-5
- - upgrade from less than cronie-1.0-4 didn't add chkconfig
- * Wed Feb 6 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-4
- - 431366 after reboot wasn't cron in chkconfig
- * Tue Feb 5 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-3
- - 431366 trigger part => after update from vixie-cron on cronie will
- be daemon running.
- * Wed Jan 30 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-2
- - change the provides on higher version than obsoletes
- * Tue Jan 8 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-1
- - packaging cronie
- - thank's for help with packaging to my reviewers
|