librsvg2-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423
  1. %define __libtoolize :
  2. Name: librsvg2
  3. Summary: An SVG library based on cairo.
  4. Summary(ja): cairo ベースの SVG ライブラリ
  5. Group: graphics,system
  6. Version: 2.50.4
  7. Release: 1%{?_dist_release}
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPL
  11. %global shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
  12. Source: https://download.gnome.org/sources/librsvg/%{shortver}/librsvg-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: gobject-introspection-devel
  15. BuildRequires: cairo-devel
  16. BuildRequires: fontconfig-devel
  17. BuildRequires: gdk-pixbuf2-devel
  18. BuildRequires: glib2-devel
  19. BuildRequires: libxml2-devel
  20. BuildRequires: pango-devel
  21. BuildRequires: gtk-doc
  22. BuildRequires: vala
  23. BuildRequires: rust
  24. BuildRequires: cargo
  25. Requires: cairo
  26. Requires(post,postun): gdk-pixbuf2
  27. %description
  28. An SVG library based on cairo.
  29. %description -l ja
  30. cairo ベースの SVG ライブラリです
  31. %package devel
  32. Summary: Libraries and include files for developing with librsvg.
  33. Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
  34. Group: programming
  35. Requires: %{name} = %{version}
  36. Requires: gdk-pixbuf2-devel
  37. Requires: cairo-devel
  38. %description devel
  39. This package provides the necessary development libraries and include
  40. files to allow you to develop with librsvg.
  41. %package docs
  42. Summary: Documentation for %{name}
  43. Summary(ja): %{name} 用のドキュメント
  44. Group: documentation
  45. BuildArch: noarch
  46. Requires: %{name} = %{version}-%{release}
  47. %description docs
  48. This package contains documentation for %{name}.
  49. %package vala
  50. Summary: Vala bindings for %{name}
  51. Summary(ja): %{name} の Vala バインディング
  52. Group: programming
  53. Requires: %{name} = %{version}-%{release}
  54. Requires: vala
  55. %description vala
  56. Vala bindings for %{name}.
  57. %debug_package
  58. %prep
  59. %setup -q -n librsvg-%{version}
  60. %build
  61. %configure --enable-gtk-doc \
  62. --enable-introspection=yes \
  63. --enable-vala=yes \
  64. --with-svgz \
  65. --enable-gtk-theme \
  66. --disable-static
  67. %__make %{?_smp_mflags}
  68. %install
  69. rm -rf %{buildroot}
  70. make install DESTDIR=%{buildroot}
  71. rm -f %{buildroot}%{_libdir}/*.{a,la}
  72. rm -f %{buildroot}%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
  73. rm -f %{buildroot}%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
  74. rm -rf %{buildroot}%{_docdir}/librsvg
  75. %find_lang librsvg
  76. %clean
  77. rm -rf %{buildroot}
  78. %post
  79. /sbin/ldconfig
  80. if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
  81. /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
  82. fi ||:
  83. %postun
  84. /sbin/ldconfig
  85. if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
  86. /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
  87. fi ||:
  88. %files -f librsvg.lang
  89. %defattr(-,root,root,-)
  90. %license COPYING.LIB
  91. %doc AUTHORS NEWS README.md
  92. %{_bindir}/rsvg-convert
  93. %{_libdir}/librsvg-2.so.*
  94. %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so
  95. %{_libdir}/girepository-1.0/Rsvg-2.0.typelib
  96. %dir %{_datadir}/thumbnailers
  97. %{_datadir}/thumbnailers/librsvg.thumbnailer
  98. %{_mandir}/man1/rsvg-convert.1.gz
  99. %files devel
  100. %defattr(-,root,root,-)
  101. %{_libdir}/librsvg-2.so
  102. %{_includedir}/librsvg-2.0/librsvg
  103. %{_libdir}/pkgconfig/librsvg-2.0.pc
  104. %{_datadir}/gir-1.0/Rsvg-2.0.gir
  105. %files docs
  106. %defattr(-,root,root,-)
  107. %{_datadir}/gtk-doc/html/rsvg-2.0
  108. %files vala
  109. %defattr(-,root,root,-)
  110. %{_datadir}/vala/vapi/librsvg-2.0.*
  111. %changelog
  112. * Thu Apr 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.50.4-1
  113. - new upstream release.
  114. * Mon Mar 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.50.3-1
  115. - new upstream release.
  116. * Thu Aug 13 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.48.8-1
  117. - new upstream release.
  118. - cleaned BR: up.
  119. * Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.46.4-1
  120. - new upstream release.
  121. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.16-1
  122. - new upstream release
  123. * Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.12-1
  124. - new upstream release
  125. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.11-1
  126. - new upstream release
  127. - remove Patch0
  128. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.10-1
  129. - new upstream release
  130. - add Patch0 (librsvg-2.40.10-git20150811.patch)
  131. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.9-1
  132. - new upstream release
  133. * Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.8-1
  134. - new upstream release
  135. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.7-1
  136. - new upstream release
  137. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.6-1
  138. - new upstream release
  139. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.5-1
  140. - new upstream release
  141. * Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
  142. - new upstream release
  143. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-2
  144. - rebuild with libpng-1.6.12
  145. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
  146. - new upstream release
  147. * Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-2
  148. - fix typo
  149. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
  150. - new upstream release
  151. - remove BuildRequires: gtk2-devel
  152. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-2
  153. - add BuildRequires: autoconf, gtk-doc, vala-devel, vala-tools
  154. - create %%{name}-docs and %%{name}-vala subpackages
  155. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
  156. - new upstream release
  157. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
  158. - new upstream release
  159. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
  160. - new upstream release
  161. * Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
  162. - new upstream release
  163. - add BuildRequires: gobject-introspection-devel
  164. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
  165. - new upstream release
  166. - remove Patch0
  167. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
  168. - new upstream release
  169. - add Patch0 (librsvg2-2.34.0-git20110728.patch)
  170. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  171. - new upstream release
  172. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  173. - new upstream release
  174. - remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
  175. - remove Requires: libart_lgpl
  176. - add configure option (--disable-static)
  177. - remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
  178. - fix %install, %files, %post and %postun
  179. * Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
  180. - build with rpm-4.8.1-1 for pkg-config file
  181. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
  182. - new upstream release
  183. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  184. - new upstream release
  185. - remove static libs
  186. * Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
  187. - new upstream release
  188. - spec in UTF-8
  189. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
  190. - new upstream release
  191. * Sat Mar 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
  192. - rebuilt with libgsf-1.14.8
  193. * Sat Sep 8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  194. - new upstream release
  195. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
  196. - new upstream release
  197. - add BuildRequires: dbus-glib-devel, avahi-glib-devel
  198. - add BuildRequires: libgsf-devel, libcroco-devel
  199. - add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
  200. - add Requires(post,postun): glib2
  201. * Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
  202. - rebuild with gtk+-2.10
  203. * Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
  204. - rebuilt without libgsf-devel
  205. * Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
  206. - update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
  207. for biarch support. (TODO: add compat32)
  208. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
  209. - rebuild
  210. * Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
  211. - new upstream release
  212. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
  213. - new upstream release
  214. * Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  215. - new upstream release
  216. * Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
  217. - new upstream release
  218. - added --disable-gtk-doc option
  219. * Sat Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
  220. - new upstream release
  221. - added gtk-doc to devel package
  222. * Sun Oct 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
  223. - new upstream release
  224. - added Japanese description
  225. - added --without-svgz option (because it requires libgsf)
  226. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  227. - new upstream release
  228. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  229. - new upstream release
  230. * Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
  231. - rebuilt to avoid unwanted dependency (libgsf)
  232. * Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
  233. - add gdk-pixbuf-query-loaders to post/postun script.
  234. * Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
  235. - rebuild with gtk+-2.4.0
  236. * Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  237. - new upstream release
  238. * Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
  239. - fix kanji code of spec file
  240. - fix file entry, add missing files
  241. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
  242. - new upstream release
  243. * Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
  244. - added --without-svgz and --without-gimp to %configure
  245. * Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
  246. - new upstream release
  247. - added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
  248. - added %{_libdir}/gtk-2.0/* to devel package
  249. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  250. - new upstream release
  251. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
  252. - new upstream release
  253. * Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
  254. - new upstream release
  255. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
  256. - build for Vine Linux
  257. - new upstream release from gnome-2.1.4
  258. * Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
  259. - 2.0.1
  260. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  261. - automated rebuild
  262. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  263. - automated rebuild
  264. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  265. - rebuild in different environment
  266. * Thu May 02 2002 Havoc Pennington <hp@redhat.com>
  267. - rebuild in different environment
  268. * Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
  269. - 1.1.6
  270. * Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
  271. - Update to 1.1.3
  272. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  273. - automated rebuild
  274. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  275. - new CVS snap 1.1.0.91
  276. - remove automake/autoconf calls
  277. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  278. - convert to librsvg2 RPM
  279. * Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
  280. - 1.0.2
  281. * Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
  282. - Add a patch that moves the includes to librsvg-1/librsvg
  283. - in preparation for a later librsvg 2 library.
  284. * Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
  285. - build requires gnome-libs-devel, #49509
  286. * Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
  287. - own /usr/include/librsvg
  288. * Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
  289. - fixed the linefeed problem in multibyte environment. (Bug#49310)
  290. * Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
  291. - put .la file back in package
  292. * Fri Jul 6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  293. - Put changelog at the end
  294. - Move .so files to devel subpackage
  295. - Don't mess with ld.so.conf
  296. - Don't use %%{prefix}, this isn't a relocatable package
  297. - Don't define a bad docdir
  298. - Add BuildRequires
  299. - Use %%{_tmppath}
  300. - Don't define name, version etc. on top of the file (why do so many do that?)
  301. - s/Copyright/License/
  302. * Wed May 9 2001 Jonathan Blandford <jrb@redhat.com>
  303. - Put into Red Hat Build system
  304. * Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
  305. - removed obsoletes from sub packages and added mozilla and trilobite
  306. subpackages
  307. * Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
  308. - created this thing