mate-panel-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248
  1. Summary: The MATE Panel
  2. Name: mate-panel
  3. Version: 1.1.0
  4. Release: 2%{?_dist_release}
  5. Source0: %{name}-%{version}.tar.xz
  6. Source1: vine-mate-panel-default-setup.entries
  7. License: GPLv2
  8. Group: User Interface/Desktops
  9. URL: https://matsusoft.com.ar/projects/mate/
  10. BuildRequires: mate-common
  11. BuildRequires: mate-doc-utils
  12. BuildRequires: mate-conf-devel
  13. BuildRequires: mate-desktop-devel
  14. BuildRequires: mate-menus-devel
  15. BuildRequires: libmateweather-devel
  16. BuildRequires: libmatecomponentui-devel
  17. BuildRequires: gtk2-devel
  18. BuildRequires: libSM-devel
  19. BuildRequires: libcanberra-devel
  20. BuildRequires: dbus-glib-devel
  21. BuildRequires: libwnck-devel
  22. BuildRequires: librsvg2-devel
  23. BuildRequires: evolution-data-server-devel
  24. BuildRequires: NetworkManager-devel
  25. BuildRequires: gtk-doc
  26. BuildRequires: autoconf
  27. BuildRequires: automake
  28. Requires(post,pre,preun): mate-conf
  29. Requires(post,postun): desktop-file-utils
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. Packager: Takemikaduchi
  34. %description
  35. mate-panel contains the MATE panel, the libmate-panel-applet library and
  36. several applets:
  37. + the MATE panel is the area on your desktop from which you can run
  38. applications and applets, and perform other tasks.
  39. + the libmate-panel-applet library allows to develop small applications
  40. which may be embedded in the panel. These are called applets.
  41. Documentation for the API is available with gtk-doc.
  42. + the applets supplied here include the Workspace Switcher, the Window
  43. List, the Window Selector, the Notification Area, the Clock and the
  44. infamous 'Wanda the Fish'.
  45. %package devel
  46. Summary: Development tools for mate-panel
  47. Summary(ja): mate-panel の開発環境
  48. Group: Development/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. Requires: pkgconfig
  51. %description devel
  52. Header files and libraries for building a extension library for the
  53. mate-panel.
  54. %package doc
  55. Summary: Documentation for mate-panel
  56. Summary(ja): mate-panel 用のドキュメント
  57. Group: Documentation
  58. Requires: %{name} = %{version}-%{release}
  59. BuildArch: noarch
  60. %description doc
  61. This package contains documentation for mate-panel.
  62. %prep
  63. %setup -q
  64. cp -f %{SOURCE1} mate-panel/panel-default-setup.entries
  65. %build
  66. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
  67. %configure \
  68. --libexecdir=%{_libexecdir}/mate \
  69. --disable-static \
  70. --disable-scrollkeeper \
  71. --enable-introspection \
  72. --enable-matecomponent
  73. %{__make} %{?_smp_mflags}
  74. %install
  75. %{__rm} -rf ${RPM_BUILD_ROOT}
  76. export MATECONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  77. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  78. unset MATECONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  79. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
  80. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  81. %find_lang %{name}-2.0
  82. %clean
  83. %{__rm} -rf ${RPM_BUILD_ROOT}
  84. %post
  85. /sbin/ldconfig
  86. export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
  87. SCHEMAS=" \
  88. clock.schemas \
  89. fish.schemas \
  90. panel-compatibility.schemas \
  91. panel-default-setup.entries \
  92. panel-general.schemas \
  93. panel-global.schemas \
  94. panel-object.schemas \
  95. panel-toplevel.schemas \
  96. window-list.schemas \
  97. workspace-switcher.schemas"
  98. for S in $SCHEMAS; do
  99. echo %{_sysconfdir}/mateconf/schemas/$S; done \
  100. | xargs mateconftool-2 --makefile-install-rule >& /dev/null ||:
  101. mateconftool-2 --direct --config-source=$MATECONF_CONFIG_SOURCE --load %{_sysconfdir}/mateconf/schemas/panel-default-setup.entries > /dev/null || :
  102. mateconftool-2 --direct --config-source=$MATECONF_CONFIG_SOURCE --load %{_sysconfdir}/mateconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
  103. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  104. touch --no-create %{_datadir}/icons/hicolor
  105. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  106. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  107. fi
  108. %pre
  109. if [ "$1" -gt 1 ]; then
  110. export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
  111. SCHEMAS=" \
  112. clock.schemas \
  113. fish.schemas \
  114. panel-compatibility.schemas \
  115. panel-default-setup.entries \
  116. panel-general.schemas \
  117. panel-global.schemas \
  118. panel-object.schemas \
  119. panel-toplevel.schemas \
  120. window-list.schemas \
  121. workspace-switcher.schemas"
  122. for S in $SCHEMAS; do
  123. echo %{_sysconfdir}/mateconf/schemas/$S; done \
  124. | xargs mateconftool-2 --makefile-uninstall-rule >& /dev/null ||:
  125. fi
  126. %preun
  127. if [ "$1" -eq 0 ]; then
  128. export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
  129. SCHEMAS=" \
  130. clock.schemas \
  131. fish.schemas \
  132. panel-compatibility.schemas \
  133. panel-default-setup.entries \
  134. panel-general.schemas \
  135. panel-global.schemas \
  136. panel-object.schemas \
  137. panel-toplevel.schemas \
  138. window-list.schemas \
  139. workspace-switcher.schemas"
  140. for S in $SCHEMAS; do
  141. echo %{_sysconfdir}/mateconf/schemas/$S; done \
  142. | xargs mateconftool-2 --makefile-uninstall-rule >& /dev/null ||:
  143. fi
  144. %postun
  145. /sbin/ldconfig
  146. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  147. touch --no-create %{_datadir}/icons/hicolor
  148. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  149. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  150. fi
  151. %files -f %{name}-2.0.lang
  152. %defattr(-,root,root,-)
  153. %doc COPYING ChangeLog NEWS README
  154. %{_sysconfdir}/mateconf/schemas/clock.schemas
  155. %{_sysconfdir}/mateconf/schemas/fish.schemas
  156. %{_sysconfdir}/mateconf/schemas/panel-compatibility.schemas
  157. %{_sysconfdir}/mateconf/schemas/panel-default-setup.entries
  158. %{_sysconfdir}/mateconf/schemas/panel-general.schemas
  159. %{_sysconfdir}/mateconf/schemas/panel-global.schemas
  160. %{_sysconfdir}/mateconf/schemas/panel-object.schemas
  161. %{_sysconfdir}/mateconf/schemas/panel-toplevel.schemas
  162. %{_sysconfdir}/mateconf/schemas/window-list.schemas
  163. %{_sysconfdir}/mateconf/schemas/workspace-switcher.schemas
  164. %{_bindir}/mate-desktop-item-edit
  165. %{_bindir}/mate-panel
  166. %{_bindir}/mate-panel-test-applets
  167. %{_bindir}/panel-test-applets-matecomponent
  168. %{_libdir}/libmate-panel-applet-*.so.*
  169. %{_libdir}/girepository-1.0/MatePanelApplet-3.0.typelib
  170. %{_libdir}/mate-panel/modules/libmate-panel-applets-matecomponent.so
  171. %{_libexecdir}/mate/clock-applet
  172. %{_libexecdir}/mate/fish-applet
  173. %{_libexecdir}/mate/mate-panel-add
  174. %{_libexecdir}/mate/notification-area-applet
  175. %{_libexecdir}/mate/wnck-applet
  176. %{_datadir}/applications/mate-panel.desktop
  177. %{_datadir}/dbus-1/services/*.service
  178. %{_datadir}/icons/hicolor/*/*/*
  179. %{_datadir}/idl/mate-panel-2.0/MATE_Panel.idl
  180. %{_datadir}/mate/help
  181. %{_datadir}/mate-2.0/ui/MATE_Panel_Popup.xml
  182. %{_datadir}/mate-panel
  183. %{_datadir}/mate-panelrc
  184. %{_datadir}/omf/mate-applet-clock
  185. %{_datadir}/omf/mate-applet-fish
  186. %{_mandir}/man1/mate-panel.1.gz
  187. %files devel
  188. %defattr(-,root,root,-)
  189. %{_includedir}/mate-panel-3.0/
  190. %{_includedir}/panel-2.0/
  191. %{_libdir}/libmate-panel-applet-*.so
  192. %{_libdir}/pkgconfig/libmatepanelapplet-2.0.pc
  193. %{_libdir}/pkgconfig/libmatepanelapplet-3.0.pc
  194. %{_datadir}/gir-1.0/MatePanelApplet-3.0.gir
  195. %files doc
  196. %defattr(-,root,root,-)
  197. %{_datadir}/gtk-doc/html/mate-panel-applet
  198. %changelog
  199. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
  200. - change category
  201. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
  202. - initial build for Vine Linux