zint-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168
  1. Summary: A barcode generator and library
  2. Summary(ja): Zintバーコード作成プログラム
  3. Name: zint
  4. Version: 2.4.2
  5. Release: 3%{?_dist_release}
  6. License: GPLv3+
  7. URL: http://www.zint.org.uk
  8. Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  9. Patch0: zint-2.4.0-qr-kanji.patch
  10. Patch1: %{name}-rpath.patch
  11. Patch2: %{name}-2.4.2-libpng16.patch
  12. Group: Applications/Engineering
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: cmake
  15. BuildRequires: libpng-devel
  16. BuildRequires: zlib-devel
  17. BuildRequires: qt4-devel
  18. BuildRequires: desktop-file-utils
  19. Distribution: Vine Linux
  20. Vendor: Project Vine
  21. Packager: owa
  22. %description
  23. Zint is a C library for encoding data in several barcode variants. The
  24. bundled command-line utility provides a simple interface to the library.
  25. Features of the library:
  26. - Over 50 symbologies including all ISO/IEC standards, like QR codes.
  27. - Unicode translation for symbologies which support Latin-1 and
  28. Kanji character sets.
  29. - Full GS1 support including data verification and automated insertion of
  30. FNC1 characters.
  31. - Support for encoding binary data including NULL (ASCII 0) characters.
  32. - Health Industry Barcode (HIBC) encoding capabilities.
  33. - Output in PNG, EPS and SVG formats with user adjustable sizes and colors.
  34. - Verification stage for SBN, ISBN and ISBN-13 data.
  35. %package devel
  36. Summary: Library and header files for %{name}
  37. Summary(ja): Zintバーコードの開発用ライブラリとヘッダファイル
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. %description devel
  41. C library and header files needed to develop applications using %{name}.
  42. The API documentation can be found ont the project website:
  43. http://www.zint.org.uk/zintSite/Manual.aspx
  44. %package qt
  45. Summary: Zint Barcode Studio GUI and library
  46. Summary(ja): Zintバーコード作成GUI(QT)とライブラリ
  47. Group: Applications/Engineering
  48. Requires: %{name} = %{version}-%{release}
  49. BuildRequires: qt4-devel >= 4.4
  50. BuildRequires: desktop-file-utils
  51. %description qt
  52. Zint Barcode Studio is a Qt-based GUI which allows desktop users to generate
  53. barcodes which can then be embedded in documents or HTML pages, and a library
  54. which can be used to incorporate barcode generation functionality into other
  55. software.
  56. %package qt-devel
  57. Summary: Library and header files for %{name}-qt
  58. Summary(ja): ZintバーコードのGUI(QT)開発用ライブラリとヘッダファイル
  59. Group: Development/Libraries
  60. Requires: %{name}-devel = %{version}-%{release}
  61. Requires: %{name}-qt = %{version}-%{release}
  62. %description qt-devel
  63. C library and header files needed to develop applications using %{name}-qt.
  64. %prep
  65. %setup -q
  66. %patch0 -p 1 -b .qr-kanji
  67. %patch1 -p 1 -b .rpath
  68. %patch2 -p1 -b .libpng16
  69. # remove BSD-licensed file required for Windows only
  70. # (just to ensure that this package is plain GPLv3+)
  71. rm -f backend/ms_stdint.h
  72. # remove bundled getopt sources (we use the corresponding Fedora package instead)
  73. rm -f frontend/getopt*.*
  74. %build
  75. %cmake CMakeLists.txt
  76. make VERBOSE=1 %{?_smp_mflags}
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. make install DESTDIR=$RPM_BUILD_ROOT
  80. rm -rf $RPM_BUILD_ROOT/%{_datadir}/cmake
  81. cat <<EOF >%{name}-qt.desktop
  82. [Desktop Entry]
  83. Encoding=UTF-8
  84. Name=Zint Barcode Studio
  85. Name[ja]=Zintバーコードスタジオ
  86. Comment=Zint Barcode Studio
  87. Comment[ja]=バーコードを作成するツールです
  88. GenericName=Zint Barcode Studio
  89. Exec=zint-qt
  90. Icon=zint
  91. Terminal=false
  92. Type=Application
  93. Categories=Utility;
  94. EOF
  95. install -D -p -m 644 %{name}.png %{buildroot}/usr/share/pixmaps/%{name}.png
  96. install -D -p -m 644 %{name}-qt.desktop %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
  97. desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
  98. %clean
  99. rm -rf $RPM_BUILD_ROOT
  100. %post -p /sbin/ldconfig
  101. %postun -p /sbin/ldconfig
  102. %post qt -p /sbin/ldconfig
  103. %postun qt -p /sbin/ldconfig
  104. %files
  105. %defattr(-,root,root,-)
  106. %license COPYING
  107. %doc INSTALL README* TODO
  108. %{_bindir}/%{name}
  109. %{_libdir}/libzint.so.*
  110. %files devel
  111. %defattr(-,root,root,-)
  112. %{_includedir}/%{name}.h
  113. %{_libdir}/libzint.so
  114. %files qt
  115. %defattr(-,root,root,-)
  116. %{_bindir}/%{name}-qt
  117. %{_libdir}/libQZint.so.*
  118. %{_datadir}/applications/%{name}-qt.desktop
  119. %{_datadir}/pixmaps/%{name}.png
  120. %files qt-devel
  121. %defattr(-,root,root,-)
  122. %{_includedir}/qzint.h
  123. %{_libdir}/libQZint.so
  124. %changelog
  125. * Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.2-3
  126. - rebuilt with new toolchain.
  127. * Sun Jul 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.2-2
  128. - rebuilt with current environment.
  129. - added Patch2 for libpng16.
  130. * Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
  131. - updated zint to 2.4.2
  132. - added %{name}-rpath.patch
  133. - added BR: qt4-devel, desktop-file-utils
  134. * Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.0-2
  135. - added zint-2.4.0-qr-kanji.patch (BTS:1062)
  136. - install %{name}.png
  137. * Thu Oct 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.0-1
  138. - initial build for Vine