libtermcap-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252
  1. Summary: A basic system library for accessing the termcap database.
  2. Name: libtermcap
  3. Version: 2.0.8
  4. Release: 47%{?_dist_release}
  5. Source: ftp://metalab.unc.edu/pub/Linux/GCC/termcap-2.0.8.tar.bz2
  6. Url: ftp://metalab.unc.edu/pub/Linux/GCC/
  7. License: LGPL
  8. Group: System Environment/Libraries
  9. Patch0: termcap-2.0.8-shared.patch
  10. Patch1: termcap-2.0.8-setuid.patch
  11. Patch2: termcap-2.0.8-instnoroot.patch
  12. Patch3: termcap-2.0.8-compat21.patch
  13. Patch4: termcap-2.0.8-xref.patch
  14. Patch5: termcap-2.0.8-fix-tc.patch
  15. Patch6: termcap-2.0.8-ignore-p.patch
  16. Patch7: termcap-buffer.patch
  17. # This patch is a REALLY BAD IDEA without patch #10 below....
  18. Patch8: termcap-2.0.8-bufsize.patch
  19. Patch9: termcap-2.0.8-colon.patch
  20. Patch10: libtermcap-aaargh.patch
  21. Patch11: termcap-2.0.8-glibc22.patch
  22. Patch12: libtermcap-2.0.8-ia64.patch
  23. Patch13: termcap-116934.patch
  24. Patch14: termcap-2.0.8-shrink.patch
  25. Patch15: termcap-2.0.8-octal.patch
  26. Patch16: termcap-2.0.8-nofree.patch
  27. Requires: termcap
  28. BuildPrereq: texinfo
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. Obsoletes: libtermcap-devel <= 2.0.8-46vl1
  31. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  32. %description
  33. The libtermcap package contains a basic system library needed to
  34. access the termcap database. The termcap library supports easy access
  35. to the termcap database, so that programs can output character-based
  36. displays in a terminal-independent manner.
  37. %package -n compat32-%{name}
  38. Summary: A basic system library for accessing the termcap database.
  39. Group: System Environment/Libraries
  40. Requires: %{name} = %{version}-%{release}
  41. %description -n compat32-%{name}
  42. The libtermcap package contains a basic system library needed to
  43. access the termcap database. The termcap library supports easy access
  44. to the termcap database, so that programs can output character-based
  45. displays in a terminal-independent manner.
  46. %prep
  47. %setup -q -n termcap-2.0.8
  48. %patch0 -p1
  49. %patch1 -p1
  50. %patch2 -p1 -b .nochown
  51. %patch3 -p1 -b .compat21
  52. %patch4 -p1
  53. %patch5 -p1 -b .fix-tc
  54. %patch6 -p1 -b .ignore-p
  55. %patch7 -p1 -b .buffer
  56. %patch8 -p1 -b .bufsize
  57. %patch9 -p1 -b .colon
  58. %patch10 -p1 -b .aaargh
  59. %patch11 -p1 -b .glibc22
  60. %ifarch ia64
  61. %patch12 -p1 -b .ia64
  62. %endif
  63. %patch13 -p1 -b .116934
  64. %patch14 -p1 -b .shrink
  65. %patch15 -p1 -b .octal
  66. %patch16 -p1 -b .nofree
  67. %build
  68. make AR=%{__ar} CC=%{__cc} CFLAGS="$RPM_OPT_FLAGS -I."
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. %ifarch x86_64
  72. mkdir -p $RPM_BUILD_ROOT/{usr/lib,usr/lib64,%{_infodir},usr/include,etc,lib64}
  73. %else
  74. mkdir -p $RPM_BUILD_ROOT/{usr/lib,%{_infodir},usr/include,etc,lib}
  75. %endif
  76. export PATH=/sbin:$PATH
  77. make prefix=$RPM_BUILD_ROOT/usr install
  78. install -c -m644 termcap.src $RPM_BUILD_ROOT/etc/termcap
  79. cp termcap.info* $RPM_BUILD_ROOT/%{_infodir}
  80. ( cd $RPM_BUILD_ROOT
  81. rm -f ./etc/termcap
  82. mv ./usr/lib/libtermcap.so* ./%{_lib}
  83. #ln -sf libtermcap.so.2.0.8 ./%{_lib}/libtermcap.so
  84. rm -f ./%{_lib}/libtermcap.so
  85. cd usr/%{_lib}
  86. ln -sf ../../%{_lib}/libtermcap.so.2.0.8 libtermcap.so
  87. %ifarch x86_64
  88. mv ../lib/libtermcap.a .
  89. rmdir ../lib
  90. %endif
  91. cd ../..
  92. strip -R .comments --strip-unneeded ./%{_lib}/libtermcap.so.2.0.8
  93. gzip -9nf ./%{_infodir}/termcap.info*
  94. chmod 644 ./%{_infodir}/termcap.info*
  95. )
  96. %clean
  97. rm -rf $RPM_BUILD_ROOT
  98. %post -p /sbin/ldconfig
  99. %postun -p /sbin/ldconfig
  100. %post -n compat32-%{name} -p /sbin/ldconfig
  101. %postun -n compat32-%{name} -p /sbin/ldconfig
  102. %files
  103. %defattr(-,root,root)
  104. /%{_lib}/libtermcap.so.2.0.8
  105. %if %{build_compat32}
  106. %files -n compat32-%{name}
  107. %defattr(-,root,root)
  108. /%{_lib}/libtermcap.so.2.0.8
  109. %changelog
  110. * Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-47
  111. - new versioning policy
  112. - remove libtermcap-devel, replaced by ncurses-devel(libtinfo)
  113. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.8-46vl1
  114. - rebuit with new toolchain
  115. - not postun but preun to execute install-info --delete - fixed.
  116. - Tue Jun 27 2006 Florian La Roche <laroche@redhat.com> - 2.0.8-46
  117. - no need for the trigger, if info files are in the -devel subrpm
  118. - Mon Feb 27 2006 Miloslav Trmac <mitr@redhat.com> - 2.0.8-45
  119. - Add Requires(postun): /sbin/install-info to libtermcap-devel (#182836)
  120. * Wed Feb 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.8-44vl1
  121. - s/Copyright/License/
  122. - use %%{_tmppath}/%%{name}-%%{version}-root as BuildRoot
  123. - import patch13-16 from FC 2.0.8-44
  124. * Mon Jan 2 2006 Petr Raszyk <praszyk@redhat.com> 2.0.8-43
  125. - libtermcap does not 'free()'memory. See #74346
  126. A patch termcap-2.0.8-nofree.patch
  127. * Fri Mar 18 2005 Nalin Dahyabhai <nalin@redhat.com> 2.0.8-41
  128. - don't trip over capabilities which end in '^' or '\'
  129. - don't accept numbers with '8' or '9' in them as valid octal numbers
  130. * Fri May 7 2004 Tim Waugh <twaugh@redhat.com> 2.0.8-38
  131. - Fix tgetent() (bug #116934).
  132. * Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 2.0.8-36vl2
  133. - added compat32- packages for x86_64 architecture support
  134. * Wed Jun 11 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.8-36vl1
  135. - added patch12 from rawhide
  136. * Wed Dec 19 2001 Toru Sagami <sagami@vinelinux.org> 2.0.8-26vl2
  137. - enabled patch11 in order to build on glibc-22
  138. * Sat Jun 09 2001 <sagami@vinelinux.org>
  139. - 2.0.8-26vl1: follow up with 2.0.8-26 from 2.0.8-20vl1
  140. - disabled patch11 for glibc-22
  141. * Sat Oct 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  142. - Uninstall info pages in %%postun devel rather than %%postun
  143. (Bug #18545)
  144. * Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  145. - fix broken symlink (#16285)
  146. * Mon Aug 14 2000 Preston Brown <pbrown@redhat.com>
  147. - absolute --> relative symlink (#16131)
  148. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  149. - automatic rebuild
  150. * Tue Jul 4 2000 Matt Wilson <msw@redhat.com>
  151. - move the trigger to the devel package, that's where the info pages
  152. live now
  153. * Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
  154. - rebuild for next release
  155. - move info pages to the development package
  156. - use %%{_infodir}
  157. - patched to build against new glibc (patch11)
  158. * Sun Feb 6 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
  159. - BuildPrereq: texinfo (#8927)
  160. * Sat Feb 5 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
  161. - strip library
  162. - fix up handling of RPM_OPT_FLAGS
  163. * Tue Aug 30 1999 Bill Nottingham <notting@redhat.com>
  164. - ignore the first argument to tgetent, so the last change doesn't
  165. keep blowing up programs.
  166. - ignore the second argument to tgetstr() as well.
  167. * Sat Aug 21 1999 Jeff Johnson <jbj@redhat.com>
  168. - increase default size of malloc'ed tgetent buffer from 1024 to 1536.
  169. - don't shrink colons (#4270).
  170. - rebuild for 6.1.
  171. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  172. - add buffer overflow patch from Kevin Vajk <kvajk@ricochet.net>
  173. * Sat May 15 1999 Jeff Johnson <jbj@redhat.com>
  174. - permit multiple tc= continuations and ignore unnecessary %p ("push arg") (#54)
  175. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  176. - auto rebuild in the new build environment (release 13)
  177. - fix to make the texi documenattion compile
  178. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  179. - use __PMT(...) prototypes (#761)
  180. * Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
  181. - build against glibc 2.1
  182. * Wed Aug 05 1998 Erik Troan <ewt@redhat.com>
  183. - run install-info from a %trigger so we don't have to make it a prereq; as
  184. termcap is used by bash, the install ordering issues are hairy
  185. - commented out the chown stuff from 'make install' so you don't have to
  186. be root to build this
  187. - don't run ldconfig if prefix= is used during 'make install'
  188. * Tue Aug 4 1998 Jeff Johnson <jbj@redhat.com>
  189. - build root.
  190. * Tue Jun 30 1998 Alan Cox <alan@redhat.com>
  191. - But assume system termcap is sane. Also handle setfsuid return right.
  192. * Tue Jun 30 1998 Alan Cox <alan@redhat.com>
  193. - TERMCAP environment hole for setuid apps squished.
  194. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  195. - translations modified for de, fr, tr
  196. * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
  197. - spec file cleanups
  198. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  199. - built against glibc