pcre2-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Perl-compatible regular expression library
  3. Summary(ja): Perl 互換の正規表現ライブラリ
  4. Name: pcre2
  5. Version: 10.36
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: inagaki
  11. License: BSD
  12. URL: https://www.pcre.org/
  13. Source0: https://ftp.pcre.org/pub/pcre/%{name}-%{version}.tar.bz2
  14. # Upstream thinks RPATH is good idea.
  15. Patch0: pcre2-10.31-multilib.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: zlib-devel
  18. BuildRequires: bzip2-devel
  19. BuildRequires: libedit-devel
  20. # New libtool to get rid of rpath
  21. BuildRequires: autoconf, automake, libtool
  22. %description
  23. Perl-compatible regular expression library.
  24. PCRE has its own native API, but a set of "wrapper" functions that are based on
  25. the POSIX API are also supplied in the library libpcreposix. Note that this
  26. just provides a POSIX calling interface to PCRE: the regular expressions
  27. themselves still follow Perl syntax and semantics. The header file
  28. for the POSIX-style functions is called pcreposix.h.
  29. %package devel
  30. Summary: Development files for %{name}
  31. Summary(ja): %{name} の開発用ファイル
  32. Group: programming
  33. Requires: %{name} = %{version}-%{release}
  34. %description devel
  35. Development files (Headers, libraries for static linking, etc) for %{name}.
  36. %package -n compat32-%{name}
  37. Summary: Perl-compatible regular expression library
  38. Summary(ja): Perl 互換の正規表現ライブラリ
  39. Group: system
  40. %description -n compat32-%{name}
  41. Perl-compatible regular expression library.
  42. PCRE has its own native API, but a set of "wrapper" functions that are based on
  43. the POSIX API are also supplied in the library libpcreposix. Note that this
  44. just provides a POSIX calling interface to PCRE: the regular expressions
  45. themselves still follow Perl syntax and semantics. The header file
  46. for the POSIX-style functions is called pcreposix.h.
  47. %package -n compat32-%{name}-devel
  48. Summary: Development files for %{name}
  49. Summary(ja): %{name} の開発用ファイル
  50. Group: programming,legacy
  51. Requires: compat32-%{name} = %{version}-%{release}
  52. %description -n compat32-%{name}-devel
  53. Development files (Headers, libraries for static linking, etc) for %{name}.
  54. %debug_package
  55. %prep
  56. %setup -q
  57. # Get rid of rpath
  58. %patch0 -p1 -b .multilib
  59. # Because of rpath patch
  60. libtoolize --copy --force && autoreconf -vif
  61. # One contributor's name is non-UTF-8
  62. for F in ChangeLog; do
  63. iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
  64. touch --reference "$F" "${F}.utf8"
  65. mv "${F}.utf8" "$F"
  66. done
  67. %build
  68. %configure \
  69. --enable-jit \
  70. --disable-static \
  71. --enable-utf8 \
  72. --enable-unicode-properties \
  73. --enable-pcregrep-libz \
  74. --enable-pcregrep-libbz2 \
  75. --enable-pcretest-libedit \
  76. --enable-pcre2-8 \
  77. --enable-pcre2-16 \
  78. --enable-pcre2-32
  79. make %{?_smp_mflags}
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. make install DESTDIR=$RPM_BUILD_ROOT
  83. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
  84. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  85. %check
  86. %ifarch s390 s390x ppc
  87. # larger stack is needed on s390, ppc
  88. ulimit -s 10240
  89. %endif
  90. make %{?_smp_mflags} check VERBOSE=yes
  91. %clean
  92. rm -rf $RPM_BUILD_ROOT
  93. %post -p /sbin/ldconfig
  94. %postun -p /sbin/ldconfig
  95. %post -n compat32-%{name} -p /sbin/ldconfig
  96. %postun -n compat32-%{name} -p /sbin/ldconfig
  97. %files
  98. %defattr(-,root,root)
  99. %license COPYING LICENCE
  100. %doc AUTHORS ChangeLog NEWS README
  101. %{_bindir}/pcre2grep
  102. %{_libdir}/*.so.*
  103. %{_mandir}/man1/pcre2grep.*
  104. %files devel
  105. %defattr(-,root,root)
  106. %doc doc/html/*
  107. %{_bindir}/pcre2-config
  108. %{_bindir}/pcre2test
  109. %{_includedir}/*
  110. %{_libdir}/*.so
  111. %{_libdir}/pkgconfig/*.pc
  112. %{_mandir}/man1/pcre2-config.*
  113. %{_mandir}/man1/pcre2test.*
  114. %{_mandir}/man3/*
  115. %if %{build_compat32}
  116. %files -n compat32-%{name}
  117. %defattr(-, root, root)
  118. %{_libdir}/*.so.*
  119. %files -n compat32-%{name}-devel
  120. %defattr(-, root, root)
  121. %{_libdir}/*.so
  122. %endif
  123. %changelog
  124. * Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.36-1
  125. - new upstream release.
  126. * Thu Oct 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.35-1
  127. - new upstream release.
  128. * Sun Mar 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.34-1
  129. - new upstream release.
  130. * Sun May 20 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 10.31-1
  131. - new: pcre2 package
  132. - update multilib patch (Patch0)
  133. - drop unnecessary patch (Patch1)
  134. * Fri Jul 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.39-2
  135. - create comapt32 packages
  136. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.39-1
  137. - new upstream release.
  138. - dropped Patch1000,1001: fixed in upstream.
  139. * Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
  140. - new upstream release.
  141. - removed Patch2,Patch3 (no longer needed).
  142. - added Patch1000 to fix CVE-2016-1283.
  143. * Sun Apr 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
  144. - new upstream release
  145. - added patches including security fix from Fedora (CVE-2014-8964)
  146. * Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
  147. - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
  148. (bug #1165626)
  149. * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
  150. - Reset non-matched groups within capturing group up to forced match
  151. (bug #1161587)
  152. * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
  153. - Fix typos in manual pages (bugs #675476, #675477)
  154. * Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
  155. - new upstream release
  156. - add --enable-pcre32 and --enable-pcretest-libedit
  157. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
  158. - new upstream release
  159. - add --enable-pcre16 --enable-pcre8 --enable-jit
  160. - API change
  161. - change includedir to /usr/include
  162. * Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
  163. - new upstream release
  164. * Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
  165. - new upstream release
  166. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
  167. - rebuilt with rpm-4.8.1 for pkg-config
  168. * Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
  169. - new upstream release
  170. * Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
  171. - new upstream release with security fix
  172. * Sat Feb 6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
  173. - new upstream release
  174. * Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
  175. - new upstream release
  176. * Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
  177. - add --enable-unicode-properties to configure option
  178. * Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
  179. - new upstream release
  180. - added BR: zlib-devel, bzip2-devel
  181. - removed static libraries from devel package
  182. - added Packager tag
  183. * Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
  184. - new upstream release
  185. - spec in UTF-8
  186. * Sun Jul 6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
  187. - new upstream release
  188. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  189. - use macro for Release
  190. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  191. - apply new virsioning policy.
  192. - remove *.la
  193. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
  194. - new upstream release
  195. * Wed Nov 7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
  196. - new upstream release
  197. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
  198. - new upstream release
  199. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
  200. - rebuild with new environment/toolchain
  201. * Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
  202. - new upstream release
  203. * Mon Sep 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
  204. - added --enable-utf8 option
  205. * Sun Sep 4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
  206. - new upstream release
  207. * Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
  208. - new upstream release
  209. - added Japanese summary
  210. * Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
  211. - new upstream release
  212. * Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
  213. - new upstream release
  214. * Mon May 5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
  215. - skip 'make check' on alpha
  216. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
  217. - change install section
  218. - change files section
  219. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
  220. - update to 4.1
  221. - add %{_bindir}/pcretest
  222. - add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
  223. * Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
  224. - rebuild with new toolchains
  225. * Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
  226. - Update to 3.9
  227. * Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
  228. - Update to 3.7
  229. * Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
  230. - Update to 3.5
  231. * Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
  232. - Build for VineSeed
  233. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
  234. - Move libpcre to /lib, grep uses it these days (#41104)
  235. * Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  236. - Move this to a separate package, used to be in kdesupport, but it's
  237. generally useful...