parted-vl.spec 9.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300
  1. %define _sbindir /sbin
  2. Summary: The GNU disk partition manipulation program.
  3. Summary(ja): ディスクパーティション操作ツール
  4. Name: parted
  5. Version: 3.4
  6. Release: 1%{?_dist_release}
  7. Group: admin-tools,system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv3
  11. URL: http://www.gnu.org/software/parted/
  12. Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
  13. Buildroot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: e2fsprogs-devel, ncurses-devel, readline-devel
  15. BuildRequires: python3-devel, ncurses-devel
  16. BuildRequires: device-mapper-devel
  17. BuildRequires: libtool, automake, autoconf
  18. BuildRequires: gettext-devel >= 0.18
  19. BuildRequires: texinfo
  20. BuildRequires: libuuid-devel
  21. BuildRequires: libblkid-devel >= 2.17
  22. BuildRequires: gnupg
  23. Provides: libparted = %{version}-%{release}
  24. %description
  25. GNU Parted is a program that allows you to create, destroy,
  26. resize, move and copy hard disk partitions. This is useful for
  27. creating space for new operating systems, reorganising disk
  28. usage, and copying data to new hard disks.
  29. %description -l ja
  30. GNU Parted はハードディスクのパーティションを作成/削除/リサイズ/
  31. 移動/コピーすることが出来るプログラムです.新しいオペレーティング
  32. システムをインストールするスペースを確保したり,ディスクのパーティションを
  33. 整理したり,新しいハードディスクにデータをコピーする際に非常に便利です.
  34. %package devel
  35. Summary: Files for developing apps which will manipulate disk partitions.
  36. Summary(ja) : パーティション操作をするアプリケーションの開発用ファイル
  37. Group: programming
  38. Requires: parted = %{version}-%{release}
  39. Provides: libparted-devel = %{version}-%{release}
  40. %description devel
  41. The GNU Parted library is a set of routines for hard disk partition
  42. manipulation. If you want to develop programs that manipulate disk
  43. partitions and filesystems using the routines provided by the GNU
  44. Parted library, you need to install this package.
  45. %description devel -l ja
  46. GNU Parted ライブラリにはハードディスクのパーティションを操作する
  47. 関数が用意されています。GNU Parted ライブラリが提供する関数を使って
  48. ディスクパーティションやファイルシステムを操作するプログラムを開発
  49. したいのであれば、このパッケージをインストールして下さい。
  50. %debug_package
  51. %prep
  52. %setup -q
  53. iconv -f ISO-8859-1 -t UTF8 AUTHORS > tmp; touch -r AUTHORS tmp; mv tmp AUTHORS
  54. %build
  55. autoreconf
  56. autoconf
  57. CFLAGS="$RPM_OPT_FLAGS -Wno-unused-but-set-variable"; export CFLAGS
  58. %configure \
  59. --enable-device-mapper \
  60. --enable-shared
  61. # Don't use rpath!
  62. %{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  63. %{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  64. %__make %{?_smp_mflags}
  65. %install
  66. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  67. %__make install DESTDIR=$RPM_BUILD_ROOT
  68. # Remove components we do not ship
  69. %{__rm} -rf %{buildroot}%{_libdir}/*.la
  70. %{__rm} -rf %{buildroot}%{_infodir}/dir
  71. %{__rm} -rf %{buildroot}%{_bindir}/label
  72. %find_lang %{name}
  73. %clean
  74. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  75. %post
  76. /sbin/ldconfig
  77. /sbin/install-info %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
  78. %postun
  79. /sbin/ldconfig
  80. %preun
  81. if [ $1 = 0 ]; then
  82. /sbin/install-info --delete %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
  83. fi
  84. %files -f %{name}.lang
  85. %defattr(-,root,root)
  86. %license COPYING
  87. %doc AUTHORS BUGS ChangeLog* NEWS README* THANKS TODO
  88. %doc doc/FAT doc/USER.jp
  89. %{_sbindir}/*
  90. %{_mandir}/man8/*
  91. %{_libdir}/lib*.so.*
  92. %{_infodir}/parted.info*
  93. %files devel
  94. %defattr(-,root,root)
  95. %doc doc/API
  96. %{_includedir}/*
  97. %{_libdir}/lib*.so
  98. %{_libdir}/*.a
  99. %{_libdir}/pkgconfig/libparted*.pc
  100. %changelog
  101. * Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4-1
  102. - new upstream release.
  103. - dropped Patch0.
  104. * Mon Aug 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3-1
  105. - new upstream release.
  106. * Mon Sep 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.153-1
  107. - new upstream release.
  108. - built with readline-8.0.
  109. * Thu Apr 2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2-2
  110. - rebuilt with readline 6.3
  111. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2-1
  112. - new upstream release
  113. * Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1-2
  114. - rebuild with VineSeed environment
  115. * Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1-1
  116. - new upstream release
  117. - remove Patch1
  118. * Thu Jan 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
  119. - new upstream release
  120. - remove Patch0
  121. * Tue Nov 9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3-1
  122. - new upstream release
  123. - drop old patches
  124. - new patch for 2.3 from fc14
  125. - add BRs: libuuid-devel, libblkid-devel >= 2.17, gnupg
  126. - change BR: gettext -> gettext-devel >= 0.18
  127. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.8-2
  128. - rebuilt with rpm-4.8.1 for pkg-config
  129. * Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  130. - new upstream release
  131. - import patch[1-8] from fedora
  132. * Sat May 19 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.1-1vl2
  133. - rebuild with new environment/toolchain.
  134. * Fri Dec 8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-1vl1
  135. - new upstream release
  136. - remove Patch0, 3, 100, 150, 151 and 152 (merged into upstream)
  137. * Sat Sep 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25.1-0vl2
  138. - changed Group to Applications/Administration
  139. * Wed May 3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25.1-0vl1
  140. - new upstream release
  141. * Thu Dec 1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25-3vl1
  142. - new upstream release
  143. - updated Patch3, 100, 150 and 151 from Fedora
  144. * Wed Nov 09 2005 Chris Lumens <clumens@redhat.com> 1.6.25-1
  145. - Update DASD, iseries, and SX8 patches.
  146. * Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.24-0vl1
  147. - new upstream release
  148. - updated Patch100, 151
  149. * Mon Apr 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.22-0vl1
  150. - new upstream release
  151. * Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.21-1vl1
  152. - new upstream release
  153. - added Patch3 and Patch152, updated Patch150 (from Fedora)
  154. * Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.19-2
  155. - add support for Promise SX8 devices
  156. * Thu Nov 11 2004 Jeremy Katz <katzj@redhat.com> - 1.6.16-2
  157. - add patch from Matt Domsch to fix consistency of GPT disk labels
  158. with the EFI specification for disks > 2TB (#138480)
  159. * Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.18-0vl1
  160. - new upstream release
  161. * Thu Nov 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.16-0vl1
  162. - new upstream release
  163. * Sun Sep 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.15-0vl1
  164. - new upstream release
  165. - added BuildRequires: automake autoconf gettext
  166. - patches from Fedora development
  167. * Tue Aug 24 2004 Jeremy Katz <katzj@redhat.com> - 1.6.12-2
  168. - fix assertion error when checking flags on non-active partition (#130692)
  169. - buildrequires: gettext-devel
  170. * Mon Aug 16 2004 Jeremy Katz <katzj@redhat.com> - 1.6.12-1
  171. - update to 1.6.12 with major changes to CHS handling to hopefully fix #115980
  172. - adjust dasd patch accordingly, drop some included patches
  173. * Mon Jul 19 2004 Karsten Hopp <karsten@redhat.de> 1.6.11-4
  174. - update dasd patch for dos-type partitions on mainframes (scsi disks)
  175. * Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.12-0vl1
  176. - new upstream release
  177. - removed BuildRequires: automake17 autoconf
  178. - updated %post %postun section to install .info file
  179. * Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.10-0vl2
  180. - dropped BuildRequires: libunicode-devel
  181. * Sat Apr 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.10-0vl1
  182. - updated to current stable release 1.6.10
  183. - changed BuildRequires: automake17
  184. - added compile optioin -Os
  185. - dropped patch1
  186. * Fri Jun 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.5-0vl1
  187. - updated to current stable release 1.6.5
  188. - changed summay and description based on Rawhide specfile
  189. * Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 1.4.24-0vl1
  190. - updated to current stable release 1.4.24
  191. * Sun Jan 06 2002 Toru Sagami <sagami@vinelinux.org>
  192. - 1.4.21-0vl1
  193. - enable __libtoolize
  194. * Wed Nov 21 2001 Toru Sagami <sagami@vinelinux.org>
  195. - 1.4.19-0vl1
  196. * Thu Oct 04 2001 Toru Sagami <sagami@vinelinux.org>
  197. - 1.4.19-0vl1
  198. * Sun Aug 19 2001 Toru Sagami <sagami@vinelinux.org>
  199. - 1.4.18-0vl1
  200. - Where did any python related files go? Erase'em.
  201. * Wed Aug 15 2001 <sagami@vinelinux.org>
  202. - 1.4.16-0vl1
  203. - build w/ --enable-shared --enable-all-static, instead of --disable-shared
  204. - consequently, eliminate Requires against e2fsprogs, readline
  205. - ldconfig at post/postun
  206. * Mon Jul 09 2001 <sagami@vinelinux.org>
  207. - 1.4.15-0vl1: use %%{find_lang}, added doc/FAQ
  208. - %%define __libtoolize /bin/true
  209. * Mon May 28 2001 <sagami@vinelinux.org>
  210. - 1.4.13-0vl1
  211. * Wed Apr 18 2001 <sagami@vinelinux.org>
  212. - 1.4.10-0vl1
  213. * Sun Jan 21 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  214. - updated to 1.4.7-0vl1
  215. - changed Group for devel subpackage
  216. - added USER.jp in %doc
  217. * Sun Dec 10 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  218. - 1.4.2-1vl2
  219. - partially used rpmmacros
  220. * Mon Nov 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  221. - 1.4.2-1vl1
  222. - build for Vine Linux
  223. - added Japanese summary and description
  224. * Mon Mar 13 2000 Fabian Emmes <fab@orlen.de>
  225. - changed "unset LINGUAS" line
  226. - reintroduced %build section ;)
  227. - started changelog