bison-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247
  1. %bcond_without check
  2. Summary: A GNU general-purpose parser generator.
  3. Summary(ja): GNU 汎用構文解析器生成プログラム
  4. Name: bison
  5. Version: 3.7.5
  6. Release: 1%{?_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPL
  11. Source: https://ftp.gnu.org/gnu/bison/bison-%{version}.tar.xz
  12. URL: https://www.gnu.org/software/bison/
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: flex
  15. Requires: m4 >= 1.4
  16. Requires(post): install-info
  17. Requires(preun): install-info
  18. %description
  19. Bison is a general purpose parser generator which converts a grammar
  20. description for an LALR(1) context-free grammar into a C program to parse
  21. that grammar. Bison can be used to develop a wide range of language
  22. parsers, from ones used in simple desk calculators to complex programming
  23. languages. Bison is upwardly compatible with Yacc, so any correctly
  24. written Yacc grammar should work with Bison without any changes. If
  25. you know Yacc, you shouldn't have any trouble using Bison. You do need
  26. to be very proficient in C programming to be able to use Bison). Bison
  27. is only needed on systems that are used for development.
  28. If your system will be used for C development, you should install Bison
  29. since it is used to build many C programs.
  30. #'
  31. %description -l ja
  32. bison は汎用構文解析器を生成するプログラムで,LALR(1) 文脈自由文法で
  33. 書かれた文法記述を元に,その記述を解析する C プログラムを生成します.
  34. bison は簡単な電卓から複雑なプログラミング言語まで,幅広い種類の
  35. 言語解析器を開発するのに使うことが出来ます.
  36. bison は yacc の上位互換ですので,yacc で書かれた文法を修正すること
  37. なしに解析することが出来ます.yacc を知っているのであれば,bison を
  38. 使って困ることは何もないでしょう.bison を使うには C プログラミングの
  39. 豊富な知識が必要となります.bison は開発を行うシステム以外では特に
  40. 必要にならないでしょう.
  41. C 言語による開発を行う場合は,多くの C プログラムの作成に使われるので
  42. bison をインストールして下さい.
  43. %debug_package
  44. %prep
  45. %setup -q
  46. %build
  47. %configure
  48. make %{_smp_mflags}
  49. %if %{with check}
  50. %check
  51. make check
  52. %endif
  53. %install
  54. rm -rf $RPM_BUILD_ROOT
  55. %makeinstall
  56. # Remove unpackaged files.
  57. rm -f $RPM_BUILD_ROOT/%{_bindir}/yacc
  58. rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
  59. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/yacc*
  60. rm -f pkgdoc
  61. cp -af %{buildroot}%{_docdir}/%{name} ./pkgdoc
  62. rm -rf %{buildroot}%{_docdir}/%{name}
  63. rm -f pkgdoc/COPYING
  64. %find_lang %{name}
  65. %find_lang %{name}-gnulib
  66. cat %{name}-gnulib.lang >> %{name}.lang
  67. %clean
  68. rm -rf $RPM_BUILD_ROOT
  69. %post
  70. /sbin/install-info %{_infodir}/bison.info.gz %{_infodir}/dir \
  71. --entry="* bison: (bison). The GNU parser generator."
  72. %preun
  73. if [ $1 = 0 ]; then
  74. /sbin/install-info --delete %{_infodir}/bison.info.gz %{_infodir}/dir \
  75. --entry="* bison: (bison). The GNU parser generator."
  76. fi
  77. %files -f %{name}.lang
  78. %defattr(-,root,root)
  79. %license COPYING
  80. %doc pkgdoc/*
  81. %{_bindir}/bison
  82. %{_libdir}/liby.a
  83. %{_datadir}/bison
  84. %{_datadir}/aclocal/*.m4
  85. %{_datadir}/locale/*/LC_MESSAGES/%{name}-runtime.mo
  86. %{_mandir}/*/bison*
  87. %{_infodir}/bison.info*
  88. %changelog
  89. * Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7.5-1
  90. - new upstream release.
  91. * Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7.2-1
  92. - new upstream release.
  93. * Thu Sep 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7.1-1
  94. - new upstream release.
  95. * Thu Jun 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.4-1
  96. - new upstream release.
  97. * Tue Nov 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.2-1
  98. - new upstream release.
  99. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-1
  100. - update to 2.7.1
  101. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 2.5-1
  102. - new upstream release
  103. * Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.3-1
  104. - new upstream release
  105. - delete Patch1
  106. * Wed Feb 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-2
  107. - rebuilt with new toolchain
  108. * Tue Feb 3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.1-1
  109. - new upstream release
  110. - import Patch1 from Fedora
  111. * Sat Nov 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
  112. - new upstream release
  113. - spec in UTF-8
  114. * Sun Apr 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.3-1
  115. - rebuild with new toolchain.
  116. - apply new versioning policy.
  117. * Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl1
  118. - new upstream release
  119. * Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-0vl1
  120. - new upstream release
  121. * Wed Jun 09 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-6vl1
  122. - new upstream release
  123. - dropped Patch1
  124. - added %doc files
  125. - updated URL
  126. * Sun Feb 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.875-6vl1
  127. - add Patch1 from fedora
  128. - add Requires: m4
  129. * Thu Oct 30 2003 Roland McGrath <roland@redhat.com> 1.875-6
  130. - add dependency on m4 (bug #108655)
  131. * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 1.875-5
  132. - remove problematic __attribute__ use for label (bug #105034)
  133. * Sun Jul 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.875-3vl1
  134. - based on Rawhide 1.875-3
  135. - s/Copyright/License/
  136. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.75-2vl1
  137. - new upstream release
  138. - merged with rawhide release
  139. * Thu Nov 21 2002 Tim Waugh <twaugh@redhat.com> 1.75-2
  140. - Run 'make check'.
  141. - Apply patch from bison-patches to fix bash compilation.
  142. * Thu Oct 17 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  143. - update to 1.75
  144. * Fri May 31 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
  145. - 1.35-2vl1: synced with rawhide
  146. * Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  147. - 1.28-5vl1
  148. - rebuilt with new %%{_mandir} definition
  149. - added Japanese summary and description
  150. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.28-5vl1
  151. - build on Vine Linux with gcc-2.95.3
  152. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  153. - automatic rebuild
  154. * Sun Jun 18 2000 Than Ngo <than@redhat.de>
  155. - rebuilt in the new build environment
  156. - FHS packaging
  157. * Sat May 27 2000 Ngo Than <than@redhat.de>
  158. - rebuild for 7.0
  159. - put man pages and info files to correct place
  160. * Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
  161. - rebuild to gzip man page.
  162. * Fri Jul 16 1999 Jeff Johnson <jbj@redhat.com>
  163. - update to 1.28.
  164. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  165. - auto rebuild in the new build environment (release 3)
  166. * Mon Mar 8 1999 Jeff Johnson <jbj@redhat.com>
  167. - configure with datadir=/usr/lib (#1386).
  168. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  169. - updated text in spec file.
  170. - update to 1.27
  171. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  172. - build for glibc 2.1
  173. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  174. - translations modified for de, fr, tr
  175. * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
  176. - built for Manhattan
  177. - added build root
  178. * Wed Oct 15 1997 Donnie Barnes <djb@redhat.com>
  179. - various spec file cleanups
  180. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  181. - built against glibc