rest-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: rest
  3. Version: 0.8.1
  4. Release: 2%{?_dist_release}
  5. Summary: RESTful web api query library
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: LGPLv2+
  10. URL: http://git.gnome.org/browse/librest
  11. %global shortver %(echo %{version} | cut -d . -f 1-2)
  12. Source0: https://download.gnome.org/sources/rest/%{shortver}/%{name}-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: glib2-devel
  15. BuildRequires: gobject-introspection-devel
  16. BuildRequires: libsoup-devel
  17. BuildRequires: ca-certificates
  18. BuildRequires: gtk-doc
  19. Requires: ca-certificates
  20. %description
  21. This library has been designed to make it easier to access web services that
  22. claim to be "RESTful". A reasonable definition of what this means can be found
  23. on Wikipedia [1]. However a reasonable description is that a RESTful service
  24. should have urls that represent remote objects which methods can then be
  25. called on.
  26. %package devel
  27. Summary: Development tools for rest
  28. Summary(ja): rest の開発環境
  29. Group: programming
  30. Requires: %{name} = %{version}-%{release}
  31. Requires: pkgconfig
  32. Requires: glib2-devel
  33. Requires: libsoup-devel
  34. Requires: libxml2-devel
  35. %description devel
  36. Header files and libraries for building a extension library for the
  37. rest.
  38. %package doc
  39. Summary: Documentation for rest
  40. Summary(ja): rest 用のドキュメント
  41. Group: documentation
  42. Requires: %{name} = %{version}-%{release}
  43. BuildArch: noarch
  44. %description doc
  45. This package contains documentation for rest.
  46. # compat32
  47. %package -n compat32-%{name}
  48. Summary: RESTful web api query library
  49. Group: system,legacy
  50. %description -n compat32-%{name}
  51. This library has been designed to make it easier to access web services that
  52. claim to be "RESTful". A reasonable definition of what this means can be found
  53. on Wikipedia [1]. However a reasonable description is that a RESTful service
  54. should have urls that represent remote objects which methods can then be
  55. called on.
  56. %debug_package
  57. %prep
  58. %setup -q
  59. %build
  60. %configure \
  61. --enable-gtk-doc \
  62. --disable-static \
  63. --enable-introspection=yes
  64. make %{?_smp_mflags}
  65. %install
  66. make DESTDIR=$RPM_BUILD_ROOT install
  67. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  68. %files
  69. %defattr(-,root,root,-)
  70. %license COPYING
  71. %doc AUTHORS README
  72. %{_libdir}/*.so.*
  73. %{_libdir}/girepository-1.0/*.typelib
  74. %files devel
  75. %defattr(-, root, root)
  76. %{_includedir}/%{name}-0.7
  77. %{_libdir}/*.so
  78. %{_libdir}/pkgconfig/*.pc
  79. %{_datadir}/gir-1.0/*.gir
  80. %files doc
  81. %defattr(-, root, root)
  82. %{_datadir}/gtk-doc/html/%{name}-0.7
  83. %if %{build_compat32}
  84. %files -n compat32-%{name}
  85. %defattr(-,root,root,-)
  86. %{_libdir}/*.so.*
  87. %endif
  88. %changelog
  89. * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.1-2
  90. - dropped scriptlets.
  91. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.1-1
  92. - new upstream release.
  93. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.93-2
  94. - create compat32-rest subpakcage
  95. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.93-1
  96. - new upstream release
  97. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.92-1
  98. - new upstream release
  99. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.91-1
  100. - new upstream release
  101. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.90-2
  102. - rebuild with VineSeed environment
  103. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.90-1
  104. - new upstream release
  105. - change BuildRequires: ca-certificates instead of openssl-devel
  106. * Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.12-2
  107. - fix URL
  108. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.12-1
  109. - new upstream release
  110. - add BuildRequires: openssl
  111. * Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.11-1
  112. - new upstream release
  113. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.10-1
  114. - initial build for Vine Linux