libdatrie-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Double-Array Trie Library
  3. Name: libdatrie
  4. Version: 0.2.13
  5. Release: 1%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv2
  10. URL: https://linux.thai.net/~thep/datrie/datrie.html
  11. Source0: https://github.com/tlwg/libdatrie/releases/download/v%{version}/%{name}-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: doxygen
  14. %description
  15. This is an implementation of double-array structure for representing trie,
  16. as proposed by Junichi Aoe.
  17. Trie is a kind of digital search tree, an efficient indexing method with
  18. O(1) time complexity for searching. Comparably as efficient as hashing,
  19. trie also provides flexibility on incremental matching and key spelling
  20. manipulation. This makes it ideal for lexical analyzers, as well as spelling
  21. dictionaries.
  22. %package devel
  23. Summary: Development tools for libdatrie
  24. Summary(ja): libdatrie の開発環境
  25. Group: programming
  26. Requires: %{name} = %{version}-%{release}
  27. Requires: pkgconfig
  28. %description devel
  29. Header files and libraries for building a extension library for the
  30. libdatrie.
  31. %package docs
  32. Summary: Documentation for libdatrie
  33. Summary(ja): libdatrie 用のドキュメント
  34. Group: documentation
  35. Requires: %{name} = %{version}-%{release}
  36. BuildArch: noarch
  37. Provides: %{name}-doc = %{version}-%{release}
  38. %description docs
  39. This package contains documentation for libdatrie
  40. # compat32
  41. %package -n compat32-%{name}
  42. Summary: Double-Array Trie Library
  43. Group: system,legacy
  44. Requires: %{name} = %{version}-%{release}
  45. %description -n compat32-%{name}
  46. This is an implementation of double-array structure for representing trie,
  47. as proposed by Junichi Aoe.
  48. Trie is a kind of digital search tree, an efficient indexing method with
  49. O(1) time complexity for searching. Comparably as efficient as hashing,
  50. trie also provides flexibility on incremental matching and key spelling
  51. manipulation. This makes it ideal for lexical analyzers, as well as spelling
  52. dictionaries.
  53. %package -n compat32-%{name}-devel
  54. Summary: Development tools for libdatrie
  55. Summary(ja): libdatrie の開発環境
  56. Group: programming,legacy
  57. Requires: compat32-%{name} = %{version}-%{release}
  58. Requires: pkgconfig
  59. %description -n compat32-%{name}-devel
  60. Header files and libraries for building a extension library for the
  61. libdatrie.
  62. %debug_package
  63. %prep
  64. %setup -q
  65. %build
  66. %configure \
  67. --disable-static
  68. %{__make} %{?_smp_mflags}
  69. %install
  70. %{__rm} -rf ${RPM_BUILD_ROOT}
  71. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  72. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
  73. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  74. %clean
  75. %{__rm} -rf ${RPM_BUILD_ROOT}
  76. %files
  77. %defattr(-,root,root,-)
  78. %license COPYING
  79. %doc AUTHORS ChangeLog NEWS README
  80. %{_bindir}/trietool
  81. %{_bindir}/trietool-0.2
  82. %{_libdir}/%{name}.so.*
  83. %{_mandir}/man1/*.gz
  84. %files devel
  85. %defattr(-,root,root,-)
  86. %{_includedir}/datrie
  87. %{_libdir}/%{name}.so
  88. %{_libdir}/pkgconfig/datrie-0.2.pc
  89. %files docs
  90. %defattr(-,root,root,-)
  91. %doc README.migration
  92. %doc %{_docdir}/datrie/html
  93. %if %{build_compat32}
  94. %files -n compat32-%{name}
  95. %defattr(-, root, root,-)
  96. %{_libdir}/%{name}.so.*
  97. %files -n compat32-%{name}-devel
  98. %defattr(-, root, root,-)
  99. %{_libdir}/%{name}.so
  100. %endif
  101. %changelog
  102. * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.2.13-1
  103. - new upstream release.
  104. - dropped scriptlets.
  105. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.10-1
  106. - new upstream release
  107. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.8-1
  108. - new upstream release
  109. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.7.1-1
  110. - new upstream release
  111. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.6-1
  112. - update to 0.2.6
  113. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.5-2
  114. - remove *.pc from compat32-%{name}-devel
  115. - fix typo
  116. * Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.5-1
  117. - initial build for Vine Linux