perl-Mail-DKIM-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147
  1. #
  2. # - Mail::DKIM -
  3. # This spec file was automatically generated by cpan2rpm [ver: 2.028]
  4. # The following arguments were used:
  5. # Mail::DKIM
  6. # For more information on cpan2rpm please visit: http://perl.arix.com/
  7. #
  8. %define pkgname Mail-DKIM
  9. %define filelist %{pkgname}-%{version}-filelist
  10. %define NVR %{pkgname}-%{version}-%{release}
  11. %define maketest 1
  12. Name: perl-Mail-DKIM
  13. Summary: Mail-DKIM - Signs/verifies Internet mail with DKIM/DomainKey signatures
  14. Version: 0.40
  15. Release: 2%{?_dist_release}
  16. License: Artistic
  17. Group: Development/Languages
  18. Url: http://www.cpan.org
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
  20. BuildArch: noarch
  21. Source: http://search.cpan.org//CPAN/authors/id/J/JA/JASLONG/Mail-DKIM-%{version}.tar.gz
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: tomop
  25. BuildRequires: perl(Mail::Address)
  26. %description
  27. This module implements the various components of the DKIM and
  28. DomainKeys message-signing and verifying standards for Internet mail.
  29. It currently tries to implement these specifications:
  30. =over
  31. =item RFC4871, for DKIM
  32. =item RFC4870, for DomainKeys
  33. =back
  34. The module uses an object-oriented interface. You use one of
  35. two different classes, depending on whether you are signing or verifying
  36. a message. To sign, use the L<Mail::DKIM::Signer> class. To verify, use
  37. the L<Mail::DKIM::Verifier> class. Simple, eh?
  38. #
  39. # This package was generated automatically with the cpan2rpm
  40. # utility. To get this software or for more information
  41. # please visit: http://perl.arix.com/
  42. #
  43. %prep
  44. %setup -q -n %{pkgname}-%{version}
  45. chmod -R u+w %{_builddir}/%{pkgname}-%{version}
  46. %build
  47. grep -rsl '^#!.*perl' . |
  48. grep -v '.bak$' |xargs --no-run-if-empty \
  49. %__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
  50. CFLAGS="$RPM_OPT_FLAGS"
  51. %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLDIRS=vendor
  52. %{__make}
  53. %if %maketest
  54. %{__make} test
  55. %endif
  56. %install
  57. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  58. %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
  59. cmd=/usr/share/spec-helper/compress_files
  60. [ -x $cmd ] || cmd=/usr/lib/rpm/brp-compress
  61. [ -x $cmd ] && $cmd
  62. # SuSE Linux
  63. if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
  64. then
  65. %{__mkdir_p} %{buildroot}/var/adm/perl-modules
  66. %{__cat} `find %{buildroot} -name "perllocal.pod"` \
  67. | %{__sed} -e s+%{buildroot}++g \
  68. > %{buildroot}/var/adm/perl-modules/%{name}
  69. fi
  70. # remove special files
  71. find %{buildroot} -name "perllocal.pod" \
  72. -o -name ".packlist" \
  73. -o -name "*.bs" \
  74. |xargs -i rm -f {}
  75. # no empty directories
  76. find %{buildroot}%{_prefix} \
  77. -type d -depth \
  78. -exec rmdir {} \; 2>/dev/null
  79. %{__perl} -MFile::Find -le '
  80. find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
  81. print "%doc TODO scripts Changes README";
  82. for my $x (sort @dirs, @files) {
  83. push @ret, $x unless indirs($x);
  84. }
  85. print join "\n", sort @ret;
  86. sub wanted {
  87. return if /auto$/;
  88. local $_ = $File::Find::name;
  89. my $f = $_; s|^\Q%{buildroot}\E||;
  90. return unless length;
  91. return $files[@files] = $_ if -f $f;
  92. $d = $_;
  93. /\Q$d\E/ && return for reverse sort @INC;
  94. $d =~ /\Q$_\E/ && return
  95. for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
  96. $dirs[@dirs] = $_;
  97. }
  98. sub indirs {
  99. my $x = shift;
  100. $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
  101. }
  102. ' > %filelist
  103. [ -z %filelist ] && {
  104. echo "ERROR: empty %files listing"
  105. exit -1
  106. }
  107. %clean
  108. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  109. %files -f %filelist
  110. %defattr(-,root,root)
  111. %changelog
  112. * Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40-2
  113. - rebuilt with perl-5.16.3.
  114. * Thu Mar 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40-1
  115. - new upstream release.
  116. * Fri Dec 02 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.39-1
  117. - Initial build.