cmake-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258
  1. # Set to bcond_without or use --with bootstrap if bootstrapping a new release
  2. # or architecture
  3. %bcond_with bootstrap
  4. # Set to bcond_with or use --without gui to disable qt4 gui build
  5. %bcond_with gui
  6. %global major_version 3
  7. %global minor_version 10
  8. Name: cmake
  9. Summary: Cross-platform make system
  10. Summary(ja): クロスプラットフォームな Make システム
  11. Version: 3.10.1
  12. Release: 1%{?_dist_release}
  13. Group: Development/Tools
  14. License: BSD
  15. URL: http://www.cmake.org/
  16. Source0: http://www.cmake.org/files/v3.10/%{name}-%{version}.tar.gz
  17. Source1: macros.cmake
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: curl-devel
  20. BuildRequires: expat-devel
  21. BuildRequires: gcc-gfortran
  22. BuildRequires: libarchive-devel
  23. BuildRequires: libidn-devel
  24. BuildRequires: ncurses-devel
  25. BuildRequires: openssl-devel
  26. BuildRequires: zlib-devel
  27. BuildRequires: xz-devel
  28. BuildRequires: jsoncpp-devel
  29. %if %{with gui}
  30. BuildRequires: qt4-devel, desktop-file-utils
  31. %define qt_gui --qt-gui
  32. %else
  33. %define qt_gui --no-qt-gui
  34. %endif
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. %description
  38. CMake is used to control the software compilation process using simple
  39. platform and compiler independent configuration files. CMake generates
  40. native makefiles and workspaces that can be used in the compiler
  41. environment of your choice. CMake is quite sophisticated: it is possible
  42. to support complex environments requiring system configuration, pre-processor
  43. generation, code generation, and template instantiation.
  44. %package gui
  45. Summary: Qt GUI for %{name}
  46. Group: Development/Tools
  47. Requires: %{name} = %{version}-%{release}
  48. Requires(post): desktop-file-utils, shared-mime-info
  49. Requires(postun): desktop-file-utils, shared-mime-info
  50. %description gui
  51. The %{name}-gui package contains the Qt based GUI for CMake.
  52. %prep
  53. %setup -q
  54. %build
  55. ./bootstrap \
  56. --prefix=%{_prefix} \
  57. --datadir=/share/%{name} \
  58. --docdir=/share/doc/%{name} \
  59. --mandir=/share/man \
  60. %if 0%{?with_bootstrap}
  61. --no-system-libs \
  62. %else
  63. --system-curl \
  64. --system-expat \
  65. --system-jsoncpp \
  66. --system-zlib \
  67. --system-bzip2 \
  68. --system-liblzma \
  69. --system-libarchive \
  70. --no-system-librhash \
  71. %endif
  72. --parallel=`/usr/bin/getconf _NPROCESSORS_ONLN` \
  73. %{?qt_gui} \
  74. -- -DCMAKE_USE_SYSTEM_LIBUV=OFF
  75. sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
  76. make VERBOSE=1 %{?_smp_mflags}
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. make install DESTDIR=$RPM_BUILD_ROOT
  80. find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
  81. rm -rf $RPM_BUILD_ROOT/usr/doc
  82. # RPM macros
  83. install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  84. sed -i -e "s|@@CMAKE_MAJOR_VERSION@@|%{major_version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  85. touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  86. %if %{with gui}
  87. # Desktop file
  88. desktop-file-install --delete-original \
  89. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  90. $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
  91. %endif
  92. rm -rf doc
  93. mv -f %{buildroot}%{_docdir}/%{name} ./doc
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %if %{with gui}
  97. %post gui
  98. update-desktop-database &> /dev/null || :
  99. update-mime-database %{_datadir}/mime &> /dev/null || :
  100. %postun gui
  101. update-desktop-database &> /dev/null || :
  102. update-mime-database %{_datadir}/mime &> /dev/null || :
  103. %endif
  104. %files
  105. %defattr(-,root,root)
  106. %doc CMakeLogo.gif README.* doc
  107. %doc Help
  108. %doc Licenses
  109. %config(noreplace) %{_sysconfdir}/rpm/macros.cmake
  110. %{_bindir}/ccmake
  111. %{_bindir}/cmake
  112. %{_bindir}/cpack
  113. %{_bindir}/ctest
  114. %{_datadir}/%{name}/
  115. %{_datadir}/aclocal/cmake.m4
  116. %if %{with gui}
  117. %files gui
  118. %defattr(-,root,root,-)
  119. %{_bindir}/cmake-gui
  120. %{_datadir}/applications/CMake.desktop
  121. %{_datadir}/mime/packages/cmakecache.xml
  122. %{_datadir}/icons/hicolor/*/*/*
  123. %endif
  124. %changelog
  125. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10.1-1
  126. - updated to 3.10.1.
  127. - updated macros.cmake.
  128. - disabled gui.
  129. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-2
  130. - rebuild with gcc-5.4.0
  131. * Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
  132. - update to 3.5.2
  133. - add BuildRequires: xz-devel, jsoncpp-devel
  134. - remove old patches
  135. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
  136. - update to 2.8.12.2
  137. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
  138. - update to 2.8.12.2
  139. - add Patch2 (cmake-2.8.12.2-ruby-2.2.x.patch)
  140. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-2
  141. - rebuild with libarchive-3.1.2
  142. * Mon Dec 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-1
  143. - new upstream release
  144. - add Patch1 (cmake-2.8.12.1-FindFreetype.patch)
  145. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
  146. - new upstream release
  147. * Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
  148. - new upstream release
  149. * Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
  150. - new upstream release
  151. - fixed desktop file warning
  152. * Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
  153. - rebuild with libarchive-3.0.4
  154. * Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
  155. - new upstream release
  156. - forced to link with libtinfo.so (ccmake)
  157. - used --system-libs again
  158. * Sat Jan 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
  159. - new upstream release
  160. - used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
  161. * Sun Sep 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
  162. - fixed typo (not --with-system-libs, but --system-libs)
  163. - added BR: curl-devel, expat-devel, zlib-devel
  164. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
  165. - add BuildRequires: ncurses-devel
  166. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
  167. - generate gui package
  168. - renamed module directory
  169. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
  170. - new upstream release
  171. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
  172. - rebuilt with new toolchain
  173. * Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
  174. - imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
  175. * Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
  176. - new upstream release
  177. - added Vendor/Distribution tag
  178. * Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
  179. - new upstream release
  180. * Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
  181. - new upstream release
  182. * Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
  183. - new upstream release
  184. * Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
  185. - new upstream release
  186. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
  187. - new upstream release
  188. - drop Patch100
  189. - use bootstrap script instead of configure
  190. - delete caches from %%doc
  191. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
  192. - rebuilt with new toolchain
  193. * Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
  194. - new upstream release
  195. - delete duped docs
  196. * Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
  197. - added Patch100 (especially for ppc to solve ppc/powerpc issue)
  198. * Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
  199. - source version up
  200. * Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
  201. - initial build for Vine Linux