vala-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337
  1. %global api_ver 0.14
  2. Summary: A modern programming language for GNOME
  3. Summary: GNOME 用のモダンなプログラミング言語
  4. Name: vala
  5. Version: 0.14.2
  6. Release: 1%{?_dist_release}
  7. Group: Development/Languages
  8. # Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
  9. License: LGPLv2+ and BSD
  10. URL: http://live.gnome.org/Vala
  11. Source0: http://download.gnome.org/sources/vala/0.14/vala-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: glib2-devel
  14. BuildRequires: flex
  15. BuildRequires: bison
  16. BuildRequires: libxslt
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. Vala is a new programming language that aims to bring modern programming
  21. language features to GNOME developers without imposing any additional
  22. runtime requirements and without using a different ABI compared to
  23. applications and libraries written in C.
  24. valac, the Vala compiler, is a self-hosting compiler that translates
  25. Vala source code into C source and header files. It uses the GObject
  26. type system to create classes and interfaces declared in the Vala source
  27. code. It's also planned to generate GIDL files when gobject-
  28. introspection is ready.
  29. The syntax of Vala is similar to C#, modified to better fit the GObject
  30. type system.
  31. %package devel
  32. Summary: Development files for %{name}
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. Requires: pkgconfig
  36. %description devel
  37. Vala is a new programming language that aims to bring modern programming
  38. language features to GNOME developers without imposing any additional
  39. runtime requirements and without using a different ABI compared to
  40. applications and libraries written in C.
  41. This package contains development files for %{name}. This is not necessary for
  42. using the %{name} compiler.
  43. %package tools
  44. Summary: Tools for creating projects and bindings for %{name}
  45. Group: Development/Languages
  46. License: LGPLv2+
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: gnome-common intltool libtool
  49. Provides: %{name}-vapigen = %{version}-%{release}
  50. Obsoletes: %{name}-vapigen < %{version}-%{release}
  51. %description tools
  52. Vala is a new programming language that aims to bring modern programming
  53. language features to GNOME developers without imposing any additional
  54. runtime requirements and without using a different ABI compared to
  55. applications and libraries written in C.
  56. This package contains tools to generate Vala projects, as well as API bindings
  57. from existing C libraries, allowing access from Vala programs.
  58. %package doc
  59. Summary: Documentation for %{name}
  60. Group: Documentation
  61. License: LGPLv2+
  62. BuildArch: noarch
  63. Requires: %{name} = %{version}-%{release}
  64. Requires: devhelp
  65. Provides: %{name}-docs = %{version}-%{release}
  66. Obsoletes: %{name}-docs < %{version}-%{release}
  67. %description doc
  68. Vala is a new programming language that aims to bring modern programming
  69. language features to GNOME developers without imposing any additional
  70. runtime requirements and without using a different ABI compared to
  71. applications and libraries written in C.
  72. This package contains documentation in a devhelp HTML book.
  73. %prep
  74. %setup -q
  75. %build
  76. %configure --enable-vapigen
  77. # Don't use rpath!
  78. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  79. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  80. make %{?_smp_mflags}
  81. # checks currently utilize installed Vala, not the one being compiled
  82. #%check
  83. #make check
  84. %install
  85. rm -rf $RPM_BUILD_ROOT
  86. make install DESTDIR=$RPM_BUILD_ROOT
  87. rm $RPM_BUILD_ROOT%{_libdir}/libvala-%{api_ver}.la
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %post -p /sbin/ldconfig
  91. %postun -p /sbin/ldconfig
  92. %files
  93. %defattr(-,root,root,-)
  94. %doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
  95. %{_bindir}/vala
  96. %{_bindir}/valac
  97. %{_bindir}/vala-%{api_ver}
  98. %{_bindir}/valac-%{api_ver}
  99. %{_datadir}/vala-%{api_ver}
  100. %{_libdir}/libvala-%{api_ver}.so.*
  101. %{_mandir}/*/valac*
  102. %files devel
  103. %defattr(-,root,root,-)
  104. %{_includedir}/vala-%{api_ver}
  105. %{_libdir}/libvala-%{api_ver}.so
  106. %{_libdir}/pkgconfig/libvala-%{api_ver}.pc
  107. %{_datadir}/aclocal/vala.m4
  108. %files tools
  109. %defattr(-,root,root,-)
  110. %{_bindir}/vala-gen-introspect
  111. %{_bindir}/vapicheck
  112. %{_bindir}/vapigen
  113. %{_bindir}/vala-gen-introspect-%{api_ver}
  114. %{_bindir}/vapicheck-%{api_ver}
  115. %{_bindir}/vapigen-%{api_ver}
  116. %{_libdir}/vala-%{api_ver}
  117. %{_mandir}/*/*gen*
  118. %files doc
  119. %defattr(-,root,root,-)
  120. %{_datadir}/devhelp/books/vala-%{api_ver}
  121. %changelog
  122. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
  123. - new upstream release
  124. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
  125. - new upstream release
  126. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
  127. - new upstream release
  128. - remove BuildRequires: gtk2-devel, xulrunner-devel
  129. - add BuildRequires: glib2-devel, libxslt
  130. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
  131. - new upstream release
  132. - remove BuildRequires: devhelp
  133. * Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
  134. - new upstream release
  135. * Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  136. - new upstream release
  137. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
  138. - new upstream release
  139. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
  140. - rebuilt with rpm-4.8.1 for pkg-config
  141. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
  142. - new upstream release
  143. - made -doc subpackage noarch
  144. * Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
  145. - new upstream release
  146. * Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
  147. - new upstream release
  148. * Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
  149. - new upstream release
  150. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
  151. - new upstream release
  152. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  153. - new upstream release
  154. - change BuildRequires: gecko-libs -> xulrunner-devel
  155. * Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
  156. - new upstream release
  157. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
  158. - new upstream release
  159. * Tue Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
  160. - new upstream release
  161. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
  162. - initial build for Vine Linux
  163. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
  164. - Update to 0.7.5
  165. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  167. * Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
  168. - Patch broken ModuleInit attribute (upstream bug 587444)
  169. * Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
  170. - Update to 0.7.4
  171. * Wed Jun 3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
  172. - Update to 0.7.3
  173. * Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
  174. - Update to 0.6.1
  175. * Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
  176. - Update to 0.5.7
  177. * Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
  178. - Update to 0.5.6
  179. * Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
  180. - Update to 0.5.3
  181. * Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
  182. - Fix bug in Emacs version detection
  183. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
  184. - Use buildsystem variables to determine available Emacs version
  185. - BR on gecko-devel >= 1.9, since older version is also in RHEL repo
  186. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
  187. - Update to 0.5.2
  188. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
  189. - Update to 0.5.1
  190. * Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
  191. - Update to 0.3.5
  192. * Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
  193. - Add vala-mode for editing Vala code in Emacs
  194. * Tue Jul 1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
  195. - Update to 0.3.4
  196. * Wed Jun 4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
  197. - Update to 0.3.3
  198. * Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
  199. - Update to 0.3.2
  200. * Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
  201. - Update to 0.2.0
  202. * Wed Mar 5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
  203. - Update to 0.1.7
  204. - -tool subpackage now requires gnome-common, intltool and libtoolize
  205. for out-of-the-box vala-gen-project support
  206. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
  207. - Autorebuild for GCC 4.3
  208. * Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  209. - Update to 0.1.6
  210. - Revert vapi addition, needed declarations have been inlined (r846)
  211. - Rename -docs subpackage to -doc, to comply with guidelines
  212. * Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
  213. - Manually add Gee vapi file to package (bz #428692)
  214. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
  215. - Backport patch to autodetect location of automake shared files
  216. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
  217. - Add build dependency on gtk2-devel
  218. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
  219. - Enable project generator tool
  220. * Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
  221. - Update to 0.1.5
  222. * Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
  223. - Add build dependency on devhelp
  224. * Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
  225. - Update to 0.1.4
  226. - Put newly-added documentation in its own subpackage (depends on devhelp)
  227. * Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
  228. - vapigen subpackage: add missing Require: on perl-XML-Twig
  229. * Sat Sep 8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
  230. - Split -vapigen subpackage. It is functionally self-contained and the license
  231. is more restricted
  232. - Updated license declarations
  233. * Wed Sep 5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
  234. - Licensing and URL updates
  235. * Tue Sep 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
  236. - Enable binding generation tools
  237. * Sun Sep 2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
  238. - Update to 0.1.3
  239. * Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
  240. - Update to 0.0.8
  241. * Wed Mar 7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
  242. - Update to 0.0.7
  243. * Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
  244. - Update to 0.0.6
  245. * Mon Nov 6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
  246. - Initial package