123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361 |
- Summary: Timezone data
- Summary(ja): タイムゾーンのデータ
- Name: tzdata
- Version: 2014e
- %define tzdata_version 2014e
- %define tzcode_version 2014e
- Release: 1%{?_dist_release}
- License: Public Domain
- Group: System Environment/Base
- URL: ftp://elsie.nci.nih.gov/pub/
- # The tzdata-base-0.tar.bz2 is a simple building infrastructure and
- # a test suite. It is occasionally updated from glibc sources, and as
- # such is under LGPLv2+, but none of this ever gets to be part of
- # final zoneinfo files.
- Source0: tzdata-base-0.tar.bz2
- # These are official upstream.
- Source1: ftp://munnari.oz.au/pub/tzdata%{tzdata_version}.tar.gz
- Source2: ftp://munnari.oz.au/pub/tzcode%{tzcode_version}.tar.gz
- Source3: javazic.tar.gz
- Patch100: javazic-fixup.patch
- Patch101: javazic-exclusion-fix.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildArch: noarch
- BuildRequires: gawk, glibc, perl
- BuildRequires: java-devel
- BuildRequires: glibc-common >= 2.5.90-7
- Conflicts: glibc-common <= 2.3.2-63
- %description
- This package contains data files with rules for various timezones around
- the world.
- %description -l ja
- このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
- %package java
- Summary: Timezone data for Java
- Group: System Environment/Base
- %description java
- This package contains timezone information for use by Java runtimes.
- %prep
- %setup -n tzdata
- mkdir tzdata%{tzdata_version}
- tar xzf %{SOURCE1} -C tzdata%{tzdata_version}
- mkdir tzcode%{tzcode_version}
- tar xzf %{SOURCE2} -C tzcode%{tzcode_version}
- sed -e 's|@objpfx@|'`pwd`'/obj/|' \
- -e 's|@datadir@|%{_datadir}|' \
- Makeconfig.in > Makeconfig
- pushd src
- for i in ../tzcode%{tzcode_version}/*.{c,h,ksh,[1-9]}
- do
- ln -sf $i .
- done
- popd
- mkdir javazic
- tar zxf %{SOURCE3} -C javazic
- pushd javazic
- %patch100
- %patch101
- # Hack alert! sun.tools may be defined and installed in the
- # VM. In order to guarantee that we are using IcedTea/OpenJDK
- # for creating the zoneinfo files, rebase all the packages
- # from "sun." to "rht.". Unfortunately, gcj does not support
- # any of the -Xclasspath options, so we must go this route
- # to ensure the greatest compatibility.
- mv sun rht
- find . -type f -name '*.java' -print0 \
- | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
- -e 's:sun\.util\.:rht.util.:g'
- popd
- %build
- make
- grep -v tz-art.htm tzcode%{tzcode_version}/tz-link.htm > tzcode%{tzcode_version}/tz-link.html
- pushd javazic
- javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
- popd
- pushd tzdata%{tzdata_version}
- java -classpath ../javazic/ rht.tools.javazic.Main -V %{version} \
- -d ../zoneinfo/java \
- africa antarctica asia australasia europe northamerica pacificnew \
- southamerica backward etcetera \
- ../javazic/tzdata_jdk/gmt ../javazic/tzdata_jdk/jdk11_backward
- popd
- %install
- rm -fr $RPM_BUILD_ROOT
- sed -i 's|@install_root@|%{buildroot}|' Makeconfig
- make install \
- TOPDIR=%{buildroot}%{_prefix} \
- TZDIR=%{buildroot}%{_datadir}/zoneinfo
- cp -pr zoneinfo/java $RPM_BUILD_ROOT%{_datadir}/javazi
- rm -f %{buildroot}%{_datadir}/zoneinfo-posix
- mkdir %{buildroot}%{_datadir}/zoneinfo-posix
- cp -af %{buildroot}%{_datadir}/zoneinfo/* %{buildroot}%{_datadir}/zoneinfo-posix
- mkdir %{buildroot}%{_datadir}/zoneinfo/posix
- cp -af %{buildroot}%{_datadir}/zoneinfo-posix/* %{buildroot}%{_datadir}/zoneinfo/posix
- mkdir -p %{buildroot}%{_datadir}/zoneinfo/right
- cp -a %{buildroot}%{_datadir}/zoneinfo-leaps/* %{buildroot}%{_datadir}/zoneinfo/right
- rm -rf %{buildroot}%{_datadir}/zoneinfo-{posix,leaps}
- rm -rf %{buildroot}%{_prefix}/etc
- rm -rf %{buildroot}%{_prefix}/lib
- rm -rf %{buildroot}%{_prefix}/man
- %clean
- rm -fr $RPM_BUILD_ROOT
- %files
- %defattr(-,root,root)
- %{_datadir}/zoneinfo
- %doc tzcode%{tzcode_version}/README
- %doc tzcode%{tzcode_version}/Theory
- %doc tzcode%{tzcode_version}/tz-link.html
- %files java
- %defattr(-,root,root)
- %{_datadir}/javazi
- %changelog
- * Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
- - update to tzdata-2012c, tzcode-2012b
- * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
- - rebuilt with rpm-4.8.1-3
- * Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
- - update to tzdata-2010l, tzcode-2010l
- - added java subpackage
- * Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
- - update to tzdata-2009d, tzcode-2009d
- - spec in utf-8
- * Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
- - update to tzdata-2008b, tzcode-2008a
- * Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
- - initial build for VineSeed
- * Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
- - Upstream 2007d
- - Mongolia has abolished DST.
- - Turkey will use EU rules this year, changing at 01:00 UTC rather
- than 01:00 standard time.
- - Cuba observed DST starting Sunday.
- - Resolute, Nunavut switched from Central to Eastern time last
- November.
- * Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
- - Upstream 2007c
- - Pulaski County, Indiana, switched back to eastern time.
- - Turkey switches at 01:00 standard time, not at 01:00 UTC.
- - Upstream 2007b
- - Changes to the commentary in "leapseconds".
- - Upstream 2007a
- - Updates to Bahamas, they will be in sync with 2007 US DST change
- - New zone Australia/Eucla
- - Africa/Asmera renamed to Africa/Asmara, link created
- - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
- * Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
- - Upstream 2006p
- - Covers changes from 2006m-2 and 2006m-3
- - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
- * Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
- - Patch for Western Australia DST trial
- * Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
- - Proposed upstream patch (#210058)
- - Jordan will switch to winter time on October 27, not September 29
- - Brazil's DST this year is the first Sunday in November to the last
- Sunday in February. (Thanks to Frederico A. C. Neves.)
- - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
- - Commentary and past timestamps changes
- * Tue Oct 3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
- - Upstream 2006m:
- - Adjustments for Egypt, Palestine, Uruguay
- - Better description of `until' field in zic (8) manpage
- * Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
- - Upstream 2006k, 2006l:
- - Adjustments for Egypt, Palestine, Cuba, Honduras
- - Documentation changes
- * Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
- - Upstream 2006j
- - Honduras stopped observing DST on Monday at 00:00
- - America/Bermuda will follow the US's lead next year
- - America/Moncton will use US-style rules next year
- - New Zone America/Blanc-Sablon, for Canadians who observe AST all
- year
- - New zone: America/Atikokan instead of America/Coral_Harbour
- - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
- - Historical changes
- - Commentary updates
- - Upstream 2006i
- - localtime.c fixes
- - Upstream 2006h
- - zic leapsecond fix
- * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
- - rebuild
- * Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
- - Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
- - Nicaragua updates
- * Tue May 2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
- - Upstream 2006f
- - America/Guatemala observes DST between Apr/30 and Oct/1
- - Historical changes for Nicaragua
- - Update of America/Indiana/Vincennes in zone table
- * Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
- - Upstream 2006d
- - Haiti observes DST
- - Sri Lanka change actually took effect Apr/15
- - All Canada is now scheduled for 2007 US DST rules
- - Some historical fixes
- * Thu Apr 6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
- - Upstream 2006c
- - Time-related changes:
- - dozens of historical and commentary changes
- - Iran stopped observing DST
- - Sri Lanka switches from UTC+6 to UTC+5:30
- - America/Thule and America/Edmonton will adopt new US rules,
- starting 2007
- - Tunisia is adopting regular DST
- - Code:
- - asctime.c: Chages in format strings to silent gcc warnings
- - removing K&R notation from function signatures
- - few fixes across the code
- * Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
- - Patch for Sri Lanka time zone change (#184514)
- * Thu Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
- - Upstream 2006b:
- - using tz64code version, as 32 is legacy according to tzdata ML
- - new manual pages for ctime, strftime, tzset
- - some source code reorganizations
- - no timezone/dst rule updates
- * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
- - Small changes in tst-timezone.c
- * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
- - Upstream 2006a:
- - private.h(scheck): changing char* to char const*
- - Rule changes for Palestine, zone changes for Indiana/US, both
- changes for Canada.
- - Many related doc changes.
- - Naming scheme in spec file doesn't use %%{name}, but tzdata.
- * Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
- - 2005r-3
- - Meta changes. Renaming tzdata.tar.bz2 file to tzdata$ver-base,
- so that it won't clash across updates.
- * Thu Jan 5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
- - 2005r
- - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
- northamerica to guard against old files with obsolete information
- being left in the time zone binary directory.
- - Changes for countries that are supposed to join 2007 US DST
- change. This includes most of Canada, however entries already in
- the database (Alberta, British Columbia, Newfoundland, Northwest
- Territories, and Yukon) were left alone for the time being.
- - Fixes in zdump.c (abbrok): conditions are chained, and the string
- is checked for emptiness.
- * Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
- - 2005q
- - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
- - SystemV timezone changes
- * Wed Nov 2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
- - 2005n
- - changes for Kyrgyzstan and Uruguay
- - fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
- make check), update tst-timezone.c from glibc CVS (#172102)
- * Tue Sep 6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
- - 2005m
- - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
- Australia, Kazakhstan
- - historical timezone data changes for Japan, Poland, Northern Ireland and
- Mali
- - timezone name change for East Timor
- * Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
- - 2005k
- - leap seconds update
- * Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
- - 2005i
- - updates for Iran, Haiti and Nicaragua
- * Mon Apr 4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
- - 2005h
- - fixes for Kazakhstan
- * Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
- - 2005g
- - fixes for Uruguay
- - include README and Theory from tzcode tarball in %{_docdir};
- Theory includes a good summary of how the timezone data files
- are supposed to be named
- * Tue Mar 1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
- - 2005f
- - more updates for Israel, updates for Azerbaijan
- * Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
- - 2005c
- - updates for Israel and Paraguay
- * Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
- - 2004g (#141107)
- - updates for Cuba
- * Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
- - 2004e (#135194)
- - updates for Brazil, Uruguay and Argentina
- * Wed Aug 4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
- - 2004b
- * Mon Oct 6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
- - 2003d
- * Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
- - 2003c
- - updates for Brazil (#104840)
- * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
- - rebuilt
- * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
- - initial package
|