ninja-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130
  1. #global githash 5dc55a3
  2. Name: ninja
  3. Version: 1.4.0
  4. Release: 1%{?_dist_release}
  5. Group: Development/Tools
  6. Summary: A small build system with a focus on speed
  7. License: ASL 2.0
  8. URL: http://martine.github.com/ninja/
  9. #VCS: git://github.com/martine/ninja.git
  10. # Snapshot from github
  11. # Downloaded from https://github.com/martine/ninja/tarball/%{githash}
  12. #Source0: martine-ninja-%{githash}.tar.gz
  13. Source0: https://github.com/martine/ninja/archive/v%{version}.tar.gz
  14. Source1: ninja.vim
  15. BuildRequires: asciidoc
  16. BuildRequires: gtest-devel
  17. BuildRequires: re2c
  18. Requires: emacsen
  19. Requires: vim
  20. %description
  21. Ninja is a small build system with a focus on speed. It differs from other
  22. build systems in two major respects: it is designed to have its input files
  23. generated by a higher-level build system, and it is designed to run builds as
  24. fast as possible.
  25. %prep
  26. %setup -q -n ninja-%{version}
  27. %build
  28. CFLAGS="%{optflags}"
  29. export CFLAGS
  30. ./bootstrap.py --verbose -- --debug
  31. ./ninja -v manual
  32. ./ninja -v ninja_test
  33. %check
  34. # workaround possible too low default limits
  35. ulimit -n 2048
  36. ulimit -u 2048
  37. ./ninja_test
  38. %install
  39. # TODO: Install ninja_syntax.py?
  40. install -p -m 755 -d %{buildroot}%{_bindir}
  41. install -p -m 755 ninja %{buildroot}%{_bindir}/ninja
  42. install -p -m 755 -d %{buildroot}%{_sysconfdir}/bash_completion.d
  43. install -p -m 644 misc/bash-completion %{buildroot}%{_sysconfdir}/bash_completion.d/ninja-bash-completion
  44. install -p -m 755 -d %{buildroot}%{_datadir}/emacs/site-lisp
  45. install -p -m 644 misc/ninja-mode.el %{buildroot}%{_datadir}/emacs/site-lisp/ninja-mode.el
  46. install -p -m 755 -d %{buildroot}%{_datadir}/vim/vimfiles/syntax
  47. install -p -m 644 misc/ninja.vim %{buildroot}%{_datadir}/vim/vimfiles/syntax/ninja.vim
  48. install -p -m 755 -d %{buildroot}%{_datadir}/vim/vimfiles/ftdetect
  49. install -p -m 644 %{SOURCE1} %{buildroot}%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
  50. install -p -m 755 -d %{buildroot}%{_datadir}/zsh/site-functions
  51. install -p -m 644 misc/zsh-completion %{buildroot}%{_datadir}/zsh/site-functions/_ninja
  52. %files
  53. %doc COPYING README doc/manual.html
  54. %{_bindir}/ninja
  55. # bash-completion does not own this
  56. %{_sysconfdir}/bash_completion.d/
  57. %{_datadir}/emacs/site-lisp/ninja-mode.el
  58. %{_datadir}/vim/vimfiles/syntax/ninja.vim
  59. %{_datadir}/vim/vimfiles/ftdetect/ninja.vim
  60. # zsh does not have a -filesystem package
  61. %{_datadir}/zsh/
  62. %changelog
  63. * Thu Jun 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
  64. - initial build for Vine Linux
  65. * Wed Nov 20 2013 Ben Boeckel <mathstuf@gmail.com> - 1.4.0-1
  66. - Update to 1.4.0
  67. * Sun Nov 3 2013 Ville Skyttä <ville.skytta@iki.fi> - 1.3.4-4
  68. - Use special %%doc to install all docs (#994005).
  69. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-3
  70. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  71. * Fri Jun 21 2013 Dan Horák <dan[at]danny.cz> - 1.3.4-2
  72. - workaround possible too low limits for number of processes and open files,
  73. fixes build on ppc/ppc64 and s390(x)
  74. * Sun Jun 09 2013 Ben Boeckel <mathstuf@gmail.com> - 1.3.4-1
  75. - Update to 1.3.4
  76. - Run test suite
  77. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  79. * Sun Nov 04 2012 Ben Boeckel <mathstuf@gmail.com> - 1.0.0-1
  80. - Update to 1.0.0
  81. * Thu Jul 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.6.20120719git5dc55a3
  82. - Update to new snapshot
  83. * Mon Jul 09 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.5.20120709gitb90d038
  84. - Preserve timestamps on install
  85. - Install as ninja-build to avoid conflicts with the ninja IRC package
  86. - Update snapshot
  87. * Tue Jun 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.4.20120605git54553d3
  88. - Add an ftdetect file for ninja
  89. - Fix zsh-stuff directory ownership
  90. * Thu Jun 07 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.3.20120605git54553d3
  91. - Add a Group tag
  92. * Tue Jun 05 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.2.20120605git54553d3
  93. - Update to new snapshot
  94. * Fri Mar 30 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.1.20120330gitabd33d5
  95. - Initial package