libdb-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588
  1. %define __soversion_major 5
  2. %define __soversion %{__soversion_major}.3
  3. %bcond_with java
  4. Summary: The Berkeley DB database library for C
  5. Name: libdb
  6. Version: 5.3.28
  7. Release: 6%{?_dist_release}
  8. Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
  9. Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
  10. # For mt19937db.c
  11. Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
  12. Patch0: libdb-multiarch.patch
  13. # db-1.85 upstream patches
  14. Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
  15. Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
  16. Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
  17. Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
  18. # other patches
  19. Patch20: db-1.85-errno.patch
  20. Patch22: db-4.6.21-1.85-compat.patch
  21. Patch24: db-4.5.20-jni-include-dir.patch
  22. # License clarification patch
  23. # http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
  24. Patch25: 007-mt19937db.c_license.patch
  25. URL: http://www.oracle.com/database/berkeley-db/
  26. License: BSD and LGPLv2 and Sleepycat
  27. Group: System Environment/Libraries
  28. BuildRequires: perl libtool
  29. BuildRequires: tcl >= 8.5.2-3
  30. %if %{with java}
  31. BuildRequires: java-devel >= 1:1.6.0
  32. %endif
  33. #BuildRequires: chrpath
  34. #Conflicts: filesystem < 3
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. Packager: tomop
  38. %description
  39. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  40. provides embedded database support for both traditional and
  41. client/server applications. The Berkeley DB includes B+tree, Extended
  42. Linear Hashing, Fixed and Variable-length record access methods,
  43. transactions, locking, logging, shared memory caching, and database
  44. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  45. used by many applications, including Python and Perl, so this should
  46. be installed on all systems.
  47. %package utils
  48. Summary: Command line tools for managing Berkeley DB databases
  49. Group: Applications/Databases
  50. Requires: %{name}%{?_isa} = %{version}-%{release}
  51. Obsoletes: db4-utils
  52. Provides: db4-utils
  53. %description utils
  54. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  55. provides embedded database support for both traditional and
  56. client/server applications. Berkeley DB includes B+tree, Extended
  57. Linear Hashing, Fixed and Variable-length record access methods,
  58. transactions, locking, logging, shared memory caching, and database
  59. recovery. DB supports C, C++, Java and Perl APIs.
  60. %package devel
  61. Summary: C development files for the Berkeley DB library
  62. Group: Development/Libraries
  63. Requires: %{name}%{?_isa} = %{version}-%{release}
  64. Obsoletes: db4-devel
  65. Provides: db4-devel
  66. %description devel
  67. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  68. provides embedded database support for both traditional and
  69. client/server applications. This package contains the header files,
  70. libraries, and documentation for building programs which use the
  71. Berkeley DB.
  72. %package devel-doc
  73. Summary: C development documentation files for the Berkeley DB library
  74. Group: Documentation
  75. Requires: %{name} = %{version}-%{release}
  76. Requires: %{name}-devel = %{version}-%{release}
  77. BuildArch: noarch
  78. %description devel-doc
  79. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  80. provides embedded database support for both traditional and
  81. client/server applications. This package contains the header files,
  82. libraries, and documentation for building programs which use the
  83. Berkeley DB.
  84. %package devel-static
  85. Summary: Berkeley DB static libraries
  86. Group: Development/Libraries
  87. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  88. %description devel-static
  89. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  90. provides embedded database support for both traditional and
  91. client/server applications. This package contains static libraries
  92. needed for applications that require static linking of
  93. Berkeley DB.
  94. %package cxx
  95. Summary: The Berkeley DB database library for C++
  96. Group: System Environment/Libraries
  97. Requires: %{name}%{?_isa} = %{version}-%{release}
  98. %description cxx
  99. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  100. provides embedded database support for both traditional and
  101. client/server applications. The Berkeley DB includes B+tree, Extended
  102. Linear Hashing, Fixed and Variable-length record access methods,
  103. transactions, locking, logging, shared memory caching, and database
  104. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  105. used by many applications, including Python and Perl, so this should
  106. be installed on all systems.
  107. %package cxx-devel
  108. Summary: The Berkeley DB database library for C++
  109. Group: System Environment/Libraries
  110. Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
  111. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  112. %description cxx-devel
  113. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  114. provides embedded database support for both traditional and
  115. client/server applications. The Berkeley DB includes B+tree, Extended
  116. Linear Hashing, Fixed and Variable-length record access methods,
  117. transactions, locking, logging, shared memory caching, and database
  118. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  119. used by many applications, including Python and Perl, so this should
  120. be installed on all systems.
  121. %package tcl
  122. Summary: Development files for using the Berkeley DB with tcl
  123. Group: Development/Libraries
  124. Requires: %{name}%{?_isa} = %{version}-%{release}
  125. %description tcl
  126. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  127. provides embedded database support for both traditional and
  128. client/server applications. This package contains the libraries
  129. for building programs which use the Berkeley DB in Tcl.
  130. %package tcl-devel
  131. Summary: Development files for using the Berkeley DB with tcl
  132. Group: Development/Libraries
  133. Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
  134. %description tcl-devel
  135. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  136. provides embedded database support for both traditional and
  137. client/server applications. This package contains the libraries
  138. for building programs which use the Berkeley DB in Tcl.
  139. %package sql
  140. Summary: Development files for using the Berkeley DB with sql
  141. Group: Development/Libraries
  142. Requires: %{name}%{?_isa} = %{version}-%{release}
  143. %description sql
  144. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  145. provides embedded database support for both traditional and
  146. client/server applications. This package contains the libraries
  147. for building programs which use the Berkeley DB in SQL.
  148. %package sql-devel
  149. Summary: Development files for using the Berkeley DB with sql
  150. Group: Development/Libraries
  151. Requires: %{name}-sql%{?_isa} = %{version}-%{release}
  152. %description sql-devel
  153. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  154. provides embedded database support for both traditional and
  155. client/server applications. This package contains the libraries
  156. for building programs which use the Berkeley DB in SQL.
  157. %if %{with java}
  158. %package java
  159. Summary: Development files for using the Berkeley DB with Java
  160. Group: Development/Libraries
  161. Requires: %{name}%{?_isa} = %{version}-%{release}
  162. %description java
  163. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  164. provides embedded database support for both traditional and
  165. client/server applications. This package contains the libraries
  166. for building programs which use the Berkeley DB in Java.
  167. %package java-devel
  168. Summary: Development files for using the Berkeley DB with Java
  169. Group: Development/Libraries
  170. Requires: %{name}-java%{?_isa} = %{version}-%{release}
  171. %description java-devel
  172. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  173. provides embedded database support for both traditional and
  174. client/server applications. This package contains the libraries
  175. for building programs which use the Berkeley DB in Java.
  176. %endif
  177. %prep
  178. %setup -q -n db-%{version} -a 1
  179. cp %{SOURCE2} .
  180. %patch0 -p1 -b .multiarch
  181. pushd db.1.85/PORT/linux
  182. %patch10 -p0 -b .1.1
  183. popd
  184. pushd db.1.85
  185. %patch11 -p0 -b .1.2
  186. %patch12 -p0 -b .1.3
  187. %patch13 -p0 -b .1.4
  188. %patch20 -p1 -b .errno
  189. popd
  190. %patch22 -p1 -b .185compat
  191. %patch24 -p1 -b .4.5.20.jni
  192. %patch25 -p1 -b .licensefix
  193. cd dist
  194. ./s_config
  195. cd ..
  196. %build
  197. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  198. CFLAGS="$CFLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
  199. export CFLAGS
  200. # Build the old db-185 libraries.
  201. make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
  202. test -d dist/dist-tls || mkdir dist/dist-tls
  203. # Static link db_dump185 with old db-185 libraries.
  204. /bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
  205. /bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
  206. # Update config files to understand aarch64
  207. #for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
  208. # cp /usr/lib/rpm/config.{guess,sub} "$dir"
  209. #done
  210. pushd dist/dist-tls
  211. %define _configure ../configure
  212. %configure -C \
  213. --enable-compat185 \
  214. --enable-dump185 \
  215. --enable-shared \
  216. --enable-static \
  217. --enable-tcl \
  218. --with-tcl=%{_libdir} \
  219. --enable-cxx \
  220. --enable-sql \
  221. --enable-test \
  222. --disable-rpath \
  223. --with-tcl=%{_libdir}/tcl8.5 \
  224. %if %{with java}
  225. --enable-java
  226. %endif
  227. # Remove libtool predep_objects and postdep_objects wonkiness so that
  228. # building without -nostdlib doesn't include them twice. Because we
  229. # already link with g++, weird stuff happens if you don't let the
  230. # compiler handle this.
  231. perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
  232. perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
  233. perl -pi -e 's/-shared -nostdlib/-shared/' libtool
  234. make %{?_smp_mflags}
  235. %if %{with java}
  236. # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
  237. LDBJ=./.libs/libdb_java-%{__soversion}.la
  238. if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
  239. sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
  240. fi
  241. %endif
  242. popd
  243. %install
  244. rm -rf ${RPM_BUILD_ROOT}
  245. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
  246. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  247. %makeinstall STRIP=/bin/true -C dist/dist-tls
  248. # XXX Nuke non-versioned archives and symlinks
  249. rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
  250. chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
  251. # Move the header files to a subdirectory, in case we're deploying on a
  252. # system with multiple versions of DB installed.
  253. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
  254. mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
  255. # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
  256. for i in db.h db_cxx.h db_185.h; do
  257. ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
  258. done
  259. %if %{with java}
  260. # Move java jar file to the correct place
  261. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
  262. mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
  263. %endif
  264. # Eliminate installed doco
  265. rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
  266. # XXX Avoid Permission denied. strip when building as non-root.
  267. chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
  268. # remove unneeded .la files (#225675)
  269. rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
  270. # remove RPATHs
  271. #chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
  272. # unify documentation and examples, remove stuff we don't need
  273. rm -rf docs/csharp
  274. rm -rf examples/csharp
  275. rm -rf docs/installation
  276. mv examples docs
  277. %clean
  278. rm -rf ${RPM_BUILD_ROOT}
  279. %post
  280. /sbin/ldconfig
  281. %postun
  282. /sbin/ldconfig
  283. %post cxx
  284. /sbin/ldconfig
  285. %postun cxx
  286. /sbin/ldconfig
  287. %post sql
  288. /sbin/ldconfig
  289. %postun sql
  290. /sbin/ldconfig
  291. %post tcl
  292. /sbin/ldconfig
  293. %postun tcl
  294. /sbin/ldconfig
  295. %if %{with java}
  296. %post java
  297. /sbin/ldconfig
  298. %postun java
  299. /sbin/ldconfig
  300. %endif
  301. %files
  302. %defattr(-,root,root,-)
  303. %doc LICENSE README lgpl-2.1.txt
  304. %{_libdir}/libdb-%{__soversion}.so
  305. %{_libdir}/libdb-%{__soversion_major}.so
  306. %files devel
  307. %defattr(-,root,root,-)
  308. %{_libdir}/libdb.so
  309. %dir %{_includedir}/%{name}
  310. %{_includedir}/%{name}/db.h
  311. %{_includedir}/%{name}/db_185.h
  312. %{_includedir}/db.h
  313. %{_includedir}/db_185.h
  314. %files devel-doc
  315. %defattr(-,root,root,-)
  316. %doc docs/*
  317. %files devel-static
  318. %defattr(-,root,root,-)
  319. %{_libdir}/libdb-%{__soversion}.a
  320. %{_libdir}/libdb_cxx-%{__soversion}.a
  321. %{_libdir}/libdb_tcl-%{__soversion}.a
  322. %{_libdir}/libdb_sql-%{__soversion}.a
  323. %if %{with java}
  324. %{_libdir}/libdb_java-%{__soversion}.a
  325. %endif
  326. %files utils
  327. %defattr(-,root,root,-)
  328. %{_bindir}/db*_archive
  329. %{_bindir}/db*_checkpoint
  330. %{_bindir}/db*_deadlock
  331. %{_bindir}/db*_dump*
  332. %{_bindir}/db*_hotbackup
  333. %{_bindir}/db*_load
  334. %{_bindir}/db*_printlog
  335. %{_bindir}/db*_recover
  336. %{_bindir}/db*_replicate
  337. %{_bindir}/db*_stat
  338. %{_bindir}/db*_upgrade
  339. %{_bindir}/db*_verify
  340. %{_bindir}/db*_tuner
  341. %files cxx
  342. %defattr(-,root,root,-)
  343. %{_libdir}/libdb_cxx-%{__soversion}.so
  344. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  345. %files cxx-devel
  346. %defattr(-,root,root,-)
  347. %{_includedir}/%{name}/db_cxx.h
  348. %{_includedir}/db_cxx.h
  349. %{_libdir}/libdb_cxx.so
  350. %files tcl
  351. %defattr(-,root,root,-)
  352. %{_libdir}/libdb_tcl-%{__soversion}.so
  353. %{_libdir}/libdb_tcl-%{__soversion_major}.so
  354. %files tcl-devel
  355. %defattr(-,root,root,-)
  356. %{_libdir}/libdb_tcl.so
  357. %files sql
  358. %defattr(-,root,root,-)
  359. %{_libdir}/libdb_sql-%{__soversion}.so
  360. %{_libdir}/libdb_sql-%{__soversion_major}.so
  361. %files sql-devel
  362. %defattr(-,root,root,-)
  363. %{_bindir}/dbsql
  364. %{_libdir}/libdb_sql.so
  365. %{_includedir}/%{name}/dbsql.h
  366. %if %{with java}
  367. %files java
  368. %defattr(-,root,root,-)
  369. %{_libdir}/libdb_java-%{__soversion_major}*.so
  370. %{_datadir}/java/*.jar
  371. %files java-devel
  372. %defattr(-,root,root,-)
  373. %{_libdir}/libdb_java.so
  374. %endif
  375. %changelog
  376. * Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-6
  377. - added "Provides: db4-{utils,devel}".
  378. * Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
  379. - initial build for Vine Linux.
  380. * Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
  381. - Add some of the previous aarch64 bits back as the sub configure don't use the macro
  382. * Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
  383. - Fix configure macro usage for better aarch64 build fix
  384. * Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
  385. - Updated config files to allow build on aarch64 (#1022970)
  386. * Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
  387. - Added Sleepycat to the license list (#1013841)
  388. - Updated to 5.3.28 (#1013233)
  389. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
  390. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  391. * Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
  392. - add copy of lgpl-2.1.txt
  393. * Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
  394. - Fix missing debuginfo issue for utils subpackage
  395. * Thu May 9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
  396. - add license clarification fix
  397. * Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
  398. - Added sqlite compability CFLAGS (#788496)
  399. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
  400. - Cleaning the specfile - removed gcc-java dependecy other way
  401. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
  402. - Removed dependency on obsolete gcc-java package (#927742)
  403. * Thu Mar 7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
  404. - add LGPLv2+ and remove Sleepycat in license tag (#886838)
  405. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
  406. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  407. * Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
  408. - fix license tag
  409. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
  410. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  411. * Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
  412. - Specify tag for libtool (fixes FTBFS # 838334 )
  413. * Thu Jul 5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
  414. - update to 5.3.21
  415. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  416. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
  417. - move C++ header files to cxx-devel
  418. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
  419. - fix -devel packages dependencies yet more (#832225)
  420. * Sun May 6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
  421. - package -devel packages correctly
  422. * Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
  423. - fix multiarch conflict in libdb-devel (#812901)
  424. - remove unneeded dos2unix BR
  425. * Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
  426. - update to 5.3.15
  427. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  428. * Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
  429. - Resolves rhbz#794472
  430. - Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
  431. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
  432. - add filesystem guard
  433. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
  434. - install everything in /usr
  435. https://fedoraproject.org/wiki/Features/UsrMove
  436. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
  437. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  438. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
  439. - update to 5.2.36,
  440. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
  441. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
  442. - move development documentation to devel-doc subpackage (#705386)
  443. * Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
  444. - update to 5.2.28
  445. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
  446. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  447. * Thu Feb 3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
  448. - update to 5.1.25
  449. * Wed Sep 29 2010 jkeating - 5.1.19-2
  450. - Rebuilt for gcc bug 634757
  451. * Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
  452. - update to 5.1.19
  453. - rename -devel-static to -static subpackage (#617800)
  454. - build java on all arches
  455. * Wed Jul 7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
  456. - update to 5.0.26
  457. - drop BR: ed
  458. * Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
  459. - add Requires: libdb-cxx to libdb-devel
  460. * Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
  461. - initial build
  462. * Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
  463. - remove C# documentation
  464. - disable/remove rpath
  465. - fix description
  466. - tighten dependencies
  467. - run ldconfig for cxx and sql subpackages
  468. * Fri Apr 9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
  469. - enable sql
  470. - package 5.0.21