nghttp2-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %bcond_with test
  3. %bcond_with boost
  4. %bcond_without app
  5. %define _unpackaged_files_terminate_build 1
  6. Summary: Experimental HTTP/2 client, server and proxy
  7. Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
  8. Name: nghttp2
  9. Version: 1.58.0
  10. Release: 1%{?_dist_release}
  11. Group: internet
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: MIT
  15. URL: https://nghttp2.org/
  16. Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
  17. %if %{with test}
  18. BuildRequires: CUnit-devel
  19. %endif
  20. BuildRequires: jemalloc-devel
  21. BuildRequires: libev-devel
  22. BuildRequires: openssl-devel
  23. BuildRequires: zlib-devel
  24. %if %{with boost}
  25. BuildRequires: libboost-devel
  26. BuildRequires: libboost-thread
  27. %endif
  28. %if %{with app}
  29. Requires: libnghttp2 = %{version}-%{release}
  30. BuildRequires: c-ares-devel
  31. BuildRequires: jansson-devel
  32. BuildRequires: libxml2-devel
  33. %endif
  34. %description
  35. This package contains the HTTP/2 client, server and proxy programs.
  36. %description -l ja
  37. This package contains the HTTP/2 client, server and proxy programs.
  38.  このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
  39. が含まれています。
  40. %package -n libnghttp2
  41. Summary: A library implementing the HTTP/2 protocol
  42. Summary(ja): HTTP/2ライブラリ
  43. Group: system
  44. %description -n libnghttp2
  45. libnghttp2 is a library implementing the Hypertext Transfer Protocol
  46. version 2 (HTTP/2) protocol in C.
  47. %description -l ja -n libnghttp2
  48.  libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
  49. 実装したライブラリです。
  50. %package -n libnghttp2-devel
  51. Summary: Files needed for building applications with libnghttp2
  52. Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
  53. Group: programming
  54. Requires: libnghttp2%{?_isa} = %{version}-%{release}
  55. Requires: pkgconfig
  56. %description -n libnghttp2-devel
  57. The libnghttp2-devel package includes libraries and header files needed
  58. for building applications with libnghttp2.
  59. %description -l ja -n libnghttp2-devel
  60.  libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
  61. をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
  62. す。
  63. %package -n compat32-libnghttp2
  64. Summary: A library implementing the HTTP/2 protocol
  65. Summary(ja): HTTP/2ライブラリ
  66. Group: system,legacy
  67. %description -n compat32-libnghttp2
  68. libnghttp2 is a library implementing the Hypertext Transfer Protocol
  69. version 2 (HTTP/2) protocol in C.
  70. %description -l ja -n compat32-libnghttp2
  71.  libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
  72. 実装したライブラリです。
  73. %package -n compat32-libnghttp2-devel
  74. Summary: Files needed for building applications with libnghttp2
  75. Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
  76. Group: programming,legacy
  77. Requires: compat32-libnghttp2%{?_isa} = %{version}-%{release}
  78. Requires: pkgconfig
  79. %description -n compat32-libnghttp2-devel
  80. The libnghttp2-devel package includes libraries and header files needed
  81. for building applications with libnghttp2.
  82. %description -l ja -n compat32-libnghttp2-devel
  83.  libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
  84. をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
  85. す。
  86. %debug_package
  87. %prep
  88. %setup -q
  89. %build
  90. CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS" \
  91. CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS" \
  92. %configure \
  93. %if %{with app}
  94. --enable-app \
  95. %endif
  96. %if %{with boost}
  97. --with-boost \
  98. --with-boost-asio \
  99. --with-boost-system \
  100. --with-boost-thread \
  101. %endif
  102. --with-pic \
  103. --disable-python-bindings \
  104. --disable-static \
  105. --with-libxml2 \
  106. %{nil}
  107. # avoid using rpath
  108. sed -i libtool \
  109. -e 's/^runpath_var=.*/runpath_var=/' \
  110. -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
  111. make %{?_smp_mflags} V=1
  112. %install
  113. %make_install
  114. # not needed on Fedora/RHEL
  115. rm -f %{buildroot}%{_libdir}/libnghttp2*.la
  116. # will be installed via %%doc
  117. rm -f "%{buildroot}%{_datadir}/doc/nghttp2/README.rst"
  118. %if ! %{with app}
  119. rm -f %{buildroot}%{_mandir}/man1/*
  120. %endif
  121. %check
  122. %if %{with test}
  123. # test the just built library instead of the system one, without using rpath
  124. export "LD_LIBRARY_PATH=%{buildroot}%{_libdir}:$LD_LIBRARY_PATH"
  125. make %{?_smp_mflags} check
  126. %endif
  127. %if %{with app}
  128. %files
  129. %{_bindir}/h2load
  130. %{_bindir}/nghttp
  131. %{_bindir}/nghttpd
  132. %{_bindir}/nghttpx
  133. %{_bindir}/deflatehd
  134. %{_bindir}/inflatehd
  135. %{_datadir}/nghttp2
  136. %{_mandir}/man1/h2load.1*
  137. %{_mandir}/man1/nghttp.1*
  138. %{_mandir}/man1/nghttpd.1*
  139. %{_mandir}/man1/nghttpx.1*
  140. %endif
  141. %files -n libnghttp2
  142. %{_libdir}/libnghttp2*.so.*
  143. %{_datadir}/%{name}/fetch-ocsp-response
  144. %{!?_licensedir:%global license %%doc}
  145. %license COPYING
  146. %files -n libnghttp2-devel
  147. %{_includedir}/nghttp2
  148. %{_libdir}/pkgconfig/libnghttp2*.pc
  149. %{_libdir}/libnghttp2*.so
  150. %doc README.rst
  151. %if %{build_compat32}
  152. %files -n compat32-libnghttp2
  153. %{_libdir}/libnghttp2*.so.*
  154. %{!?_licensedir:%global license %%doc}
  155. %license COPYING
  156. %files -n compat32-libnghttp2-devel
  157. %{_includedir}/nghttp2
  158. %{_libdir}/pkgconfig/libnghttp2*.pc
  159. %{_libdir}/libnghttp2*.so
  160. %doc README.rst
  161. %endif
  162. %changelog
  163. * Sat Oct 28 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.58.0-1
  164. - new upstream release.
  165. * Wed Oct 11 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.57.0-1
  166. - new upstream release.
  167. * Mon Sep 04 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.56.0-1
  168. - new upstream release.
  169. * Sat Jul 15 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.55.1-1
  170. - new upstream release.
  171. * Wed Jul 12 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.55.0-1
  172. - new upstream release.
  173. * Thu Jun 08 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.54.0-1
  174. - new upstream release.
  175. * Wed May 10 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.53.0-1
  176. - new upstream release.
  177. * Tue Feb 14 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.52.0-1
  178. - new upstream release.
  179. * Sun Nov 13 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.51.0-1
  180. - new upstream release.
  181. * Fri Oct 28 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.50.0-2
  182. - rebuilt with libboost-1.80.0.
  183. * Wed Sep 21 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.50.0-1
  184. - new upstream release.
  185. * Thu Aug 25 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.49.0-1
  186. - new upstream release.
  187. * Wed Jun 29 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.48.0-1
  188. - new upstream release.
  189. * Wed Feb 23 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.47.0-1
  190. - new upstream release.
  191. * Tue Oct 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.46.0-1
  192. - new upstream release.
  193. * Sat Oct 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.45.1-2
  194. - rebuilt with openssl-3.0.0.
  195. * Thu Sep 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.45.1-1
  196. - new upstream release.
  197. * Thu Jul 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.44.0-1
  198. - new upstream release.
  199. - dropped ldconfig scriptlets.
  200. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.43.0-1
  201. - new upstream release.
  202. * Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.42.0-1
  203. - new upstream release.
  204. * Tue Jun 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.41.0-1
  205. - new upstream release.
  206. * Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.40.0-2
  207. - rebuilt with boost-1.72.0.
  208. * Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.40.0-1
  209. - new upstream release.
  210. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.39.2-1
  211. - new upstream release.
  212. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.34.0-1
  213. - new upstream release.
  214. * Fri Mar 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31.0-1
  215. - new upstream release.
  216. * Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-2
  217. - rebuilt with libboost-1.66.0.
  218. * Sun Dec 24 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-1
  219. - new upstream release.
  220. - enabled to build apps as default.
  221. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.0-1
  222. - new upstream release.
  223. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.20.0-1
  224. - new upstream release.
  225. - disabled to build apps as default.
  226. * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.17.0-1
  227. - new upstream release.
  228. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
  229. - added compat32-* packages.
  230. * Thu Jul 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
  231. - new upstream release.
  232. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
  233. - initial build for Vne Linux.
  234. * Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
  235. - update to the latest upstream release
  236. * Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
  237. - update to the latest upstream release
  238. * Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
  239. - update to the latest upstream release
  240. * Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
  241. - update to the latest upstream release
  242. * Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
  243. - update to the latest upstream release
  244. * Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
  245. - update to the latest upstream release
  246. * Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
  247. - update to the latest upstream release (fixes CVE-2016-1544)
  248. * Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
  249. - make the package compile with gcc-6
  250. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
  251. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  252. * Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
  253. - update to the latest upstream release
  254. * Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
  255. - update to the latest upstream release (fixes CVE-2015-8659)
  256. * Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
  257. - update to the latest upstream release
  258. * Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
  259. - update to the latest upstream release
  260. * Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
  261. - update to the latest upstream release
  262. * Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
  263. - update to the latest upstream release
  264. * Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
  265. - update to the latest upstream release
  266. * Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
  267. - update to the latest upstream release
  268. * Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
  269. - update to the latest upstream release
  270. * Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
  271. - update to the latest upstream release
  272. * Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
  273. - update to the latest upstream release
  274. * Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
  275. - update to the latest upstream release
  276. * Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
  277. - packaged for Fedora (#1237247)