unbound-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %global with_munin 1
  3. %{?!enable_gost: %global enable_gost 1}
  4. # not ready yet
  5. %{?!with_python: %global with_python 0}
  6. %define _sharedstatedir /var/lib
  7. Summary: Validating, recursive, and caching DNS(SEC) resolver
  8. Name: unbound
  9. Version: 1.9.6
  10. Release: 1%{?_dist_release}
  11. License: BSD
  12. Url: http://www.unbound.net/
  13. Source: https://nlnetlabs.nl/downloads/unbound/%{name}-%{version}.tar.gz
  14. Source1: unbound.init
  15. Source3: unbound.munin
  16. Source4: dlv.isc.org.key
  17. Source5: root.key
  18. Source6: root.anchor
  19. Source7: icannbundle.pem
  20. Source8: unbound.cron
  21. Source9: example.com.key
  22. Source10: example.com.conf
  23. Source11: block-example.com.conf
  24. Group: System Environment/Daemons
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  26. BuildRequires: flex
  27. BuildRequires: libevent-devel
  28. BuildRequires: expat-devel
  29. %if %{with_python}
  30. BuildRequires: python-devel python-rpm-macros swig
  31. %endif
  32. %if %{enable_gost}
  33. BuildRequires: openssl-devel >= 1.0.0
  34. %else
  35. BuildRequires: openssl-devel
  36. %endif
  37. # Required for SVN versions
  38. #BuildRequires: bison
  39. Requires(post): chkconfig
  40. Requires(preun): chkconfig
  41. Requires(preun): initscripts
  42. Requires(postun): initscripts
  43. Requires(pre): shadow-utils
  44. Distribution: Vine Linux
  45. Vendor: Project Vine
  46. Packager: iwaim, daisuke
  47. %description
  48. Unbound is a validating, recursive, and caching DNS(SEC) resolver.
  49. The C implementation of Unbound is developed and maintained by NLnet
  50. Labs. It is based on ideas and algorithms taken from a java prototype
  51. developed by Verisign labs, Nominet, Kirei and ep.net.
  52. Unbound is designed as a set of modular components, so that also
  53. DNSSEC (secure DNS) validation and stub-resolvers (that do not run
  54. as a server, but are linked into an application) are easily possible.
  55. %if %{with_munin}
  56. %package munin
  57. Summary: Plugin for the munin / munin-node monitoring package
  58. Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
  59. Group: System Environment/Daemons
  60. Requires: munin-node
  61. Requires: %{name} = %{version}-%{release}, bc
  62. %description munin
  63. Plugin for the munin / munin-node monitoring package
  64. %endif
  65. %package devel
  66. Summary: Development package that includes the unbound header files
  67. Group: Development/Libraries
  68. Requires: %{name}-libs = %{version}-%{release}, openssl-devel
  69. %description devel
  70. The devel package contains the unbound library and the include files
  71. %package libs
  72. Summary: Libraries used by the unbound server and client applications
  73. Group: Applications/System
  74. Requires(post): /sbin/ldconfig
  75. Requires(postun): /sbin/ldconfig
  76. Requires: openssl >= 0.9.8g-12
  77. %description libs
  78. Contains libraries used by the unbound server and client applications
  79. %if %{with_python}
  80. %package python
  81. Summary: Python modules and extensions for unbound
  82. Group: Applications/System
  83. Requires: %{name}-libs = %{version}-%{release}
  84. %description python
  85. Python modules and extensions for unbound
  86. %endif
  87. %package -n compat32-%{name}-libs
  88. Summary: Libraries used by the unbound server and client applications
  89. Group: Applications/System
  90. Requires: %{name}-libs = %{version}-%{release}
  91. Requires(post): /sbin/ldconfig
  92. Requires(postun): /sbin/ldconfig
  93. Requires: openssl >= 0.9.8g-12
  94. %description -n compat32-%{name}-libs
  95. Contains libraries used by the unbound server and client applications
  96. %prep
  97. %setup -q
  98. %build
  99. %configure --with-libevent --with-pthreads --with-ssl \
  100. --disable-rpath --enable-debug --disable-static \
  101. --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
  102. --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
  103. %if %{with_python}
  104. --with-pythonmodule --with-pyunbound \
  105. %endif
  106. %if !%{enable_gost}
  107. --disable-gost \
  108. %endif
  109. --enable-sha2 \
  110. --disable-sha1 \
  111. --with-rootkey-file=%{_sharedstatedir}/unbound/root.key
  112. %{__make} %{?_smp_mflags}
  113. %install
  114. rm -rf %{buildroot}
  115. %{__make} DESTDIR=%{buildroot} install
  116. install -d 0755 %{buildroot}%{_initrddir}
  117. install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
  118. install -m 0644 %{SOURCE7} %{buildroot}%{_sysconfdir}/unbound
  119. install -d 0755 %{buildroot}%{_sysconfdir}/cron.d
  120. install -p -m 0644 %{SOURCE8} %{buildroot}%{_sysconfdir}/cron.d/unbound-anchor
  121. echo "include: %{_sysconfdir}/unbound/conf.d/*.conf" >> %{buildroot}%{_sysconfdir}/unbound/unbound.conf
  122. %if %{with_munin}
  123. # Install munin plugin and its softlinks
  124. install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
  125. install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
  126. install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
  127. install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
  128. for plugin in unbound_munin_hits unbound_munin_queue \
  129. unbound_munin_memory unbound_munin_by_type \
  130. unbound_munin_by_class unbound_munin_by_opcode \
  131. unbound_munin_by_rcode unbound_munin_by_flags \
  132. unbound_munin_histogram; do
  133. ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
  134. done
  135. %endif
  136. # install root and DLV key
  137. install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
  138. install -d -m 0755 %{buildroot}%{_sharedstatedir}/unbound
  139. install -m 0644 %{SOURCE6} %{buildroot}%{_sharedstatedir}/unbound/root.key
  140. # remove static library from install (fedora packaging guidelines)
  141. rm -rf %{buildroot}%{_libdir}/*.la
  142. %if %{with_python}
  143. rm -rf %{buildroot}%{python_sitelib}/*/*.la
  144. %endif
  145. mkdir -p %{buildroot}%{_localstatedir}/run/unbound
  146. # Install directories for easier config file drop in
  147. install -d -m 0755 %{buildroot}%{_sysconfdir}/unbound/{keys.d,local.d,conf.d}
  148. install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/unbound/keys.d/
  149. install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/unbound/conf.d/
  150. install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/unbound/local.d/
  151. %clean
  152. rm -rf ${RPM_BUILD_ROOT}
  153. %files
  154. %defattr(-,root,root,-)
  155. %license doc/LICENSE
  156. %doc doc/README doc/CREDITS doc/FEATURES
  157. %attr(0755,root,root) %{_initrddir}/%{name}
  158. %attr(0755,root,root) %dir %{_sysconfdir}/%{name}
  159. %attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
  160. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
  161. %dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/keys.d
  162. %attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/keys.d/*.key
  163. %dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/conf.d
  164. %attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/conf.d/*.conf
  165. %dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/local.d
  166. %attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/local.d/*.conf
  167. %{_sbindir}/*
  168. %exclude %{_sbindir}/unbound-anchor
  169. %{_mandir}/*/*
  170. %if %{with_python}
  171. %files python
  172. %{python_sitelib}/*
  173. %endif
  174. %if %{with_munin}
  175. %files munin
  176. %defattr(-,root,root,-)
  177. %config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
  178. %{_datadir}/munin/plugins/unbound*
  179. %endif
  180. %files devel
  181. %defattr(-,root,root,-)
  182. %{_libdir}/libunbound.so
  183. %{_includedir}/unbound.h
  184. %{_libdir}/pkgconfig/libunbound.pc
  185. %doc README
  186. %files libs
  187. %defattr(-,root,root,-)
  188. %license doc/LICENSE
  189. %doc doc/README
  190. %{_sbindir}/unbound-anchor
  191. %{_libdir}/libunbound.so.*
  192. %{_sysconfdir}/%{name}/icannbundle.pem
  193. %attr(0644,root,root) %{_sysconfdir}/cron.d/unbound-anchor
  194. %dir %attr(0755,unbound,unbound) %{_sharedstatedir}/%{name}
  195. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
  196. %attr(0644,unbound,unbound) %config(noreplace) %{_sharedstatedir}/%{name}/root.key
  197. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
  198. %if %{build_compat32}
  199. %files -n compat32-%{name}-libs
  200. %defattr(-,root,root,-)
  201. %{_libdir}/libunbound.so.*
  202. %endif
  203. %pre libs
  204. getent group unbound >/dev/null || groupadd -r unbound
  205. getent passwd unbound >/dev/null || \
  206. useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
  207. -c "Unbound DNS resolver" unbound
  208. exit 0
  209. %post
  210. /sbin/chkconfig --add %{name}
  211. # dnssec-conf used to contain our DLV key, but now we include it via unbound
  212. # If unbound had previously been configured with dnssec-configure, we need
  213. # to migrate the location of the DLV key file (to keep DLV enabled, and because
  214. # unbound won't start with a bad location for a DLV key file.
  215. sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
  216. %post libs
  217. /sbin/ldconfig
  218. /sbin/runuser --command="%{_sbindir}/unbound-anchor -a %{_sharedstatedir}/unbound/root.key -c %{_sysconfdir}/unbound/icannbundle.pem" --shell /bin/sh unbound ||:
  219. %preun
  220. if [ "$1" -eq 0 ]; then
  221. /sbin/service %{name} stop >/dev/null 2>&1
  222. /sbin/chkconfig --del %{name}
  223. fi
  224. %postun
  225. if [ "$1" -ge "1" ]; then
  226. /sbin/service %{name} condrestart >/dev/null 2>&1 || :
  227. fi
  228. %postun libs
  229. /sbin/ldconfig
  230. %post -n compat32-%{name}-libs
  231. /sbin/ldconfig
  232. %postun -n compat32-%{name}-libs
  233. /sbin/ldconfig
  234. %changelog
  235. * Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.6-1
  236. - updated to 1.9.6.
  237. * Fri Oct 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.4-1
  238. - updated to 1.9.4.
  239. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.3-1
  240. - updated to 1.9.3.
  241. * Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-1
  242. - updated to 1.9.2.
  243. * Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-2
  244. - added a subpackage 'compat32-unbound-libs'.
  245. * Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-1
  246. - updated to 1.8.1.
  247. - rebuilt with openssl-1.1.1 and libevent-2.1.8.
  248. - updated root.key and root.anchor.
  249. * Thu Oct 4 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.0-1
  250. - update to 1.8.0
  251. - drop mesh patch (Patch0): upstream fixed
  252. * Thu May 24 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-3
  253. - Fix mesh state assertion failure due to callback removal. (Patch0)
  254. * Sun May 6 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-2
  255. - enable ECDSA support
  256. - enable GOST support
  257. * Sat May 5 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-1
  258. - update to 1.7.1
  259. - add pkgconfig file in devel sub package
  260. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.7-1
  261. - updated to 1.6.7.
  262. * Mon Jul 31 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.4-1
  263. - update to 1.6.4
  264. * Sat Jun 24 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.3-1
  265. - update to 1.6.3
  266. * Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.2-1
  267. - update to 1.6.2
  268. - disables SHA1 support
  269. * Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.1-1
  270. - update to 1.6.1
  271. * Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-2
  272. - fix Requires and BuildRequres
  273. - drop ldns
  274. * Thu Dec 29 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-1
  275. - update to 1.6.0
  276. * Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.9-1
  277. - new upstream release.
  278. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.8-1
  279. - new upstream release.
  280. * Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.7-1
  281. - new upstream release.
  282. * Tue Nov 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-1
  283. - new upstream release.
  284. * Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.5.3-1
  285. - update to 1.5.3
  286. * Tue Dec 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.1-1
  287. - update to 1.5.1
  288. * Tue Jun 17 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-3
  289. - move create user script to libs subpackage
  290. * Wed Jun 11 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-2
  291. - add {B,C}.ROOT-SERVERS.NET. IPv6 address
  292. * Wed Apr 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
  293. - update to 1.4.22
  294. - move root.key to /var/lib/unbound
  295. - add icannbundle.pem from http://data.iana.org/root-anchors/icannbundle.pem
  296. - add unbound.cron
  297. - move keys and unbound-anchor to libs subpackage
  298. * Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.21-1
  299. - new upstream release
  300. * Tue Mar 26 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.20-1
  301. - new upstream release
  302. * Thu Dec 13 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.19-1
  303. - new upstream release
  304. - drop glob patch (Patch1): upstream merged
  305. * Wed Dec 5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
  306. - new upstream release
  307. * Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
  308. - update to 1.4.17
  309. - add root.key for DNSSEC
  310. - enable munin subpackage by default
  311. - buildrequire ldns-devel >= 1.6.13
  312. * Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
  313. - rebuild with python-2.7.2
  314. * Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
  315. - new upstream release
  316. * Sat Sep 3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
  317. - new upstream release
  318. * Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
  319. - new upstream releas
  320. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
  321. - new upstream release
  322. * Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
  323. - new upstream release
  324. * Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
  325. - rebuilt with libevent-2.0.10
  326. * Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
  327. - new upstream release
  328. - add enable_gost flag: default disable
  329. - add BuildRequires: expat-devel
  330. * Thu Sep 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
  331. - new upstream release
  332. * Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
  333. - new upstream release
  334. * Wed May 5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
  335. - initial build for Vine Linux: based Fedora 1.4.3-1.fc14
  336. - update to 1.4.4
  337. - build without munin
  338. * Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
  339. - Update to 1.4.3 that fixes 64bit crasher
  340. * Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
  341. - Updated to 1.4.2
  342. - Updated unbound.conf with new options
  343. - Enabled pre-fetching DNSKEY records (DNSSEC speedup)
  344. - Enabled re-fetching popular records before they expire
  345. - Enabled logging of DNSSEC validation errors
  346. * Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
  347. - Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
  348. with pthreads
  349. * Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
  350. - Change make/configure lines to attempt to fix -lphtread linking issue
  351. * Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
  352. - Removed dependancy for dnssec-conf
  353. - Added ISC DLV key (formerly in dnssec-conf)
  354. - Fixup old DLV locations in unbound.conf file via %%post
  355. - Fix parent child disagreement handling and no-ipv6 present [svn r1953]
  356. * Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
  357. - Updated to 1.4.1
  358. - Changed %%define to %%global
  359. * Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
  360. - Bump version
  361. * Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
  362. - Upgraded to 1.3.4. Security fix with validating NSEC3 records
  363. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
  364. - rebuilt with new openssl
  365. * Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
  366. - Updated to 1.3.3
  367. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
  368. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  369. * Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  370. - Added missing glob patch to cvs
  371. - Place python macros within the %%with_python check
  372. * Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  373. - Updated to 1.3.0
  374. - Added unbound-python sub package. disabled for now
  375. - Patch from svn to fix DLV lookups
  376. - Patches from svn to detect wrong truncated response from BIND 9.6.1 with
  377. minimal-responses)
  378. - Added Default-Start and Default-Stop to unbound.init
  379. - Re-enabled --enable-sha2
  380. - Re-enabled glob.patch
  381. * Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
  382. - unbound-iterator.patch was not commited
  383. * Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
  384. - Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
  385. * Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
  386. - Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
  387. * Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
  388. - enable DNSSEC only if it is enabled in sysconfig/dnssec
  389. * Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
  390. - add DNSSEC support to initscript and enabled it per default
  391. - add requires dnssec-conf
  392. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
  393. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  394. * Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
  395. - updated to 1.2.1
  396. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
  397. - rebuild with new openssl
  398. * Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
  399. - Updated to 1.2.0
  400. - Added dependancy on minimum SSL for CVE-2008-5077
  401. - Added dependancy on bc for unbound-munin
  402. - Added minimum requirement of libevent 1.4.5. Crashes with older versions
  403. (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
  404. - Removed dependancy on selinux-policy (will get used when available)
  405. - Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
  406. - Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
  407. - Enable val-clean-additional to drop addition unsigned data from signed
  408. response.
  409. - Removed patches (got merged into upstream)
  410. * Mon Jan 5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
  411. - Modified scandir patch to silently fail when wildcard matches nothing
  412. - Patch to allow unbound-checkconf to find empty wildcard matches
  413. * Mon Jan 5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
  414. - Added scandir patch for trusted-keys-file: option, which
  415. is used to load multiple dnssec keys in bind file format
  416. * Mon Dec 8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
  417. - Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
  418. * Mon Dec 1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
  419. - We did not own the /etc/unbound directory (#474020)
  420. - Fixed cvs anomalies
  421. * Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
  422. - removed all obsolete chroot related stuff
  423. - label control certs after generation correctly
  424. * Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
  425. - Updated to unbound 1.1.1 which fixes a crasher and
  426. addresses nlnetlabs bug #219
  427. * Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
  428. - Remove the chroot, obsoleted by SElinux
  429. - Add additional munin plugin links supported by unbound plugin
  430. - Move configuration directory from /var/lib/unbound to /etc/unbound
  431. - Modified unbound.init and unbound.conf to account for chroot changes
  432. - Updated unbound.conf with new available options
  433. - Enabled dns-0x20 protection per default
  434. * Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
  435. - unbound-1.1.0-log_open.patch
  436. - make sure log is opened before chroot call
  437. - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
  438. - removed /dev/log and /var/run/unbound and /etc/resolv.conf from
  439. chroot, not needed
  440. - don't mount files in chroot, it causes problems during updates
  441. - fixed typo in default config file
  442. * Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
  443. - Updated to version 1.1.0
  444. - Updated unbound.conf's statistics options and remote-control
  445. to work properly for munin
  446. - Added unbound-munin package
  447. - Generate unbound remote-control key/certs on first startup
  448. - Required ldns is now 1.4.0
  449. * Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
  450. - Only call ldconfig in -libs package
  451. - Move configure into build section
  452. - devel subpackage should only depend on libs subpackage
  453. * Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
  454. - Fix CFLAGS getting lost in build
  455. - Don't enable interface-automatic:yes because that
  456. causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
  457. * Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
  458. - Split off unbound-libs, make build verbose
  459. * Thu Oct 9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
  460. - FSB compliance, chroot fixes, initscript fixes
  461. * Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
  462. - Upgraded to 1.0.2
  463. * Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
  464. - upgraded to new release
  465. * Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
  466. - Build against ldns-1.3.0
  467. * Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
  468. - Split of -devel package, fixed dependancies, make rpmlint happy
  469. * Fri Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
  470. - Using parts from ports collection entry by Jaap Akkerhuis.
  471. - Using Fedoraproject wiki guidelines.
  472. * Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
  473. - Initial version.