strongswan-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773
  1. %bcond_with systemd
  2. %bcond_with fips2
  3. %bcond_without tss
  4. %global _unpackaged_files_terminate_build 1
  5. %global _hardened_build 0
  6. #%%define prerelease dr1
  7. Name: strongswan
  8. Version: 5.8.1
  9. Release: 1%{?_dist_release}
  10. Summary: An OpenSource IPsec-based VPN and TNC solution
  11. Summary(ja): オープンソースのIPsec VPN/TNCソリューション
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: tomop
  15. License: GPLv2+
  16. URL: http://www.strongswan.org/
  17. Source0: https://download.strongswan.org/%{name}-%{version}%{?prerelease}.tar.bz2
  18. Source1000: strongswan.init
  19. Patch1: strongswan-5.6.0-uintptr_t.patch
  20. Patch3: strongswan-5.6.2-CVE-2018-5388.patch
  21. # only needed for pre-release versions
  22. #BuildRequires: autoconf automake
  23. BuildRequires: gmp-devel
  24. BuildRequires: curl-devel
  25. BuildRequires: openldap-devel
  26. BuildRequires: openssl-devel
  27. BuildRequires: sqlite3-devel
  28. BuildRequires: gettext-devel
  29. BuildRequires: libxml2-devel
  30. BuildRequires: pam-devel
  31. BuildRequires: libgcrypt-devel
  32. BuildRequires: iptables-devel
  33. %if %{with tss}
  34. BuildRequires: trousers-devel
  35. BuildRequires: json-c-devel
  36. %endif
  37. %if "%{?_dist_release}" != "vl6"
  38. BuildRequires: NetworkManager-libnm-devel
  39. %endif
  40. %if %{with systemd}
  41. BuildRequires: systemd-devel
  42. Requires(post): systemd
  43. Requires(preun): systemd
  44. Requires(postun): systemd
  45. %else
  46. Requires(post): /sbin/chkconfig
  47. Requires(preun): /sbin/chkconfig
  48. Requires(postun): /sbin/chkconfig
  49. %endif
  50. %description
  51. The strongSwan IPsec implementation supports both the IKEv1 and IKEv2 key
  52. exchange protocols in conjunction with the native NETKEY IPsec stack of the
  53. Linux kernel.
  54. %package libipsec
  55. Summary: Strongswan's libipsec backend
  56. %description libipsec
  57. The kernel-libipsec plugin provides an IPsec backend that works entirely
  58. in userland, using TUN devices and its own IPsec implementation libipsec.
  59. %package charon-nm
  60. Summary: NetworkManager plugin for Strongswan
  61. Requires: dbus
  62. Obsoletes: %{name}-NetworkManager < 0:5.0.4-5
  63. Conflicts: %{name}-NetworkManger < 0:5.0.4-5
  64. %description charon-nm
  65. NetworkManager plugin integrates a subset of Strongswan capabilities
  66. to NetworkManager.
  67. %if %{with tss}
  68. %package tnc-imcvs
  69. Summary: Trusted network connect (TNC)'s IMC/IMV functionality
  70. Requires: %{name} = %{version}
  71. %description tnc-imcvs
  72. This package provides Trusted Network Connect's (TNC) architecture support.
  73. It includes support for TNC client and server (IF-TNCCS), IMC and IMV message
  74. exchange (IF-M), interface between IMC/IMV and TNC client/server (IF-IMC
  75. and IF-IMV). It also includes PTS based IMC/IMV for TPM based remote
  76. attestation, SWID IMC/IMV, and OS IMC/IMV. It's IMC/IMV dynamic libraries
  77. modules can be used by any third party TNC Client/Server implementation
  78. possessing a standard IF-IMC/IMV interface. In addition, it implements
  79. PT-TLS to support TNC over TLS.
  80. %endif
  81. %prep
  82. %setup -q -n %{name}-%{version}%{?prerelease}
  83. %patch1 -p1
  84. %patch3 -p1
  85. %build
  86. # only for snapshots
  87. #autoreconf
  88. # --with-ipsecdir moves internal commands to /usr/libexec/strongswan
  89. # --bindir moves 'pki' command to /usr/libexec/strongswan
  90. # See: http://wiki.strongswan.org/issues/552
  91. # too broken to enable: --enable-sha3 --enable-rdrand --enable-connmark --enable-forecast
  92. %configure --disable-static \
  93. --with-ipsec-script=strongswan \
  94. --sysconfdir=%{_sysconfdir}/strongswan \
  95. --with-ipsecdir=%{_libexecdir}/strongswan \
  96. --bindir=%{_libexecdir}/strongswan \
  97. --with-ipseclibdir=%{_libdir}/strongswan \
  98. %if %{with fips2}
  99. --with-fips-mode=2 \
  100. %endif
  101. %if "%{?_dist_release}" != "vl6"
  102. --enable-nm \
  103. %endif
  104. --enable-openssl \
  105. --enable-unity \
  106. --enable-ctr \
  107. --enable-ccm \
  108. --enable-gcm \
  109. --enable-chapoly \
  110. --enable-md4 \
  111. --enable-gcrypt \
  112. --enable-newhope \
  113. --enable-xauth-eap \
  114. --enable-xauth-pam \
  115. --enable-xauth-noauth \
  116. --enable-eap-identity \
  117. --enable-eap-md5 \
  118. --enable-eap-gtc \
  119. --enable-eap-tls \
  120. --enable-eap-ttls \
  121. --enable-eap-peap \
  122. --enable-eap-mschapv2 \
  123. --enable-eap-tnc \
  124. --enable-eap-sim \
  125. --enable-eap-sim-file \
  126. --enable-eap-aka \
  127. --enable-eap-aka-3gpp \
  128. --enable-eap-aka-3gpp2 \
  129. --enable-eap-dynamic \
  130. --enable-eap-radius \
  131. --enable-ext-auth \
  132. --enable-ipseckey \
  133. --enable-pkcs11 \
  134. --enable-farp \
  135. --enable-dhcp \
  136. --enable-ha \
  137. --enable-led \
  138. --enable-sqlite \
  139. --enable-tnc-ifmap \
  140. --enable-tnc-pdp \
  141. --enable-tnc-imc \
  142. --enable-tnc-imv \
  143. --enable-tnccs-20 \
  144. --enable-tnccs-11 \
  145. --enable-tnccs-dynamic \
  146. --enable-curl \
  147. --enable-cmd \
  148. --enable-acert \
  149. --enable-vici \
  150. --enable-swanctl \
  151. --enable-duplicheck \
  152. %if %{with tss}
  153. --enable-tss-trousers \
  154. --enable-aikgen \
  155. --enable-tpm \
  156. --enable-imc-test \
  157. --enable-imv-test \
  158. --enable-imc-scanner \
  159. --enable-imv-scanner \
  160. --enable-imc-attestation \
  161. --enable-imv-attestation \
  162. --enable-imv-os \
  163. --enable-imc-os \
  164. --enable-imc-swid \
  165. --enable-imv-swid \
  166. --enable-imc-swima \
  167. --enable-imv-swima \
  168. --enable-imc-hcd \
  169. --enable-imv-hcd \
  170. %endif
  171. %ifarch x86_64 %{ix86}
  172. --enable-aesni \
  173. %endif
  174. %if %{with systemd}
  175. --enable-systemd \
  176. %endif
  177. --enable-kernel-libipsec
  178. make %{?_smp_mflags}
  179. %install
  180. rm -rf %{buildroot}
  181. make install DESTDIR=%{buildroot}
  182. %if "%{?_dist_release}" != "vl6"
  183. mv %{buildroot}%{_sysconfdir}/strongswan/dbus-1 %{buildroot}%{_sysconfdir}/
  184. %endif
  185. # prefix man pages
  186. for i in %{buildroot}%{_mandir}/*/*; do
  187. if echo "$i" | grep -vq '/strongswan[^\/]*$'; then
  188. mv "$i" "`echo "$i" | sed -re 's|/([^/]+)$|/strongswan_\1|'`"
  189. fi
  190. done
  191. find %{buildroot} -type f -name '*.la' -delete
  192. # delete unwanted library files - no consumers, so no -devel package
  193. rm %{buildroot}%{_libdir}/strongswan/*.so
  194. # fix config permissions
  195. chmod 644 %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
  196. # Create ipsec.d directory tree.
  197. install -d -m 700 %{buildroot}%{_sysconfdir}/%{name}/ipsec.d
  198. for i in aacerts acerts certs cacerts crls ocspcerts private reqs; do
  199. install -d -m 700 %{buildroot}%{_sysconfdir}/%{name}/ipsec.d/${i}
  200. done
  201. %if ! %{with systemd}
  202. mkdir -p %{buildroot}%{_initdir}
  203. install -m755 %{SOURCE1000} %{buildroot}%{_initdir}/ipsec
  204. %endif
  205. %post
  206. %if %{with systemd}
  207. %systemd_post %{name}.service
  208. %else
  209. /sbin/chkconfig --add ipsec
  210. %endif
  211. %preun
  212. %if %{with systemd}
  213. %systemd_preun %{name}.service
  214. %else
  215. if [ $1 -eq 0 ]; then
  216. /sbin/service ipsec stop
  217. /sbin/chkconfig --del ipsec
  218. fi
  219. %endif
  220. %postun
  221. %if %{with systemd}
  222. %systemd_postun_with_restart %{name}.service
  223. %else
  224. if [ $1 -gt 0 ]; then
  225. /sbin/service ipsec condrestart
  226. fi
  227. %endif
  228. %files
  229. %doc README NEWS TODO ChangeLog
  230. %{!?_licensedir:%global license %%doc}
  231. %license COPYING
  232. %dir %attr(0700,root,root) %{_sysconfdir}/strongswan
  233. %config(noreplace) %{_sysconfdir}/strongswan/*
  234. %dir %{_libdir}/strongswan
  235. %dir %{_libdir}/strongswan/plugins
  236. %dir %{_libexecdir}/strongswan
  237. %{_sbindir}/charon-cmd
  238. %{_sbindir}/strongswan
  239. %{_sbindir}/swanctl
  240. %{_libdir}/strongswan/*.so.*
  241. %exclude %{_libdir}/strongswan/libipsec.so.*
  242. %{_libdir}/strongswan/plugins/*.so
  243. %exclude %{_libdir}/strongswan/plugins/libstrongswan-kernel-libipsec.so
  244. %{_libexecdir}/strongswan/*
  245. %if "%{?_dist_release}" != "vl6"
  246. %exclude %{_libexecdir}/strongswan/charon-nm
  247. %endif
  248. %{_mandir}/man?/*.gz
  249. %{_datadir}/strongswan/templates/config/
  250. %if %{with tss}
  251. %exclude %{_libdir}/strongswan/imcvs
  252. %exclude %{_libdir}/strongswan/libimcv.so.*
  253. %exclude %{_libdir}/strongswan/libtnccs.so.*
  254. %exclude %{_libdir}/strongswan/libradius.so.*
  255. %exclude %{_libdir}/strongswan/plugins/libstrongswan-pkcs7.so
  256. %exclude %{_libdir}/strongswan/plugins/libstrongswan-sqlite.so
  257. %exclude %{_libdir}/strongswan/plugins/libstrongswan-*tnc*.so
  258. %exclude %{_libdir}/strongswan/plugins/libstrongswan-eap-radius.so
  259. %exclude %{_libexecdir}/strongswan/attest
  260. %exclude %{_libexecdir}/strongswan/pt-tls-client
  261. %{_datadir}/strongswan/templates/database/
  262. %exclude %dir %{_datadir}/strongswan/swidtag
  263. %endif
  264. %if %{with systemd}
  265. %{_sbindir}/charon-systemd
  266. %{_unitdir}/strongswan.service
  267. %{_unitdir}/strongswan-swanctl.service
  268. %else
  269. %{_initdir}/ipsec
  270. %endif
  271. %if %{with tss}
  272. %files tnc-imcvs
  273. %{_sbindir}/sw-collector
  274. %{_sbindir}/sec-updater
  275. %dir %{_libdir}/strongswan/imcvs
  276. %dir %{_libdir}/strongswan/plugins
  277. %{_libdir}/strongswan/libimcv.so.*
  278. %{_libdir}/strongswan/libtnccs.so.*
  279. %{_libdir}/strongswan/libradius.so.*
  280. %{_libdir}/strongswan/plugins/libstrongswan-pkcs7.so
  281. %{_libdir}/strongswan/plugins/libstrongswan-sqlite.so
  282. %{_libdir}/strongswan/plugins/libstrongswan-*tnc*.so
  283. %{_libdir}/strongswan/plugins/libstrongswan-eap-radius.so
  284. %{_libexecdir}/strongswan/attest
  285. %{_libexecdir}/strongswan/pt-tls-client
  286. %dir %{_datadir}/strongswan/swidtag
  287. %{_datadir}/strongswan/swidtag/*.swidtag
  288. %endif
  289. %files libipsec
  290. %{_libdir}/strongswan/libipsec.so.*
  291. %{_libdir}/strongswan/plugins/libstrongswan-kernel-libipsec.so
  292. %if "%{?_dist_release}" != "vl6"
  293. %files charon-nm
  294. %doc COPYING
  295. %{_sysconfdir}/dbus-1/system.d/nm-strongswan-service.conf
  296. %{_libexecdir}/strongswan/charon-nm
  297. %endif
  298. %changelog
  299. * Wed Nov 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.1-1
  300. - new upstream release.
  301. * Tue Jan 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.7.2-1
  302. - new upstream release.
  303. * Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.7.1-1
  304. - new upstream release.
  305. - imported Patch3 from rawhide.
  306. * Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.2-2
  307. - initial build for Vine Linux.
  308. * Wed Feb 21 2018 Lubomir Rintel <lkundrak@v3.sk> - 5.6.2-1
  309. - Updated to 5.6.2 (Dropped libnm-glib use in charon-nm)
  310. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.1-2
  311. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  312. * Fri Dec 22 2017 Paul Wouters <pwouters@redhat.com> - 5.6.1-1
  313. - Updated to 5.6.1 (RSA-PSS support)
  314. * Sun Dec 10 2017 Björn Esser <besser82@fedoraproject.org> - 5.6.0-3
  315. - Rebuilt for libjson-c.so.3
  316. * Fri Dec 01 2017 Lubomir Rintel <lkundrak@v3.sk> - 5.6.0-2
  317. - Fix the placement of charon-nm D-Bus policy
  318. * Sat Sep 09 2017 Paul Wouters <pwouters@redhat.com> - 5.6.0-1
  319. - Updated to 5.6.0
  320. - Fixup configure arguments, enabled a bunch of new features
  321. - Added new BuildRequires:
  322. - Fixup Obsolete/Conflicts, use license macro
  323. - Don't require autoconf/autotools for non-snapshots
  324. - Remove macro overuse, remove fedora/rhel checks and sysvinit support
  325. - Make listings/grouping of all plugins/libs to reduce file listing
  326. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.3-3
  327. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  328. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.3-2
  329. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  330. * Mon Jun 12 2017 Paul Wouters <pwouters@redhat.com> - 5.5.3-1
  331. - Updated to 5.5.3
  332. * Sat May 27 2017 Paul Wouters <pwouters@redhat.com> - 5.5.2-1
  333. - Updated to 5.5.2
  334. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.0-3
  335. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  336. * Thu Sep 15 2016 Pavel Šimerda <psimerda@redhat.com> - 5.5.0-2
  337. - Resolves: #1367796 - Enable the unity plugin
  338. * Mon Aug 08 2016 Pavel Šimerda <psimerda@redhat.com> - 5.5.0-1
  339. - New version 5.5.0
  340. * Wed Jun 22 2016 Pavel Šimerda <psimerda@redhat.com>
  341. - Enable IKEv2 GCM (requires gcrypt module as well) - merged from f22 by Paul Wouters
  342. * Wed Jun 22 2016 Pavel Šimerda <psimerda@redhat.com> - 5.4.0-1
  343. - New version 5.4.0
  344. * Thu Mar 03 2016 Pavel Šimerda <psimerda@redhat.com> - 5.3.5-1
  345. - New version 5.3.5
  346. * Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.3.3-3
  347. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  348. * Fri Jan 15 2016 Paul Wouters <pwouters@redhat.com> - 5.3.3-2
  349. - Enable IKEv2 GCM (requires gcrypt module as well)
  350. * Tue Sep 29 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.3-1
  351. - new version 5.3.3
  352. * Thu Sep 24 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.2-3
  353. - Resolves: #1264598 - strongswan: many configuration files are not protected
  354. * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.2-2
  355. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  356. * Tue Jun 09 2015 Pavel Šimerda <psimerda@redhat.com>
  357. - new version 5.3.2
  358. * Fri Jun 05 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.1-1
  359. - new version 5.3.1
  360. * Tue Mar 31 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.0-1
  361. - new version 5.3.0
  362. * Fri Feb 20 2015 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-2
  363. - Fixes strongswan swanctl service issue rhbz#1193106
  364. * Tue Jan 06 2015 Pavel Šimerda <psimerda@redhat.com> - 5.2.2-1
  365. - new version 5.2.2
  366. * Thu Dec 18 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-0.2.dr1
  367. - Enabled ccm, and ctr plugins as it seems enabling just openssl does
  368. not work for using ccm and ctr algos.
  369. * Mon Dec 8 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-0.1.dr1
  370. - New strongswan developer release 5.2.2dr1
  371. * Mon Nov 24 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-2
  372. - 1167331: Enabled native systemd support.
  373. - Does not disable old systemd, starter, ipsec.conf support yet.
  374. * Thu Oct 30 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-1
  375. - New upstream release 5.2.1
  376. * Thu Oct 16 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-0.2.rc1
  377. - New upstream release candidate 5.2.1rc1
  378. * Fri Oct 10 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.1-1
  379. - new version 5.2.1dr1
  380. * Thu Sep 25 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-7
  381. - use upstream patch for json/json-c dependency
  382. * Thu Sep 25 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-6
  383. - Resolves: #1146145 - Strongswan is compiled without xauth-noauth plugin
  384. * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.0-5
  385. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  386. * Tue Aug 05 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-4
  387. - Resolves: #1081804 - enable Kernel IPSec support
  388. * Wed Jul 30 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-3
  389. - rebuilt
  390. * Tue Jul 29 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-2
  391. - fix json-c dependency
  392. * Tue Jul 15 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.0-1
  393. - New upstream release 5.2.0
  394. - The Attestation IMC/IMV pair supports the IMA-NG
  395. measurement format
  396. - Aikgen tool to generate an Attestation Identity Key bound
  397. to a TPM
  398. - Swanctl tool to provide a portable, complete IKE
  399. configuration and control interface for the command
  400. line using vici interface with libvici library
  401. - PT-EAP transport protocol (RFC 7171) for TNC
  402. - Enabled support for acert for checking X509 attribute certificate
  403. - Updated patches, removed selinux patch as upstream has fixed it
  404. in this release.
  405. - Updated spec file with minor cleanups
  406. * Thu Jun 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.4.dr6
  407. - improve prerelease macro
  408. * Thu Jun 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.3
  409. - Resolves: #1111895 - bump to 5.2.0dr6
  410. * Thu Jun 12 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.2
  411. - Related: #1087437 - remove or upstream all patches not specific to fedora/epel
  412. * Thu Jun 12 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.1.dr5
  413. - fix the pre-release version according to guidelines before it gets branched
  414. * Fri Jun 06 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr5-1
  415. - new version 5.2.0dr5
  416. - add json-c-devel to build deps
  417. * Mon May 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr4-3
  418. - merge two related patches
  419. * Mon May 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr4-2
  420. - clean up the patches a bit
  421. * Thu May 22 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.0dr4-1
  422. - New upstream developer release 5.2.0dr4
  423. - Attestation IMV/IMC supports IMA-NG measurement format now
  424. - Aikgen tool to generate an Attestation Identity Key bound
  425. to a TPM
  426. - PT-EAP transport protocol (RFC 7171) for TNC
  427. - vici plugin provides IKE Configuration Interface for charon
  428. - Enabled support for acert for checking X509 attribute certificate
  429. - Updated patches
  430. - Updated spec file with minor cleanups
  431. * Tue Apr 15 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.3-1
  432. - new version 5.1.3
  433. * Mon Apr 14 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.3rc1-1
  434. - new version 5.1.3rc1
  435. * Mon Mar 24 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-4
  436. - #1069928 - updated libexec patch.
  437. * Tue Mar 18 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-3
  438. - fixed el6 initscript
  439. - fixed pki directory location
  440. * Fri Mar 14 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-2
  441. - clean up the specfile a bit
  442. - replace the initscript patch with an individual initscript
  443. - patch to build for epel6
  444. * Mon Mar 03 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-1
  445. - #1071353 - bump to 5.1.2
  446. - #1071338 - strongswan is compiled without xauth-pam plugin
  447. - remove obsolete patches
  448. - sent all patches upstream
  449. - added comments to all patches
  450. - don't touch the config with sed
  451. * Thu Feb 20 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-6
  452. - Fixed full hardening for strongswan (full relro and PIE).
  453. The previous macros had a typo and did not work
  454. (see bz#1067119).
  455. - Fixed tnc package description to reflect the current state of
  456. the package.
  457. - Fixed pki binary and moved it to /usr/libexece/strongswan as
  458. others binaries are there too.
  459. * Wed Feb 19 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-5
  460. - #903638 - SELinux is preventing /usr/sbin/xtables-multi from 'read' accesses on the chr_file /dev/random
  461. * Thu Jan 09 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-4
  462. - Removed redundant patches and *.spec commands caused by branch merging
  463. * Wed Jan 08 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-3
  464. - rebuilt
  465. * Mon Dec 2 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-2
  466. - Resolves: 973315
  467. - Resolves: 1036844
  468. * Fri Nov 1 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-1
  469. - Support for PT-TLS (RFC 6876)
  470. - Support for SWID IMC/IMV
  471. - Support for command line IKE client charon-cmd
  472. - Changed location of pki to /usr/bin
  473. - Added swid tags files
  474. - Added man pages for pki and charon-cmd
  475. - Renamed pki to strongswan-pki to avoid conflict with
  476. pki-core/pki-tools package.
  477. - Update local patches
  478. - Fixes CVE-2013-6075
  479. - Fixes CVE-2013-6076
  480. - Fixed autoconf/automake issue as configure.ac got changed
  481. and it required running autoreconf during the build process.
  482. - added strongswan signature file to the sources.
  483. * Thu Sep 12 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-3
  484. - Fixed initialization crash of IMV and IMC particularly
  485. attestation imv/imc as libstrongswas was not getting
  486. initialized.
  487. * Fri Aug 30 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-2
  488. - Enabled fips support
  489. - Enabled TNC's ifmap support
  490. - Enabled TNC's pdp support
  491. - Fixed hardocded package name in this spec file
  492. * Wed Aug 7 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-1
  493. - rhbz#981429: New upstream release
  494. - Fixes CVE-2013-5018: rhbz#991216, rhbz#991215
  495. - Fixes rhbz#991859 failed to build in rawhide
  496. - Updated local patches and removed which are not needed
  497. - Fixed errors around charon-nm
  498. - Added plugins libstrongswan-pkcs12.so, libstrongswan-rc2.so,
  499. libstrongswan-sshkey.so
  500. - Added utility imv_policy_manager
  501. * Thu Jul 25 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 5.0.4-5
  502. - rename strongswan-NetworkManager to strongswan-charon-nm
  503. - fix enable_nm macro
  504. * Mon Jul 15 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 5.0.4-4
  505. - %%files tries to package some of the shared objects as directories (#984437)
  506. - fix broken systemd unit file (#984300)
  507. - fix rpmlint error: description-line-too-long
  508. - fix rpmlint error: macro-in-comment
  509. - fix rpmlint error: spelling-error Summary(en_US) fuctionality
  510. - depend on 'systemd' instead of 'systemd-units'
  511. - use new systemd scriptlet macros
  512. - NetworkManager subpackage should have a copy of the license (#984490)
  513. - enable hardened_build as this package meets the PIE criteria (#984429)
  514. - invocation of "ipsec _updown iptables" is broken as ipsec is renamed
  515. to strongswan in this package (#948306)
  516. - invocation of "ipsec scepclient" is broken as ipsec is renamed
  517. to strongswan in this package
  518. - add /etc/strongswan/ipsec.d and missing subdirectories
  519. - conditionalize building of strongswan-NetworkManager subpackage as the
  520. version of NetworkManager in EL6 is too old (#984497)
  521. * Fri Jun 28 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-3
  522. - Patch to fix a major crash issue when Freeradius loads
  523. attestatiom-imv and does not initialize libstrongswan which
  524. causes crash due to calls to PTS algorithms probing APIs.
  525. So this patch fixes the order of initialization. This issues
  526. does not occur with charon because libstrongswan gets
  527. initialized earlier.
  528. - Patch that allows to outputs errors when there are permission
  529. issues when accessing strongswan.conf.
  530. - Patch to make loading of modules configurable when libimcv
  531. is used in stand alone mode without charon with freeradius
  532. and wpa_supplicant.
  533. * Tue Jun 11 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-2
  534. - Enabled TNCCS 1.1 protocol
  535. - Fixed libxm2-devel build dependency
  536. - Patch to fix the issue with loading of plugins
  537. * Wed May 1 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-1
  538. - New upstream release
  539. - Fixes for CVE-2013-2944
  540. - Enabled support for OS IMV/IMC
  541. - Created and applied a patch to disable ECP in fedora, because
  542. Openssl in Fedora does not allow ECP_256 and ECP_384. It makes
  543. it non-compliant to TCG's PTS standard, but there is no choice
  544. right now. see redhat bz # 319901.
  545. - Enabled Trousers support for TPM based operations.
  546. * Sat Apr 20 2013 Pavel Šimerda <psimerda@redhat.com> - 5.0.3-2
  547. - Rebuilt for a single specfile for rawhide/f19/f18/el6
  548. * Fri Apr 19 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.3-1
  549. - New upstream release
  550. - Enabled curl and eap-identity plugins
  551. - Enabled support for eap-radius plugin.
  552. * Thu Apr 18 2013 Pavel Šimerda <psimerda@redhat.com> - 5.0.2-3
  553. - Add gettext-devel to BuildRequires because of epel6
  554. - Remove unnecessary comments
  555. * Tue Mar 19 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.2-2
  556. - Enabled support for eap-radius plugin.
  557. * Mon Mar 11 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.2-1
  558. - Update to upstream release 5.0.2
  559. - Created sub package strongswan-tnc-imcvs that provides trusted network
  560. connect's IMC and IMV funtionality. Specifically it includes PTS
  561. based IMC/IMV for TPM based remote attestation and scanner and test
  562. IMCs and IMVs. The Strongswan's IMC/IMV dynamic libraries can be used
  563. by any third party TNC Client/Server implementation possessing a
  564. standard IF-IMC/IMV interface.
  565. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.1-2
  566. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  567. * Thu Oct 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.1-1
  568. - Update to release 5.0.1
  569. * Thu Oct 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-4.git20120619
  570. - Add plugins to interoperate with Windows 7 and Android (#862472)
  571. (contributed by Haim Gelfenbeyn)
  572. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.0-3.git20120619
  573. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  574. * Sun Jul 08 2012 Pavel Šimerda <pavlix@pavlix.net> - 5.0.0-2.git20120619
  575. - Fix configure substitutions in initscripts
  576. * Wed Jul 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-1.git20120619
  577. - Update to current upstream release
  578. - Comment out all stuff that is only needed for git builds
  579. - Remove renaming patch from git
  580. - Improve init patch used for EPEL
  581. * Thu Jun 21 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-0.3.git20120619
  582. - Build with openssl plugin enabled
  583. * Wed Jun 20 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-0.2.git20120619
  584. - Add README.Fedora with link to 4.6 to 5.0 migration information
  585. * Tue Jun 19 2012 Pavel Šimerda - 5.0.0-0.1.git20120619
  586. - Snapshot of upcoming major release
  587. - Move patches and renaming upstream
  588. http://wiki.strongswan.org/issues/194
  589. http://wiki.strongswan.org/issues/195
  590. - Notified upstream about manpage issues
  591. * Tue Jun 19 2012 Pavel Šimerda - 4.6.4-2
  592. - Make initscript patch more distro-neutral
  593. - Add links to bugreports for patches
  594. * Fri Jun 01 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.4-1
  595. - New upstream version (CVE-2012-2388)
  596. * Sat May 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.3-2
  597. - Add --enable-nm to configure
  598. - Add NetworkManager-devel to BuildRequires
  599. - Add NetworkManager-glib-devel to BuildRequires
  600. - Add strongswan-NetworkManager package
  601. * Sat May 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.3-1
  602. - New version of Strongswan
  603. - Support for RFC 3110 DNSKEY (see upstream changelog)
  604. - Fix corrupt scriptlets
  605. * Fri Mar 30 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.2-2
  606. - #808612 - strongswan binary renaming side-effect
  607. * Sun Feb 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.2-1
  608. - New upstream version
  609. - Changed from .tar.gz to .tar.bz2
  610. - Added libstrongswan-pkcs8.so
  611. * Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-8
  612. - Fix initscript's status function
  613. * Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-7
  614. - Expand tabs in config files for better readability
  615. - Add sysvinit script for epel6
  616. * Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-6
  617. - Fix program name in systemd unit file
  618. * Tue Feb 14 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-5
  619. - Improve fedora/epel conditionals
  620. * Sat Jan 21 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-4
  621. - Protect configuration directory from ordinary users
  622. - Add still missing directory /etc/strongswan
  623. * Fri Jan 20 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-3
  624. - Change directory structure to avoid clashes with Openswan
  625. - Prefixed all manpages with 'strongswan_'
  626. - Every file now includes 'strongswan' somewhere in its path
  627. - Removed conflict with Openswan
  628. - Finally fix permissions on strongswan.conf
  629. * Fri Jan 20 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-2
  630. - Change license tag from GPL to GPLv2+
  631. - Change permissions on /etc/strongswan.conf to 644
  632. - Rename ipsec.8 manpage to strongswan.8
  633. - Fix empty scriptlets for non-fedora builds
  634. - Add ldconfig scriptlet
  635. - Add missing directories and files
  636. * Sun Jan 01 2012 Pavel Šimerda <pavlix@pavlix.net - 4.6.1-1
  637. - Bump to version 4.6.1
  638. * Sun Jan 01 2012 Pavel Šimerda <pavlix@pavlix.net - 4.6.0-3
  639. - Add systemd scriptlets
  640. - Add conditions to also support EPEL6
  641. * Sat Dec 10 2011 Pavel Šimerda <pavlix@pavlix.net> - 4.6.0-2
  642. - Experimental build for development