nsd-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343
  1. Summary: Fast and lean authoritative DNS Name Server
  2. Summary(ja): 高速で最小限のAuthoritative専用DNSネームサーバ
  3. Name: nsd
  4. Version: 4.2.4
  5. Release: 1%{?_dist_release}
  6. License: BSD
  7. Url: http://www.nlnetlabs.nl/%{name}/
  8. Source: http://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
  9. Source1: nsd.init
  10. Source3: nsd.sysconfig
  11. Patch0: nsd-4.1.10-config.patch
  12. Group: System Environment/Daemons
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. BuildRequires: flex, libevent-devel, openssl-devel
  17. Requires(pre): shadow-utils
  18. %description
  19. NSD is a complete implementation of an authoritative DNS name server.
  20. For further information about what NSD is and what NSD is not please
  21. consult the REQUIREMENTS document which is a part of this distribution
  22. %description -l ja
  23. NSD は Authoritative DNSネームサーバの完全な実装です。
  24. NSD に関する詳しい情報は REQUIREMENTS ドキュメントを参照してください。
  25. %prep
  26. %setup -q
  27. %patch0 -p1
  28. %build
  29. %configure \
  30. --with-configdir=%{_sysconfdir}/nsd \
  31. --with-nsd_conf_file=%{_sysconfdir}/nsd/nsd.conf \
  32. --with-zonesdir=%{_sysconfdir}/nsd \
  33. --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
  34. --with-dbfile=%{_localstatedir}/lib/%{name}/nsd.db \
  35. --with-difffile=%{_localstatedir}/lib/%{name}/ixfr.db \
  36. --with-xfrdfile=%{_localstatedir}/lib/%{name}/ixfr.state \
  37. --with-max-ips=1024 \
  38. --with-ssl \
  39. --with-user=nsd \
  40. --enable-bind8-stats \
  41. --enable-checking \
  42. --enable-mmap \
  43. --enable-nsec3 \
  44. --enable-ratelimit
  45. %{__make} %{?_smp_mflags}
  46. #convert to utf8
  47. iconv -f iso8859-1 -t utf-8 doc/RELNOTES > doc/RELNOTES.utf8
  48. iconv -f iso8859-1 -t utf-8 doc/CREDITS > doc/CREDITS.utf8
  49. mv -f doc/RELNOTES.utf8 doc/RELNOTES
  50. mv -f doc/CREDITS.utf8 doc/CREDITS
  51. %install
  52. rm -rf %{buildroot}
  53. %{__make} DESTDIR=%{buildroot} install
  54. install -d -m 0755 %{buildroot}%{_initrddir}
  55. install -m 0755 %{SOURCE1} %{buildroot}/%{_initrddir}/nsd
  56. install -d -m 0700 %{buildroot}%{_localstatedir}/run/%{name}
  57. install -d -m 0700 %{buildroot}%{_localstatedir}/lib/%{name}
  58. install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
  59. install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
  60. # change .sample to normal config files
  61. mv %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample %{buildroot}%{_sysconfdir}/nsd/nsd.conf
  62. %clean
  63. rm -rf ${RPM_BUILD_ROOT}
  64. %files
  65. %defattr(-,root,root,-)
  66. %doc doc/*
  67. %doc contrib/nsd.zones2nsd.conf
  68. %dir %{_sysconfdir}/nsd/
  69. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.conf
  70. #%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.zones
  71. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/nsd
  72. %attr(0755,root,root) %{_initrddir}/%{name}
  73. %ghost %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
  74. %attr(0755,%{name},%{name}) %dir %{_localstatedir}/lib/%{name}
  75. %{_sbindir}/*
  76. %{_mandir}/*/*
  77. %pre
  78. getent group nsd >/dev/null || groupadd -r nsd
  79. getent passwd nsd >/dev/null || \
  80. useradd -r -g nsd -d /etc/nsd -s /sbin/nologin \
  81. -c "nsd daemon account" nsd
  82. exit 0
  83. %post
  84. /sbin/chkconfig --add %{name}
  85. chown -R nsd.nsd %{_localstatedir}/lib/nsd 2>/dev/null ||:
  86. chown -R nsd.nsd %{_localstatedir}/run/nsd 2>/dev/null ||:
  87. if [ ! -f %{_sysconfdir}/nsd/nsd_control.pem ]; then
  88. /usr/sbin/nsd-control-setup
  89. fi
  90. %preun
  91. if [ $1 -eq 0 ]; then
  92. /sbin/service %{name} stop
  93. /sbin/chkconfig --del %{name}
  94. fi
  95. %postun
  96. if [ "$1" -ge "1" ]; then
  97. /sbin/service %{name} condrestart
  98. fi
  99. %changelog
  100. * Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.4-1
  101. - new upstream release.
  102. * Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.2-1
  103. - new upstream release.
  104. * Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.25-1
  105. - new upstream release.
  106. - rebuilt with openssl-1.1.1 and libevent-2.1.8.
  107. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.19-1
  108. - new upstream release.
  109. * Wed Mar 8 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.15-1
  110. - new upstream release.
  111. * Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.10-1
  112. - new upstream release.
  113. * Wed Mar 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.9-1
  114. - new upstream release.
  115. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-2
  116. - rebuilt with openssl-1.0.2g.
  117. * Sat Mar 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-1
  118. - new upstream release.
  119. * Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.7-1
  120. - new upstream release.
  121. * Tue Nov 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.6-1
  122. - new upstream release.
  123. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.3-1
  124. - new upstream release.
  125. - dropped Source2 (no longer needed).
  126. * Sat Feb 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.15-1
  127. - new upstream release
  128. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.12-1
  129. - new upstream release
  130. * Wed Feb 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.10-1
  131. - new upstream release
  132. * Fri Mar 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
  133. - new upstream release
  134. * Sat May 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
  135. - initial build for Vine Linux
  136. * Wed Jan 06 2010 Paul Wouters <paul@xelerance.com> - 3.2.4-1
  137. - Updated to nsd 3.2.4
  138. * Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 3.2.3-4
  139. - Incorporated Ville Mattila's fixes to nsd.cron
  140. - Support for NSD_AUTOREBUILD in /etc/sysconfig/nsd [Ville]
  141. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.3-3
  142. - rebuilt with new openssl
  143. * Thu Aug 20 2009 Ville Mattila <vmattila@csc.fi> - 3.2.3-2
  144. - The 'nsdc patch' and 'nsdc rebuild' commands wrote a %%1 file by mistake
  145. * Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 3.2.3-1
  146. -Updated to version 3.2.3
  147. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-4
  148. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  149. * Sat Jun 06 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-3
  150. - Fixed /dev/nul which cause a file \%%1 to be written by cron
  151. - Bump for EVR.
  152. * Mon May 18 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-1
  153. - Upgraded to 3.2.2 security release
  154. http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html
  155. * Thu Apr 09 2009 Ville Mattila <vmattila@csc.fi> - 3.2.1-6
  156. - Make various file paths used by the nsd.init script configurable
  157. from /etc/sysconfig/nsd.
  158. - Add template /etc/sysconfig/nsd.
  159. * Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-5
  160. - nsd used the 'named' subsystem in one call in the init script
  161. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-4
  162. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  163. * Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-3
  164. - Fix init script 'unary operator' error.
  165. * Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-1
  166. - Updated to new version 3.2.1
  167. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.0-4
  168. - rebuild with new openssl
  169. * Mon Nov 24 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-3
  170. - Updates summary as per Richard Hughes guidelines
  171. * Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-2
  172. - Bump version after pre-release version correction.
  173. * Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-1
  174. - 3.2.0-1
  175. * Thu Oct 9 2008 Paul Wouters <paul@xelerance.com> - 3.1.1-1
  176. - updated to 3.1.1
  177. * Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.0-2
  178. - fix license tag
  179. - fix static user creation
  180. * Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 3.1.0-1
  181. - Updated to 3.1.0
  182. * Tue May 6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-2
  183. - Fix /dev/null redirection [Venkatesh Krishnamurthi]
  184. * Tue May 6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-1
  185. - Updated to 3.0.8
  186. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.7-3
  187. - Autorebuild for GCC 4.3
  188. * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-2
  189. - Rebuild for new libcrypto
  190. * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-1
  191. - Updated to new version
  192. - fix RELNOTES/README to be utf8
  193. - Fix path to nsd.db in cron job.
  194. * Thu Nov 8 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-7
  195. - Modified cron to only rebuild/reload when zone updates
  196. have been received
  197. * Wed Nov 7 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-6
  198. - Added hourly cron job to do various maintenance tasks
  199. - Added nsd rebuild to create the proper nsd.db file on startup
  200. - Added nsd patch on shutdown to ensure zonefiles are up to date
  201. * Tue Oct 2 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-5
  202. - nsdc update and nsdc notify are no longer needed in initscript.
  203. * Mon Sep 24 2007 Jesse Keating <jkeating@redhat.com> - 3.0.6-4
  204. - Bump release for upgrade path.
  205. * Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-3
  206. - Do not include examples from nsd.conf.sample that causes
  207. bogus network traffic.
  208. * Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-2
  209. - Change locations of ixfr.db and xfrd.state to /var/lib/nsd
  210. - Enable NSEC3
  211. - Delay running nsdc update until after nsd has started
  212. - Delete xfrd.state on nsd stop
  213. - Run nsdc notify in the background, since it can take
  214. a very long time when remote servers are unavailable.
  215. * Tue Sep 11 2007 Paul Wouters <paul@xelerance.com> 3.0.6-1
  216. - Upgraded to 3.0.6
  217. - Do not include bind2nsd, since it didn't compile for me
  218. * Fri Jul 13 2007 Paul Wouters <paul@xelerance.com> 3.0.5-2
  219. - Fix init script, bug #245546
  220. * Fri Mar 23 2007 Paul Wouters <paul@xelerance.com> 3.0.5-1
  221. - Upgraded to 3.0.5
  222. * Thu Dec 7 2006 Paul Wouters <paul@xelerance.com> 3.0.3-1
  223. - Upgraded to 3.0.3
  224. * Mon Nov 27 2006 Paul Wouters <paul@xelerance.com> 3.0.2-1
  225. - Upgraded to 3.0.2.
  226. - Use new configuration file nsd.conf. Still needs migration script.
  227. patch from Farkas Levente <lfarkas@bppiac.hu>
  228. * Mon Oct 16 2006 Paul Wouters <paul@xelerance.com> 2.3.6-2
  229. - Bump version for upgrade path
  230. * Thu Oct 12 2006 Paul Wouters <paul@xelerance.com> 2.3.6-1
  231. - Upgraded to 2.3.6
  232. - Removed obsolete workaround in nsd.init
  233. - Fixed spec file so daemon gets properly restarted on upgrade
  234. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 2.3.5-4
  235. - Rebuild requested for PT_GNU_HASH support from gcc
  236. - Removed dbaccess.c from doc section
  237. * Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-3
  238. - Bump version for FC-x upgrade path
  239. * Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-1
  240. - Upgraded to nsd-2.3.5
  241. * Sun May 7 2006 Paul Wouters <paul@xelerance.com> - 2.3.4-3
  242. - Upgraded to nsd-2.3.4.
  243. - Removed manual install targets because DESTDIR is now supported
  244. - Re-enabled --checking, checking patch no longer needed and removed.
  245. - Work around in nsd.init for nsd failing to start when there is no ipv6
  246. * Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-7
  247. - chkconfig and attribute changes as proposed by Dmitry Butskoy
  248. * Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-6
  249. - Moved pid file to /var/run/nsd/nsd.pid.
  250. - Use _localstatedir instead of "/var"
  251. * Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-5
  252. - Added BuildRequires for openssl-devel, removed Requires for openssl.
  253. * Mon Dec 12 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-4
  254. - upgraded to nsd-2.3.3
  255. * Wed Dec 7 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.3.2-2
  256. - minor cleanups
  257. * Mon Dec 5 2005 Paul Wouters <paul@xelerance.com> - 2.3.2-1
  258. - Upgraded to 2.3.2. Changed post scripts to comply to Fedora
  259. Extras policies (eg do not start daemon on fresh install)
  260. * Tue Oct 4 2005 Paul Wouters <paul@xelerance.com> - 2.3.1-1
  261. - Initial version