iputils-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347
  1. Summary: Network monitoring tools including ping.
  2. Summary(ja): ping 等のネットワークモニタツール集
  3. Name: iputils
  4. Version: 20190709
  5. Release: 2%{?_dist_release}
  6. # some parts are under the original BSD (ping.c)
  7. # some are under GPLv2+ (tracepath.c)
  8. License: BSD and GPLv2+
  9. Group: System Environment/Daemons
  10. URL: https://github.com/iputils/iputils
  11. Source0: https://github.com/iputils/iputils/archive/s%{version}.tar.gz#/%{name}-s%{version}.tar.gz
  12. Source1: ifenslave.tar.gz
  13. Source3: rdisc.initd
  14. Source5: rdisc.sysconfig
  15. Source6: ninfod.initd
  16. Source7: ninfod.sysconfig
  17. Source10: bsd.txt
  18. Source11: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
  19. Patch1: iputils-ifenslave.patch
  20. Patch2: iputils-fix-arping.patch
  21. # Vine Source(s)/Patch(es)
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: docbook-utils perl-SGMLSpm
  24. BuildRequires: glibc-kernheaders >= 2.4-8.19
  25. BuildRequires: libidn2-devel
  26. BuildRequires: openssl-devel
  27. BuildRequires: libcap-devel
  28. BuildRequires: libxslt
  29. BuildRequires: docbook5-style-xsl
  30. BuildRequires: meson
  31. Requires(post): chkconfig
  32. Requires(preun): chkconfig
  33. Requires(preun): initscripts
  34. Requires(postun): initscripts
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. %description
  38. The iputils package contains basic utilities for monitoring a network,
  39. including ping. The ping command sends a series of ICMP protocol
  40. ECHO_REQUEST packets to a specified network host to discover whether
  41. the target machine is alive and receiving network traffic.
  42. %prep
  43. %setup -q -a 1 -n %{name}-s%{version}
  44. cp %{SOURCE10} %{SOURCE11} .
  45. %patch1 -p1
  46. %patch2 -p1
  47. %build
  48. %ifarch s390 s390x
  49. export CFLAGS="$RPM_OPT_FLAGS -fPIE"
  50. %else
  51. export CFLAGS="$RPM_OPT_FLAGS -fpie"
  52. %endif
  53. export LDFLAGS="-pie -Wl,-z,relro,-z,now"
  54. %meson
  55. %meson_build
  56. %ninja_build -C %{_target_platform} iputils-gmo
  57. gcc -Wall $RPM_OPT_FLAGS $CFLAGS $LDFLAGS ifenslave.c -o ifenslave
  58. %install
  59. rm -rf ${RPM_BUILD_ROOT}
  60. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  61. mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
  62. mkdir -p ${RPM_BUILD_ROOT}/{bin,sbin}
  63. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  64. pushd %{_target_platform}
  65. install -c clockdiff ${RPM_BUILD_ROOT}%{_sbindir}/
  66. install -cp arping ${RPM_BUILD_ROOT}/sbin/
  67. ln -s /sbin/arping ${RPM_BUILD_ROOT}%{_sbindir}/arping
  68. install -cp ping ${RPM_BUILD_ROOT}/bin/
  69. install -cp ../ifenslave ${RPM_BUILD_ROOT}/sbin/
  70. install -cp rdisc ${RPM_BUILD_ROOT}/sbin/
  71. install -cp tracepath ${RPM_BUILD_ROOT}/bin/
  72. install -cp ninfod/ninfod ${RPM_BUILD_ROOT}/sbin/
  73. ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}
  74. ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}/ping6
  75. ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
  76. ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}/tracepath6
  77. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
  78. install -cp doc/clockdiff.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  79. install -cp doc/arping.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  80. install -cp doc/ping.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  81. install -cp doc/rdisc.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  82. install -cp doc/tracepath.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  83. install -cp doc/ninfod.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  84. install -cp ../ifenslave.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  85. ln -s ping.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/ping6.8.gz
  86. ln -s tracepath.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/tracepath6.8.gz
  87. install -dp ${RPM_BUILD_ROOT}%{_datadir}/locale/ja/LC_MESSAGES
  88. install -m 644 po/ja.gmo $RPM_BUILD_ROOT%{_datadir}/locale/ja/LC_MESSAGES/iputils.mo
  89. popd
  90. find ${RPM_BUILD_ROOT}%{_mandir} -type f | xargs chmod 644
  91. install -dp ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
  92. install -m 755 -p %{SOURCE3} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/rdisc
  93. install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rdisc
  94. install -m 755 -p %{SOURCE6} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/ninfod
  95. install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ninfod
  96. %find_lang %{name}
  97. %post
  98. /sbin/chkconfig --add rdisc
  99. /sbin/chkconfig --add ninfod
  100. %preun
  101. if [ $1 = 0 ]; then
  102. service rdisc stop >/dev/null 2>&1
  103. service ninfod stop >/dev/null 2>&1
  104. /sbin/chkconfig --del rdisc
  105. /sbin/chkconfig --del ninfod
  106. fi
  107. %postun
  108. if [ "$1" -ge "1" ]; then
  109. service rdisc condrestart >/dev/null 2>&1 || :
  110. service ninfod condrestart >/dev/null 2>&1 || :
  111. fi
  112. %clean
  113. rm -rf ${RPM_BUILD_ROOT}
  114. %files -f %{name}.lang
  115. %defattr(-,root,root)
  116. %license LICENSE*
  117. %doc README.*
  118. %{_sbindir}/clockdiff
  119. /sbin/arping
  120. %{_sbindir}/arping
  121. %attr(4755,root,root) /bin/ping
  122. /sbin/ifenslave
  123. /sbin/rdisc
  124. /bin/tracepath
  125. /sbin/ninfod
  126. %{_sbindir}/ping
  127. %{_sbindir}/ping6
  128. %{_sbindir}/tracepath
  129. %{_sbindir}/tracepath6
  130. %{_mandir}/man8/*
  131. %{_sysconfdir}/rc.d/init.d/rdisc
  132. %{_sysconfdir}/rc.d/init.d/ninfod
  133. %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/rdisc
  134. %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/ninfod
  135. %changelog
  136. * Wed Nov 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20190709-2
  137. - imported Patch2 from upstream to fix arping.
  138. * Tue Oct 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20190709-1
  139. - updated to 20190709.
  140. - dropped Source1000 and Patch1000: merged into upstream.
  141. - switched buildsystem to meson.
  142. - dropped Patch0: Makefile is deprecated.
  143. * Sat Nov 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20180629-1
  144. - updated to 20180629.
  145. - dropped Patch2-5 (fixed in upstream).
  146. - updated gettext patch and translation.
  147. - added BR:libxslt.
  148. - added BR:docbook-style-xsl.
  149. * Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-2
  150. - fixed initscripts.
  151. * Fri Feb 23 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-1
  152. - updated to 20161105.
  153. - updated gettext patch and translation.
  154. - updated license.
  155. * Sun Jul 13 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 20140519-1
  156. - update to 20140519
  157. - update URL to new upstream
  158. - update gettext patch and translation
  159. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 20101006-1
  160. - new upstream release
  161. - merget with fedora/20101006-8
  162. - update gettext patch and ja.po
  163. * Fri Apr 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-2
  164. - rebuild to add sign..
  165. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-1
  166. - new upstream release
  167. - spec in utf-8
  168. * Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-41vl1
  169. - remove traceroute6 that is now provided by traceroute package.
  170. - merge changes from FC
  171. * Sat Jul 31 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20020927-13vl2
  172. - ppc patch (Patch110) removed (it's no necessary now)
  173. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-13vl1
  174. - update to 20020927 merged with 20020927-13
  175. - update i18n patch, ja.po
  176. * Thu Oct 02 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-12
  177. - Fixed unaligned access problem on ia64 (#101417)
  178. * Wed Sep 10 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-11
  179. - Dont use own headers, use glibc and kernheaders.
  180. * Thu Sep 04 2003 Bill Nottingham <notting@redhat.com> 20020927-10
  181. - fix build with new glibc-kernheaders
  182. * Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9
  183. - Start icmp_seq from 0 instead of 1 (Conform with debian and Solaris #100609).
  184. * Thu Jul 31 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-8
  185. - One more update to ifenslave.c
  186. * Mon Jun 16 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-7
  187. - Updated ifenslave.c and README.bonding to latest version.
  188. * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-5
  189. - Bumped release and rebuilt
  190. * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-4
  191. - Fixed DNS lookup problems (#68212).
  192. - Added warning if binding problem failed on subinterface (#81640).
  193. * Tue May 13 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-3
  194. - Removed bonding tarball and replaced it with ifenslave.c and README
  195. - FHS compliance for all tools, now to be found in /bin with compat symlinks to
  196. old places.
  197. * Fri Nov 29 2002 Phil Knirsch <pknirsch@redhat.com> 20020927-1
  198. - Updated to latest upstream version.
  199. * Tue Jun 18 2002 Phil Knirsch <pknirsch@redhat.com> 20020124-7
  200. - Added new BuildPreReqs for docbook-utils and perl-SGMLSpm (#66661)
  201. - Fixed ipv6 error printing problem (#66659).
  202. * Tue May 21 2002 Phil Knirsch <pknirsch@redhat.com>
  203. - Added a patch to activate the rdisc server (#64270).
  204. - Display the countermeasures warning only in verbose (#55236)
  205. * Thu Apr 18 2002 Bill Nottingham <notting@redhat.com>
  206. - quit trying to build HTML versions of the man pages
  207. * Thu Mar 14 2002 Phil Knirsch <pknirsch@redhat.com>
  208. - Added fix by Tom "spot" Callaway to fix buffer overflow problems in stats.
  209. * Wed Feb 27 2002 Phil Knirsch <pknirsch@redhat.com>
  210. - Update to iputils-ss020124.
  211. * Sat Feb 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl2
  212. - changed Patch110 to have clear_bit() within the ipv6 source for ppc
  213. * Sun Jan 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl1
  214. - based on 20001110-7 from Rawhide
  215. - merged Vine changes from 20001010-1vl4
  216. --- Mon Jul 16 2001 <sagami@vinelinux.org>
  217. - 20001010-1vl4
  218. - use %%{find_lang} to fix so as not to own locale dir
  219. --- Thu Jun 07 2001 <sagami@vinelinux.org>
  220. - 20001010-1vl3: rebuilt for %%{_mandir}
  221. --- Fri Oct 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  222. - 20001010-1vl2
  223. - remove ping6 for ppc
  224. - added Japanese summary and description
  225. --- Thu Oct 26 2000 Jun Nishii <jun@vinelinux.org>
  226. - added ja.po and nls patch
  227. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  228. - automated rebuild
  229. * Mon Aug 27 2001 Philipp Knirsch <pknirsch@redhat.de> 20001110-6
  230. - Fixed buffer overflow problem in traceroute6.c (#51135)
  231. * Sun Jul 01 2001 Philipp Knirsch <pknirsch@redhat.de>
  232. - Made ping6 and traceroute6 setuid (safe as they drop it VERY early) (#46769)
  233. * Thu Jun 28 2001 Philipp Knirsch <pknirsch@redhat.de>
  234. - Fixed ping statistics overflow bug (#43801)
  235. * Tue Jun 26 2001 Philipp Knirsch <pknirsch@redhat.de>
  236. - Fixed a bunch of compiler warnings (#37131)
  237. - Fixed wrong exit code for no packets and deadline (#40323)
  238. - Moved arping to /sbin from /usr/sbin due to ifup call (#45785). Symlink from
  239. /usr/sbin/ provided for backwards compatibility.
  240. * Mon Apr 30 2001 Preston Brown <pbrown@redhat.com>
  241. - install in.rdisc.8c as rdisc.8
  242. * Tue Jan 16 2001 Jeff Johnson <jbj@redhat.com>
  243. - update to ss001110
  244. - doco fixes (#23844).
  245. * Sun Oct 8 2000 Jeff Johnson <jbj@redhat.com>
  246. - update to ss001007.
  247. * Tue Aug 8 2000 Tim Waugh <twaugh@redhat.com>
  248. - fix spelling mistake (#15714).
  249. * Tue Aug 8 2000 Tim Waugh <twaugh@redhat.com>
  250. - turn on -U on machines without TSC (#15223).
  251. * Tue Aug 1 2000 Jeff Johnson <jbj@redhat.com>
  252. - better doco patch (#15050).
  253. * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
  254. - fix include-glibc/ to work with new glibc 2.2 resolver headers
  255. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  256. - automatic rebuild
  257. * Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
  258. - FHS packaging.
  259. - update to ss000418.
  260. - perform reverse DNS lookup only once for same input.
  261. * Sun Mar 5 2000 Jeff Johnson <jbj@redhat.com>
  262. - include README.ifenslave doco.
  263. - "ping -i N" was broke for N >= 3 (#9929).
  264. - update to ss000121:
  265. -- clockdiff: preserve raw socket errno.
  266. -- ping: change error exit code to 1 (used to be 92,93, ...)
  267. -- ping,ping6: if -w specified, transmit until -c limit is reached.
  268. -- ping,ping6: exit code non-zero if some packets not received within deadline.
  269. * Tue Feb 22 2000 Jeff Johnson <jbj@redhat.com>
  270. - man page corrections (#9690).
  271. * Wed Feb 9 2000 Jeff Johnson <jbj@jbj.org>
  272. - add ifenslave.
  273. * Thu Feb 3 2000 Elliot Lee <sopwith@redhat.com>
  274. - List /usr/sbin/rdisc in %files list.
  275. * Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
  276. - add remaining binaries.
  277. - casts to remove compilation warnings.
  278. - terminate if -w deadline is reached exactly (#8724).
  279. * Fri Dec 24 1999 Jeff Johnson <jbj@redhat.com>
  280. - create (only ping for now, traceroute et al soon).