MySQL-vl.spec 32 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864
  1. %define mysqld_user mysql
  2. %define mysqld_group mysql
  3. %define server_suffix -community
  4. %define mysqldatadir /var/lib/mysql
  5. %{?_with_static:%define STATIC_BUILD 1}
  6. %{!?_with_static:%define STATIC_BUILD 0}
  7. # Working around perl dependency problem
  8. %define __perl_requires %{SOURCE998}
  9. # We don't package all files installed into the build root by intention -
  10. # See BUG#998 for details.
  11. %define _unpackaged_files_terminate_build 0
  12. %define see_base For a description of MySQL see the base MySQL RPM or http://www.mysql.com
  13. %define mysql_version 5.5.24
  14. %define client_version 18
  15. %if %{?_dist_release}!="vl5"
  16. %define libpkgname libmysqlclient%{client_version}
  17. %else
  18. %define libpkgname MySQL-shared
  19. %endif
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: tomop
  23. Name: MySQL
  24. Summary: MySQL: a very fast and reliable SQL database server
  25. Version: %{mysql_version}
  26. Release: 1%{_dist_release}
  27. Group: Applications/Databases
  28. # exceptions allow client libraries to be linked with most open source SW,
  29. # not only GPL code.
  30. License: GPLv2 with exceptions
  31. URL: http://www.mysql.com/
  32. Source: mysql-%{version}.tar.gz
  33. # Don't depend on lib::mtr*
  34. Source998: perl-requires-%{name}.sh
  35. Patch0: mysql-5.5.15-jp-all.patch
  36. # lib64 patch for vine
  37. Patch200: pysql-5.1.44-lib64.patch
  38. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  39. BuildRequires: perl, readline-devel, libaio-devel
  40. BuildRequires: gcc-c++, ncurses-devel, zlib-devel, openssl-devel
  41. BuildRequires: groff, cmake, bison
  42. Requires: fileutils sh-utils
  43. Provides: msqlormysql MySQL-server mysql
  44. Obsoletes: mysql MySQL5
  45. # From the manual
  46. %description
  47. The MySQL(TM) software delivers a very fast, multi-threaded, multi-user,
  48. and robust SQL (Structured Query Language) database server. MySQL Server
  49. is intended for mission-critical, heavy-load production systems as well
  50. as for embedding into mass-deployed software. MySQL is a trademark of
  51. Sun Microsystems, Inc.
  52. Copyright 2000-2008 MySQL AB, 2009 Sun Microsystems, Inc. All rights reserved.
  53. Use is subject to license terms.
  54. This software comes with ABSOLUTELY NO WARRANTY. This is free software,
  55. and you are welcome to modify and redistribute it under the GPL license.
  56. The MySQL web site (http://www.mysql.com/) provides the latest
  57. news and information about the MySQL software. Also please see the
  58. documentation and the manual for more information.
  59. %package server
  60. Release: %{release}
  61. Summary: MySQL: a very fast and reliable SQL database server
  62. Group: Applications/Databases
  63. Requires: fileutils sh-utils net-tools
  64. Provides: msqlormysql mysql-server mysql MySQL MySQL5-server
  65. Obsoletes: MySQL mysql mysql-server MySQL5-server MySQL-Max
  66. %description server
  67. The MySQL(TM) software delivers a very fast, multi-threaded, multi-user,
  68. and robust SQL (Structured Query Language) database server. MySQL Server
  69. is intended for mission-critical, heavy-load production systems as well
  70. as for embedding into mass-deployed software. MySQL is a trademark of
  71. Sun Microsystems, Inc.
  72. Copyright 2000-2008 MySQL AB, 2009 Sun Microsystems, Inc. All rights reserved.
  73. Use is subject to license terms.
  74. This software comes with ABSOLUTELY NO WARRANTY. This is free software,
  75. and you are welcome to modify and redistribute it under the GPL license.
  76. The MySQL web site (http://www.mysql.com/) provides the latest
  77. news and information about the MySQL software. Also please see the
  78. documentation and the manual for more information.
  79. This package includes the MySQL server binary (incl. InnoDB) as well
  80. as related utilities to run and administrate a MySQL server.
  81. If you want to access and work with the database, you have to install
  82. package "MySQL-client" as well!
  83. %package client
  84. Summary: MySQL - Client
  85. Group: Applications/Databases
  86. Obsoletes: mysql-client MySQL5-client
  87. Provides: mysql-client MySQL5-client
  88. %description client
  89. This package contains the standard MySQL clients and administration tools.
  90. %{see_base}
  91. %package test
  92. Requires: %{name}-client = %{version}-%{release} perl-DBI perl
  93. Summary: MySQL - Test suite
  94. Group: Applications/Databases
  95. Obsoletes: mysql-bench MySQL5-bench MySQL-bench
  96. Provides: perl(mtr_misc.pl)
  97. %description test
  98. This package contains the MySQL regression test suite.
  99. %{see_base}
  100. %package devel
  101. Summary: MySQL - Development header files and libraries
  102. Group: Development/Libraries
  103. Requires: %{libpkgname} = %{version}-%{release}
  104. Requires: openssl-devel, zlib-devel
  105. Provides: mysql-devel MySQL5-devel
  106. Obsoletes: mysql-devel MySQL5-devel
  107. %description devel
  108. This package contains the development header files and libraries
  109. necessary to develop MySQL client applications.
  110. %{see_base}
  111. %package -n %{libpkgname}
  112. Summary: The shared libraries required for MySQL clients
  113. Group: System Environment/Libraries
  114. %if %{?_dist_release}!="vl5"
  115. Obsoletes: MySQL-shared < %{version}
  116. %endif
  117. %description -n %{libpkgname}
  118. This package contains the shared libraries (*.so*) which certain
  119. languages and applications need to dynamically load and use MySQL.
  120. #%package embedded
  121. #Summary: MySQL as an embeddable library
  122. #Group: System Environment/Libraries
  123. #Obsoletes: mysql-embedded MySQL5-embedded
  124. #Provides: mysql-embedded MySQL5-embedded
  125. #%description embedded
  126. #MySQL is a multi-user, multi-threaded SQL database server. This
  127. #package contains a version of the MySQL server that can be embedded
  128. #into a client application instead of running as a separate process.
  129. #%{see_base}
  130. %package embedded-devel
  131. Summary: Development files for MySQL as an embeddable library
  132. Group: Development/Libraries
  133. Requires: %{name}-devel = %{version}-%{release}
  134. %description embedded-devel
  135. MySQL is a multi-user, multi-threaded SQL database server. This
  136. package contains files needed for developing and testing with
  137. the embedded version of the MySQL server.
  138. %{see_base}
  139. %prep
  140. %setup -q -n mysql-%{version}
  141. %patch0 -p1 -b .jp
  142. #%if %{_lib} == lib64
  143. #%patch200 -p0 -b .lib64
  144. #%endif
  145. #aclocal
  146. #autoheader
  147. #libtoolize --automake --force
  148. #automake --add-missing --copy
  149. #autoconf
  150. #perl -pi -e 's/-Werror"/"/' configure
  151. %build
  152. # Be strict about variables, bail at earliest opportunity, etc.
  153. set -eu
  154. # Optional package files
  155. touch optional-files-devel
  156. export PATH=${MYSQL_BUILD_PATH:-$PATH}
  157. export CC=${MYSQL_BUILD_CC:-${CC:-gcc}}
  158. export CXX=${MYSQL_BUILD_CXX:-${CXX:-gcc}}
  159. export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
  160. export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
  161. export LDFLAGS=${MYSQL_BUILD_LDFLAGS:-${LDFLAGS:-}}
  162. export CMAKE=${MYSQL_BUILD_CMAKE:-${CMAKE:-cmake}}
  163. export MAKE_JFLAG=${MYSQL_BUILD_MAKE_JFLAG:-}
  164. # Build full release
  165. mkdir release
  166. (
  167. cd release
  168. # XXX: MYSQL_UNIX_ADDR should be in cmake/* but mysql_version is included before
  169. # XXX: install_layout so we can't just set it based on INSTALL_LAYOUT=RPM
  170. ${CMAKE} ../ -DBUILD_CONFIG=mysql_release -DINSTALL_LAYOUT=RPM \
  171. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  172. -DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
  173. -DFEATURE_SET="community" \
  174. -DCOMPILATION_COMMENT="VineLinux MySQL RPM" \
  175. -DMYSQL_SERVER_SUFFIX="%{server_suffix}" \
  176. -DWITH_PIC="ON" \
  177. -DWITH_ZLIB="system" \
  178. -DWITH_EMBEDDED_SERVER="ON" \
  179. -DWITH_SSL="yes"
  180. echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
  181. make %{?_smp_mflags} VERBOSE=1
  182. )
  183. # Use the build root for temporary storage of the shared libraries.
  184. RBR=$RPM_BUILD_ROOT
  185. # Clean up the BuildRoot first
  186. [ "$RBR" != "/" ] && [ -d "$RBR" ] && rm -rf "$RBR";
  187. # For gcc builds, include libgcc.a in the devel subpackage (BUG 4921). This
  188. # needs to be during build phase as $CC is not set during install.
  189. if "$CC" -v 2>&1 | grep '^gcc.version' >/dev/null 2>&1
  190. then
  191. libgcc=`$CC $CFLAGS --print-libgcc-file`
  192. if [ -f $libgcc ]
  193. then
  194. mkdir -p $RBR%{_libdir}/mysql
  195. # install -m 644 $libgcc $RBR%{_libdir}/mysql/libmygcc.a
  196. # echo "%{_libdir}/mysql/libmygcc.a" >>optional-files-devel
  197. fi
  198. fi
  199. ##############################################################################
  200. %install
  201. RBR=$RPM_BUILD_ROOT
  202. MBD=$RPM_BUILD_DIR/mysql-%{mysql_version}
  203. rm -rf $RBR
  204. # Ensure that needed directories exists
  205. install -d $RBR%{_sysconfdir}/{logrotate.d,init.d}
  206. install -d $RBR%{mysqldatadir}/mysql
  207. install -d $RBR%{_datadir}/mysql-test
  208. install -d $RBR%{_includedir}
  209. install -d $RBR%{_libdir}
  210. install -d $RBR%{_mandir}
  211. install -d $RBR%{_sbindir}
  212. # Install all binaries
  213. # Install all binaries
  214. (
  215. cd $MBD/release
  216. make DESTDIR=$RBR install
  217. )
  218. # Install logrotate and autostart
  219. install -m 644 $MBD/release/support-files/mysql-log-rotate $RBR%{_sysconfdir}/logrotate.d/mysql
  220. install -m 755 $MBD/release/support-files/mysql.server $RBR%{_sysconfdir}/init.d/mysql
  221. # Create a symlink "rcmysql", pointing to the init.script. SuSE users
  222. # will appreciate that, as all services usually offer this.
  223. ln -s %{_sysconfdir}/init.d/mysql $RBR%{_sbindir}/rcmysql
  224. # Touch the place where the my.cnf config file might be located
  225. # Just to make sure it's in the file list and marked as a config file
  226. touch $RBR%{_sysconfdir}/my.cnf
  227. # Remove man pages we explicitly do not want to package, avoids 'unpackaged
  228. # files' warning.
  229. rm -f $RBR%{_mandir}/man1/make_win_bin_dist.1*
  230. ##############################################################################
  231. %pre server
  232. # Shut down a previously installed server first
  233. if test -x %{_sysconfdir}/init.d/mysql
  234. then
  235. %{_sysconfdir}/init.d/mysql stop > /dev/null 2>&1
  236. echo "Giving mysqld a couple of seconds to exit nicely"
  237. sleep 5
  238. elif test -x %{_sysconfdir}/rc.d/init.d/mysql
  239. then
  240. %{_sysconfdir}/rc.d/init.d/mysql stop > /dev/null 2>&1
  241. echo "Giving mysqld a couple of seconds to exit nicely"
  242. sleep 5
  243. fi
  244. %post server
  245. mysql_datadir=%{mysqldatadir}
  246. # Create data directory if needed
  247. if test ! -d $mysql_datadir; then mkdir -m 755 $mysql_datadir; fi
  248. if test ! -d $mysql_datadir/mysql; then mkdir $mysql_datadir/mysql; fi
  249. if test ! -d $mysql_datadir/test; then mkdir $mysql_datadir/test; fi
  250. # Make MySQL start/shutdown automatically when the machine does it.
  251. # use insserv for older SuSE Linux versions
  252. if test -x /sbin/insserv
  253. then
  254. /sbin/insserv %{_sysconfdir}/init.d/mysql
  255. # use chkconfig on Red Hat and newer SuSE releases
  256. elif test -x /sbin/chkconfig
  257. then
  258. /sbin/chkconfig --add mysql
  259. fi
  260. # Create a MySQL user and group. Do not report any problems if it already
  261. # exists.
  262. groupadd -r %{mysqld_group} 2> /dev/null || true
  263. useradd -M -r -d $mysql_datadir -s /bin/bash -c "MySQL server" -g %{mysqld_group} %{mysqld_user} 2> /dev/null || true
  264. # The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
  265. usermod -g %{mysqld_group} %{mysqld_user} 2> /dev/null || true
  266. # Change permissions so that the user that will run the MySQL daemon
  267. # owns all database files.
  268. chown -R %{mysqld_user}:%{mysqld_group} $mysql_datadir
  269. # Initiate databases if needed
  270. %{_bindir}/mysql_install_db --rpm --user=%{mysqld_user}
  271. # Upgrade databases if needed would go here - but it cannot be automated yet
  272. # Change permissions again to fix any new files.
  273. chown -R %{mysqld_user}:%{mysqld_group} $mysql_datadir
  274. # Fix permissions for the permission database so that only the user
  275. # can read them.
  276. chmod -R og-rw $mysql_datadir/mysql
  277. # Restart in the same way that mysqld will be started normally.
  278. %{_sysconfdir}/init.d/mysql start
  279. # Allow mysqld_safe to start mysqld and print a message before we exit
  280. sleep 2
  281. #echo "Thank you for installing the MySQL Community Server! For Production
  282. #systems, we recommend MySQL Enterprise, which contains enterprise-ready
  283. #software, intelligent advisory services, and full production support with
  284. #scheduled service packs and more. Visit www.mysql.com/enterprise for more
  285. #information."
  286. %preun server
  287. if test $1 = 0
  288. then
  289. # Stop MySQL before uninstalling it
  290. if test -x %{_sysconfdir}/init.d/mysql
  291. then
  292. %{_sysconfdir}/init.d/mysql stop > /dev/null
  293. # Remove autostart of mysql
  294. # for older SuSE Linux versions
  295. if test -x /sbin/insserv
  296. then
  297. /sbin/insserv -r %{_sysconfdir}/init.d/mysql
  298. # use chkconfig on Red Hat and newer SuSE releases
  299. elif test -x /sbin/chkconfig
  300. then
  301. /sbin/chkconfig --del mysql
  302. fi
  303. fi
  304. fi
  305. # We do not remove the mysql user since it may still own a lot of
  306. # database files.
  307. %post -n %{libpkgname}
  308. /sbin/ldconfig
  309. %postun -n %{libpkgname}
  310. /sbin/ldconfig
  311. # Clean up the BuildRoot
  312. %clean
  313. [ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
  314. %files server
  315. %defattr(-,root,root,0755)
  316. %doc COPYING README
  317. %doc Docs/ChangeLog
  318. %doc Docs/INFO_SRC*
  319. %doc release/Docs/INFO_BIN*
  320. %doc release/support-files/my-*.cnf
  321. %doc %attr(644, root, root) %{_infodir}/mysql.info*
  322. %doc %attr(644, root, man) %{_mandir}/man1/innochecksum.1*
  323. %doc %attr(644, root, man) %{_mandir}/man1/my_print_defaults.1*
  324. %doc %attr(644, root, man) %{_mandir}/man1/myisam_ftdump.1*
  325. %doc %attr(644, root, man) %{_mandir}/man1/myisamchk.1*
  326. %doc %attr(644, root, man) %{_mandir}/man1/myisamlog.1*
  327. %doc %attr(644, root, man) %{_mandir}/man1/myisampack.1*
  328. %doc %attr(644, root, man) %{_mandir}/man1/mysql_convert_table_format.1*
  329. %doc %attr(644, root, man) %{_mandir}/man1/mysql_fix_extensions.1*
  330. %doc %attr(644, root, man) %{_mandir}/man8/mysqld.8*
  331. %doc %attr(644, root, man) %{_mandir}/man1/mysqld_multi.1*
  332. %doc %attr(644, root, man) %{_mandir}/man1/mysqld_safe.1*
  333. %doc %attr(644, root, man) %{_mandir}/man1/mysqldumpslow.1*
  334. %doc %attr(644, root, man) %{_mandir}/man1/mysql_install_db.1*
  335. %doc %attr(644, root, man) %{_mandir}/man1/mysql_plugin.1*
  336. %doc %attr(644, root, man) %{_mandir}/man1/mysql_secure_installation.1*
  337. %doc %attr(644, root, man) %{_mandir}/man1/mysql_setpermission.1*
  338. %doc %attr(644, root, man) %{_mandir}/man1/mysql_upgrade.1*
  339. %doc %attr(644, root, man) %{_mandir}/man1/mysqlhotcopy.1*
  340. %doc %attr(644, root, man) %{_mandir}/man1/mysqlman.1*
  341. %doc %attr(644, root, man) %{_mandir}/man1/mysql.server.1*
  342. %doc %attr(644, root, man) %{_mandir}/man1/mysqltest.1*
  343. %doc %attr(644, root, man) %{_mandir}/man1/mysql_tzinfo_to_sql.1*
  344. %doc %attr(644, root, man) %{_mandir}/man1/mysql_zap.1*
  345. %doc %attr(644, root, man) %{_mandir}/man1/mysqlbug.1*
  346. %doc %attr(644, root, man) %{_mandir}/man1/perror.1*
  347. %doc %attr(644, root, man) %{_mandir}/man1/replace.1*
  348. %doc %attr(644, root, man) %{_mandir}/man1/resolve_stack_dump.1*
  349. %doc %attr(644, root, man) %{_mandir}/man1/resolveip.1*
  350. %ghost %config(noreplace,missingok) %{_sysconfdir}/my.cnf
  351. %attr(755, root, root) %{_bindir}/innochecksum
  352. %attr(755, root, root) %{_bindir}/my_print_defaults
  353. %attr(755, root, root) %{_bindir}/myisam_ftdump
  354. %attr(755, root, root) %{_bindir}/myisamchk
  355. %attr(755, root, root) %{_bindir}/myisamlog
  356. %attr(755, root, root) %{_bindir}/myisampack
  357. %attr(755, root, root) %{_bindir}/mysql_convert_table_format
  358. %attr(755, root, root) %{_bindir}/mysql_fix_extensions
  359. %attr(755, root, root) %{_bindir}/mysql_install_db
  360. %attr(755, root, root) %{_bindir}/mysql_plugin
  361. %attr(755, root, root) %{_bindir}/mysql_secure_installation
  362. %attr(755, root, root) %{_bindir}/mysql_setpermission
  363. %attr(755, root, root) %{_bindir}/mysql_tzinfo_to_sql
  364. %attr(755, root, root) %{_bindir}/mysql_upgrade
  365. %attr(755, root, root) %{_bindir}/mysql_zap
  366. %attr(755, root, root) %{_bindir}/mysqlbug
  367. %attr(755, root, root) %{_bindir}/mysqld_multi
  368. %attr(755, root, root) %{_bindir}/mysqld_safe
  369. %attr(755, root, root) %{_bindir}/mysqldumpslow
  370. %attr(755, root, root) %{_bindir}/mysqlhotcopy
  371. %attr(755, root, root) %{_bindir}/mysqltest
  372. %attr(755, root, root) %{_bindir}/perror
  373. %attr(755, root, root) %{_bindir}/replace
  374. %attr(755, root, root) %{_bindir}/resolve_stack_dump
  375. %attr(755, root, root) %{_bindir}/resolveip
  376. %attr(755, root, root) %{_sbindir}/mysqld
  377. %attr(755, root, root) %{_sbindir}/rcmysql
  378. %attr(755, root, root) %{_libdir}/mysql/plugin/*.so
  379. %attr(644, root, root) %config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
  380. %attr(755, root, root) %{_sysconfdir}/init.d/mysql
  381. %attr(755, root, root) %{_datadir}/mysql/
  382. %files client
  383. %defattr(-, root, root, 0755)
  384. %attr(755, root, root) %{_bindir}/msql2mysql
  385. %attr(755, root, root) %{_bindir}/mysql
  386. %attr(755, root, root) %{_bindir}/mysql_find_rows
  387. %attr(755, root, root) %{_bindir}/mysql_waitpid
  388. %attr(755, root, root) %{_bindir}/mysqlaccess
  389. # XXX: This should be moved to %{_sysconfdir}
  390. %attr(644, root, root) %{_bindir}/mysqlaccess.conf
  391. %attr(755, root, root) %{_bindir}/mysqladmin
  392. %attr(755, root, root) %{_bindir}/mysqlbinlog
  393. %attr(755, root, root) %{_bindir}/mysqlcheck
  394. %attr(755, root, root) %{_bindir}/mysqldump
  395. %attr(755, root, root) %{_bindir}/mysqlimport
  396. %attr(755, root, root) %{_bindir}/mysqlshow
  397. %attr(755, root, root) %{_bindir}/mysqlslap
  398. %doc %attr(644, root, man) %{_mandir}/man1/msql2mysql.1*
  399. %doc %attr(644, root, man) %{_mandir}/man1/mysql.1*
  400. %doc %attr(644, root, man) %{_mandir}/man1/mysql_find_rows.1*
  401. %doc %attr(644, root, man) %{_mandir}/man1/mysql_waitpid.1*
  402. %doc %attr(644, root, man) %{_mandir}/man1/mysqlaccess.1*
  403. %doc %attr(644, root, man) %{_mandir}/man1/mysqladmin.1*
  404. %doc %attr(644, root, man) %{_mandir}/man1/mysqlbinlog.1*
  405. %doc %attr(644, root, man) %{_mandir}/man1/mysqlcheck.1*
  406. %doc %attr(644, root, man) %{_mandir}/man1/mysqldump.1*
  407. %doc %attr(644, root, man) %{_mandir}/man1/mysqlimport.1*
  408. %doc %attr(644, root, man) %{_mandir}/man1/mysqlshow.1*
  409. %doc %attr(644, root, man) %{_mandir}/man1/mysqlslap.1*
  410. %files devel -f optional-files-devel
  411. %defattr(-, root, root, 0755)
  412. %doc %attr(644, root, man) %{_mandir}/man1/comp_err.1*
  413. %doc %attr(644, root, man) %{_mandir}/man1/mysql_config.1*
  414. %attr(755, root, root) %{_bindir}/mysql_config
  415. %dir %attr(755, root, root) %{_includedir}/mysql
  416. %dir %attr(755, root, root) %{_libdir}/mysql
  417. %{_includedir}/mysql/*
  418. %{_datadir}/aclocal/mysql.m4
  419. %{_libdir}/*.so
  420. %exclude %{_libdir}/*.a
  421. %files -n %{libpkgname}
  422. %defattr(-, root, root, 0755)
  423. # Shared libraries (omit for architectures that don't support them)
  424. %{_libdir}/libmysql*.so.*
  425. #/etc/ld.so.conf.d/*
  426. %files test
  427. %defattr(-, root, root, 0755)
  428. %attr(-, root, root) %{_datadir}/mysql-test
  429. %attr(755, root, root) %{_bindir}/mysql_client_test
  430. %attr(755, root, root) %{_bindir}/mysql_client_test_embedded
  431. %attr(755, root, root) %{_bindir}/mysqltest_embedded
  432. %doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test.1*
  433. %doc %attr(644, root, man) %{_mandir}/man1/mysql-stress-test.pl.1*
  434. %doc %attr(644, root, man) %{_mandir}/man1/mysql-test-run.pl.1*
  435. %doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test_embedded.1*
  436. %doc %attr(644, root, man) %{_mandir}/man1/mysqltest_embedded.1*
  437. %files embedded-devel
  438. %defattr(-,root,root)
  439. #{_libdir}/libmysqld.a
  440. %{_bindir}/mysql_embedded
  441. %{_bindir}/mysql_client_test_embedded
  442. %{_bindir}/mysqltest_embedded
  443. %doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test_embedded.1*
  444. %doc %attr(644, root, man) %{_mandir}/man1/mysqltest_embedded.1*
  445. %changelog
  446. * Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
  447. - new upstream release.
  448. * Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
  449. - new upstream release.
  450. - added "Vendor:" and "Distribution:" tag.
  451. * Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
  452. - new upstream release.
  453. - removed NDB cluster support.
  454. * Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
  455. - Added "BR: zlib-devel" to MySQL-devel.
  456. * Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
  457. - Added "BR: openssl-devel" to MySQL-devel.
  458. * Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
  459. - new upstream release.
  460. * Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
  461. - new upstream release.
  462. - updated jp-patch.
  463. - added ssl support.
  464. * Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
  465. - new upstream release.
  466. - replaced '%%__find_requires' to '%%__perl_requires'.
  467. - updated jp-patch.
  468. * Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
  469. - added mysql-5.1.44-lib64.patch (on x86_64)
  470. - added -fPIC (on x86_64)
  471. * Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
  472. - made embedded package again
  473. * Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
  474. - new upstream release.
  475. - updated jp-patch.
  476. * Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
  477. - VineSeed: rebuilt with new toolchain.
  478. * Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
  479. - new upstream release.
  480. - fixed CVE-2009-4484.
  481. * Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
  482. - new upstream release.
  483. * Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
  484. - added net-tools to 'Requires'.
  485. - added groff to 'BuildRequires'.
  486. - renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
  487. * Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
  488. - new upstream release.
  489. * Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
  490. - new upstream release.
  491. * Sun Jul 5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
  492. - new upstream release.
  493. - dropped %%Patch100 (fixed in upstream).
  494. * Sat Jun 6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
  495. - new upstream release.
  496. - add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
  497. * Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
  498. - new upstream release.
  499. - rename 'MySQL-bench' to 'MySQL-test'.
  500. - update Patch0.
  501. - change default charset to 'utf8'.
  502. * Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
  503. - new upstream release.
  504. - update Patch0.
  505. - add "--with-client-charset=ujis".
  506. - sync %%files to official RPM.
  507. - remove MySQL-Max.
  508. * Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
  509. - for VineSeed
  510. * Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
  511. - move shared library from /usr/lib/ to /usr/lib/mysql/
  512. - add /etc/ld.so.conf.d/*.conf
  513. - fix broken libmysqlcient*.la files (or should we remove them permanently?)
  514. * Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
  515. - rebuild <BTS:VineLinux:534>
  516. * Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
  517. - added -fPIC
  518. * Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
  519. - fixed dependency. <BTS:338>
  520. * Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
  521. - add %%Patch1. <BTS:320>
  522. * Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
  523. - new upstream release.
  524. * Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
  525. - new upstream release.
  526. * Sat Jun 3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
  527. - new upstream release.
  528. * Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
  529. - release++.
  530. * Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
  531. - new upstream release.
  532. - for VineSeed.
  533. * Wed Feb 8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
  534. - new upstream release.
  535. - replace Patch0 for MySQL-4.1.16.
  536. * Thu Oct 6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
  537. - new upstream release.
  538. - add Patch0.
  539. * Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
  540. - new upstream version
  541. -- mysql-4.0.25
  542. * Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
  543. - new upstream version
  544. -- mysql-4.0.23
  545. * Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
  546. - new upstream version
  547. -- mysql-4.0.22
  548. * Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
  549. - new upstream version
  550. -- mysql-4.0.21
  551. * Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
  552. - new upstream version
  553. -- mysql-4.0.20
  554. * Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
  555. - modify CFLAGS, CXXFLAGS and configure options for alpha
  556. * Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
  557. - Upgraded to MySQL-4
  558. - added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
  559. - merged to MySQL Official packages
  560. -- renamed package "MySQL" to "MySQL-server"
  561. -- when using gcc, _always_ use CXX=gcc
  562. -- replaced Copyright with License field (Copyright is obsolete)
  563. -- added myisam_ftdump to the Server package
  564. -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
  565. -- fixed file permissions (BUG 1672)
  566. -- removed dependency on MySQL-client from the MySQL-devel subpackage
  567. -- as it is not really required. (BUG 1610)
  568. -- Fixed BUG 1162 (removed macro names from the changelog)
  569. -- Really fixed BUG 998 (disable the checking for installed but
  570. -- unpackaged files)
  571. -- Fixed BUG 959 (libmysqld not being compiled properly)
  572. -- Fixed BUG 998 (RPM build errors): added missing files to the
  573. -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
  574. -- mysql_fix_privilege_tables.1), removed "-n" from install section.
  575. -- removed the GIF Icon (file was not included in the sources anyway)
  576. -- removed unused variable shared_lib_version
  577. -- do not run automake before building the standard binary
  578. -- (should not be necessary)
  579. -- add server suffix '-standard' to standard binary (to be in line
  580. -- with the binary tarball distributions)
  581. -- allow overriding CC and CXX (required when building
  582. -- with other compilers)
  583. * Thu Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
  584. - added BuildRequires: automake16
  585. * Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
  586. - add '-fPIC -DPIC' to CFLAGS on alpha
  587. - little fix of spec file
  588. * Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
  589. - enable MySQL-shared subpackage for alpha
  590. - delete 'BuildPrereq: kernel24-headers' for alpha
  591. - fix shared %files (exclude sparc)
  592. * Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
  593. - new upstream version
  594. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
  595. - fixed devel %files (dropped *.la files)
  596. * Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
  597. - new upstream version
  598. - fixed document permission
  599. * Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
  600. - new upstream version
  601. * Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
  602. - dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
  603. -- don't work
  604. * Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
  605. - new upstream version
  606. - diseble-assembler in configure on sparc,sparc64,alpha
  607. * Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
  608. - new upstream version
  609. - moved some man files to main package
  610. - added enable-local-infile in configure
  611. - changed --with-extra-charsets=all in configure
  612. * Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
  613. - fixed changelog
  614. * Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
  615. - updated to mysql-3.23.51
  616. * Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
  617. - rebuild on zlib-1.1.4(security fix.)
  618. * Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
  619. - updated to mysql-2.23.49
  620. * Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
  621. - add 'BuildPrereq: kernel24-headers' on alpha
  622. - remove shared library and max on alpha
  623. * Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
  624. - updated to mysql-3.23.48
  625. * Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
  626. - updated to mysql-3.23.47
  627. * Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
  628. - updated to mysql-3.23.46
  629. * Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
  630. - updated to mysql-3.23.45
  631. * Tue Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
  632. - updated to mysql-3.23.44
  633. * Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
  634. - updated to mysql-3.23.43
  635. - removed shared library and max on sparc
  636. * Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
  637. - updated to mysql-3.23.42
  638. - changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
  639. * Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
  640. - updated to mysql-3.23.41
  641. * Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
  642. - updated to mysql-3.23.40
  643. * Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
  644. - updated to mysql-3.23.39
  645. * Sat Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
  646. - added configure --with-charset=ujis
  647. * Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
  648. - used some rpmmacro
  649. * Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
  650. - updated to MySQL-3.23.38
  651. * Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
  652. - removed Bench pakages
  653. * Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
  654. - removed pt_BR locale
  655. - build on Vine Linux
  656. - partially used rpmmacros
  657. - added %clean tag
  658. * Fri Aug 18 2000 Tim Smith <tim@mysql.com>
  659. - Added separate libmysql_r directory; now both a threaded
  660. and non-threaded library is shipped.
  661. * Wed Sep 28 1999 David Axmark <davida@mysql.com>
  662. - Added the support-files/my-example.cnf to the docs directory.
  663. - Removed devel dependency on base since it is about client
  664. development.
  665. * Wed Sep 8 1999 David Axmark <davida@mysql.com>
  666. - Cleaned up some for 3.23.
  667. * Thu Jul 1 1999 David Axmark <davida@mysql.com>
  668. - Added support for shared libraries in a separate sub
  669. package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
  670. - The --enable-assembler switch is now automatically disables on
  671. platforms there assembler code is unavailable. This should allow
  672. building this RPM on non i386 systems.
  673. * Mon Feb 22 1999 David Axmark <david@detron.se>
  674. - Removed unportable cc switches from the spec file. The defaults can
  675. now be overridden with environment variables. This feature is used
  676. to compile the official RPM with optimal (but compiler version
  677. specific) switches.
  678. - Removed the repetitive description parts for the sub rpms. Maybe add
  679. again if RPM gets a multiline macro capability.
  680. - Added support for a pt_BR translation. Translation contributed by
  681. Jorge Godoy <jorge@bestway.com.br>.
  682. * Wed Nov 4 1998 David Axmark <david@detron.se>
  683. - A lot of changes in all the rpm and install scripts. This may even
  684. be a working RPM :-)
  685. * Sun Aug 16 1998 David Axmark <david@detron.se>
  686. - A developers changelog for MySQL is available in the source RPM. And
  687. there is a history of major user visible changed in the Reference
  688. Manual. Only RPM specific changes will be documented here.