self-build-kino-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161
  1. %define pkgname kino
  2. %define name self-build-%{pkgname}
  3. %define version 1.3.4
  4. %define release 3%{?_dist_release}
  5. %define sourceurl0 http://prdownloads.sourceforge.net/kino/%{pkgname}-%{version}.tar.gz
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. Source100: kino-udev.patch
  13. License: GPL
  14. Group: Restricted Software
  15. Obsoletes: kino < 1.3.3-2
  16. Requires(post): self-build-setup >= 0.9.9
  17. Requires(post): desktop-file-utils
  18. Requires(post): gettext
  19. Requires(post): intltool
  20. Requires(post): libsamplerate-devel
  21. Requires(post): libdv-devel
  22. Requires(post): libavc1394-devel
  23. Requires(post): libraw1394-devel
  24. Requires(post): libiec61883-devel
  25. Requires(post): libogg-devel
  26. Requires(post): libvorbis-devel
  27. Requires(post): gtk2-devel >= 2.6.0
  28. Requires(post): XOrg-devel
  29. Requires(post): imlib-devel
  30. Requires(post): libxml2-devel
  31. Requires(post): perl
  32. Requires: libdv
  33. Requires: libavc1394
  34. Requires: libraw1394
  35. Requires: libogg
  36. Requires: libvorbis
  37. Requires: gtk2
  38. Requires: imlib
  39. Requires: libxml2
  40. Requires(post): shared-mime-info
  41. Requires(post): self-build-libquicktime
  42. Requires(post): self-build-mjpegtools
  43. Requires(post): self-build-mplayer
  44. Requires(post): self-build-ffmpeg
  45. Requires(post): self-build-ffmpeg2theora
  46. BuildArch: noarch
  47. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  48. Packager: munepi
  49. %description
  50. The new generation of digital camcorders use the Digital Video (DV) data
  51. format. Kino allows you to record, create, edit, and play movies recorded
  52. with DV camcorders. Unlike other editors, this program uses many keyboard
  53. commands for fast navigating and editing inside the movie.
  54. If you install this package, it automaticaly downloads source
  55. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  56. And the created rpm packages are automatically installed
  57. if installation is executed by apt-get command or synaptic
  58. package manager.
  59. [Note]
  60. This package requires many other packages to compile
  61. targetsoftware. So it consume more disk space than usual.
  62. Also installation takes logner time because of compilation.
  63. (This will take a few minutes to quarter or half of an hour,
  64. depends on building environment)
  65. [About self-build package]
  66. For some kind of software, distributing of binary package
  67. may viorate the patent or law. Therefore we chose self-build
  68. packge, create binary package on your machine, for such kind
  69. of softwares instead of distributing binary package.
  70. Please obey the national law when you use the created binary
  71. packages. And if you want to use the softwares using patented
  72. thechnology, it may be required to get a permission, make an
  73. agreement or purchas a license. Please consider it with your
  74. purpose or way of use and take appropriate action.
  75. %description -l ja
  76. デジタルビデオカメラの新世代は
  77. Digital Video (DV) データフォーマットを使います。
  78. Kino は DV デジタルビデオカメラで録画された動画を
  79. 録画、作成、編集、再生できます。
  80. 他の編集ソフトとは異なり、
  81. 動画の中へ素早く移動や編集するために
  82. 多くのキーボードコマンドを使えます。
  83. このパッケージをインストールすると、自動的にソースコードを
  84. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  85. パッケージを作成します。
  86. また apt-get コマンドや synaptic パッケージマネージャから実行
  87. した場合は、作成された rpm パッケージのインストールも自動的に
  88. 行います。
  89. [注意]
  90. コンパイルに必要な多くの関連パッケージを要求するので通常より
  91. ディスクの領域を多く消費します。
  92. またインストール時にコンパイルを行うため、通常より時間がかか
  93. る場合があります。(環境にもよりますが数分から数十分程度)
  94. [self-build パッケージについて]
  95. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  96. 違反する可能性があるものがあります。その為、このような問題が
  97. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  98. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  99. ジという方法を採っています。
  100. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  101. アのライセンス、および利用する国の各種法令に従ってください。
  102. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  103. センスの購入などが必要となる場合がありますので、利用する目的
  104. や形態に応じて各自で判断し適切な対応を取ってください。
  105. %prep
  106. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  107. %install
  108. %{__rm} -rf ${RPM_BUILD_ROOT}
  109. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  110. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  111. %{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  112. %clean
  113. %{__rm} -rf ${RPM_BUILD_ROOT}
  114. %posttrans
  115. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 105000
  116. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  117. %{pkgname}-devel-%{version}-%{release}
  118. %files
  119. %defattr(-,root,root)
  120. %{_datadir}/%{name}
  121. %changelog
  122. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-3
  123. - added Requires(post): self-build-mjpegtools, self-build-mplayer
  124. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-2
  125. - renamed %%{Source0} to kino-vl.spec
  126. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-1
  127. - new upstream release
  128. - with recent ffmpeg
  129. * Sun Jun 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-2
  130. - initial bulid