graphviz-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322
  1. Name: graphviz
  2. Summary: Graph Visualization Tools
  3. Version: 2.28.0
  4. Release: 2%{?_dist_release}
  5. Group: Applications/Graphics
  6. License: CPL
  7. URL: http://www.graphviz.org/
  8. Source: http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: bison
  11. BuildRequires: cairo-devel
  12. BuildRequires: expat-devel
  13. BuildRequires: flex
  14. BuildRequires: fontconfig-devel
  15. BuildRequires: freetype2-devel
  16. BuildRequires: gd-devel
  17. BuildRequires: gtk2-devel
  18. BuildRequires: guile-devel
  19. BuildRequires: libjpeg-turbo-devel
  20. BuildRequires: libpng-devel
  21. BuildRequires: libSM-devel
  22. BuildRequires: libtool-ltdl-devel >= 2.2.6a
  23. BuildRequires: libXaw-devel
  24. BuildRequires: libXext-devel
  25. BuildRequires: librsvg2-devel
  26. BuildRequires: m4
  27. BuildRequires: perl
  28. BuildRequires: python-devel
  29. BuildRequires: ruby-devel
  30. BuildRequires: swig
  31. BuildRequires: tcl >= 8.4
  32. BuildRequires: tk >= 8.4
  33. BuildRequires: zlib-devel
  34. Requires: urw-fonts
  35. # only for this release
  36. BuildConflicts: graphviz-devel
  37. %description
  38. A collection of tools and tcl packages for the manipulation and layout
  39. of graphs (as in nodes and edges, not as in barcharts).
  40. %package devel
  41. Group: Development/Libraries
  42. Summary: Development tools for version %{version} of %{name}
  43. Requires: %{name} = %{version}
  44. %description devel
  45. The %{name}-devel package contains the header files
  46. and man3 pages necessary for developing programs
  47. using version %{version} of the %{name} libraries.
  48. %package doc
  49. Summary: PDF and HTML documents for graphviz
  50. Group: Applications/Documentation
  51. %description doc
  52. Provides some additional PDF and HTML documentation for graphviz.
  53. %package guile
  54. Group: Applications/Graphics
  55. Summary: Guile extension for graphviz
  56. Requires: %{name} = %{version}-%{release}, guile
  57. %description guile
  58. Guile extension for graphviz.
  59. %package perl
  60. Group: Applications/Graphics
  61. Summary: Perl extension for graphviz
  62. Requires: %{name} = %{version}-%{release}
  63. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  64. %description perl
  65. Perl extension for graphviz.
  66. %package python
  67. Group: Applications/Graphics
  68. Summary: Python extension for graphviz
  69. Requires: %{name} = %{version}-%{release}
  70. Requires: python
  71. %description python
  72. Python extension for graphviz.
  73. %package ruby
  74. Group: Applications/Multimedia
  75. Summary: Ruby extension for graphviz
  76. Requires: %{name} = %{version}-%{release}
  77. Requires: ruby
  78. %description ruby
  79. Ruby extension for graphviz.
  80. %package tcl
  81. Group: Applications/Graphics
  82. Summary: Tcl extension & tools for graphviz
  83. Requires: tcl >= 8.4, tk >= 8.4
  84. Requires: %{name} = %{version}
  85. %description tcl
  86. Various tcl packages (extensions) for the graphviz tools.
  87. %prep
  88. %setup -q
  89. # using archdir instead of sitearchdir for Vine
  90. sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
  91. autoreconf -f -i
  92. %build
  93. # Rewrite config_ruby.rb to work with Ruby 1.9
  94. sed -i 's|expand(|expand(Config::|' config/config_ruby.rb
  95. sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
  96. export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
  97. # XXX ix86 only used to have -ffast-math, let's use everywhere
  98. %{expand: %%define optflags %{optflags} -ffast-math}
  99. %configure \
  100. --with-x \
  101. --disable-static \
  102. --with-mylibgd \
  103. --with-ipsepcola \
  104. --with-pangocairo \
  105. --with-gdk-pixbuf \
  106. --without-mylibgd \
  107. --without-ming \
  108. --disable-sharp \
  109. --enable-guile \
  110. --enable-io \
  111. --disable-java \
  112. --disable-lua \
  113. --disable-ocaml \
  114. --enable-perl \
  115. --disable-php \
  116. --enable-python \
  117. --disable-r \
  118. --enable-ruby \
  119. --enable-tcl
  120. make %{?_smp_mflags}
  121. %install
  122. rm -rf $RPM_BUILD_ROOT __doc
  123. make DESTDIR=$RPM_BUILD_ROOT \
  124. docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
  125. pkgconfigdir=%{_libdir}/pkgconfig \
  126. install
  127. find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
  128. chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
  129. cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
  130. rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
  131. %clean
  132. rm -rf $RPM_BUILD_ROOT
  133. # run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
  134. %post
  135. /sbin/ldconfig
  136. %{_bindir}/dot -c
  137. # if there is no dot after everything else is done, then remove config
  138. %postun
  139. if [ $1 -eq 0 ]; then
  140. rm -f %{_libdir}/graphviz/config || :
  141. fi
  142. /sbin/ldconfig
  143. %files
  144. %defattr(-,root,root)
  145. %doc AUTHORS COPYING ChangeLog NEWS README
  146. %{_bindir}/*
  147. %dir %{_datadir}/%{name}
  148. %{_datadir}/%{name}/lefty
  149. %{_mandir}/man1/*
  150. %{_mandir}/man7/*
  151. %dir %{_libdir}/%{name}
  152. %{_libdir}/*.so.*
  153. %{_libdir}/%{name}/*.so.*
  154. %exclude %{_libdir}/graphviz/*/*
  155. %files devel
  156. %defattr(-,root,root)
  157. %{_includedir}/%{name}
  158. %{_libdir}/*.so
  159. %{_libdir}/%{name}/*.so
  160. %{_libdir}/pkgconfig/*.pc
  161. %{_datadir}/%{name}/graphs
  162. %{_mandir}/man3/*.3.gz
  163. %files doc
  164. %defattr(-,root,root,-)
  165. %doc __doc/*
  166. %files guile
  167. %defattr(-,root,root,-)
  168. %{_libdir}/graphviz/guile/
  169. %{_mandir}/man3/gv.3guile*
  170. %files perl
  171. %defattr(-,root,root,-)
  172. %{_libdir}/graphviz/perl/
  173. %{perl_vendorarch}/*
  174. %{_mandir}/man3/gv.3perl*
  175. %files python
  176. %defattr(-,root,root,-)
  177. %{_libdir}/graphviz/python/
  178. %{_libdir}/python*/*
  179. %{_mandir}/man3/gv.3python*
  180. %files ruby
  181. %defattr(-,root,root,-)
  182. %{_libdir}/graphviz/ruby/
  183. %{_libdir}/*ruby*/*
  184. %{_mandir}/man3/gv.3ruby*
  185. %files tcl
  186. %defattr(-,root,root)
  187. %{_libdir}/%{name}/tcl/*
  188. %{_libdir}/tcl*/*
  189. %{_datadir}/%{name}/demo
  190. # hack to include gv.3tcl only if available
  191. # always includes tcldot.3tcl, gdtclft.3tcl
  192. %{_mandir}/man3/*.3tcl*
  193. %{_mandir}/man3/tkspline.3tk*
  194. %changelog
  195. * Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
  196. - re-enable ruby binding, which is accidentally disabled in 2.28.0-1
  197. - rewrite config_ruby.rb to build with ruby-1.9.3
  198. - add search path for ruby/config.h to CPPFLAGS for configure
  199. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  200. - new upstream release
  201. - remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
  202. - add BuildRequires: librsvg2-devel
  203. * Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
  204. - add Patch10 to avoid build failure on ppc
  205. * Sat Oct 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
  206. - new upstream release
  207. - built with rpm-4.8.1
  208. - split doc, guile, perl, python, ruby subpackage
  209. * Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
  210. - rebuild with libtool-2.2.6a
  211. * Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
  212. - new upstream release
  213. * Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  214. - rebuild with libXaw.so.7 (libXaw-1.0.5)
  215. * Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
  216. - new upstream release
  217. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
  218. - new upstream release
  219. - build with expat-2.0.1
  220. - add man7
  221. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
  222. - rebuild with tcl/tk-8.4.16
  223. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
  224. - new upstream release
  225. - add BuildPrereq: swig
  226. - delete BuildPrereq: gd-progs gd-devel
  227. - add --with-mylibgd and --disable-FEATURE to configure option
  228. - update %%files
  229. * Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
  230. - added BuildPrereq: ruby-devel
  231. * Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
  232. - new upstream release
  233. - add BuildPrereq: libtool-ltdl-devel
  234. - move pkgconfig files to %%{_libdir}/pkgconfig
  235. - add --disable-rpath --disable-static to configure option
  236. - add %%post to every package
  237. * Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
  238. - new upstream release
  239. - BuildPrereq: tcl >= 8.4, tk >= 8.4
  240. - add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
  241. - update %%files
  242. - remove lines about Vine2.6
  243. - change License to CPL
  244. * Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
  245. - source upgrade
  246. - remove patch0 and commented lines
  247. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
  248. - build for VineSeed
  249. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
  250. - source upgrade
  251. - change spec to build both VineSeed and Vine2.5/2.6
  252. - add BuildPrereq: expat-devel and Requires: libexpat
  253. - add patch0 to build against freetype2-2.1.7
  254. - stop using autogen.sh script
  255. - add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
  256. - add graphviz-tcl package (VineSeed)
  257. * Thu Aug 7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
  258. - rebuild for new Vine
  259. * Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
  260. - import from offical site (src.rpm)