ulogd-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320
  1. Summary: Userspace logging daemon for netfilter
  2. Name: ulogd
  3. Version: 2.0.4
  4. Release: 3%{?_dist_release}
  5. License: GPLv2+
  6. Group: System Environment/Daemons
  7. URL: http://www.netfilter.org/projects/%{name}/
  8. Source0: http://ftp.netfilter.org/pub/%{name}/%{name}-%{version}.tar.bz2
  9. Source1: %{name}.init
  10. BuildRequires: libnetfilter_conntrack-devel >= 0.0.95
  11. BuildRequires: libnetfilter_log-devel >= 1.0.0
  12. BuildRequires: libnfnetlink-devel >= 0.0.39
  13. BuildRequires: libnetfilter_acct-devel >= 1.0.1
  14. BuildRequires: libmnl-devel
  15. BuildRequires: linuxdoc-tools
  16. BuildRequires: texlive-collection-fontsrecommended
  17. Requires(post): /sbin/service
  18. Requires(post): /sbin/chkconfig
  19. Requires(preun): /sbin/chkconfig
  20. Requires(preun): /sbin/service
  21. Requires(postun): /sbin/service
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: tomop
  25. %description
  26. %{name} is a logging daemon that reads event messages coming from the Netfilter
  27. connection tracking and the Netfilter packet logging subsystem. You have to
  28. enable support for connection tracking event delivery; ctnetlink and the NFLOG
  29. target in your Linux kernel 2.6.x or load their respective modules. The
  30. deprecated ULOG target (which has been superseded by NFLOG) is also supported.
  31. %package libdbi
  32. Summary: Libdbi framework output plugin for %{name}
  33. Group: System Environment/Daemons
  34. BuildRequires: libdbi-devel
  35. Requires: %{name} = %{version}
  36. %description libdbi
  37. %{name}-libdbi is a libdbi output plugin for %{name}. It enables logging of
  38. firewall information through a libdbi interface.
  39. %package mysql
  40. Summary: MySQL output plugin for %{name}
  41. Group: System Environment/Daemons
  42. BuildRequires: libmysqlclient-devel
  43. Requires: %{name} = %{version}
  44. %description mysql
  45. %{name}-mysql is a MySQL output plugin for %{name}. It enables logging of
  46. firewall information into a MySQL database.
  47. %package pgsql
  48. Summary: PostgreSQL output plugin for %{name}
  49. Group: System Environment/Daemons
  50. BuildRequires: libpq-devel
  51. Requires: %{name} = %{version}
  52. %description pgsql
  53. %{name}-pgsql is a PostgreSQL output plugin for %{name}. It enables logging of
  54. firewall information into a PostgreSQL database.
  55. %package pcap
  56. Summary: PCAP output plugin for %{name}
  57. Group: System Environment/Daemons
  58. BuildRequires: libpcap-devel
  59. Requires: %{name} = %{version}
  60. %description pcap
  61. %{name}-pcap is a output plugin for %{name} that saves packet logs as PCAP
  62. file. PCAP is a standard format that can be later analyzed by a lot of tools
  63. such as tcpdump and wireshark.
  64. %package sqlite
  65. Summary: SQLITE output plugin for %{name}
  66. Group: System Environment/Daemons
  67. BuildRequires: sqlite3-devel
  68. Requires: %{name} = %{version}
  69. %description sqlite
  70. %{name}-sqlite is a SQLITE output plugin for %{name}. It enables logging of
  71. firewall information into an SQLITE database.
  72. %prep
  73. %setup -q
  74. %{__sed} -i -e 's|/var/log/|%{_localstatedir}/log/%{name}/|g' %{name}.conf.in
  75. %{__sed} -i -e 's|/var/log/|%{_localstatedir}/log/%{name}/|g' %{name}.logrotate
  76. %{__sed} -i -e 's|/bin/killall|%{_bindir}/killall|g' %{name}.logrotate
  77. %build
  78. %configure \
  79. --disable-static \
  80. --enable-shared \
  81. --with-dbi-lib=%{_libdir} \
  82. --with-pcap-lib=%{_libdir} \
  83. --with-sqlite3-lib=%{_libdir}
  84. %{__make} %{?_smp_mflags}
  85. %{__make} %{?_smp_mflags} -C doc
  86. %install
  87. %{__rm} -rf %{buildroot}
  88. %{__make} DESTDIR=%{buildroot} install
  89. %{__mkdir_p} -m 0755 %{buildroot}%{_localstatedir}/log/%{name}/
  90. %{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/
  91. %{__install} -m 0644 %{name}.conf %{buildroot}%{_sysconfdir}/
  92. %{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/logrotate.d/
  93. %{__install} -m 0644 %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  94. %{__mkdir_p} -m 0755 %{buildroot}%{_initrddir}/
  95. %{__install} -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  96. %post
  97. /sbin/chkconfig --add %{name}
  98. /sbin/service %{name} condrestart >/dev/null 2>&1 || :
  99. %preun
  100. # if we are uninstalling...
  101. if [ "$1" = 0 ]; then
  102. /sbin/service %{name} stop > /dev/null 2>&1 ||:
  103. /sbin/chkconfig --del %{name}
  104. fi
  105. %postun
  106. # if we are upgrading...
  107. if [ "$1" -ge "1" ]; then
  108. /sbin/service %{name} condrestart >/dev/null 2>&1 || :
  109. fi
  110. %check
  111. %{__make} %{?_smp_mflags} check
  112. %clean
  113. %{__rm} -rf %{buildroot}
  114. %files
  115. %defattr(0755,root,root,0755)
  116. %{_sbindir}/%{name}
  117. %{_initrddir}/%{name}
  118. %{_libdir}/%{name}
  119. %defattr(0644,root,root,0755)
  120. %doc COPYING
  121. %doc AUTHORS README
  122. %doc doc/%{name}.txt doc/%{name}.ps doc/%{name}.html
  123. %doc %{_mandir}/man?/*
  124. %config(noreplace) %{_sysconfdir}/%{name}.conf
  125. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  126. %dir %{_localstatedir}/log/%{name}
  127. %exclude %{_libdir}/%{name}/*.la
  128. %exclude %{_libdir}/%{name}/%{name}_output_DBI.so
  129. %exclude %{_libdir}/%{name}/%{name}_output_MYSQL.so
  130. %exclude %{_libdir}/%{name}/%{name}_output_PGSQL.so
  131. %exclude %{_libdir}/%{name}/%{name}_output_PCAP.so
  132. %exclude %{_libdir}/%{name}/%{name}_output_SQLITE3.so
  133. %files libdbi
  134. %defattr(0755,root,root,0755)
  135. %{_libdir}/%{name}/%{name}_output_DBI.so
  136. %defattr(0644,root,root,0755)
  137. %doc COPYING
  138. %files mysql
  139. %defattr(0755,root,root,0755)
  140. %{_libdir}/%{name}/%{name}_output_MYSQL.so
  141. %defattr(0644,root,root,0755)
  142. %doc COPYING
  143. %files pgsql
  144. %defattr(0755,root,root,0755)
  145. %{_libdir}/%{name}/%{name}_output_PGSQL.so
  146. %defattr(0644,root,root,0755)
  147. %doc COPYING
  148. %files pcap
  149. %defattr(0755,root,root,0755)
  150. %{_libdir}/%{name}/%{name}_output_PCAP.so
  151. %defattr(0644,root,root,0755)
  152. %doc COPYING
  153. %files sqlite
  154. %defattr(0755,root,root,0755)
  155. %{_libdir}/%{name}/%{name}_output_SQLITE3.so
  156. %defattr(0644,root,root,0755)
  157. %doc COPYING
  158. %changelog
  159. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-3
  160. - rebuild with libdbi-0.9.0
  161. * Mon Jul 14 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-2
  162. - fixed configuration for logrotate.
  163. * Sun Jun 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
  164. - new upstream release.
  165. - initial build for Vine Linux.
  166. * Tue Sep 24 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-2
  167. - added accidentaly removed dist suffix in release
  168. - fixed up bogus dates in changelog
  169. * Mon Sep 09 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-1
  170. - update version
  171. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-5.beta4
  172. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  173. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4.beta4
  174. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  175. * Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-3.beta4
  176. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  177. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-2.beta4
  178. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  179. * Wed Nov 23 2011 Stephen Beahm <stephenbeahm@comcast.net> - 2.0.0-1.beta4
  180. - update version.
  181. - spec review.
  182. - (rebased on top of the remaining 1.24 changes, original date was Nov 16 2010)
  183. * Wed Mar 23 2011 Dan Horák <dan@danny.cz> - 1.24-15
  184. - rebuilt for mysql 5.5.10 (soname bump in libmysqlclient)
  185. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-14
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  187. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.24-13
  188. - rebuilt with new openssl
  189. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-12
  190. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  191. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-11
  192. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  193. * Sat Jan 24 2009 Aurelien Bompard <abompard@fedoraproject.org> 1.24-10
  194. - rebuild for mysql
  195. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.24-9
  196. - Autorebuild for GCC 4.3
  197. * Wed Jan 9 2008 Leopold Aichinger <linuxtrainer@gmx.at> 1.24-8
  198. - Support for libpcap added
  199. * Thu Dec 06 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.24-7
  200. - Rebuild for deps
  201. * Tue Aug 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-5
  202. - Fix the deprecated way of getting the DSO initializers run, causing
  203. builds to fails with rpm-build > 4.4.2.1-3 (new find-debuginfo.sh script)
  204. * Sat Jul 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-4
  205. - add patch to fix bug 247345
  206. - update URL
  207. - fix initscript (bug 247083)
  208. - unmark init script as %%config (Fedora policy)
  209. * Sat Dec 09 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-3
  210. - rebuild
  211. * Thu Aug 31 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-2
  212. - rebuild
  213. * Wed Feb 22 2006 Aurelien Bompard <gauret[AT]free.fr> 1.24-1
  214. - version 1.24
  215. - drop patch3 (applied upstream)
  216. - drop patch4 (upstream uses mysql-config to detect libdir now)
  217. - drop patch5 (applied upstream)
  218. * Tue Feb 21 2006 Aurelien Bompard <gauret[AT]free.fr> 1.23-3
  219. - rebuild for FC5
  220. * Sun Jul 24 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-2
  221. - compress rotated logs
  222. - start after mysql in the init process
  223. - use dist tag
  224. * Tue Apr 19 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-1.fc4
  225. - version 1.23
  226. - change release tag for FC4
  227. - add patch for GCC4 (upstream bug #323)
  228. * Thu Apr 07 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  229. - rebuilt
  230. * Wed Mar 09 2005 Aurelien Bompard <gauret[AT]free.fr> 1.22-1
  231. - version 1.22
  232. - add gpg signature to sources
  233. * Sun Feb 20 2005 Aurelien Bompard <gauret[AT]free.fr> 1.21-1
  234. - version 1.21
  235. * Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-8
  236. - revise x86_64 patch to remove more hardcoded /lib badness
  237. * Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-7
  238. - x86_64, patch configure to look for mysql/pgsql below %%_libdir.
  239. - delete undefined %%epoch in mysql/pgsql sub package dep.
  240. * Sun Oct 31 2004 Aurelien Bompard <gauret[AT]free.fr> 1.02-6
  241. - apply Michael Schwendt's suggestions in bug 1598
  242. * Wed Oct 20 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.5
  243. - enable MySQL and PostgreSQL in subpackages
  244. - add man page from Debian
  245. * Wed Oct 06 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.4
  246. - apply QA suggestions (bug 1598)
  247. * Sat Jul 10 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.3
  248. - disable parallel builds
  249. - add chkconfig to Requires(pre,post)
  250. - set the right mode for /etc/logrotate.d/ulogd
  251. - rotate weekly
  252. * Sun May 16 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.2
  253. - Add Epoch: 0