rrdtool-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234
  1. # Basic Information
  2. Name: rrdtool
  3. Version: 1.4.9
  4. Release: 2%{?_dist_release}
  5. License: GPLv2+ with exceptions
  6. Group: Applications/Databases
  7. URL: http://oss.oetiker.ch/rrdtool/
  8. Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
  9. Patch3: rrdtool-1.4.7-ruby-2-fix.patch
  10. Summary: RRDtool - Round Robin Database tool
  11. Summary(ja): RRDtool - ラウンドロビンデータベースツール
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. # Dependency
  14. BuildRequires: glib2-devel
  15. BuildRequires: glibc-devel
  16. BuildRequires: libdbi-devel
  17. BuildRequires: libxml2-devel
  18. BuildRequires: lua-devel
  19. BuildRequires: pango-devel
  20. BuildRequires: perl(ExtUtils::MakeMaker)
  21. BuildRequires: python-devel
  22. BuildRequires: ruby-devel
  23. BuildRequires: tcl
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. Packager: yasumichi
  27. %description
  28. It is pretty easy to gather status information from all sorts of things,
  29. ranging from the temperature in your office to the number of octets which
  30. have passed through the FDDI interface of your router. But it is not so
  31. trivial to store this data in a efficient and systematic manner. This is
  32. where RRDtool kicks in. It lets you log and analyze the data you gather from
  33. all kinds of data-sources (DS). The data analysis part of RRDtool is based
  34. on the ability to quickly generate graphical representations of the data
  35. values collected over a definable time period.
  36. #%%description -l ja
  37. %package devel
  38. Summary: Libraries and include files of RRDtool
  39. Group: Development/Libraries
  40. Requires: %{name} = %{version}-%{release}
  41. %description devel
  42. Libraries and include files of RRDtool
  43. %package doc
  44. Summary: RRDtool documentation
  45. Summary(ja): RRDtool のドキュメント
  46. Group: Applications/Documentation
  47. BuildArch: noarch
  48. %description doc
  49. RRD is the Acronym for Round Robin Database. RRD is a system to store and
  50. display time-series data (i.e. network bandwidth, machine-room temperature,
  51. server load average). This package contains documentation on using RRD.
  52. %package tcl
  53. Summary: RRDTool modules for tcl
  54. Group: Development/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. %description tcl
  57. RRDTool bindings for Tcl.
  58. %package -n perl-rrdtool
  59. Summary: Perl RRDtool bindings
  60. Summary(ja): RRDTool の perl バインディング
  61. Group: Development/Libraries
  62. Requires: %{name} = %{version}-%{release}
  63. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  64. %description -n perl-rrdtool
  65. The Perl RRDTool bindings.
  66. %package -n python-rrdtool
  67. Summary: Python RRDTool bindings
  68. Summary(ja): RRDTool の Python バインディング
  69. Group: Development/Libraries
  70. Requires: %{name} = %{version}-%{release}
  71. %description -n python-rrdtool
  72. RDTool bindings for python.
  73. %package -n ruby-rrdtool
  74. Summary: Ruby RRDTool bindings
  75. Summary(ja): RRDTool の ruby バインディング
  76. Group: Development/Libraries
  77. Requires: %{name} = %{version}-%{release}
  78. %description -n ruby-rrdtool
  79. RRDtool bindings for Ruby.
  80. %prep
  81. %setup -q
  82. %patch3 -p1 -b .ruby-2-fix
  83. %build
  84. %configure \
  85. --disable-rpath \
  86. --disable-static \
  87. --enable-perl-site-install \
  88. --with-perl-options="INSTALLDIRS=vendor" \
  89. --enable-ruby \
  90. --with-pic
  91. # Fix another rpath issue
  92. %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
  93. bindings/perl-shared/Makefile.PL
  94. # Remove Rpath from Ruby
  95. %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$\(EPREFIX\)/lib||g' \
  96. bindings/ruby/extconf.rb
  97. sed -i 's| extconf.rb| extconf.rb --vendor |' bindings/Makefile
  98. perl -pi -e 's/(rrdcached_LDADD =)/$1 \$(ALL_LIBS) /' src/Makefile
  99. %{__make} %{?_smp_mflags}
  100. %install
  101. %{__rm} -rf ${RPM_BUILD_ROOT}
  102. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  103. # Install ruby module by force
  104. mkdir -p $RPM_BUILD_ROOT/%{ruby_vendorarchdir}
  105. make -C bindings/ruby install DESTDIR=$RPM_BUILD_ROOT
  106. # We only want .txt and .html files for the main documentation
  107. rm -rf docs_to_be_included
  108. mkdir -p docs_to_be_included/html docs_to_be_included/txt
  109. mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html/* docs_to_be_included/html/
  110. mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/txt/* docs_to_be_included/txt/
  111. # Put perl docs in perl package
  112. rm -rf docs_perl
  113. mkdir -p docs_perl/html
  114. mv docs_to_be_included/html/RRD*.html docs_perl/html/
  115. # Clean up
  116. %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-*
  117. %{__rm} -f ${RPM_BUILD_ROOT}%{_prefix}/lib/lua/*/rrd.la
  118. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/librrd*.la
  119. %{__rm} -f ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
  120. %{__rm} -f ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/*/.packlist
  121. %clean
  122. %{__rm} -rf ${RPM_BUILD_ROOT}
  123. %post -p /sbin/ldconfig
  124. %postun -p /sbin/ldconfig
  125. %files
  126. %defattr(-,root,root)
  127. #doc COPYING NEWS README TODO
  128. %{_bindir}/rrd*
  129. %{_prefix}/lib/lua/*/rrd.so.*
  130. %{_libdir}/librrd*.so.*
  131. %{_mandir}/man1/*.1*
  132. %{_datadir}/rrdtool/examples/cgi-demo.cgi
  133. %files devel
  134. %defattr(-,root,root)
  135. %{_includedir}/rrd*.h
  136. %{_prefix}/lib/lua/*/rrd.so
  137. %{_libdir}/librrd.so
  138. %{_libdir}/librrd_th.so
  139. %{_libdir}/pkgconfig/librrd.pc
  140. %{_mandir}/man3/librrd.3*
  141. %files doc
  142. %defattr(-,root,root,-)
  143. %doc CONTRIBUTORS COPYING COPYRIGHT README TODO NEWS THREADS
  144. %doc docs_to_be_included/html docs_to_be_included/txt
  145. %files tcl
  146. %defattr(-,root,root)
  147. %doc bindings/tcl/README
  148. %{_datadir}/rrdtool/ifOctets.tcl
  149. %{_datadir}/rrdtool/pkgIndex.tcl
  150. %{_libdir}/tclrrd*.so
  151. %files -n perl-rrdtool
  152. %defattr(-,root,root)
  153. %{perl_vendorlib}/RRDp.pm
  154. %{perl_vendorarch}/RRDs.pm
  155. %{perl_vendorarch}/auto/RRDs/RRDs.bs
  156. %{perl_vendorarch}/auto/RRDs/RRDs.so
  157. %{_datadir}/rrdtool/examples/*.pl
  158. %{_datadir}/rrdtool/examples/rrdcached/RRDCached.pm
  159. %{_datadir}/rrdtool/examples/rrdcached/rrdcached-size.pl
  160. %{_mandir}/man3/RRD?.3pm*
  161. %files -n python-rrdtool
  162. %defattr(-,root,root)
  163. %doc bindings/python/AUTHORS bindings/python/COPYING bindings/python/README
  164. %{python_sitearch}/py_rrdtool-*-py*.egg-info
  165. %{python_sitearch}/rrdtoolmodule.so
  166. %files -n ruby-rrdtool
  167. %defattr(-,root,root,-)
  168. %doc bindings/ruby/README
  169. %{ruby_vendorarchdir}/RRD.so
  170. %changelog
  171. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-2
  172. - rebuild with libdbi-0.9.0
  173. * Mon Jan 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.9-1
  174. - new upstream release.
  175. - added Group tag to subpackages
  176. - added ruby subpackages
  177. - split documents into subpackages
  178. - added %%post and %%postun section
  179. * Tue Jul 1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-1
  180. - new upstream release.
  181. * Fri Feb 17 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4.7-1
  182. - initial build for Vine Linux