libdbi-drivers-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226
  1. Summary: Database-specific drivers for libdbi
  2. Name: libdbi-drivers
  3. Version: 0.9.0
  4. Release: 1%{?_dist_release}
  5. Group: Development/Libraries
  6. License: LGPLv2+
  7. URL: http://libdbi-drivers.sourceforge.net/
  8. Source: http://prdownloads.sourceforge.net/libdbi-drivers/%{name}-%{version}.tar.gz
  9. # old automake does not offer aarch64
  10. Patch1: libdbi-drivers-aarch64.patch
  11. Requires: libdbi >= 0.9
  12. BuildRequires: libdbi-devel >= 0.9
  13. BuildRequires: autoconf
  14. BuildRequires: openjade docbook-style-dsssl
  15. BuildRequires: docbook-style-dsssl
  16. BuildRequires: libmysqlclient-devel
  17. BuildRequires: openssl-devel
  18. BuildRequires: libpq-devel
  19. BuildRequires: krb5-devel
  20. BuildRequires: sqlite3-devel
  21. %description
  22. libdbi implements a database-independent abstraction layer in C, similar to the
  23. DBI/DBD layer in Perl. Writing one generic set of code, programmers can
  24. leverage the power of multiple databases and multiple simultaneous database
  25. connections by using this framework.
  26. libdbi-drivers contains the database-specific plugins needed to connect
  27. libdbi to particular database servers.
  28. %package -n libdbi-dbd-mysql
  29. Summary: MySQL plugin for libdbi
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}-%{release}
  32. %description -n libdbi-dbd-mysql
  33. This plugin provides connectivity to MySQL/MariaDB database servers through
  34. the libdbi database independent abstraction layer. Switching a program's
  35. plugin does not require recompilation or rewriting source code.
  36. %package -n libdbi-dbd-pgsql
  37. Summary: PostgreSQL plugin for libdbi
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. %description -n libdbi-dbd-pgsql
  41. This plugin provides connectivity to PostgreSQL database servers through the
  42. libdbi database independent abstraction layer. Switching a program's plugin
  43. does not require recompilation or rewriting source code.
  44. %package -n libdbi-dbd-sqlite
  45. Summary: SQLite plugin for libdbi
  46. Group: Development/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. %description -n libdbi-dbd-sqlite
  49. This plugin provides access to an embedded SQL engine using libsqlite3 through
  50. the libdbi database independent abstraction layer. Switching a program's plugin
  51. does not require recompilation or rewriting source code.
  52. %prep
  53. %setup -q -n %{name}-%{version}
  54. %patch1 -p1
  55. autoconf
  56. # mariadb provides headers in a subfolder <mysql/mysql.h>
  57. sed -i -r 's|<(mysql\.h)>|<mysql/\1>|' drivers/mysql/dbd_mysql.c
  58. # exporting LDFLAGS or LIBS or SQLITE3_LIBS before running autoconf or
  59. # ./configure doesn't help => hardcode it
  60. sed -i -r "s|(SQLITE3_LIBS=)-lsqlite[^[:space:]]*|\1$(pkg-config --libs-only-l sqlite3)|" \
  61. configure
  62. %build
  63. # configure is broken, must pass both --with-*sql-libdir _AND_
  64. # --with-*sql-incdir in order for --with-*sql-libdir to be used
  65. %configure --with-mysql --with-pgsql --with-sqlite3 \
  66. --with-mysql-libdir=%{_libdir}/mysql \
  67. --with-mysql-incdir=%{_includedir} \
  68. --with-pgsql-libdir=%{_libdir} \
  69. --with-pgsql-incdir=%{_includedir}/pgsql \
  70. --with-sqlite3-libdir=%{_libdir} \
  71. --with-sqlite3-incdir=%{_includedir} \
  72. --with-dbi-libdir=%{_libdir}
  73. make %{?_smp_mflags}
  74. %install
  75. make DESTDIR=$RPM_BUILD_ROOT install
  76. rm -f ${RPM_BUILD_ROOT}%{_libdir}/dbd/*.a
  77. rm -f ${RPM_BUILD_ROOT}%{_libdir}/dbd/*.la
  78. # package the docs via %%doc directives
  79. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
  80. %post -p /sbin/ldconfig
  81. %postun -p /sbin/ldconfig
  82. %files
  83. %doc AUTHORS ChangeLog COPYING README
  84. %doc drivers/mysql/dbd_mysql/*.html
  85. %doc drivers/mysql/*.pdf
  86. %doc drivers/pgsql/dbd_pgsql/*.html
  87. %doc drivers/pgsql/*.pdf
  88. %doc drivers/sqlite3/dbd_sqlite3/*.html
  89. %doc drivers/sqlite3/*.pdf
  90. %dir %{_libdir}/dbd
  91. %files -n libdbi-dbd-mysql
  92. %{_libdir}/dbd/libdbdmysql.*
  93. %files -n libdbi-dbd-pgsql
  94. %{_libdir}/dbd/libdbdpgsql.*
  95. %files -n libdbi-dbd-sqlite
  96. %{_libdir}/dbd/libdbdsqlite3.*
  97. %changelog
  98. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.9.0-1
  99. - initial build for Vine Linux based on fedora
  100. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-3
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  102. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  104. * Thu Jan 23 2014 Jan Pacner <jpacner@redhat.com> - 0.9.0-1
  105. - new release
  106. * Mon Jul 29 2013 Honza Horak <hhorak@redhat.com> 0.8.3-13
  107. - Spec file clean-up
  108. - Add support for aarch64
  109. * Tue Mar 5 2013 Tom Lane <tgl@redhat.com> 0.8.3-12
  110. - Remove unnecessary package-name Requires:, since dependencies on library
  111. sonames should be enough, and we don't want to hard-wire assumptions about
  112. which packages provide which libraries
  113. - isa-ify cross-subpackage Requires:
  114. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-11
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  116. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-10
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  118. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-9
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  120. * Tue Mar 22 2011 Tom Lane <tgl@redhat.com> 0.8.3-8
  121. - Rebuild for libmysqlclient 5.5.10 soname version bump
  122. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-7
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  124. * Fri Sep 3 2010 Tom Lane <tgl@redhat.com> 0.8.3-6
  125. - Do not use -ffast-math; it breaks things and seems quite unlikely to offer
  126. any useful performance benefit for this type of package, anyway
  127. Resolves: #629964
  128. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-5
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  130. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-4
  131. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  132. * Thu Jan 22 2009 Tom Lane <tgl@redhat.com> 0.8.3-3
  133. - Rebuild for mysql 5.1
  134. * Mon Sep 1 2008 Tom Lane <tgl@redhat.com> 0.8.3-2
  135. - Fix mistaken external reference in libdbdsqlite3.so. (I'm applying this
  136. as a patch, rather than updating to upstream's 0.8.3-1, because that isn't
  137. acceptable as an RPM Version tag.)
  138. Resolves: #460734
  139. * Mon Feb 11 2008 Tom Lane <tgl@redhat.com> 0.8.3-1
  140. - Update to version 0.8.3.
  141. - Code is now all licensed LGPLv2+, so adjust License tags.
  142. * Tue Oct 30 2007 Tom Lane <tgl@redhat.com> 0.8.2-1.3
  143. - Fix package's selection of CFLAGS to include RPM_OPT_FLAGS
  144. Resolves: #330691
  145. * Fri Aug 3 2007 Tom Lane <tgl@redhat.com> 0.8.2-1.2
  146. - Correct License tag for sqlite subpackage; it's currently not same license
  147. as the rest of the code.
  148. * Thu Aug 2 2007 Tom Lane <tgl@redhat.com> 0.8.2-1.1
  149. - Update to version 0.8.2-1.
  150. - Update License tag to match code.
  151. - Remove static libraries and .la files, per packaging guidelines.
  152. - Fix up packaging of documentation.
  153. * Mon Dec 11 2006 Tom Lane <tgl@redhat.com> 0.8.1a-2
  154. - Enable building of sqlite driver
  155. Resolves: #184568
  156. - Rebuild needed anyway for Postgres library update
  157. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1a-1.2.2
  158. - rebuild
  159. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1a-1.2.1
  160. - bump again for double-long bug on ppc(64)
  161. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1a-1.2
  162. - rebuilt for new gcc4.1 snapshot and glibc changes
  163. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  164. - rebuilt
  165. * Sat Nov 12 2005 Tom Lane <tgl@redhat.com> 0.8.1a-1
  166. - Update to version 0.8.1a.
  167. * Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.7.1-3
  168. - Rebuild for Postgres 8.0.2 (new libpq major version).
  169. * Fri Mar 11 2005 Tom Lane <tgl@redhat.com> 0.7.1-2
  170. - Packaging improvements per discussion with sopwith.
  171. * Thu Mar 10 2005 Tom Lane <tgl@redhat.com> 0.7.1-1
  172. - Import new libdbi version, splitting libdbi-drivers into a separate SRPM
  173. so we can track new upstream packaging.