lilypond-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349
  1. %define buildinfo yes
  2. %define name lilypond
  3. %define iconsdir /usr/share/pixmaps
  4. %define infodir %{_infodir}/%{name}
  5. Summary: A typesetting system for music notation
  6. Summary(ja):楽譜作成プログラム
  7. Group: Applications/Publishing
  8. Name: %{name}
  9. Version: 2.18.2
  10. Release: 1%{?_dist_release}
  11. License: GPLv2
  12. URL: http://www.lilypond.org/
  13. Source0: http://download.linuxaudio.org/lilypond/sources/v2.12/%{name}-%{version}.tar.gz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. ## from fc11
  16. Patch12: lilypond-2.21.2-gcc44-relocate.patch
  17. BuildRequires: t1utils ImageMagick-devel gettext texlive-common
  18. BuildRequires: gcc-c++
  19. BuildRequires: bison flex m4
  20. BuildRequires: python-devel >= 2.4.0
  21. BuildRequires: mftrace >= 1.1.19
  22. BuildRequires: texinfo >= 4.8
  23. BuildRequires: texi2html
  24. BuildRequires: guile18-devel >= 1.8
  25. BuildRequires: ghostscript >= 8.15
  26. BuildRequires: pango-devel >= 1.12.0
  27. BuildRequires: rsync
  28. BuildRequires: texlive-collection-metapost
  29. BuildRequires: texlive-collection-genericrecommended
  30. BuildRequires: dblatex
  31. BuildRequires: potrace >= 1.3
  32. BuildRequires: netpbm-progs
  33. BuildRequires: which
  34. BuildRequires: glibc-devel groff
  35. BuildRequires: fontforge
  36. %description
  37. LilyPond is a music typesetter. It produces beautiful sheet music using a
  38. high level description file as input. Lilypond is part of the GNU project.
  39. LilyPond is split into two packages. The package "lilypond" provides the
  40. core package, containing the utilities for converting the music source
  41. (.ly) files into printable output. The package "lilypond-documentation"
  42. provides the full documentation, example .ly files for various features and
  43. the Mutopia project files (musical equivalent of the Gutenberg project - see
  44. http://www.mutopiaproject.org for details).
  45. If you are new to lilypond, you will almost certainly want to install the
  46. "lilypond-documentation" package in addition to the "lilypond" package.
  47. %description -l ja
  48. LilyPond は GNU プロジェクトで開発されている楽譜作成ソフトです。高解像度の
  49. とてもきれいな楽譜を作ることができます。
  50. LiLyPond は2つのパッケージにわかれています。"lilypond"パッケージがメインパッ
  51. ケージ"で、楽譜ソースファイル(.ly)を印刷可能な形式に変換するプログラムが入っ
  52. てます。tex, html等に簡単に楽譜を挿入するための lilypond-book コマンドもあり
  53. ます.(Vine用パッケージでは,platexでの利用も可能に変更してあります.)
  54. "lilypond-documentation" にはマニュアルやいろいろなサンプルファイル(.ly)、
  55. Mutopiaプロジェクトによるいつくかのファイルが入ってます。Mutopia プロジェクト
  56. (musical equivalent of the Gutenberg project)については
  57. http://www.mutopiaproject.orgを見てください。
  58. %package -n liblilypond
  59. Summary: Lilypond libraries
  60. Summary(ja): Lilypond ライブラリ
  61. Group: System Environment/Libraries
  62. Requires: lilypond >= %{version}
  63. %description -n liblilypond
  64. Lilypond libs
  65. %package documentation
  66. Summary: LilyPond documentation, examples and Mutopia files.
  67. Summary(ja): LilyPond のマニュアル, サンプル,Mutopiaファイル
  68. Group: Applications/Documentation
  69. Requires: %{name}
  70. %description documentation
  71. The documentation of LilyPond, both in HTML and PostScript, along with
  72. example input files and the files from the Mutopia project.
  73. %description documentation -l ja
  74. LiLyPond のマニュアルです.HTML ,PostScript, PDF の形式のものがあります.
  75. サンプルや Mutopiaプロジェクトによるファイルも入ってます.
  76. %prep
  77. rm -rf $RPM_BUILD_ROOT
  78. %setup -q
  79. # from fc11
  80. %patch12 -p0
  81. %build
  82. sed -i "s|guile-config|guile-config-1.8|g" aclocal.m4
  83. autoconf
  84. %configure \
  85. --without-kpathsea \
  86. --disable-checking \
  87. --with-ncsb-dir=%{_datadir}/fonts/default/Type1
  88. %{__make}
  89. %install
  90. %{__rm} -rf %{buildroot}
  91. make install DESTDIR=$RPM_BUILD_ROOT package_infodir=%{_infodir} vimdir=%{_datadir}/vim/vim74
  92. chmod +x $RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}/python/midi.so
  93. # Symlink lilypond-init.el in emacs' site-start.d directory
  94. pushd $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
  95. mkdir site-start.d
  96. ln -s ../lilypond-init.el site-start.d
  97. popd
  98. # Change encoding to UTF8
  99. pushd $RPM_BUILD_ROOT%{_infodir}
  100. iconv -f iso-8859-1 -t utf-8 music-glossary.info > music-glossary.info.utf8
  101. mv music-glossary.info.utf8 music-glossary.info
  102. sed -e s,lilypond/,, -i *.info
  103. popd
  104. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  105. %find_lang %{name}
  106. mkdir -p $RPM_BUILD_ROOT%{_fontdir}
  107. mv $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf/*.otf $RPM_BUILD_ROOT%{_fontdir}
  108. rmdir $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf
  109. ln -s %{_fontdir} $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf
  110. %clean
  111. %{__rm} -rf %{buildroot}
  112. %files -f %{name}.lang
  113. %defattr(-, root, root)
  114. %doc AUTHORS.txt COPYING DEDICATION INSTALL.txt NEWS.txt README.txt
  115. %doc ROADMAP THANKS
  116. %{_datadir}/emacs/site-lisp/site-start.d/%{name}-init.el
  117. %{_datadir}/emacs/site-lisp/lilypond*
  118. %{_bindir}/*
  119. %{_infodir}/*
  120. %{_mandir}/man1/*
  121. %{_datadir}/%{name}/%{version}/
  122. %{_datadir}/vim/vim*
  123. %files -n liblilypond
  124. %defattr(-,root,root)
  125. %{_libdir}/%{name}/%{version}/python/*.so
  126. %files documentation
  127. %defattr(-, root, root)
  128. %{_docdir}/*
  129. %changelog
  130. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.2-1
  131. - update to 2.18.2
  132. - change BuildRequires: texlive-common instead of tetex
  133. - change BuildRequires: guile18-devel instead of guile-devel
  134. - remove Patch0,10,13
  135. - add BuildRequires: texlive-collection-metapost, texlive-collection-genericrecommended, rsync, dblatex, texi2html
  136. * Thu Apr 22 2010 Shu KONNO <owa@bg.wakwak.com> 2.12.3-1
  137. - updated LilyPond to 2.12.3
  138. - applied new versioning policy, spec in utf-8
  139. - dropt Patch0: lilypond-platex-2.4.5.patch
  140. - imported patch from fc11
  141. Patch10: lilypond-2.11.65-python26.patch
  142. Patch12: lilypond-2.21.2-gcc44-relocate.patch
  143. Patch13: lilypond-consts.patch
  144. - replaced build, install, pre/post scripts (from fc11)
  145. * Sun Jul 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl2
  146. - rebuilt for VineSeed
  147. * Sat Mar 12 2005 Jun NISHII <jun@vinelinux.org> 2.4.5-0vl1
  148. - build on Vine 3.1
  149. * Wed Mar 24 2004 Jun Nishii <jun@vinelinux.org> 2.0.3-0vl1
  150. - build for Vine Linux
  151. - many fixes in post/postun scripts
  152. * Fri Mar 12 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.30-1thac
  153. - Updated to latest devel release
  154. * Wed Mar 10 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.29-1thac
  155. - Updated to latest devel release
  156. * Wed Feb 25 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.27-1thac
  157. - Updated to latest devel release
  158. * Thu Feb 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.25-1thac
  159. - Updated to latest devel release
  160. * Tue Feb 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.24-1thac
  161. - Updated to latest devel release
  162. * Fri Feb 13 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.21-1thac
  163. - Updated to latest devel release
  164. - Built against latest pfaedit-040211 and mftrace-1.0.27
  165. - Added requirement for potrace
  166. * Mon Feb 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.20-1thac
  167. - Updated to latest devel release
  168. * Tue Jan 27 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.15-1thac
  169. - Updated to latest devel release
  170. * Sat Jan 24 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.14-1thac
  171. - Updated to latest devel release
  172. * Mon Jan 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.12-1thac
  173. - Updated to latest devel release
  174. * Sun Jan 18 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.11-1thac
  175. - Updated to latest devel release
  176. * Sat Jan 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.10-1thac
  177. - Updated to latest devel release
  178. * Thu Jan 15 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.9-1thac
  179. - Updated to latest devel release
  180. * Fri Jan 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.8-1thac
  181. - Updated to latest devel release
  182. * Tue Jan 06 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.7-1thac
  183. - Updated to latest devel release
  184. * Mon Jan 05 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.6-1thac
  185. - Updated to latest devel release
  186. * Fri Jan 02 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.4-1thac
  187. - Updated to latest devel release
  188. * Sun Dec 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.3-1thac
  189. - Updated to latest devel release
  190. * Sun Dec 21 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.2-1thac
  191. - Updated to latest devel release
  192. * Wed Dec 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.1-1thac
  193. - Updated to latest devel release
  194. * Thu Oct 30 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-2thac
  195. - Rebuilt for Mandrake 9.2
  196. * Fri Oct 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-1thac
  197. - Updated to latest devel release
  198. * Mon Oct 06 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.1-1thac
  199. - Updated to latest devel release
  200. * Thu Sep 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.0-1thac
  201. - Updated to latest devel release
  202. - removed lilypond-words
  203. * Tue Sep 23 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.9-1thac
  204. - Updated to latest devel release
  205. - fixed lilypond.word install
  206. * Wed Sep 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.6-1thac
  207. - Updated to latest devel release
  208. * Thu Sep 11 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.5-1thac
  209. - Updated to latest devel release
  210. - Built against pyton2.3
  211. * Mon Sep 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.4-1thac
  212. - Updated to latest devel release
  213. * Sun Aug 31 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.3-1thac
  214. - Updated to latest devel release
  215. * Thu Aug 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.2-1thac
  216. - Updated to latest devel release
  217. * Wed Aug 27 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.1-1thac
  218. - Updated to latest devel release
  219. - Changed naming to differ from Mandrake cooker
  220. * Mon Aug 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-3mdk
  221. - Fixed documentation path
  222. - Added some of Heikki Johannes Junes suggestions
  223. * Sun Aug 24 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-2mdk
  224. - Added Heikki Johannes Junes fix for confilcting PHP variable
  225. out=/dev/vc/ by adding unset out before compiling
  226. - Compiled with recent guile = 1.6.4 and mftrace = 1.0.17
  227. - Changed icon to lilypond.png
  228. - Added menu and icons again
  229. * Sat Aug 23 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.8.1-1mdk
  230. - removed menu and icons, sync with redhat-spec
  231. * Thu Jun 12 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.23-1mdk
  232. - refreshed dependencies and file list.
  233. * Sat Feb 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.7.12-1mdk
  234. - Built for Mandrake 9.1
  235. * Sun Dec 01 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.9-1mdk
  236. - set menu-items to lilypond-info and lilypond-documentation.
  237. * Sat Nov 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.8-4mdk
  238. - add pre/post-dependencies and menus with icon from source.
  239. * Mon Oct 28 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.4-1mdk
  240. - info, commented menu
  241. * Fri Aug 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.6.0-1mdk
  242. - Adapted from lilypond.redhat.skel and skeleton found in Mandrake's RPM-docs.
  243. - TODO: info (?) and dependencies.
  244. * Fri Jun 01 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.4.2-1mdk
  245. - updated by Michael Brown <mbrown@linux-mandrake.com> :
  246. - Upgraded to 1.4.2
  247. - Changed URL
  248. - Removed /etc/profile.d scripts: all TeX bits are now located properly
  249. - Rearranged documentation
  250. - Tidied spec file
  251. - Updated README.first
  252. * Mon Feb 26 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.3.129-1mdk
  253. - added in contribs by Michael Brown <mbrown@fensystems.co.uk> :
  254. - Removed info files completely (couldn't get info reader to read them)
  255. - TODO: Get this to work at some point (in the meantime, use documentation in lilypond-extras)
  256. * Sat Feb 17 2001 Michael Brown <mbrown@fensystems.co.uk>
  257. - Moved TeX font folders into the system TeX tree (this ensures that the /var/lib/texmf font cache is used instead of current folder)
  258. - Added mktexlsr to post-install and post-uninstall scripts
  259. - Patched scripts in /etc/profile.d to reflect changes to font locations
  260. - Added QuickStart guide and Points to note sections to README.first (well worth reading)
  261. - Fixed install-info and uninstall-info sections to use Mandrake's RPM macros :-)
  262. * Tue Feb 13 2001 Michael Brown <mbrown@fensystems.co.uk>
  263. - First Mandrake package
  264. - spec file heavily adapted from PowerPC contribs.
  265. - Note HTML documentation may contain duff links and may be incomplete. Lots of warnings appear when building HTML docs.
  266. - PostScript documentation is duplicated (how do you get an rpm package to contain a symlink?)
  267. - Created README.first file