guile-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define mver 2.0
  3. Name: guile
  4. Summary: A GNU implementation of Scheme for application extensibility.
  5. Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
  6. Version: 2.0.11
  7. Release: 1%{?_dist_release}
  8. Group: Development/Languages
  9. License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
  10. URL: http://www.gnu.org/software/guile/
  11. Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.gz
  12. # following patchs are imported from fedora-dev
  13. Patch1: guile-1.8.7-multilib.patch
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
  16. BuildRequires: gmp-devel readline-devel emacs
  17. BuildRequires: libunistring-devel
  18. BuildRequires: libffi-devel
  19. BuildRequires: gc-devel
  20. Requires(post): /sbin/install-info
  21. Requires(preun): /sbin/install-info
  22. Requires: coreutils
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. Packager: yasumichi
  26. %description
  27. GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
  28. implementation of the Scheme programming language, written in C. GUILE
  29. provides a machine-independent execution platform that can be linked in
  30. as a library during the building of extensible programs.
  31. Install the guile package if you'd like to add extensibility to programs
  32. that you are developing.
  33. %package devel
  34. Summary: Libraries and header files for the GUILE extensibility library.
  35. Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: gmp-devel
  39. Requires: gc-devel
  40. %description devel
  41. The guile-devel package includes the libraries, header files, etc.,
  42. that you'll need to develop applications that are linked with the
  43. GUILE extensibility library.
  44. You need to install the guile-devel package if you want to develop
  45. applications that will be linked to GUILE. You'll also need to
  46. install the guile package.
  47. %package -n compat32-%{name}
  48. Summary: A GNU implementation of Scheme for application extensibility.
  49. Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
  50. Group: Development/Languages
  51. Requires: %{name} = %{version}-%{release}
  52. %description -n compat32-%{name}
  53. GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
  54. implementation of the Scheme programming language, written in C. GUILE
  55. provides a machine-independent execution platform that can be linked in
  56. as a library during the building of extensible programs.
  57. Install the guile package if you'd like to add extensibility to programs
  58. that you are developing.
  59. %package -n compat32-%{name}-devel
  60. Summary: Libraries and header files for the GUILE extensibility library.
  61. Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
  62. Group: Development/Libraries
  63. Requires: %{name}-devel = %{version}-%{release}
  64. Requires: compat32-%{name} = %{version}-%{release}
  65. Requires: compat32-gmp-devel
  66. Requires: compat32-gc-devel
  67. %description -n compat32-%{name}-devel
  68. The guile-devel package includes the libraries, header files, etc.,
  69. that you'll need to develop applications that are linked with the
  70. GUILE extensibility library.
  71. You need to install the guile-devel package if you want to develop
  72. applications that will be linked to GUILE. You'll also need to
  73. install the guile package.
  74. %prep
  75. %setup -q
  76. %patch1 -p1 -b .multilib
  77. %build
  78. %configure --disable-static --disable-error-on-warning
  79. # Remove RPATH
  80. sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
  81. libtool
  82. make %{?_smp_mflags}
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. make DESTDIR=$RPM_BUILD_ROOT install
  86. mkdir -p $RPM_BUILD_ROOT%{_datadir}/guile/site/%{mver}
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.la
  88. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  89. # Our gdb doesn't support guile yet
  90. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libguile*gdb.scm
  91. # Compress large documentation
  92. bzip2 NEWS
  93. for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
  94. iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
  95. done
  96. %clean
  97. rm -rf $RPM_BUILD_ROOT
  98. %post
  99. /sbin/ldconfig
  100. /sbin/install-info %{_infodir}/guile.info.gz %{_infodir}/dir
  101. /sbin/install-info %{_infodir}/r5rs.info.gz %{_infodir}/dir
  102. %postun -p /sbin/ldconfig
  103. %preun
  104. if [ "$1" = 0 ]; then
  105. /sbin/install-info --delete %{_infodir}/guile.info.gz %{_infodir}/dir
  106. /sbin/install-info --delete %{_infodir}/r5rs.info.gz %{_infodir}/dir
  107. fi
  108. :
  109. %post -n compat32-%{name} -p /sbin/ldconfig
  110. %postun -n compat32-%{name} -p /sbin/ldconfig
  111. %files
  112. %defattr(-,root,root,-)
  113. %doc AUTHORS COPYING* ChangeLog HACKING NEWS.bz2 README THANKS
  114. %{_bindir}/guild
  115. %{_bindir}/guile
  116. %{_bindir}/guile-tools
  117. %{_libdir}/libguile*.so.*
  118. %{_libdir}/libguilereadline-*.so
  119. %dir %{_libdir}/guile/%{mver}
  120. %{_libdir}/guile/%{mver}/ccache
  121. %dir %{_datadir}/guile
  122. %dir %{_datadir}/guile/%{mver}
  123. %{_datadir}/guile/%{mver}/*.scm
  124. %{_datadir}/guile/%{mver}/ice-9
  125. %{_datadir}/guile/%{mver}/language
  126. %{_datadir}/guile/%{mver}/oop
  127. %{_datadir}/guile/%{mver}/rnrs
  128. %{_datadir}/guile/%{mver}/scripts
  129. %{_datadir}/guile/%{mver}/srfi
  130. %{_datadir}/guile/%{mver}/sxml
  131. %{_datadir}/guile/%{mver}/system
  132. %{_datadir}/guile/%{mver}/texinfo
  133. %{_datadir}/guile/%{mver}/web
  134. %{_datadir}/guile/%{mver}/guile-procedures.txt
  135. %dir %{_datadir}/guile/site
  136. %{_infodir}/*
  137. %{_mandir}/man1/guile.1*
  138. %files devel
  139. %defattr(-,root,root,-)
  140. %{_bindir}/guile-config
  141. %{_bindir}/guile-snarf
  142. %{_datadir}/aclocal/*
  143. %{_libdir}/libguile-%{mver}.so
  144. %{_libdir}/pkgconfig/*.pc
  145. %{_includedir}/guile/%{mver}
  146. # compat32
  147. %if %{build_compat32}
  148. %files -n compat32-%{name}
  149. %defattr(-,root,root,-)
  150. %{_libdir}/libguile*.so.*
  151. %{_libdir}/libguilereadline-*.so
  152. %files -n compat32-%{name}-devel
  153. %defattr(-,root,root,-)
  154. %{_libdir}/libguile-%{mver}.so
  155. %endif
  156. %changelog
  157. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.11-1
  158. - update to 2.0.11
  159. - add BuildRequires: libunistring-devel, libffi-devel, gc-devel
  160. - remove Patch2,4
  161. * Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-1
  162. - update to 1.8.8
  163. - remove Patch3,5,6 (guile-1.8.7-ia64jmp.patch)
  164. * Sat Oct 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-2
  165. - rebuilt with rpm-4.8.1
  166. - added Patch1, 2, 3, 5 and 6 from Fedora
  167. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
  168. - new upstream release.
  169. - comment out Patch11,12.
  170. * Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
  171. - added Requires: gmp-devel to guile-devel
  172. * Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
  173. - added compat32 package for x86_64 arch support
  174. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
  175. - rebuild with libtool-2.2.6a
  176. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
  177. - new upstream release
  178. - import some patches from fedora development
  179. - drop some old patches
  180. - update spec based on fedora package
  181. - spec in utf-8
  182. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
  183. - use macro for Release
  184. * Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
  185. - apply new virsioning policy.
  186. - remove *.la
  187. * Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
  188. - rebuilt with readline 5.1
  189. * Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
  190. - added Patches from Fedora
  191. * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
  192. - Fix dynamic linking on 64bit archs (#159971)
  193. * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
  194. - Moved info files to base package as they are not devel related (#139948)
  195. - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
  196. - Fixed guile-tools not finding guile lib dir (#142642)
  197. - Added some nice tools (#142642)
  198. - Removed smp build, seems to be broken atm
  199. * Fri Jan 7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
  200. - new upstream release
  201. - dropped patch2, 4, 6
  202. - added BuildPrereq: perl
  203. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
  204. - rebuild with new toolchains
  205. - s/Copyright/License/
  206. - added srfi libs
  207. - patch for ppc64 from Fedora package
  208. * Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
  209. - update to 1.6.4
  210. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
  211. - rebuild with readline-4.3
  212. * Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
  213. - based on Rawhide 1.6.0-4
  214. - Included s390 as working arch as well, switch to general unknown arch patch
  215. - rebuild to fix broken deps
  216. - fix continuations.h on ia64
  217. - new upstream 1.6.3
  218. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
  219. - porting for Vine Linux
  220. - remove 1.3 patches( not required so that upstream upgrade )
  221. * Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  222. - Add version number to prereq for umb-scheme to get the post-install to
  223. work properly.
  224. * Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
  225. - Add an Epoch = 1 in case anyone happened to have 1.4 installed.
  226. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  227. - automatic rebuild
  228. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  229. - Back down to 1.3.4.
  230. - Fix to actually link against the version of libguile in the package.
  231. * Sun Jun 4 2000 Nalin Dahyabhai <nalin@redhat.com>
  232. - FHS fixups using the %%{makeinstall} macro.
  233. * Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  234. - fix preun-devel
  235. - call ldconfig directly in postun
  236. * Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  237. - rebuild with new readline
  238. - update to 1.3.4
  239. * Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  240. - using the same catalog as umb-scheme makes umb-scheme a prereq
  241. * Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  242. - readline is needed for %post
  243. * Tue Feb 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  244. - use the same catalog as umb-scheme
  245. * Thu Sep 2 1999 Jeff Johnson <jbj@redhat.com>
  246. - fix broken %postun
  247. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  248. - auto rebuild in the new build environment (release 6)
  249. * Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
  250. - added .ansi patch to fix #endif
  251. * Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
  252. - add patch for the scm stuff
  253. * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
  254. - integrate changes from rhcn version (#640)
  255. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  256. - call libtoolize first to get it to compile on the arm
  257. * Sat Jan 9 1999 Todd Larason <jtl@molehill.org>
  258. - Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
  259. * Fri Jan 1 1999 Todd Larason <jtl@molehill.org>
  260. - guile-devel does depend on guile
  261. - remove devel dependancy on m4
  262. - move guile-snarf from guile to guile-devel
  263. - Converted to rhcn
  264. * Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
  265. - update to 1.3.
  266. - don't strip libguile.so.*.0.0. (but set the execute bits).
  267. * Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
  268. - spec file fixups
  269. * Wed Sep 2 1998 Michael Fulbright <msf@redhat.com>
  270. - Updated for RH 5.2
  271. * Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
  272. - Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
  273. - added slib link
  274. * Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl> (1.2-3)
  275. - added %attr(-, root, root) for %doc,
  276. - in %post, %postun ldconfig runed as parameter "-p",
  277. - removed /bin/sh from requires,
  278. - added %description,
  279. - changes in %files.
  280. * Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl> (1.2-2)
  281. - all rewrited for using Buildroot,
  282. - added %postun,
  283. - removed making buid logs,
  284. - removed "--inclededir", added "--enable-dynamic-linking" to configure
  285. parameters,
  286. - added striping shared libs and /usr/bin/guile,
  287. - added "Requires: /bin/sh" (for guile-snarf) in guile package and
  288. "Requires: m4" for guile-devel,
  289. - added macro %{PACKAGE_VERSION} in "Source:" and %files,
  290. - added %attr macros in %files.