gnucash-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265
  1. %define ver 2.6.5
  2. %define rel 1%{?_dist_release}
  3. %define __libtoolize /bin/true
  4. Name: gnucash
  5. Summary: GnuCash is an application to keep track of your finances.
  6. Summary(ja): 個人用財務管理アプリケーション
  7. Version: %{ver}
  8. Release: %{rel}
  9. License: GPL/LGPL/GFDL
  10. Group: Applications/Productivity
  11. URL: http://www.gnucash.org/
  12. Source: %{name}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: aqbanking-devel >= 3.7.2
  15. BuildRequires: bzip2-devel
  16. BuildRequires: expat-devel
  17. BuildRequires: gettext
  18. BuildRequires: goffice08-devel >= 0.8
  19. BuildRequires: gtk2-devel
  20. BuildRequires: WebKit-gtk-devel
  21. BuildRequires: guile-devel
  22. BuildRequires: libofx-devel
  23. BuildRequires: libgnomeui-devel
  24. BuildRequires: libdbi-devel
  25. BuildRequires: libjpeg-devel
  26. BuildRequires: pcre-devel
  27. BuildRequires: popt-devel
  28. BuildRequires: swig
  29. #BuildRequires: slib
  30. BuildRequires: gwenhywfar-devel
  31. BuildRequires: desktop-file-utils
  32. BuildRequires: libdbi-dbd-pgsql
  33. BuildRequires: libdbi-dbd-mysql
  34. BuildRequires: libdbi-dbd-sqlite
  35. Requires: aqbanking
  36. Requires: perl-DateManip
  37. Requires: yelp
  38. Requires(post,postun): gtk2
  39. Requires(postun,posttrans): glib2
  40. Obsoletes: gnucash-backend-postgres
  41. Packager: kenta, inagaki
  42. %description
  43. GnuCash is a personal finance manager. A check-book like
  44. register GUI allows you to enter and track bank accounts,
  45. stocks, income and even currency trades. The interface is
  46. designed to be simple and easy to use, but is backed with
  47. double-entry accounting principles to ensure balanced books.
  48. %description -l ja
  49. GnuCashは 個人用財務管理をするアプリケーションです.
  50. 預金, 株式, 所得そして通貨取引さえ入力し、追跡することができる
  51. グラフィカルな小切手帖です.インターフェスはシンプルかつ簡単に
  52. 使用できるようにデザインされています.
  53. %prep
  54. %setup -q
  55. %build
  56. %configure \
  57. --enable-error-on-warning=no \
  58. --disable-sql \
  59. --enable-ofx \
  60. --enable-aqbanking \
  61. --disable-static \
  62. --enable-dbi \
  63. --with-html-engine=webkit \
  64. --docdir=%{_datadir}/doc/gnucash-%{version}
  65. make LIBTOOL=%{_bindir}/libtool
  66. %configure
  67. make
  68. %install
  69. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  70. make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
  71. %find_lang %name
  72. # vfolder desktop file install stuff
  73. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/applications/
  74. desktop-file-install --vendor gnome --delete-original \
  75. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  76. --add-category X-Red-Hat-Extra \
  77. --add-category Application \
  78. --add-category Office \
  79. $RPM_BUILD_ROOT%{_datadir}/applications/gnucash.desktop
  80. echo "StartupWMClass=GnuCash" >> $RPM_BUILD_ROOT%{_datadir}/applications/gnome-gnucash.desktop
  81. rm -rf $RPM_BUILD_ROOT/%{_infodir} \
  82. $RPM_BUILD_ROOT/%{_includedir} \
  83. $RPM_BUILD_ROOT/%{_libdir}/lib*.a \
  84. $RPM_BUILD_ROOT/%{_libdir}/gnucash/lib*.a
  85. %clean
  86. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  87. %post
  88. /sbin/ldconfig
  89. touch --no-create %{_datadir}/icons/hicolor || :
  90. gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
  91. %postun
  92. if [ $1 -eq 0 ] ; then
  93. /sbin/ldconfig
  94. touch --no-create %{_datadir}/icons/hicolor || :
  95. gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
  96. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  97. fi
  98. %posttrans
  99. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  100. %files -f %{name}.lang
  101. %defattr(-,root,root,755)
  102. %config %{_sysconfdir}/%{name}
  103. %{_bindir}/*
  104. %{_libexecdir}/%{name}
  105. %{_libdir}/*
  106. %{_datadir}/appdata/%{name}.appdata.xml
  107. %{_datadir}/applications/*
  108. %{_datadir}/glib-2.0/schemas/*.xml
  109. %{_datadir}/%{name}
  110. %{_datadir}/icons/hicolor/*/apps/*
  111. %{_docdir}/%{name}
  112. %{_mandir}/man*/*
  113. %doc AUTHORS COPYING ChangeLog* DOCUMENTERS HACKING NEWS README
  114. %doc doc/README.german doc/README.francais doc/guile-hackers.txt
  115. %doc doc/README.OFX
  116. %changelog
  117. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  118. - update to 2.6.5
  119. - remove old patches
  120. - add BuildRequires: libdbi-devel
  121. - change BuildRequires: goffice08-devel instead of goffice-devel
  122. * Tue Sep 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3
  123. - rebuilt with new toolchain, aqbanking-4.2.4, goffice-0.8.10
  124. - added Patch1 for building with aqbanking-4.2.4
  125. - added Patch2 for building with goffice-0.8.10
  126. * Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-2
  127. - added slib to BuildRequires: and Requires:
  128. * Sat May 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-1
  129. - new upstream release
  130. * Wed Jan 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.8-1
  131. - new upstream release
  132. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.7-2
  133. - rebuild with guile-1.8.6
  134. - add BuildRequires: gwenhywfar-devel
  135. * Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-1
  136. - new upstream release
  137. - applied new versioning policy
  138. - built with aqbanking-3.7.2, gwenheyfar-3.4.1, libofx-0.9.0
  139. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
  140. - new upstream release
  141. - rebuilt with goffice-0.6.0
  142. * Tue Jan 22 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl1
  143. - new upstream release
  144. * Sun Jan 20 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.2-0vl1
  145. - new upstream release
  146. - enable HBCI (Home Banking Computer Interface)
  147. * Tue Jan 08 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl2
  148. - rebuild with libofx-0.8.3 (libofx.so.3)
  149. * Sun Dec 30 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl1
  150. - new upstream release
  151. - disable postgresql backend, as it is unmaintained upstream
  152. - added Patch0: gnucash-2.2.0-quiet.patch
  153. * Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.12-0vl1
  154. - new upstream release
  155. - remove BuildRequiers: autoconf213
  156. - update ja.po
  157. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
  158. - new upstream release
  159. - added BuildPrereq: libtool-ltdl-devel
  160. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
  161. - rebuild with new toolchains
  162. - update ja.po
  163. * Sun Nov 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl1
  164. - new upstream release
  165. * Sun Oct 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-1vl1
  166. - merged gnucash-docs-1.8.3
  167. - added patch from Redhat Rawhide 1.8.7-1
  168. - changed Group, License
  169. * Mon Oct 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-0vl1
  170. - updated to 1.8.7
  171. - updated print.patch
  172. - overwrite prefs.scm
  173. - s/Copyright/License/
  174. * Tue May 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
  175. - updated to 1.8.3
  176. - added datelength.patch
  177. - separated devel packages
  178. (and ofx, hbci, backend-postgres. But default is off)
  179. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl3
  180. - Build against with new gal.
  181. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl2
  182. - Fixed printing issue.
  183. * Tue Dec 25 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl1
  184. - New upstream release.
  185. * Thu Jul 26 2001 <sagami@vinelinux.org>
  186. - 1.6.0-0vl3: fix to not to own mandir itself, use %%{find_lang}
  187. * Tue Jun 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  188. - %%make line is now commented out (bash2 complains it)
  189. (BTW, what the hell is the macro %%make anyway? I don't even know...)
  190. * Tue Jun 12 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  191. - update to 1.6.0 (stable release version)
  192. * Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.96-0vl1
  193. - update to 1.5.96 ( pre beta for 1.6.0 )
  194. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl2
  195. - added japanese patch for reporting and printing (thanx tagoh-san)
  196. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl1
  197. - updated to 1.5.6
  198. * Thu Apr 05 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.4-1vl2
  199. - added translation messages to ja.po
  200. - enable guppi
  201. * Mon Apr 2 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.4-1vl1
  202. - upstream update
  203. - fixed broken ja.po
  204. * Wed Mar 28 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl2
  205. - fixed registor window cursor position problem(gnucash-cursor_pos.patch)
  206. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl1
  207. - initial relese package