g-wrap-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205
  1. %define ver 1.9.14
  2. %define rel 3%{?_dist_release}
  3. Summary: A tool for creating Scheme interfaces to C libraries.
  4. Summary(ja): C ライブラリへの Scheme 言語インタフェースを作成するツール
  5. Name: g-wrap
  6. Version: %{ver}
  7. Release: %{rel}
  8. Group: Development/Libraries
  9. License: GPL
  10. URL: http://www.gnucash.org/
  11. Source: ftp://ftp.gnucash.org/pub/g-wrap/%{name}-%{version}.tar.gz
  12. # upstream patch
  13. Patch0: g-wrap-1.9.14-guile-2.0.patch
  14. Requires: guile
  15. BuildRequires: guile-devel, libffi-devel
  16. BuildRequires: glib2-devel
  17. Requires(pre): /sbin/install-info /sbin/ldconfig
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. %description
  22. g-wrap is a tool for creating Scheme interfaces to C libraries. At
  23. the moment it is most heavily focused on providing access to C
  24. libraries from guile, but it also supports RScheme.
  25. The g-wrap package contains the libraries necessary to run
  26. applications built with g-wrap. If you wish to build applications
  27. that use g-wrap, you should install the g-wrap-devel package.
  28. %description -l ja
  29. g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
  30. guile から C言語のライブライリへのアクセスを提供することを目的
  31. としています。 RScheme もサポートしています
  32. g-wrap には g-wrap 使って作成したアプリケーションを動作させるために
  33. 必要なライブラリが含まれています. g-wrap を使ってアプリケーションを
  34. 作成したい場合 g-wrap-devel をinstallしてください.
  35. %package devel
  36. Summary: Include files and libraries needed for g-wrap development.
  37. Summary(ja): g-wrap を使用した開発に必要なヘッダファイルやライブラリ
  38. Group: Development/Libraries
  39. Requires(pre): /sbin/install-info
  40. Requires: g-wrap = %{version}, guile-devel
  41. %description devel
  42. g-wrap is a tool for creating Scheme interfaces to C libraries. At
  43. the moment it is most heavily focused on providing access to C
  44. libraries from guile, but it also supports RScheme.
  45. You can provide access to a given C API by creating a specification
  46. file describing the interface you want published at the Scheme level.
  47. g-wrap will handle generating all the lower level library interface
  48. code so that the C library shows up as a set of Scheme functions.
  49. You should install g-wrap-devel if you need to compile programs that
  50. need to use g-wrap C<->Scheme functionality
  51. %description devel -l ja
  52. g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
  53. guile から C言語のライブライリへのアクセスを提供することを目的
  54. としています。 RScheme もサポートしています
  55. Schem レベルで表現したいインターフェースを記述を指定したファイルを作成
  56. することによりC PAI へのアクセスを提供します.
  57. g-wrap は 低レベルライブラリインターフェースすべての生成を扱うことが
  58. できます。したがって C ライブラリには Schem 関数の集合としてみえます.
  59. g-wrap のC と Scheme 間の変換機能を必要とするプログラムをコンパイルする
  60. 場合 g-wrap-devel をinstallしておかねかればなりません.
  61. %prep
  62. %setup -q
  63. %patch0 -p1 -b .guile2
  64. %build
  65. %configure --disable-static
  66. #remove Rpath
  67. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  68. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  69. #Is not parallel-build-safe
  70. %{__make}
  71. %install
  72. %{__rm} -rf ${RPM_BUILD_ROOT}
  73. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  74. #Remove unneeded file
  75. find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} ';'
  76. rm -f ${RPM_BUILD_ROOT}%{_datadir}/info/dir
  77. mv ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm ./config.old
  78. cat config.old > config.scm
  79. install -p -m 644 config.scm ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm
  80. %clean
  81. %{__rm} -rf ${RPM_BUILD_ROOT}
  82. %post -p /sbin/ldconfig
  83. %post devel
  84. /sbin/install-info \
  85. --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
  86. %preun -p /sbin/ldconfig
  87. %preun devel
  88. if [ "$1" = "0" ]; then
  89. /sbin/install-info --delete \
  90. --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
  91. fi
  92. %files
  93. %defattr(-,root,root)
  94. %doc AUTHORS COPYING.LIB ChangeLog INSTALL NEWS README THANKS
  95. %dir %{_libdir}/%{name}
  96. %dir %{_libdir}/%{name}/modules
  97. %{_libdir}/%{name}/modules/*.so.*
  98. %{_libdir}/*.so.*
  99. %{_datadir}/guile/site/*
  100. %files devel
  101. %defattr(-,root,root)
  102. %{_bindir}/*
  103. %{_libdir}/*.so
  104. %{_libdir}/%{name}/modules/libgw-guile-gw-glib.so
  105. %{_libdir}/%{name}/modules/libgw-guile-standard.so
  106. %{_includedir}/*
  107. %{_datadir}/aclocal/*
  108. %{_libdir}/pkgconfig/*
  109. %{_mandir}/man1/g-wrap-config.1.gz
  110. %doc %{_infodir}/g-wrap.*
  111. %changelog
  112. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-3
  113. - rebuild with guile-2.0.11
  114. - add Patch0 (g-wrap-1.9.14-guile-2.0.patch)
  115. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-2
  116. - rebuild with libffi-3.0.13
  117. * Tue Jun 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-1
  118. - update to 1.9.14
  119. - remove old patches
  120. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.9.1-1
  121. - new upstream release
  122. - update BuildRequires: umb-scheme -> slib
  123. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.4-10vl5
  124. - applied new versioning policy, spec in utf-8
  125. - removed *.la
  126. * Tue Oct 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-9vl1
  127. - added Patches from Fedora
  128. * Thu Jul 7 2005 Bill Nottingham <notting@redhat.com> 1.3.4-9
  129. - add patch for M4 quoting (#162649, <rc040203@freenet.de>)
  130. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl3
  131. - rebuild with new toolchains
  132. - s/Copyright/License/
  133. * Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl2
  134. - build against new guile 1.6.4
  135. * Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2vl1
  136. - based on rawhide 1.3.4-2
  137. - update to 1.3.4
  138. - move .la files to main package (#79068)
  139. - rebuild with new guile 1.6.3
  140. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.10-1vl1
  141. - updated to 1.1.10
  142. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl4
  143. - add defattr
  144. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl2
  145. - japanized spec file ( add %descripsion -l ja Summary(ja)
  146. * Wed Nov 08 2000 Derek Atkins <warlord@MIT.EDU>
  147. - Don't destroy the build directory -- RPM can do that on its own
  148. - Properly build both g-wrap and g-wrap-devel (info file into -devel)
  149. - currently only one info file
  150. * Wed Oct 25 2000 Dave Peticolas <dave@krondo.com>
  151. - use /usr/info/* for automatic gzipping
  152. * Sat May 27 2000 Mark Horning <rip6@rip6.net>
  153. - Created spec file